Loading ...
Sorry, an error occurred while loading the content.

Re: [linuxham] fldigi / flamp - New Releases

Expand Messages
  • Brian Morrison
    On Tue, 30 Jul 2013 11:02:08 -0500 ... Right, I ve now got it working. For some reason up to and including F18 I could never get pavucontrol to display the
    Message 1 of 11 , Jul 30, 2013
    • 0 Attachment
      On Tue, 30 Jul 2013 11:02:08 -0500
      w1hkj <w1hkj@...> wrote:

      > On 07/30/2013 10:36 AM, Brian Morrison wrote:
      > >
      > > On Tue, 30 Jul 2013 10:14:21 -0500
      > > w1hkj wrote:
      > >
      > > > Are you configuring fldigi to use the Pulseaudio server or
      > > > Portaudio?
      > >
      > > I'm using pulseaudio, the settings within fldigi are set to 'default'
      > > for capture and output. I believe that default means pulse if that is
      > > what is set as default (wherever that setting lives) I'm pretty sure I
      > > haven't touched it or I'd know where to find it.
      > >
      > > > If you are using the Pulse server then the sound devices
      > > > are selected from pa volume control application. The device
      > > > selection on the fldigi audio configure panel should be grayed out.
      > >
      > > This is not the case, I can select devices in the pavucontrol settings
      > > or in the fldigi settings. Maybe this is where the problem lies. I had
      > > the same setup in Fedora 18 and earlier but I didn't see any timeouts.
      > >
      > > --
      > >
      > On the new VM FC-19.
      >
      > * Built fldigi from the git repository.
      > * Configured Audio/Devices as "PulseAudio" server string left blank
      > o Capture & Playback are grayed out
      > * Configured Audio/Device as "PortAudio"
      > o Capture & Playback are selectable
      >
      > You should be using the "PulseAudio" setting Brian. Then use the
      > pavucontrol for device selection and also mixer level controls. the
      > pavucontrol will remember device/mixer settings for every application to
      > accesses the server.

      Right, I've now got it working. For some reason up to and including F18
      I could never get pavucontrol to display the application and the
      process number in its playback and recording tabs, the only way of
      getting this to work was with portaudio selected and both 'default'
      settings used. I think something deep in the bowels of a repeatedly
      upgraded Fedora installation was broken but I never found what and
      there have been so many changes since pulseaudio became the preferred
      audio sub-system that I lost track.

      So, now I have a new F19 installation for whatever reason the internals
      of the OS are providing the pulseaudio server with the correct process
      details and allowing it to feed the samples to where they should go.

      I will report on how 3.21.73 works for me later.

      Thanks for your help and assistance folks!

      --

      Brian Morrison G8SEZ
    • Brian Morrison
      On Tue, 30 Jul 2013 20:25:54 +0100 ... Well, mostly, but I am still seeing things fall over. I lost input to fldigi after about 4 hours last night, showing up
      Message 2 of 11 , Jul 31, 2013
      • 0 Attachment
        On Tue, 30 Jul 2013 20:25:54 +0100
        Brian Morrison wrote:

        > So, now I have a new F19 installation for whatever reason the
        > internals of the OS are providing the pulseaudio server with the
        > correct process details and allowing it to feed the samples to where
        > they should go.

        Well, mostly, but I am still seeing things fall over. I lost input to
        fldigi after about 4 hours last night, showing up ALSA errors
        in /var/log/messages like this:

        ALSA sound/usb/endpoint.c[391]: cannot submit urb (err = -18)

        I have been reading what I can find about this on the kernel mailing
        list and the usb-devel list. It seems that there has been a significant
        change to the way the USB core code works in kernel 3.8 and later, by
        the looks of it the kinks are being worked out but especially in
        isochronous USB usage (such as fldigi) the new code is not yet fully
        robust in dealing with slight clock frequency drift and buffer
        underruns. So any problems of this nature on Linux could be down to
        newer kernels which makes Fedora a more likely susceptible distro due
        to its approach of using the latest packages.

        If you're seeing this sort of problem then it might well not show up in
        virtual environments where the host OS's real USB driver is using older
        code so the virtualised USB stack never gets delayed packets.

        --

        Brian Morrison
      • Dick Kriss
        Thanks.. I have fldigi-3.21.73 up and running nice under OS X 10.8.5 73 Dick AA5VU
        Message 3 of 11 , Aug 8, 2013
        • 0 Attachment
          Thanks..

          I have fldigi-3.21.73 up and running nice under OS X 10.8.5

          73 Dick AA5VU


          On Jul 29, 2013, at 4:18 PM, w1hkj <w1hkj@...> wrote:

          > fldigi version 3.21.73
          >
          >
          > 73 from the NBEMS developers
          >
          > Dave, W1HKJ
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.