Loading ...
Sorry, an error occurred while loading the content.

set up of Flrig icon

Expand Messages
  • Marty Hartwell
    Hi I am stumped on getting an ICON to show up on my Flrig launcher. Using Xubuntu 12.10. Flrig 1.3.11 just downloaded from Dave s web site. I am trying to
    Message 1 of 12 , May 10 8:23 AM
    • 0 Attachment
      Hi

      I am stumped on getting an ICON to show up on my Flrig launcher.
      Using Xubuntu 12.10. Flrig 1.3.11 just downloaded from Dave's web site.
      I am trying to follow the last page of the Flrig help manual as
      quoted here, with out the icons shown.

      "The desktop icons shown at left are from an Ubuntu desktop
      and where the properties Command entry for the respective
      icons are set up as:
      1. /usr/local/bin/flrig --config-dir /home/dave/flrig.tt538
      2. /usr/local/bin/flrig --config-dir /home/dave/flrig.tt516
      3. /usr/local/bin/flrig
      The last one simply defaults to the ~/.flrig directory."

      When I create the launcher I don't have an option for an Icon. Now
      the way I get the "Create Launcher" is right click on an open space
      on my desktop and select create launcher.

      I have installed Flrig in /usr/local/bin and have in my launcher
      /usr/local/bin/flrig --config-dir/marty/flrig.ft817
      It does launch and does have the Ft817 in the banner on the top of the
      page when launched.

      When I installed Flrig I copied the tar file to /usr/local/bin and entered
      the command "sudo tar xf flrig.3.11.bin.tgz", and the application flrig
      resides there now and has permissions:
      -rwxr-xr-x 1 marty marty 2018124 Dec 28 13:23 flrig
      and executes just fine. Just doesn't have an Icon on the desktop, should it
      show something nice like in the manual.

      Marty kd8bj
    • Ed
      ... See if the .bin placed flrig and fldigi in the Internet tab. If so just drag and drop to the desktop. Ed W3NR
      Message 2 of 12 , May 10 10:00 AM
      • 0 Attachment
        On 05/10/2013 11:23 AM, Marty Hartwell wrote:
        > Hi
        >
        > I am stumped on getting an ICON to show up on my Flrig launcher.
        > Using Xubuntu 12.10. Flrig 1.3.11 just downloaded from Dave's web site.
        > I am trying to follow the last page of the Flrig help manual as
        > quoted here, with out the icons shown.
        >
        > "The desktop icons shown at left are from an Ubuntu desktop
        > and where the properties Command entry for the respective
        > icons are set up as:
        > 1. /usr/local/bin/flrig --config-dir /home/dave/flrig.tt538
        > 2. /usr/local/bin/flrig --config-dir /home/dave/flrig.tt516
        > 3. /usr/local/bin/flrig
        > The last one simply defaults to the ~/.flrig directory."
        >
        > When I create the launcher I don't have an option for an Icon. Now
        > the way I get the "Create Launcher" is right click on an open space
        > on my desktop and select create launcher.
        >
        > I have installed Flrig in /usr/local/bin and have in my launcher
        > /usr/local/bin/flrig --config-dir/marty/flrig.ft817
        > It does launch and does have the Ft817 in the banner on the top of the
        > page when launched.
        >
        > When I installed Flrig I copied the tar file to /usr/local/bin and entered
        > the command "sudo tar xf flrig.3.11.bin.tgz", and the application flrig
        > resides there now and has permissions:
        > -rwxr-xr-x 1 marty marty 2018124 Dec 28 13:23 flrig
        > and executes just fine. Just doesn't have an Icon on the desktop, should it
        > show something nice like in the manual.
        >
        > Marty kd8bj

        See if the .bin placed flrig and fldigi in the Internet tab. If so just
        drag and drop to the desktop.

        Ed W3NR
      • Ernest Wagner
        Marty, It appears that you only downloaded and installed flrig-1.3.11.bin.tgz which contains only the executable file. If you want the .desktop and icon file,
        Message 3 of 12 , May 10 10:14 PM
        • 0 Attachment


          Marty,

          It appears that you only downloaded and installed flrig-1.3.11.bin.tgz which contains only the executable file. If you want the .desktop and icon file, I suggest you download the source tar and unpack it somewhere.  If you don't want to compile/install flrig from the source, you can copy the flrig.desktop file  from flrig.1.3.11/data/flrig.desktop to your home desktop and flrig.xpm to /usr/local/share/pixmaps/.

          You might have to make the desktop executable for the icon to display on the launcher. At least that is what I had to do on my system.

          I think that begs the question: Why isn't the flrig binary packaged similarly to the fldigi binary package which includes the launcher, launcher icon and man pages along with the executable?

          Regards and 73

          Ernie D, AA1AD in the great Northwest



          On Fri, 2013-05-10 at 10:23 -0500, Marty Hartwell wrote:
           
          Hi

          I am stumped on getting an ICON to show up on my Flrig launcher.
          Using Xubuntu 12.10. Flrig 1.3.11 just downloaded from Dave's web site.
          I am trying to follow the last page of the Flrig help manual as
          quoted here, with out the icons shown.

          "The desktop icons shown at left are from an Ubuntu desktop
          and where the properties Command entry for the respective
          icons are set up as:
          1. /usr/local/bin/flrig --config-dir /home/dave/flrig.tt538
          2. /usr/local/bin/flrig --config-dir /home/dave/flrig.tt516
          3. /usr/local/bin/flrig
          The last one simply defaults to the ~/.flrig directory."

          When I create the launcher I don't have an option for an Icon. Now
          the way I get the "Create Launcher" is right click on an open space
          on my desktop and select create launcher.

          I have installed Flrig in /usr/local/bin and have in my launcher
          /usr/local/bin/flrig --config-dir/marty/flrig.ft817
          It does launch and does have the Ft817 in the banner on the top of the
          page when launched.

          When I installed Flrig I copied the tar file to /usr/local/bin and entered
          the command "sudo tar xf flrig.3.11.bin.tgz", and the application flrig
          resides there now and has permissions:
          -rwxr-xr-x 1 marty marty 2018124 Dec 28 13:23 flrig
          and executes just fine. Just doesn't have an Icon on the desktop, should it
          show something nice like in the manual.

          Marty kd8bj








        • Marty Hartwell
          Hi Ed I checked the Internet tab also and only see Fldigi and Flarg are there but no flrig. In help file the instructions say to install the file in either my
          Message 4 of 12 , May 11 8:39 AM
          • 0 Attachment
            Hi Ed

            I checked the Internet tab also and only see Fldigi and Flarg
            are there but no flrig. In help file the instructions say to
            install the file in either my home bin directory or in /usr/local
            which is where I choose to place it. My launcher points to /usr/local
            and I have a .flrig directory in my home directory and in that directory
            are four files, flrig.prefs FT-817.prefs NONE.prefs and status_log.txt.
            I wonder if an icon is somehow built into the applications and this one
            is just not showing up.

            Marty kd8bj

            On 05/10/2013 12:00 PM, Ed wrote:
            >
            > On 05/10/2013 11:23 AM, Marty Hartwell wrote:
            > > Hi
            > >
            > > I am stumped on getting an ICON to show up on my Flrig launcher.
            > > Using Xubuntu 12.10. Flrig 1.3.11 just downloaded from Dave's web site.
            > > I am trying to follow the last page of the Flrig help manual as
            > > quoted here, with out the icons shown.
            > >
            > > "The desktop icons shown at left are from an Ubuntu desktop
            > > and where the properties Command entry for the respective
            > > icons are set up as:
            > > 1. /usr/local/bin/flrig --config-dir /home/dave/flrig.tt538
            > > 2. /usr/local/bin/flrig --config-dir /home/dave/flrig.tt516
            > > 3. /usr/local/bin/flrig
            > > The last one simply defaults to the ~/.flrig directory."
            > >
            > > When I create the launcher I don't have an option for an Icon. Now
            > > the way I get the "Create Launcher" is right click on an open space
            > > on my desktop and select create launcher.
            > >
            > > I have installed Flrig in /usr/local/bin and have in my launcher
            > > /usr/local/bin/flrig --config-dir/marty/flrig.ft817
            > > It does launch and does have the Ft817 in the banner on the top of the
            > > page when launched.
            > >
            > > When I installed Flrig I copied the tar file to /usr/local/bin and
            > entered
            > > the command "sudo tar xf flrig.3.11.bin.tgz", and the application flrig
            > > resides there now and has permissions:
            > > -rwxr-xr-x 1 marty marty 2018124 Dec 28 13:23 flrig
            > > and executes just fine. Just doesn't have an Icon on the desktop,
            > should it
            > > show something nice like in the manual.
            > >
            > > Marty kd8bj
            >
            > See if the .bin placed flrig and fldigi in the Internet tab. If so just
            > drag and drop to the desktop.
            >
            > Ed W3NR
            >
            >
          • Marty Hartwell
            Hi Ed As an after thought, I was trying to point out in my post quoted below that in trying to follow the help file there are things explained that I don t see
            Message 5 of 12 , May 11 8:44 AM
            • 0 Attachment
              Hi Ed

              As an after thought, I was trying to point out in my
              post quoted below that in trying to follow the help
              file there are things explained that I don't see while
              trying it. I don't see any way to specify a "Command entry
              for the respective icons". I can enter the location of the
              location of my home working directory. In /usr/local is only
              the file "flrig" and nothing else.

              Marty kd8bj
              On 05/10/2013 12:00 PM, Ed wrote:
              >
              > On 05/10/2013 11:23 AM, Marty Hartwell wrote:
              > > Hi
              > >
              > > I am stumped on getting an ICON to show up on my Flrig launcher.
              > > Using Xubuntu 12.10. Flrig 1.3.11 just downloaded from Dave's web site.
              > > I am trying to follow the last page of the Flrig help manual as
              > > quoted here, with out the icons shown.
              > >
              > > "The desktop icons shown at left are from an Ubuntu desktop
              > > and where the properties Command entry for the respective
              > > icons are set up as:
              > > 1. /usr/local/bin/flrig --config-dir /home/dave/flrig.tt538
              > > 2. /usr/local/bin/flrig --config-dir /home/dave/flrig.tt516
              > > 3. /usr/local/bin/flrig
              > > The last one simply defaults to the ~/.flrig directory."
              > >
              > > When I create the launcher I don't have an option for an Icon. Now
              > > the way I get the "Create Launcher" is right click on an open space
              > > on my desktop and select create launcher.
              > >
              > > I have installed Flrig in /usr/local/bin and have in my launcher
              > > /usr/local/bin/flrig --config-dir/marty/flrig.ft817
              > > It does launch and does have the Ft817 in the banner on the top of the
              > > page when launched.
              > >
              > > When I installed Flrig I copied the tar file to /usr/local/bin and
              > entered
              > > the command "sudo tar xf flrig.3.11.bin.tgz", and the application flrig
              > > resides there now and has permissions:
              > > -rwxr-xr-x 1 marty marty 2018124 Dec 28 13:23 flrig
              > > and executes just fine. Just doesn't have an Icon on the desktop,
              > should it
              > > show something nice like in the manual.
              > >
              > > Marty kd8bj
              >
              > See if the .bin placed flrig and fldigi in the Internet tab. If so just
              > drag and drop to the desktop.
              >
              > Ed W3NR
              >
              >
            • w1hkj
              ... Marty, You should really take a few hours and learn how to install all of the flxxx applications from source. It is not difficult and doing so will create
              Message 6 of 12 , May 11 8:49 AM
              • 0 Attachment
                On 05/11/2013 10:44 AM, Marty Hartwell wrote:
                Hi Ed
                
                As an after thought, I was trying to point out in my
                post quoted below that in trying to follow the help
                file there are things explained that I don't see while
                trying it. I don't see any way to specify a "Command entry
                for the respective icons". I can enter the location of the
                location of my home working directory. In /usr/local is only
                the file "flrig" and nothing else.
                
                Marty kd8bj
                
                Marty,

                You should really take a few hours and learn how to install all of the flxxx applications from source.  It is not difficult and doing so will create all of the missing files, icons, etc.

                https://fedorahosted.org/fldigi/wiki/Documentation/HOWTO

                73, Dave, W1HKJ

              • Marty Hartwell
                Hi This may indeed be the answer, that I need to compile on my system to get the icon. I guess I will look into that seems I saw in one of the help files
                Message 7 of 12 , May 11 8:50 AM
                • 0 Attachment
                  Hi

                  This may indeed be the answer, that I need to compile on my system to get
                  the icon. I guess I will look into that seems I saw in one of the help files
                  reference to getting all of the needed items loaded to build these
                  applications
                  and I do have xubuntu and it should build alright on here.

                  Thanks Marty kd8bj
                  On 05/11/2013 12:14 AM, Ernest Wagner wrote:
                  >
                  >
                  >
                  > Marty,
                  >
                  > It appears that you only downloaded and installed flrig-1.3.11.bin
                  > <http://www.w1hkj.com/downloads/flrig/flrig-1.3.11.bin.tgz>.tgz which
                  > contains only the executable file. If you want the .desktop and icon
                  > file, I suggest you download the source tar and unpack it somewhere.
                  > If you don't want to compile/install flrig from the source, you can
                  > copy the flrig.desktop file from flrig.1.3.11/data/flrig.desktop to
                  > your home desktop and flrig.xpm to /usr/local/share/pixmaps/.
                  >
                  > You might have to make the desktop executable for the icon to display
                  > on the launcher. At least that is what I had to do on my system.
                  >
                  > I think that begs the question: Why isn't the flrig binary packaged
                  > similarly to the fldigi binary package which includes the launcher,
                  > launcher icon and man pages along with the executable?
                  >
                  > Regards and 73
                  >
                  > Ernie D, AA1AD in the great Northwest
                  >
                  >
                  >
                  > On Fri, 2013-05-10 at 10:23 -0500, Marty Hartwell wrote:
                  >
                  >>
                  >> Hi
                  >>
                  >> I am stumped on getting an ICON to show up on my Flrig launcher.
                  >> Using Xubuntu 12.10. Flrig 1.3.11 just downloaded from Dave's web site.
                  >> I am trying to follow the last page of the Flrig help manual as
                  >> quoted here, with out the icons shown.
                  >>
                  >> "The desktop icons shown at left are from an Ubuntu desktop
                  >> and where the properties Command entry for the respective
                  >> icons are set up as:
                  >> 1. /usr/local/bin/flrig --config-dir /home/dave/flrig.tt538
                  >> 2. /usr/local/bin/flrig --config-dir /home/dave/flrig.tt516
                  >> 3. /usr/local/bin/flrig
                  >> The last one simply defaults to the ~/.flrig directory."
                  >>
                  >> When I create the launcher I don't have an option for an Icon. Now
                  >> the way I get the "Create Launcher" is right click on an open space
                  >> on my desktop and select create launcher.
                  >>
                  >> I have installed Flrig in /usr/local/bin and have in my launcher
                  >> /usr/local/bin/flrig --config-dir/marty/flrig.ft817
                  >> It does launch and does have the Ft817 in the banner on the top of the
                  >> page when launched.
                  >>
                  >> When I installed Flrig I copied the tar file to /usr/local/bin and
                  >> entered
                  >> the command "sudo tar xf flrig.3.11.bin.tgz", and the application flrig
                  >> resides there now and has permissions:
                  >> -rwxr-xr-x 1 marty marty 2018124 Dec 28 13:23 flrig
                  >> and executes just fine. Just doesn't have an Icon on the desktop,
                  >> should it
                  >> show something nice like in the manual.
                  >>
                  >> Marty kd8bj
                  >>
                  >>
                  >>
                  >>
                  >>
                  >
                  >
                  >
                  >
                • Marty Hartwell
                  Hi Dave Thanks and I think I do remember you telling me this on another occasion and thanks for the direct link. Marty kd8bj
                  Message 8 of 12 , May 11 8:54 AM
                  • 0 Attachment
                    Hi Dave

                    Thanks and I think I do remember you telling me this on another occasion
                    and thanks for the direct link.

                    Marty kd8bj
                    On 05/11/2013 10:49 AM, w1hkj wrote:
                    >
                    > On 05/11/2013 10:44 AM, Marty Hartwell wrote:
                    >> Hi Ed
                    >>
                    >> As an after thought, I was trying to point out in my
                    >> post quoted below that in trying to follow the help
                    >> file there are things explained that I don't see while
                    >> trying it. I don't see any way to specify a "Command entry
                    >> for the respective icons". I can enter the location of the
                    >> location of my home working directory. In /usr/local is only
                    >> the file "flrig" and nothing else.
                    >>
                    >> Marty kd8bj
                    > Marty,
                    >
                    > You should really take a few hours and learn how to install all of the
                    > flxxx applications from source. It is not difficult and doing so will
                    > create all of the missing files, icons, etc.
                    >
                    > https://fedorahosted.org/fldigi/wiki/Documentation/HOWTO
                    >
                    > 73, Dave, W1HKJ
                    >
                    >
                  • Ed
                    ... Follow Dave s advice and learn to build from source. Its easier than you think. I build all of Dave s flxxx apps from source on Xubuntu 12.10. Ed W3NR
                    Message 9 of 12 , May 11 9:16 AM
                    • 0 Attachment
                      On 05/11/2013 11:50 AM, Marty Hartwell wrote:
                      > Hi
                      >
                      > This may indeed be the answer, that I need to compile on my system to get
                      > the icon. I guess I will look into that seems I saw in one of the help files
                      > reference to getting all of the needed items loaded to build these
                      > applications
                      > and I do have xubuntu and it should build alright on here.
                      >
                      > Thanks Marty kd8bj

                      >> Marty,


                      Follow Dave's advice and learn to build from source. Its easier than you
                      think.

                      I build all of Dave's flxxx apps from source on Xubuntu 12.10.

                      Ed W3NR
                    • w1hkj
                      ... Will be in the next distribution. Remember that the binary may still not run correctly on your distribution depending on the shared libraries on your
                      Message 10 of 12 , May 11 12:59 PM
                      • 0 Attachment
                        On 05/11/2013 12:14 AM, Ernest Wagner wrote:
                        Marty,

                        It appears that you only downloaded and installed flrig-1.3.11.bin.tgz which contains only the executable file. If you want the .desktop and icon file, I suggest you download the source tar and unpack it somewhere.  If you don't want to compile/install flrig from the source, you can copy the flrig.desktop file  from flrig.1.3.11/data/flrig.desktop to your home desktop and flrig.xpm to /usr/local/share/pixmaps/.

                        You might have to make the desktop executable for the icon to display on the launcher. At least that is what I had to do on my system.

                        I think that begs the question: Why isn't the flrig binary packaged similarly to the fldigi binary package which includes the launcher, launcher icon and man pages along with the executable?
                        Will be in the next distribution.  Remember that the binary may still not run correctly on your distribution depending on the shared libraries on your system versus those on the build platform.

                        Building from source is always your best bet. 

                        Regards and 73

                        Ernie D, AA1AD in the great Northwest

                        73, Dave, W1HKJ, in the greater Southeast :-)

                      • Marty Hartwell
                        Hi Ed I just set up a build environment on this system using Dave s fine help document. I installed the prerequisites and commenced and completed a build of
                        Message 11 of 12 , May 11 6:56 PM
                        • 0 Attachment
                          Hi Ed

                          I just set up a build environment on this system using Dave's fine
                          help document. I installed the prerequisites and commenced and completed
                          a build of first FLRIG, and then FLDIGI latest version.
                          And yes it is easier than I expected. Reminds me of doing builds on an
                          old Unix system seems like a lifetime ago, maybe not that long but at
                          least half a lifetime anyway.

                          Bottom line I now have my icons, so I am happy.

                          Marty kd8bj
                          On 05/11/2013 11:16 AM, Ed wrote:
                          > On 05/11/2013 11:50 AM, Marty Hartwell wrote:
                          >> Hi
                          >>
                          >> This may indeed be the answer, that I need to compile on my system to get
                          >> the icon. I guess I will look into that seems I saw in one of the help files
                          >> reference to getting all of the needed items loaded to build these
                          >> applications
                          >> and I do have xubuntu and it should build alright on here.
                          >>
                          >> Thanks Marty kd8bj
                          >>> Marty,
                          >
                          > Follow Dave's advice and learn to build from source. Its easier than you
                          > think.
                          >
                          > I build all of Dave's flxxx apps from source on Xubuntu 12.10.
                          >
                          > Ed W3NR
                          >
                          >
                          >
                          > ------------------------------------
                          >
                          > Yahoo! Groups Links
                          >
                          >
                          >
                          >
                        • w1hkj
                          ... Congratulations Marty. The best news is that you can now mentor someone else who may be reluctant to jump into the pool. Dave
                          Message 12 of 12 , May 11 7:07 PM
                          • 0 Attachment
                            On 05/11/2013 08:56 PM, Marty Hartwell wrote:
                            > Hi Ed
                            >
                            > I just set up a build environment on this system using Dave's fine
                            > help document. I installed the prerequisites and commenced and completed
                            > a build of first FLRIG, and then FLDIGI latest version.
                            > And yes it is easier than I expected. Reminds me of doing builds on an
                            > old Unix system seems like a lifetime ago, maybe not that long but at
                            > least half a lifetime anyway.
                            >
                            > Bottom line I now have my icons, so I am happy.
                            >
                            > Marty kd8bj
                            Congratulations Marty. The best news is that you can now mentor someone
                            else who may be reluctant to jump into the pool.

                            Dave
                          Your message has been successfully submitted and would be delivered to recipients shortly.