Loading ...
Sorry, an error occurred while loading the content.

Re: [linuxham] fldigi and HamQTH database query

Expand Messages
  • Cliff Scott
    ** Reply to message from Marc Farly on Tue, 23 Apr 2013 15:08:30 -0700 Sometimes you have to click the QRZ button several times. It works
    Message 1 of 15 , Apr 23, 2013
    • 0 Attachment
      ** Reply to message from Marc Farly <kj6wex@...> on Tue, 23 Apr 2013
      15:08:30 -0700

      Sometimes you have to click the QRZ button several times. It works here on
      OSx 10.7.5

      > Hello, all-
      >
      > I am a new subscriber to this list and I have a question about querying the
      > HamQTH.com database using fldigi under MacOS X. I am running the
      > most-recent version of fldigi (3.21.70).
      >
      > I have the "configuration>Web>Data base lookup" set with my login
      > credentials to HamQTH.com and the checkbox next to HamQTH.com is checked.
      > When I'm operating PSK31, I double-click a callsign and it populates the
      > Call field above my receive window. When I click the QRZ globe button above
      > the frequency display, nothing happens. I expected it would fill in the
      > remaining fields based on fetching the information linked to that callsign.
      > Am I doing something wrong? If so, what do I need to do to make this work?
      > As it is, I've been keeping a browser window open and copying/pasting info
      > from QRZ or HamQTH manually, which seems somewhat unnecessary.
      >
      > Thank you in advance for your help.
      >
      > -Marc
    • Marc Farly
      I am also running 10.7.5 and clicking the QRZ button repeatedly still does not work. I ve also tried highlighting a call in the receive pane and right-clicking
      Message 2 of 15 , Apr 23, 2013
      • 0 Attachment
        I am also running 10.7.5 and clicking the QRZ button repeatedly still does not work. I've also tried highlighting a call in the receive pane and right-clicking to choose "Look up call." That puts the call into the Call field, but no other information is populated. 

        I'm sure this would work if I didn't have some little thing messed up somewhere, but I sure can't figure it out. :)

        -Marc
      • Joel Black
        I ve noticed on my Mac setup that the fields no longer populate. I don t know when this started, but it is not working in either 3.21.69 or 3.21.70. Now, to
        Message 3 of 15 , Apr 24, 2013
        • 0 Attachment
          I've noticed on my Mac setup that the fields no longer populate. I
          don't know when this started, but it is not working in either 3.21.69 or
          3.21.70.

          Now, to select the web browser lookup, you need to be in the top half of
          the screen you mention below. From your statement, it appears you're in
          the bottom half of that window.

          If "QRZ online via default Internet Browser" is checked, that's what it
          will do. I can change mine to "Hamcall..." or "HamQTH..." and *that*
          part works fine. The "Data base lookup" section is what I'm having
          trouble with.

          73,
          Joel - W4JBB

          On 4/23/13 7:14 PM, Steve wrote:
          > Marc,
          > It sounds like you're doing it right.
          > I tried it on my OSX and no matter what box I check... hamqth or calllookup.info it always goes to QRZ..... not sure why.
          > Steve
          > KK4NNH
          >
          >
          > On Apr 23, 2013, at 5:08 PM, Marc Farly <kj6wex@...> wrote:
          >
          >> Hello, all-
          >>
          >> I am a new subscriber to this list and I have a question about querying the HamQTH.com database using fldigi under MacOS X. I am running the most-recent version of fldigi (3.21.70).
          >>
          >> I have the "configuration>Web>Data base lookup" set with my login credentials to HamQTH.com and the checkbox next to HamQTH.com is checked. When I'm operating PSK31, I double-click a callsign and it populates the Call field above my receive window. When I click the QRZ globe button above the frequency display, nothing happens. I expected it would fill in the remaining fields based on fetching the information linked to that callsign. Am I doing something wrong? If so, what do I need to do to make this work? As it is, I've been keeping a browser window open and copying/pasting info from QRZ or HamQTH manually, which seems somewhat unnecessary.
          >>
          >> Thank you in advance for your help.
          >>
          >> -Marc
          >>
          >>
          >
          >
          > ------------------------------------
          >
          > Yahoo! Groups Links
          >
          >
          >
          >
        • Steve
          Ok I ve replicated this it does it on mine too. FLdidi 3.21.70 OSX 10.8.2 If you uncheck the web browser lookup and just do the database lookup: qrz cdrom
          Message 4 of 15 , Apr 24, 2013
          • 0 Attachment
            Ok I've replicated this it does it on mine too.
            FLdidi 3.21.70 OSX 10.8.2

            If you uncheck the web browser lookup and just do the database lookup:
            qrz cdrom database works.
            qrz.com lookup works
            hamcall.net (didn't test)
            hamqth.com didn't work
            calllook.info worked

            Steve
            KK4NNH

            On Apr 24, 2013, at 5:18 AM, Joel Black <w4jbb@...> wrote:

            > I've noticed on my Mac setup that the fields no longer populate. I
            > don't know when this started, but it is not working in either 3.21.69 or
            > 3.21.70.
            >
            > Now, to select the web browser lookup, you need to be in the top half of
            > the screen you mention below. From your statement, it appears you're in
            > the bottom half of that window.
            >
            > If "QRZ online via default Internet Browser" is checked, that's what it
            > will do. I can change mine to "Hamcall..." or "HamQTH..." and *that*
            > part works fine. The "Data base lookup" section is what I'm having
            > trouble with.
            >
            > 73,
            > Joel - W4JBB
            >
            > On 4/23/13 7:14 PM, Steve wrote:
            >> Marc,
            >> It sounds like you're doing it right.
            >> I tried it on my OSX and no matter what box I check... hamqth or calllookup.info it always goes to QRZ..... not sure why.
            >> Steve
            >> KK4NNH
            >>
            >>
            >> On Apr 23, 2013, at 5:08 PM, Marc Farly <kj6wex@...> wrote:
            >>
            >>> Hello, all-
            >>>
            >>> I am a new subscriber to this list and I have a question about querying the HamQTH.com database using fldigi under MacOS X. I am running the most-recent version of fldigi (3.21.70).
            >>>
            >>> I have the "configuration>Web>Data base lookup" set with my login credentials to HamQTH.com and the checkbox next to HamQTH.com is checked. When I'm operating PSK31, I double-click a callsign and it populates the Call field above my receive window. When I click the QRZ globe button above the frequency display, nothing happens. I expected it would fill in the remaining fields based on fetching the information linked to that callsign. Am I doing something wrong? If so, what do I need to do to make this work? As it is, I've been keeping a browser window open and copying/pasting info from QRZ or HamQTH manually, which seems somewhat unnecessary.
            >>>
            >>> Thank you in advance for your help.
            >>>
            >>> -Marc
            >>>
            >>>
            >>
            >>
            >> ------------------------------------
            >>
            >> Yahoo! Groups Links
            >>
            >>
            >>
            >>
            >
            >
            >
            > ------------------------------------
            >
            > Yahoo! Groups Links
            >
            >
            >
          • mwrenn@sbcglobal.net
            I haven t seen that anyone has pointed out the simple test, is your QRZ subscription up to date? I realized recently that my CQRLog was not filling in the
            Message 5 of 15 , Apr 24, 2013
            • 0 Attachment
              I haven't seen that anyone has pointed out the simple test, is your QRZ subscription up to date? I realized recently that my CQRLog was not filling in the contact details anymore. Turned out my QRZ subscription had expired and the XML info was no longer available to me.

              Just another possible solution path to investigate.

              Good Luck,

              Michael - K5WRN

              --- In linuxham@yahoogroups.com, Marc Farly <kj6wex@...> wrote:
              >
              > Hello, all-
              >
              > I am a new subscriber to this list and I have a question about querying the
              > HamQTH.com database using fldigi under MacOS X. I am running the
              > most-recent version of fldigi (3.21.70).
              >
              > I have the "configuration>Web>Data base lookup" set with my login
              > credentials to HamQTH.com and the checkbox next to HamQTH.com is checked.
              > When I'm operating PSK31, I double-click a callsign and it populates the
              > Call field above my receive window. When I click the QRZ globe button above
              > the frequency display, nothing happens. I expected it would fill in the
              > remaining fields based on fetching the information linked to that callsign.
              > Am I doing something wrong? If so, what do I need to do to make this work?
              > As it is, I've been keeping a browser window open and copying/pasting info
              > from QRZ or HamQTH manually, which seems somewhat unnecessary.
              >
              > Thank you in advance for your help.
              >
              > -Marc
              >
            • Marc Farly
              ... Marc KJ6WEX: I can get the web browser lookup to work, too, so you re seeing exactly what I m seeing here. ... right-click/compress and then trash the
              Message 6 of 15 , Apr 24, 2013
              • 0 Attachment
                >Joel Black w4jbb@... said:
                >
                >I've noticed on my Mac setup that the fields no longer populate.  I
                >don't know when this started, but it is not working in either 3.21.69 or
                >3.21.70.
                >
                >Now, to select the web browser lookup, you need to be in the top half of
                >the screen you mention below.  From your statement, it appears you're in
                >the bottom half of that window.
                >
                >If "QRZ online via default Internet Browser" is checked, that's what it
                >will do.  I can change mine to "Hamcall..." or "HamQTH..." and *that*
                >part works fine.  The "Data base lookup" section is what I'm having
                >trouble with.
                >
                >73,
                >Joel - W4JBB

                Marc KJ6WEX: I can get the web browser lookup to work, too, so you're seeing exactly what I'm seeing here.

                >Dick Kriss aa5vu@... said:
                >Marc,
                >
                >Something is not right with your setup.  I suggest you should:
                >
                >- Quit fldigi
                >- Remove  fldigi_def.xml from you .fldigi folder (or just right-click/compress and then trash the  fldigi_def.xml)
                >- Start fldigi as a new user and see if you get it to work by only checking HamQTS.com box 
                >
                >It works fine with my fldigi-3.21.70 OSX Mountain Lion setup on an iMac
                >
                >I suspect your fldigi_def.xml file may be corrupted?
                >
                >Dick AA5VU

                Marc KJ6WEX: I just gave that a try and got the same results, unfortunately.

                >Steve stecla1@... said:
                >
                >Ok I've replicated this it does it on mine too.
                >FLdidi 3.21.70 OSX 10.8.2
                >
                >If you uncheck the web browser lookup and just do the database lookup:
                >qrz cdrom database works.
                >qrz.com lookup works
                >hamcall.net (didn't test)
                >hamqth.com didn't work

                Marc KJ6WEX: I don't have any other database resource, such as QRZ.com or the CDROM, so I can't test that. It looks like you're seeing the same problem I'm having.

                >
                >I haven't seen that anyone has pointed out the simple test, is your QRZ subscription up to date? I realized recently that my CQRLog was not filling in the contact details anymore. Turned out my QRZ subscription had expired and the XML info was no longer available to me.
                >
                >Just another possible solution path to investigate.
                >
                >Good Luck,
                >
                >Michael - K5WRN

                Marc KJ6WEX: I only have the HamQTH.com account and it's up to date. I did confirm my credentials were correct, though, just in case.

              • Cliff Scott
                ** Reply to message from Steve on Wed, 24 Apr 2013 07:38:14 -0500 Strange. I just now made a contact and it worked fine on my OSx 10.7.5 to
                Message 7 of 15 , Apr 24, 2013
                • 0 Attachment
                  ** Reply to message from Steve <stecla1@...> on Wed, 24 Apr 2013
                  07:38:14 -0500

                  Strange. I just now made a contact and it worked fine on my OSx 10.7.5 to use
                  hamqth.com. Has hamqth.com ever worked for you?

                  Cliff
                  AE5ZA

                  > Ok I've replicated this it does it on mine too.
                  > FLdidi 3.21.70 OSX 10.8.2
                  >
                  > If you uncheck the web browser lookup and just do the database lookup:
                  > qrz cdrom database works.
                  > qrz.com lookup works
                  > hamcall.net (didn't test)
                  > hamqth.com didn't work
                  > calllook.info worked
                  >
                  > Steve
                  > KK4NNH
                  >
                  > On Apr 24, 2013, at 5:18 AM, Joel Black <w4jbb@...> wrote:
                  >
                  > > I've noticed on my Mac setup that the fields no longer populate. I
                  > > don't know when this started, but it is not working in either 3.21.69 or
                  > > 3.21.70.
                  > >
                  > > Now, to select the web browser lookup, you need to be in the top half of
                  > > the screen you mention below. From your statement, it appears you're in
                  > > the bottom half of that window.
                  > >
                  > > If "QRZ online via default Internet Browser" is checked, that's what it
                  > > will do. I can change mine to "Hamcall..." or "HamQTH..." and *that*
                  > > part works fine. The "Data base lookup" section is what I'm having
                  > > trouble with.
                  > >
                  > > 73,
                  > > Joel - W4JBB
                  > >
                  > > On 4/23/13 7:14 PM, Steve wrote:
                  > >> Marc,
                  > >> It sounds like you're doing it right.
                  > >> I tried it on my OSX and no matter what box I check... hamqth or
                  > calllookup.info it always goes to QRZ..... not sure why.
                  > >> Steve
                  > >> KK4NNH
                  > >>
                  > >>
                  > >> On Apr 23, 2013, at 5:08 PM, Marc Farly <kj6wex@...> wrote:
                  > >>
                  > >>> Hello, all-
                  > >>>
                  > >>> I am a new subscriber to this list and I have a question about querying
                  > the HamQTH.com database using fldigi under MacOS X. I am running the
                  > most-recent version of fldigi (3.21.70).
                  > >>>
                  > >>> I have the "configuration>Web>Data base lookup" set with my login
                  > credentials to HamQTH.com and the checkbox next to HamQTH.com is checked.
                  > When I'm operating PSK31, I double-click a callsign and it populates the Call
                  > field above my receive window. When I click the QRZ globe button above the
                  > frequency display, nothing happens. I expected it would fill in the remaining
                  > fields based on fetching the information linked to that callsign. Am I doing
                  > something wrong? If so, what do I need to do to make this work? As it is,
                  > I've been keeping a browser window open and copying/pasting info from QRZ or
                  > HamQTH manually, which seems somewhat unnecessary.
                  > >>>
                  > >>> Thank you in advance for your help.
                  > >>>
                  > >>> -Marc
                • Marc Farly
                  I set the logging to Debug and tried a HamQTH database query. Here is the log output: W: [11:35:52] logbook/lookupcall.cxx:880: HAMQTH session id failed!
                  Message 8 of 15 , Apr 24, 2013
                  • 0 Attachment
                    I set the logging to "Debug" and tried a HamQTH database query. Here is the log output:

                    W: [11:35:52] logbook/lookupcall.cxx:880: HAMQTH session id failed!
                    http://hamqth.com...
                    I: [11:35:51] logbook/lookupcall.cxx:1060: Request sent to


                    Hopefully, that sheds some light on what is causing it to not work.

                    -Marc

                  • Dave B
                    ... Might not be relevant, but HamQTH.com have recently moved to new servers. Dave G0WBX. Hello, after long time, I m very happy that I can inform you
                    Message 9 of 15 , Apr 25, 2013
                    • 0 Attachment
                      On 24 Apr 2013 at 17:18, linuxham@yahoogroups.com wrote:

                      > Re: fldigi and HamQTH database query
                      > Posted by: "mwrenn@..." michaelwrenn@...
                      > mwrenn@... Date: Wed Apr 24, 2013 6:21 am ((PDT))
                      >
                      > I haven't seen that anyone has pointed out the simple test, is your
                      > QRZ subscription up to date? I realized recently that my CQRLog was
                      > not filling in the contact details anymore. Turned out my QRZ
                      > subscription had expired and the XML info was no longer available to
                      > me.
                      >
                      > Just another possible solution path to investigate.
                      >
                      > Good Luck,
                      >
                      > Michael - K5WRN


                      Might not be relevant, but HamQTH.com have recently moved to new servers.

                      Dave G0WBX.

                      <Quote>
                      Hello,

                      after long time, I'm very happy that I can inform you about recent news
                      at http://HamQTH.com

                      What's new?

                      * we are running on new server CPU Intel Xeon E3-1220v2, 28GB RAM, 4x1TB
                      HDD connected to RAID10, Ubuntu 12.04, MariaDB * UI design improved
                      (thnaks to Doug, KJ6OYJ) * list of recent uploaded logs is sorted by date
                      * list of DX cluster spots is reloaded every 20 seconds

                      If you are following HamQTH on Twitter and/or Facebook, you probably know
                      about my troubles with VPS where HamQTH lived. Last month or so was very
                      complicated. VPS had severail failures. Fortunately, the new server is
                      online and today I moved the webstite. Everything should be much faster.
                      Server has several times more RAM than VPS had, disk operation are very
                      fast (thanks to RAID 10). Now HamQTH can grow without any problem. Look
                      at http://HamQTH.com and check out how fast it is!


                      73 Petr, OK2CQR
                      HamQTH.com owner

                      <UnQuote>
                    • ThomasA
                      Are you logged into HamQTH? you might try this log in and save log in info in browser, then try it... HTH Tom K8WDX
                      Message 10 of 15 , Apr 25, 2013
                      • 0 Attachment
                        Are you logged into HamQTH? you might try this log in and save log in info in browser, then try it... HTH Tom K8WDX



                        --- In linuxham@yahoogroups.com, Marc Farly <kj6wex@...> wrote:
                        >
                        > I set the logging to "Debug" and tried a HamQTH database query. Here is the
                        > log output:
                        >
                        > W: [11:35:52] logbook/lookupcall.cxx:880: HAMQTH session id failed!
                        > http://hamqth.com...
                        > I: [11:35:51] logbook/lookupcall.cxx:1060: Request sent to
                        >
                        >
                        > Hopefully, that sheds some light on what is causing it to not work.
                        >
                        > -Marc
                        >
                      • Marc Farly
                        Hello, Thomas- That was a good suggestion. Unfortunately, it still gave me the same errors in the log after failing to fetch the information. -Marc
                        Message 11 of 15 , Apr 25, 2013
                        • 0 Attachment
                          Hello, Thomas-

                          That was a good suggestion. Unfortunately, it still gave me the same errors in the log after failing to fetch the information.

                          -Marc
                        • Marc Farly
                          I figured it out, at least in a quick test here at work. Through a Google search, I found this link to see if it returns a session ID or not:
                          Message 12 of 15 , Apr 25, 2013
                          • 0 Attachment
                            I figured it out, at least in a quick test here at work. Through a Google search, I found this link to see if it returns a session ID or not: http://www.hamqth.com/xml.php?u=username&p=password (replace the username and password accordingly, of course).

                            In my case, it returned that my username or password was incorrect, even though I confirmed it was correct. I then changed my HamQTH password, since I had a '#' in it and suspected it didn't like that character. After changing the password, I was able to get a session ID using the test link. Based on that success, I changed my password in fldigi and tried again and it worked. Woo!

                            If anyone else is having trouble getting it to work, try the steps I describe and see if it solves the problem.

                            Thanks

                            -Marc



                            On Wed, Apr 24, 2013 at 5:38 AM, Steve <stecla1@...> wrote:
                            Ok I've replicated this it does it on mine too.
                            FLdidi 3.21.70 OSX 10.8.2

                            If you uncheck the web browser lookup and just do the database lookup:
                            qrz cdrom database works.
                            qrz.com lookup works
                            hamcall.net (didn't test)
                            hamqth.com didn't work
                            calllook.info worked

                            Steve
                            KK4NNH

                            On Apr 24, 2013, at 5:18 AM, Joel Black <w4jbb@...> wrote:

                            > I've noticed on my Mac setup that the fields no longer populate.  I
                            > don't know when this started, but it is not working in either 3.21.69 or
                            > 3.21.70.
                            >
                            > Now, to select the web browser lookup, you need to be in the top half of
                            > the screen you mention below.  From your statement, it appears you're in
                            > the bottom half of that window.
                            >
                            > If "QRZ online via default Internet Browser" is checked, that's what it
                            > will do.  I can change mine to "Hamcall..." or "HamQTH..." and *that*
                            > part works fine.  The "Data base lookup" section is what I'm having
                            > trouble with.
                            >
                            > 73,
                            > Joel - W4JBB
                            >
                            > On 4/23/13 7:14 PM, Steve wrote:
                            >> Marc,
                            >> It sounds like you're doing it right.
                            >> I tried it on my OSX and no matter what box I check... hamqth or calllookup.info it always goes to QRZ..... not sure why.
                            >> Steve
                            >> KK4NNH
                            >>
                            >>
                            >> On Apr 23, 2013, at 5:08 PM, Marc Farly <kj6wex@...> wrote:
                            >>
                            >>> Hello, all-
                            >>>
                            >>> I am a new subscriber to this list and I have a question about querying the HamQTH.com database using fldigi under MacOS X. I am running the most-recent version of fldigi (3.21.70).
                            >>>
                            >>> I have the "configuration>Web>Data base lookup" set with my login credentials to HamQTH.com and the checkbox next to HamQTH.com is checked. When I'm operating PSK31, I double-click a callsign and it populates the Call field above my receive window. When I click the QRZ globe button above the frequency display, nothing happens. I expected it would fill in the remaining fields based on fetching the information linked to that callsign. Am I doing something wrong? If so, what do I need to do to make this work? As it is, I've been keeping a browser window open and copying/pasting info from QRZ or HamQTH manually, which seems somewhat unnecessary.
                            >>>
                            >>> Thank you in advance for your help.
                            >>>
                            >>> -Marc
                            >>>
                            >>>
                            >>
                            >>
                            >> ------------------------------------
                            >>
                            >> Yahoo! Groups Links
                            >>
                            >>
                            >>
                            >>
                            >
                            >
                            >
                            > ------------------------------------
                            >
                            > Yahoo! Groups Links
                            >
                            >
                            >



                            ------------------------------------

                            Yahoo! Groups Links

                            <*> To visit your group on the web, go to:
                                http://groups.yahoo.com/group/linuxham/

                            <*> Your email settings:
                                Individual Email | Traditional

                            <*> To change settings online go to:
                                http://groups.yahoo.com/group/linuxham/join
                                (Yahoo! ID required)

                            <*> To change settings via email:
                                linuxham-digest@yahoogroups.com
                                linuxham-fullfeatured@yahoogroups.com

                            <*> To unsubscribe from this group, send an email to:
                                linuxham-unsubscribe@yahoogroups.com

                            <*> Your use of Yahoo! Groups is subject to:
                                http://docs.yahoo.com/info/terms/


                          • Joel Black
                            Oh, good grief! After having swapped from PC to Mac in December, I loaded Fldigi and its associated software. During the installation, I failed to put in my
                            Message 13 of 15 , Apr 26, 2013
                            • 0 Attachment
                              Oh, good grief!

                              After having swapped from PC to Mac in December, I loaded Fldigi and its associated software.  During the installation, I failed to put in my user name and password for using HamQTH.  I kept reading it as a free service so I didn't figure I needed to input my user name and password - it does not require it for the web browser lookup.  It does require it for the database lookup though which makes sense.

                              I have no way of going back and looking at the PC to compare as it no longer exists in its previous configuration.

                              I didn't catch this previously as I have not been working many digital modes this year; therefore, I truly had no idea when this problem started.  Heh...  It seems it started upon my incorrect configuration.  Marc saying something about having to input a password got me on that path.

                              Sorry for all the bandwidth I've caused with *my* issue.

                              73,
                              Joel - W4JBB

                              On 4/25/13 6:57 PM, Marc Farly wrote:
                               
                              I figured it out, at least in a quick test here at work. Through a Google search, I found this link to see if it returns a session ID or not: http://www.hamqth.com/xml.php?u=username&p=password (replace the username and password accordingly, of course).

                              In my case, it returned that my username or password was incorrect, even though I confirmed it was correct. I then changed my HamQTH password, since I had a '#' in it and suspected it didn't like that character. After changing the password, I was able to get a session ID using the test link. Based on that success, I changed my password in fldigi and tried again and it worked. Woo!

                              If anyone else is having trouble getting it to work, try the steps I describe and see if it solves the problem.

                              Thanks

                              -Marc

                            Your message has been successfully submitted and would be delivered to recipients shortly.