Loading ...
Sorry, an error occurred while loading the content.

Ubuntu 12.04 - Problem Building LoTW tqsllib2.2 - libcrypto.a

Expand Messages
  • ki7mt
    Hello All, This a cross post, as I posted over in LoTW as well, but thought I may have a shot over in the Linux specific house also. The Box: Fresh Install,
    Message 1 of 4 , Apr 19, 2013
    • 0 Attachment
      Hello All,

      This a cross post, as I posted over in LoTW as well, but thought I may have a shot over in the Linux specific house also.

      The Box: Fresh Install, Ubuntu 12.04.2. + updates, and a few packages added:

      gdebi build-essentials autoconf automake gfortran checkinstall cvs subversion git-core mercurial

      I'm trying to build TrustedQSL which requires tqsllib and the deps for that are openssl, expat and zlib of which all three were installed, zlib compiled from source 1.2.7.

      I've also installed libssl-dev, which pulled in zlib-dev. libssl-dev. ./configure is looking for (libcrypto.a), but it's not accepting it, even when the path is passed to it in ./configure.

      Configure
      ./configure --with-expat=/usr/lib/i386-linux-gnu/ --with-zlib=/usr/local/zlib/lib/ --with-openssl=/usr/lib/i386-linux-gnu/

      The Error:
      checking for --enable-docs... yes
      checking for OpenSSL library (libcrypto.a)... Not found

      OpenSSL not found
      Use --with-openssl option to fix this problem

      ls -al /usr/lib/i386-linux-gnu/ | grep Libcrypto*
      -rw-r--r-- 1 root root 43648 Oct 5 2012 libcrypt.a
      -rw-r--r-- 1 root root 2963204 Mar 19 13:18 libcrypto.a
      lrwxrwxrwx 1 root root 38 Mar 19 13:18 libcrypto.so -> /lib/i386-linux-gnu/libcrypto.so.1.0.0
      lrwxrwxrwx 1 root root 33 Apr 18 21:00 libcrypt.so -> /lib/i386-linux-gnu/libcrypt.so.1

      So I'm kind of at a loss as to why it's not accepting it the path.

      Any Ideas ?

      73's Greg, KI7MT
    • Geoff McAlpin
      Greg, I m using 12.04 as well and the TrustedQSL that is in the download center works flawlessly for me. You should try that before compiling it from source.
      Message 2 of 4 , Apr 19, 2013
      • 0 Attachment

        Greg,

        I'm using 12.04 as well and the TrustedQSL that is in the download center works flawlessly for me. You should try that before compiling it from source.

        Geoff, N7PGN
        Seattle, WA
        CN87tr

        On Apr 19, 2013 1:20 AM, "ki7mt" <ki7mt@...> wrote:
         

        Hello All,

        This a cross post, as I posted over in LoTW as well, but thought I may have a shot over in the Linux specific house also.

        The Box: Fresh Install, Ubuntu 12.04.2. + updates, and a few packages added:

        gdebi build-essentials autoconf automake gfortran checkinstall cvs subversion git-core mercurial

        I'm trying to build TrustedQSL which requires tqsllib and the deps for that are openssl, expat and zlib of which all three were installed, zlib compiled from source 1.2.7.

        I've also installed libssl-dev, which pulled in zlib-dev. libssl-dev. ./configure is looking for (libcrypto.a), but it's not accepting it, even when the path is passed to it in ./configure.

        Configure
        ./configure --with-expat=/usr/lib/i386-linux-gnu/ --with-zlib=/usr/local/zlib/lib/ --with-openssl=/usr/lib/i386-linux-gnu/

        The Error:
        checking for --enable-docs... yes
        checking for OpenSSL library (libcrypto.a)... Not found

        OpenSSL not found
        Use --with-openssl option to fix this problem

        ls -al /usr/lib/i386-linux-gnu/ | grep Libcrypto*
        -rw-r--r-- 1 root root 43648 Oct 5 2012 libcrypt.a
        -rw-r--r-- 1 root root 2963204 Mar 19 13:18 libcrypto.a
        lrwxrwxrwx 1 root root 38 Mar 19 13:18 libcrypto.so -> /lib/i386-linux-gnu/libcrypto.so.1.0.0
        lrwxrwxrwx 1 root root 33 Apr 18 21:00 libcrypt.so -> /lib/i386-linux-gnu/libcrypt.so.1

        So I'm kind of at a loss as to why it's not accepting it the path.

        Any Ideas ?

        73's Greg, KI7MT

      • ki7mt
        Hi Geoff, Thanks for the info. I m aware of the package that s available in the UB software center. This is just one element of a much larger project I m
        Message 3 of 4 , Apr 19, 2013
        • 0 Attachment
          Hi Geoff,

          Thanks for the info. I'm aware of the package that's available in the UB software center.

          This is just one element of a much larger project I'm working on that leverages the use of a packaging application packaging called checkinstall.

          The Deb/UB tqsllib maintainer got in touch with me regarding this issue so I'll probably get things sorted out there and I'll post the finding / final solution here when it's all ironed out.

          73's Greg, KI7MT


          --- In linuxham@yahoogroups.com, Geoff McAlpin <geoff.n7pgn@...> wrote:
          >
          > Greg,
          >
          > I'm using 12.04 as well and the TrustedQSL that is in the download center
          > works flawlessly for me. You should try that before compiling it from
          > source.
          >
          > Geoff, N7PGN
          > Seattle, WA
          > CN87tr
          > On Apr 19, 2013 1:20 AM, "ki7mt" <ki7mt@...> wrote:
          >
          > > **
          > >
          > >
          > > Hello All,
          > >
          > > This a cross post, as I posted over in LoTW as well, but thought I may
          > > have a shot over in the Linux specific house also.
          > >
          > > The Box: Fresh Install, Ubuntu 12.04.2. + updates, and a few packages
          > > added:
          > >
          > > gdebi build-essentials autoconf automake gfortran checkinstall cvs
          > > subversion git-core mercurial
          > >
          > > I'm trying to build TrustedQSL which requires tqsllib and the deps for
          > > that are openssl, expat and zlib of which all three were installed, zlib
          > > compiled from source 1.2.7.
          > >
          > > I've also installed libssl-dev, which pulled in zlib-dev. libssl-dev.
          > > ./configure is looking for (libcrypto.a), but it's not accepting it, even
          > > when the path is passed to it in ./configure.
          > >
          > > Configure
          > > ./configure --with-expat=/usr/lib/i386-linux-gnu/
          > > --with-zlib=/usr/local/zlib/lib/ --with-openssl=/usr/lib/i386-linux-gnu/
          > >
          > > The Error:
          > > checking for --enable-docs... yes
          > > checking for OpenSSL library (libcrypto.a)... Not found
          > >
          > > OpenSSL not found
          > > Use --with-openssl option to fix this problem
          > >
          > > ls -al /usr/lib/i386-linux-gnu/ | grep Libcrypto*
          > > -rw-r--r-- 1 root root 43648 Oct 5 2012 libcrypt.a
          > > -rw-r--r-- 1 root root 2963204 Mar 19 13:18 libcrypto.a
          > > lrwxrwxrwx 1 root root 38 Mar 19 13:18 libcrypto.so ->
          > > /lib/i386-linux-gnu/libcrypto.so.1.0.0
          > > lrwxrwxrwx 1 root root 33 Apr 18 21:00 libcrypt.so ->
          > > /lib/i386-linux-gnu/libcrypt.so.1
          > >
          > > So I'm kind of at a loss as to why it's not accepting it the path.
          > >
          > > Any Ideas ?
          > >
          > > 73's Greg, KI7MT
          > >
          > >
          > >
          >
        • ki7mt
          Hello all, Problem Solved. I got an email from one of the maintainers. There is series of patches that have been issued against tqsllib-2.2, it s now 2.2-5.
          Message 4 of 4 , Apr 20, 2013
          • 0 Attachment
            Hello all,

            Problem Solved. I got an email from one of the maintainers. There is series of patches that have been issued against tqsllib-2.2, it's now 2.2-5. One of the fixes is to allow allow / trust autoconf to find openssl, zlib and expat.

            trustedqsl-1.3 is now up to 1.3.3

            Get new sources:

            dget -u http://http.debian.net/debian/pool/main/t/trustedqsl/trustedqsl_1.13-3.dsc

            dget -u http://http.debian.net/debian/pool/main/t/tqsllib/tqsllib_2.2-5.dsc


            Will post over in LoTW as well.


            73s' Greg, KI7MT
          Your message has been successfully submitted and would be delivered to recipients shortly.