Loading ...
Sorry, an error occurred while loading the content.

Re: [linuxham] Re: WSJT-X for Linux

Expand Messages
  • D.J.J. Ring, Jr.
    Hello Berndt, I get this error: main.cpp:2:30: fatal error: QtGui/QApplication: No such file or directory #include ^ compilation
    Message 1 of 44 , Apr 5, 2013
    • 0 Attachment
      Hello Berndt,


      I get this error:

      main.cpp:2:30: fatal error: QtGui/QApplication: No such file or directory
       #include <QtGui/QApplication>
                                    ^
      compilation terminated.
      make: *** [main.o] Error 1

      Can you or anyone else point me in a good direction?  I am running Arch Linux.

      David N1EA

      Gopher Hole:  gopher://sdf.org/1/users/djringjr/ (native or with Firefox's Overbite extension) or via http to gopher gateway
      Chat Skype: djringjr MSN: djringjr@... AIM: N1EA icq: 27380609

      =30=


      On Sun, Mar 31, 2013 at 11:55 AM, Berndt Josef Wulf <wulf@...> wrote:
      G'day Dave,

      FYI: I've been successful in building and executing the binary on a Ubuntu
      12.04LTS x86-64 system, although not used on-the-air. No crashes, appears to be working fine.

      First built libjt9.a inside the wsjtx/lib folder using the following command

      make -f Makefile.linux

      Upon success, go into the wsjtx folder and use the following commands

      qmake
      make

      It will create a new folder, wsjtx_install, containing the binaries.

      Hope this helps

      73, Berndt
      VK5aBN

      On Sun, 2013-03-31 at 07:04 +0000, qrpbear wrote:
      > Dave,
      >
      > Within the WSJTX folder you will find the LIB subfolder. The LIB folder contains
      > a makefile for its contents which you can execute with...
      >
      > make -f Makefile.linux
      >
      > You may have to apt-get install gFortran to satisfy a dependency.
      >
      > The contents of the WSJTX folder are meant to be compiled with the QT qmake and make commands or by using QTCreator. The QT suite is obviously needed in order to do that and is available in most repositories.
      >
      > I have apparently been able to build but keep coming up with a segmentation error message when attempting to execute the program. Either I am doing something wrong or there is some incompatibility with Ubuntu 12.04 derivatives or something wrong with the source code. I don't know which.
      >
      > Good luck figuring it out... you are probably a whole lot better qualified than I.
      >
      > 73,
      >
      > 'Bear' NH7SR
      >
      > --- In linuxham@yahoogroups.com, Dave Wright <hfradiopro@...> wrote:
      > >
      > > All,
      > >
      > > Sorry for the cross-post, but this may be of interest to many.  According to the latest change notes for WSJT-X, it now can be compiled to run on Linux.  This opens up JT-9 modes for Linux users.
      > >
      > > I have downloaded the source code:  svn co svn://svn.berlios.de/wsjt/branches/wsjtx
      > >
      > > I have not attempted to build yet.  A quick glance indicates no makefile, so I'm not sure how to go about doing this.  So far, no word in the documentation about how to do it either, so I'll have to research some more.
      > >
      > >
      > > 73
      > >
      > > --
      > > Dave Wright
      > > K3DCW
      > > www.k3dcw.net
      > >
      > > "Real radio bounces off of the sky"
      > >
      >
      >
      >
      >
      > ------------------------------------
      >
      > Yahoo! Groups Links
      >
      >
      >



      ------------------------------------

      Yahoo! Groups Links

      <*> To visit your group on the web, go to:
          http://groups.yahoo.com/group/linuxham/

      <*> Your email settings:
          Individual Email | Traditional

      <*> To change settings online go to:
          http://groups.yahoo.com/group/linuxham/join
          (Yahoo! ID required)

      <*> To change settings via email:
          linuxham-digest@yahoogroups.com
          linuxham-fullfeatured@yahoogroups.com

      <*> To unsubscribe from this group, send an email to:
          linuxham-unsubscribe@yahoogroups.com

      <*> Your use of Yahoo! Groups is subject to:
          http://docs.yahoo.com/info/terms/


    • kc9lwk@sbcglobal.net
      ... Thanks, Bear, for the shm tip. That got me the GUI. Now to sort the audio stuff ... 73, Mike
      Message 44 of 44 , Apr 5, 2013
      • 0 Attachment
        --- In linuxham@yahoogroups.com, "qrpbear" <qrpbear@...> wrote:
        >
        > Mike,
        >
        > Edit your /etc/sysctl.conf file to reflect kernel.shmmax=268435456 to increase your shared memory space.
        >
        > You may also need to create an .asoundrc file in your Home directory. For my Icom 7200 with USB interface I am using...
        >
        > pcm.radio {
        > type hw
        > card 1
        > device 0
        > }
        > pcm_slave.radioslave {
        > pcm radio
        > rate 48000
        > }
        > pcm.radioconv {
        > type rate
        > slave radioslave
        > }
        >
        > That's what got it going for me albeit still in receive only mode.
        >
        > I got the info from Dave, VK4BDJ.
        >
        > 73,
        >
        > 'Bear' NH7SR
        >

        Thanks, Bear, for the shm tip. That got me the GUI. Now to sort the audio stuff ...

        73,
        Mike
      Your message has been successfully submitted and would be delivered to recipients shortly.