Loading ...
Sorry, an error occurred while loading the content.

Re: [linuxham] grig

Expand Messages
  • Ja BG
    Pierfrancesco, that s the solution of my problem. Now it works. My rig don t change to Tx state, now I need to tell the application that PTT must go with a CAT
    Message 1 of 10 , Mar 30, 2013
    • 0 Attachment
      Pierfrancesco,

      that's the solution of my problem. Now it works. My rig don't change to Tx state, now I need to tell the application that PTT must go with a CAT command.

      I had a question, how all this parameters and options are stored in some place, or file for use the next time or for use with fldgi

      Thanke you very much
       
      Ja

      From: Pierfrancesco Caci <ik5pvx@...>
      To: linuxham@yahoogroups.com
      Sent: Saturday, March 30, 2013 7:45 PM
      Subject: Re: [linuxham] grig

       
      in this case, you need to tell grig not to assert rts or dts, depending which pin of your serial interface is used as ptt. I had to do this with my old ts450, when using a microham usb2:

      rigctld  -m 203 -r /dev/ts450
         --set-conf=rts_state="OFF",dtr_state="OFF",serial_handshake="None",itu_region="2",write_delay="10"  -D NONE -s 4800

      you need to experiment with rts_state and dtr_state and find the combination that work for you

      Pf



      On Sat, Mar 30, 2013 at 7:02 PM, Ja BG <bg_ja@...> wrote:


      Yes I've changed my group ti dialout grroup, becaude //dev/ttyUSB3 was in dialout group. And now I don't need sudo. But my rig changes to tx mode whem i start gris with tje paràmeters. The freq seems it works.
      Thank's

       
      Ja

      From: Ed <autek@...>
      To: linuxham@yahoogroups.com
      Sent: Saturday, March 30, 2013 5:28 PM
      Subject: Re: [linuxham] grig

       
      On 03/30/2013 12:01 PM, ea3awk wrote:
      > Sorry, but I need help.I'm in debian squeeze, I'm new in linux and I'm
      > trying to use the hamlib control app by cat grig.
      > The commanf I'm using is:sudo grig --model=323 --rig-file=/dev/ttyUSB3
      > --speed=19200 --civaddr=86 --enable-ptt --enable-pwr --debug=3
      > --delay=500. And I've done a lot of combinations, and alway my ham
      > starts in tx mode and without control.
      > The model and address speed device all OK. I've tried to work with HRD
      > (HamRadiodeLuxe) app with wine emulator and a lot of things do'nt work
      > but the basic controls ok. Then is not a problem of the PC Hw.Someone
      > knows anything can help me.
      >
      >

      Try not running it as sudo.

      Ed W3NR







      --
       Pierfrancesco Caci, ik5pvx


    • w1hkj
      ... If you are expecting to use grig with fldigi then you should really be installing and running flrig, which is designed to be the companion transceiver
      Message 2 of 10 , Mar 30, 2013
      • 0 Attachment
        On 03/30/2013 02:59 PM, Ja BG wrote:
        Pierfrancesco,

        that's the solution of my problem. Now it works. My rig don't change to Tx state, now I need to tell the application that PTT must go with a CAT command.

        I had a question, how all this parameters and options are stored in some place, or file for use the next time or for use with fldgi

        Thanke you very much
         
        Ja
        If you are expecting to use grig with fldigi then you should really be installing and running flrig, which is designed to be the companion transceiver control program for fldigi.

        http://www.w1hkj.com/flrig-help/index.html

        Dave
      • ea3awk
        Do you know how to install in Debian. I don¡t find .deb. Is there any other way to do?
        Message 3 of 10 , Mar 30, 2013
        • 0 Attachment
          Do you know how to install in Debian. I don¡t find .deb. Is there any other way to do?




          --- In linuxham@yahoogroups.com, w1hkj <w1hkj@...> wrote:
          >
          > On 03/30/2013 02:59 PM, Ja BG wrote:
          > >
          > >
          > > Pierfrancesco,
          > >
          > > that's the solution of my problem. Now it works. My rig don't change
          > > to Tx state, now I need to tell the application that PTT must go with
          > > a CAT command.
          > >
          > > I had a question, how all this parameters and options are stored in
          > > some place, or file for use the next time or for use with fldgi
          > >
          > > Thanke you very much
          > > Ja
          > If you are expecting to use grig with fldigi then you should really be
          > installing and running flrig, which is designed to be the companion
          > transceiver control program for fldigi.
          >
          > http://www.w1hkj.com/flrig-help/index.html
          >
          > Dave
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.