Loading ...
Sorry, an error occurred while loading the content.

Re: [linuxham] cwdaemon install problem on Mint/Ubuntu

Expand Messages
  • Ed
    ... or here :: https://launchpad.net/~kamalmostafa/+archive/cwdaemon Ed
    Message 1 of 33 , Mar 12 4:55 AM
    • 0 Attachment
      On 03/12/2013 07:49 AM, Ed wrote:
      > On 03/12/2013 07:38 AM, David Toombs wrote:
      >> Hi I get:
      >>
      >> Couldn't find any package whose name or description matched "libcw5"
      >>
      >> When trying to run:
      >>
      >> sudo aptitude reinstall libcw5
      >>
      >>
      >> 73's de Dave, G8FXM
      >
      > Look here ::
      >
      > https://launchpad.net/~ubuntu-hams-updates/+archive/ppa
      >
      >
      > Ed W3NR
      >


      or here ::

      https://launchpad.net/~kamalmostafa/+archive/cwdaemon

      Ed
    • Ernest Wagner
      Dave, You stated that you installed unixcw-3.2.0. Was this a build/install from the source? If not, is there a development package from the distribution
      Message 33 of 33 , Mar 14 3:47 PM
      • 0 Attachment

        Dave,

        You stated that you "installed" unixcw-3.2.0.  Was this a build/install from the source?  If not, is there a development package from the distribution that needs to be installed? I'm not familiar with the debian based systems so I can't point it out to you.

        I built/installed both unixcw-3.2.0 and cwdaemon on my x86_64, Fedora 18 system, and it took a little work to discover the problem as I couldn't immediately configure cwdaemon.

        I think that as the name implies, unixcw was designed specifically for a unix/freebsd system and that system architecture is a little different from most Linux systems. Unix/Freebsd  uses /lib or /usr/lib for both 32 bit and 64 bit libraries.  cwdaemon, on an x86_64 system, correctly expects the libs and libcw.pc file to be in a lib64 folder

        You might give building/installing another try keeping the above information in mind when configuring the builds.

        To compile unixcw for an x86_64 system

        ./configure --libpath=/usr/lib64       #installs executable and other files to default prefix (/usr/local) and libs to /usr/lib64 and libcw.pc to /usr/lib/pkgconfig/

        It doesn't matter too much where you install the executable and other files, but on a Linux system, I believe libraries must be in the "known" library paths (/lib, lib64, /usr/lib and /usr/lib64).

        Don't forget to run ldconfig before trying to run the cwdaemon or you will still get the missing libcw.so.5.0.0 error.

        I haven't actually tried to use it as I don't have the correct hardware, but it does start up without any error messagesl.

        73,

        Ernie D in AA1AD in Federal Way WA


        On Tue, 2013-03-12 at 15:20 +0000, David Toombs wrote:
         
        Strange thing is I've installed the unixcw-3.2.0 lib but still get the missing libcw5 error ?


        73's de Dave, G8FXM




        On 12/03/13 14:26, Brian Morrison wrote:

         
        On Tue, 12 Mar 2013 13:06:40 +0000
        David Toombs wrote:

        > Couldn't find any package whose name or description matched "libcw5"

        Isn't unixcw the package name you need? I believe that the unixcw-3.2.0
        is the latest and provides the libcw5 library.

        --

        Brian Morrison










      Your message has been successfully submitted and would be delivered to recipients shortly.