Loading ...
Sorry, an error occurred while loading the content.

Re: [linuxham] cwdaemon install problem on Mint/Ubuntu

Expand Messages
  • David A. Ranch
    Hello David, Did you install your unixcw package as a Debian package or just from raw sources? I d guess that the cwdaemon isn t finding where it s libraries
    Message 1 of 33 , Mar 6, 2013
    • 0 Attachment

      Hello David,

      Did you install your  unixcw package as a Debian package or just from raw sources?  I'd guess that the cwdaemon isn't finding where it's libraries are installed per the pkg-config system or ldd.  Before you run cwdaemon's configure script, explore forcing the libs to be found using something like:

         export LIBS=/usr/lib/cwdaemon    #just guessing the path here


      On 03/06/2013 03:06 PM, David Toombs wrote:
      Hi Ed,
      I've already been here:


      this is where I downloaded
      cwdaemon0.9.7 from, however It doesn't install on my Mint 14 PC due to the lack of libcw5previously described.

      73's de Dave, G8FXM

      On 06/03/13 12:14, Ed wrote:

      On 03/06/2013 06:39 AM, David Toombs wrote:
      > I'm currently trying to install the latest version of cwdaemon 0.9.7.
      > When I run ./configure I see the following error:
      > Can't find libcw5 from unixcw package.
      > I found via Google that for some reason Ubuntu have removed the unixcw
      > lib from it's distro.
      > So I ran:
      > git clone git://git.code.sf.net/p/unixcw/code unixcw-code
      > to reinstall it, however ./configure still reports, Can't find libcw5
      > from unixcw package.
      > Has anyone managed to install cwdaemon 0.9.7 on a Linux Mint 14 PC.
      > I'ts not a big issue as I have cwdaemon 0.9.4 running however due to the
      > lack of libcw5 output to the sound card doesn't work.


      via Google

      Ed W3NR

    • Ernest Wagner
      Dave, You stated that you installed unixcw-3.2.0. Was this a build/install from the source? If not, is there a development package from the distribution
      Message 33 of 33 , Mar 14, 2013
      • 0 Attachment


        You stated that you "installed" unixcw-3.2.0.  Was this a build/install from the source?  If not, is there a development package from the distribution that needs to be installed? I'm not familiar with the debian based systems so I can't point it out to you.

        I built/installed both unixcw-3.2.0 and cwdaemon on my x86_64, Fedora 18 system, and it took a little work to discover the problem as I couldn't immediately configure cwdaemon.

        I think that as the name implies, unixcw was designed specifically for a unix/freebsd system and that system architecture is a little different from most Linux systems. Unix/Freebsd  uses /lib or /usr/lib for both 32 bit and 64 bit libraries.  cwdaemon, on an x86_64 system, correctly expects the libs and libcw.pc file to be in a lib64 folder

        You might give building/installing another try keeping the above information in mind when configuring the builds.

        To compile unixcw for an x86_64 system

        ./configure --libpath=/usr/lib64       #installs executable and other files to default prefix (/usr/local) and libs to /usr/lib64 and libcw.pc to /usr/lib/pkgconfig/

        It doesn't matter too much where you install the executable and other files, but on a Linux system, I believe libraries must be in the "known" library paths (/lib, lib64, /usr/lib and /usr/lib64).

        Don't forget to run ldconfig before trying to run the cwdaemon or you will still get the missing libcw.so.5.0.0 error.

        I haven't actually tried to use it as I don't have the correct hardware, but it does start up without any error messagesl.


        Ernie D in AA1AD in Federal Way WA

        On Tue, 2013-03-12 at 15:20 +0000, David Toombs wrote:
        Strange thing is I've installed the unixcw-3.2.0 lib but still get the missing libcw5 error ?

        73's de Dave, G8FXM

        On 12/03/13 14:26, Brian Morrison wrote:

        On Tue, 12 Mar 2013 13:06:40 +0000
        David Toombs wrote:

        > Couldn't find any package whose name or description matched "libcw5"

        Isn't unixcw the package name you need? I believe that the unixcw-3.2.0
        is the latest and provides the libcw5 library.


        Brian Morrison

      Your message has been successfully submitted and would be delivered to recipients shortly.