Loading ...
Sorry, an error occurred while loading the content.

Re: FLDigi & Slackware

Expand Messages
  • jhaynesatalumni
    Have you tried the ldd command to see if any needed libraries are missing?
    Message 1 of 8 , Feb 23, 2013
    • 0 Attachment
      Have you tried the ldd command to see if any needed libraries
      are missing?
    • bobsch59
      Well, there s no terminal output since fldigi is running under X. I downloaded the latest binary tar.gz, which should not need the dev libraries. The online
      Message 2 of 8 , Feb 23, 2013
      • 0 Attachment
        Well, there's no terminal output since fldigi is running under X. I downloaded the latest binary tar.gz, which should not need the dev libraries.

        The online documentation called out PortAudio as a required library. I pulled that one in and built it...make check claimed that the installation was good.

        I wonder if there might have been a problem with the order I installed stuff. Since it's a fresh install, I might just do it over.

        --- In linuxham@yahoogroups.com, Ed <autek@...> wrote:
        >
        > On 02/23/2013 01:07 PM, bobsch59 wrote:
        > > I am actually having problems getting fldigi to start up on Slackware
        > > 14. I was using it with great success on Debian squeeze but just went
        > > back to Slack (I started with Slackware; the last version I ran was
        > > 10.0. The Debian habit of being behind the times with libraries in
        > > stable was causing me too much problems with other applications) and
        > > she won't start up. I obtained the hamlib, libsamplerate and
        > > PortAudio and got them built and installed correctly. My existing
        > > .fldigi directory is still in my home directory.
        > >
        > > Any hints?
        >
        > Well some terminal output might get some help from the list, right now
        > its anyone's guess.
        >
        > Default sound is Pulse, not Portaudio.
        >
        > Did you install all the needed -dev libraries ?
        >
        > Ed W3NR
        >
      • bobsch59
        I always forget that. I ll see what led tells me.
        Message 3 of 8 , Feb 23, 2013
        • 0 Attachment
          I always forget that. I'll see what led tells me.

          --- In linuxham@yahoogroups.com, jhhaynes@... wrote:
          >
          > Have you tried the ldd command to see if any needed libraries
          > are missing?
          >
        • Bob Snyder
          ... Open a terminal window and enter fldigi and then . The messages produced might be a big clue to the problem. ... I use fldigi with Port Audio
          Message 4 of 8 , Feb 23, 2013
          • 0 Attachment
            On 02/23/2013 08:16 PM, bobsch59 wrote:
            > Well, there's no terminal output since fldigi is running under X. I downloaded the latest binary tar.gz, which should not need the dev libraries.

            Open a terminal window and enter 'fldigi' and then <Enter>. The messages
            produced might be a big clue to the problem.

            > The online documentation called out PortAudio as a required library. I pulled that one in and built it...make check claimed that the installation was good.
            >

            I use fldigi with Port Audio under Slackware (13.37) and it works fine.
            Slackware has notoriously had problems with Pulse Audio.

            Bob W6CP
          • bobsch59
            As it turned out, fldigi was demanding PulseAudio. Once I had that and json built and installed fldigi came right up. Thanks everyone for the tips.
            Message 5 of 8 , Feb 24, 2013
            • 0 Attachment
              As it turned out, fldigi was demanding PulseAudio. Once I had that and json built and installed fldigi came right up. Thanks everyone for the tips.

              --- In linuxham@yahoogroups.com, "w4lkk4icx" <lkirkland@...> wrote:
              >
              > I just did a fresh install of Slackware 14.0 and the latest Fldigi. It runs great with zero problems. For some reason Pulseaudio and Slackware have never coexisted nicely, but with this new 14.0 release all is happiness and joy. See on the digital modes!
              > Larry W4LK
              >
            Your message has been successfully submitted and would be delivered to recipients shortly.