Loading ...
Sorry, an error occurred while loading the content.

Re: [linuxham] bios problem help? OT?

Expand Messages
  • romers romansky
    Hi Rick... your post gave me a few ideas. I opened the machine -- indeed there are two EIDE connectors on the MOBO, but they go to the same controller. Only
    Message 1 of 3 , Nov 7, 2007
    • 0 Attachment
      Hi Rick... your post gave me a few ideas. I opened the
      machine -- indeed there are two EIDE connectors on the
      MOBO, but they go to the same controller. Only one
      controller of the two are being used. So, I don't
      think that's an issue. The board layout gives each
      connector the same number.

      Snooping around the BIOS, I find in Enhanced mode,
      both drives are seen by the bios, so I made the
      windows drive a slave of the linux drive and the
      system booted linux ok.

      The linux disk is sda and now fdisk reports a sdb1
      present with an ntfs file system, sdb2 with an win95
      extended partition and sdb5 with a FAT32 partition.

      This is as much progress as I've made in a long time
      playing with the problem.

      OK, that said, doing a 'mount -t ntfs /dev/sdb1 /ntfs'
      doesn't' work. It reports the usual probable errors:
      wrong file system, bad super block, etc. Then I tried
      to mount sdb5 and that worked. So now I'm wondering if
      the kernel has NTFS support engaged?????

      Dmesg shows that the system tried to mount the ntfs
      drive but couldn't.

      I've made custom kernels in Slackware, but never in
      suse, so I don't know what tools are available to look
      and see if the NTFS support is there or not. Suse just
      worked for me except for this, so I never paid much
      attention to it as a distro.

      Any ideas?
      jerome - va7vv

      --- Rick Kunath <k9ao@...> wrote:

      > jerome wrote:
      > > I would dearly love to install the new Digipup on
      > a usb drive. Going
      > > back in the archives of this group, it seems it
      > can be done.
      > >
      > > But first, I thought I'd better try and solve a
      > niggling bios problem
      > > that might be in the way of booting from such a
      > drive.
      > >
      > > Here's my setup:
      > > Asus mobo: p5gd1-vm; bios: ami ver.1402 11/18/2005
      > (latest)
      > > p4-3 Ghz cpu; 500 megs of ram.
      > > two 160 gig SATA drives (one with xp-pro, the
      > other with suse-10.0).
      > >
      > > Here's my problem: There are two bios IDE
      > configurations: Enhanced
      > > mode and Compatibility mode. For either, there are
      > three choices of
      > > native mode drive setup (i.e. PATA, SATA and
      > Primary P-ATA+S-AT in
      > > Compatible mode; or PATA, SATA, and S-ATA+P-ATA in
      > Enhanced mode. Add
      > > to that I can specify which HD is drive one and
      > which is drive two
      > > and you have ....mmmm 12 combinations?
      >
      > I see that motherboard has but one EIDE connector
      > (two devices) on the
      > mainboard, with another (two devices) on a second
      > controller connector.
      > This isn't the usual EIDE 0 and 1 setup on the same
      > controller (4
      > devices on two connectors.) Are both kernel modules
      > getting loaded for
      > both EIDE controllers?
      >
      > I also see you have 4 SATA connectors on the board.
      >
      > What I've done in the past on Intel hardware was to
      > put the DVD recorder
      > on the EIDE controller, and set the SATA controller
      > to EIDE emulation
      > mode, making sure not to use the next to useless
      > software raid if there
      > is any.
      >
      > I've never had any issues booting between several
      > Linux distros and XP
      > so far. Maybe someone else will have better ideas
      > for your particular
      > hardware.
      >
      > Rick Kunath, k9ao
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.