Loading ...
Sorry, an error occurred while loading the content.

fldigi --wfall-only

Expand Messages
  • Darren Long
    3.21.50 installed by distro will run with --wfall-only option. 3.21.67 built from source will not run with --wfall-only option, and reports: Caught signal 11
    Message 1 of 14 , Feb 3, 2013
    • 0 Attachment
      3.21.50 installed by distro will run with --wfall-only option.

      3.21.67 built from source will not run with --wfall-only option, and
      reports:
      Caught signal 11
      Aborting fldigi due to a fatal error

      Any idea why this might be?

      Cheers,

      Darren, G0HWW
    • Ed
      ... Cannot repeat this here. 3.21.67 built from source on Lubuntu 12.10. I used this syntax:: fldigi --wfall-only Did you have any problems building fldigi ?
      Message 2 of 14 , Feb 3, 2013
      • 0 Attachment
        On 02/03/2013 08:53 AM, Darren Long wrote:
        > 3.21.50 installed by distro will run with --wfall-only option.
        >
        > 3.21.67 built from source will not run with --wfall-only option, and
        > reports:
        > Caught signal 11
        > Aborting fldigi due to a fatal error
        >
        > Any idea why this might be?
        >
        > Cheers,
        >
        > Darren, G0HWW
        >

        Cannot repeat this here. 3.21.67 built from source on Lubuntu 12.10. I
        used this syntax:: fldigi --wfall-only

        Did you have any problems building fldigi ? What FLTK version did you
        use ? And on what distro ?

        Ed W3NR
      • Darren Long
        I m on Ubuntu 12.10 x86_64. Running /usr/bin/fldigi --wfall-only gets the desired behaviour from the distro default version. I used apt-get build-dep to get
        Message 3 of 14 , Feb 3, 2013
        • 0 Attachment
          I'm on Ubuntu 12.10 x86_64. Running

          /usr/bin/fldigi --wfall-only

          gets the desired behaviour from the distro default version. I used
          "apt-get build-dep" to get the dependencies, and build for an install in
          /usr/local. The build is unproblematic and fldigi otherwise runs
          flawlessly, including use with jPSKmail v1.

          The full output from the failure is below. I could rebuild it for
          debugging I guess.

          Cheers,

          Darren, G0HWW

          darren@len:~$ /usr/local/bin/fldigi --wfall-only
          I: main: appname: /usr/local/bin/fldigi
          I: main: Test file (nil)
          I: main: /usr/local/bin/NBEMS.DIR not present
          I: main: HomeDir: /home/darren/.fldigi/
          I: main: RigsDir: /home/darren/.fldigi/rigs/
          I: main: ScriptsDir: /home/darren/.fldigi/scripts/
          I: main: PalettesDir: /home/darren/.fldigi/palettes/
          I: main: LogsDir: /home/darren/.fldigi/logs/
          I: main: PicsDir: /home/darren/.fldigi/images/
          I: main: HelpDir: /home/darren/.fldigi/help/
          I: main: MacrosDir: /home/darren/.fldigi/macros/
          I: main: WrapDir: /home/darren/.fldigi/wrap/
          I: main: TalkDir: /home/darren/.fldigi/talk/
          I: main: TempDir: /home/darren/.fldigi/temp/
          I: main: PskMailDir: /home/darren/
          I: main: NBEMS_dir: /home/darren/.nbems/
          I: main: ARQ_dir: /home/darren/.nbems/ARQ/
          I: main: ARQ_files_dir: /home/darren/.nbems/ARQ/files/
          I: main: ARQ_recv_dir: /home/darren/.nbems/ARQ/recv/
          I: main: ARQ_send: /home/darren/.nbems/ARQ/send/
          I: main: WRAP_dir: /home/darren/.nbems/WRAP/
          I: main: WRAP_recv_dir: /home/darren/.nbems/WRAP/recv/
          I: main: WRAP_send_dir: /home/darren/.nbems/WRAP/send/
          I: main: WRAP_auto_dir: /home/darren/.nbems/WRAP/auto/
          I: main: ICS_dir: /home/darren/.nbems/ICS/
          I: main: ICS_msg_dir: /home/darren/.nbems/ICS/messages/
          I: main: ICS_tmp_dir: /home/darren/.nbems/ICS/templates/
          I: main: FLMSG_dir: /home/darren/.nbems/
          I: main: FLMSG_dir_default: /home/darren/.nbems/
          I: main: FLMSG_WRAP_dir: /home/darren/.nbems/WRAP/
          I: main: FLMSG_WRAP_recv_dir: /home/darren/.nbems/WRAP/recv/
          I: main: FLMSG_WRAP_send_dir: /home/darren/.nbems/WRAP/send/
          I: main: FLMSG_WRAP_auto_dir: /home/darren/.nbems/WRAP/auto/
          I: main: FLMSG_ICS_dir: /home/darren/.nbems/ICS/
          I: main: FLMSG_ICS_msg_dir: /home/darren/.nbems/ICS/messages/
          I: main: FLMSG_ICS_tmp_dir: /home/darren/.nbems/ICS/templates/
          I: testCommPorts: Found serial port /dev/ttyS0
          I: testCommPorts: Found serial port /dev/ttyS1
          I: testCommPorts: Found serial port /dev/ttyS2
          I: testCommPorts: Found serial port /dev/ttyS3
          I: testCommPorts: Found serial port /dev/ttyS4
          I: testCommPorts: Found serial port /dev/ttyS5
          I: testCommPorts: Found serial port /dev/ttyS6
          I: testCommPorts: Found serial port /dev/ttyS7
          I: testCommPorts: Found serial port /dev/ttyS8
          I: testCommPorts: Found serial port /dev/ttyS9
          I: testCommPorts: Found serial port /dev/ttyUSB0
          I: testCommPorts: Found serial port /dev/ttyUSB1
          I: testCommPorts: Found serial port /dev/ttyS10
          I: testCommPorts: Found serial port /dev/ttyS11
          I: testCommPorts: Found serial port /dev/ttyS12
          I: testCommPorts: Found serial port /dev/ttyS13
          I: testCommPorts: Found serial port /dev/ttyS14
          I: testCommPorts: Found serial port /dev/ttyS15
          I: testCommPorts: Found serial port /dev/ttyS16
          I: testCommPorts: Found serial port /dev/ttyS17
          I: testCommPorts: Found serial port /dev/ttyS18
          I: testCommPorts: Found serial port /dev/ttyS19
          I: testCommPorts: Found serial port /dev/ttyS20
          I: testCommPorts: Found serial port /dev/ttyS21
          I: testCommPorts: Found serial port /dev/ttyS22
          I: testCommPorts: Found serial port /dev/ttyS23
          I: testCommPorts: Found serial port /dev/ttyS24
          I: testCommPorts: Found serial port /dev/ttyS25
          I: testCommPorts: Found serial port /dev/ttyS26
          I: testCommPorts: Found serial port /dev/ttyS27
          I: testCommPorts: Found serial port /dev/ttyS28
          I: testCommPorts: Found serial port /dev/ttyS29
          I: testCommPorts: Found serial port /dev/ttyS30
          I: testCommPorts: Found serial port /dev/ttyS31
          I: loadDefault: macro file name: /home/darren/.fldigi/macros/macros.mdf
          I: loadDefault: loading: /home/darren/.fldigi/macros/macros.mdf
          ALSA lib pcm_dsnoop.c:612:(snd_pcm_dsnoop_open) unable to open slave
          ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
          ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
          ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
          ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
          ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition
          'cards.USB-Audio.pcm.hdmi.0:CARD=0,AES0=4,AES1=130,AES2=0,AES3=2'
          ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_refer
          returned error: No such file or directory
          ALSA lib conf.c:4720:(snd_config_expand) Evaluate error: No such file or
          directory
          ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM hdmi
          ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition
          'cards.USB-Audio.pcm.hdmi.0:CARD=0,AES0=4,AES1=130,AES2=0,AES3=2'
          ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_refer
          returned error: No such file or directory
          ALSA lib conf.c:4720:(snd_config_expand) Evaluate error: No such file or
          directory
          ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM hdmi
          ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition
          'cards.USB-Audio.pcm.modem.0:CARD=0'
          ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_refer
          returned error: No such file or directory
          ALSA lib conf.c:4720:(snd_config_expand) Evaluate error: No such file or
          directory
          ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM
          cards.pcm.phoneline:CARD=0,DEV=0
          ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition
          'cards.USB-Audio.pcm.modem.0:CARD=0'
          ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_refer
          returned error: No such file or directory
          ALSA lib conf.c:4720:(snd_config_expand) Evaluate error: No such file or
          directory
          ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM
          cards.pcm.phoneline:CARD=0,DEV=0
          ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition
          'cards.USB-Audio.pcm.modem.0:CARD=0'
          ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_refer
          returned error: No such file or directory
          ALSA lib conf.c:4720:(snd_config_expand) Evaluate error: No such file or
          directory
          ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM phoneline
          ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition
          'cards.USB-Audio.pcm.modem.0:CARD=0'
          ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_refer
          returned error: No such file or directory
          ALSA lib conf.c:4720:(snd_config_expand) Evaluate error: No such file or
          directory
          ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM phoneline
          ALSA lib audio/pcm_bluetooth.c:1614:(audioservice_expect)
          BT_GET_CAPABILITIES failed : Input/output error(5)
          ALSA lib audio/pcm_bluetooth.c:1614:(audioservice_expect)
          BT_GET_CAPABILITIES failed : Input/output error(5)
          ALSA lib audio/pcm_bluetooth.c:1614:(audioservice_expect)
          BT_GET_CAPABILITIES failed : Input/output error(5)
          ALSA lib audio/pcm_bluetooth.c:1614:(audioservice_expect)
          BT_GET_CAPABILITIES failed : Input/output error(5)
          ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports
          only playback stream
          ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
          I: ADIF_RW_init: Starting logbook r/w thread
          I: do_readfile: Reading /home/darren/.fldigi/logs/newlog.adif
          I: do_readfile: Reading 36052 bytes from newlog.adif
          I: do_readfile: Read 140 records in 0.00 seconds

          Caught signal 11
          Aborting fldigi due to a fatal error.
          Please report this to: fldigi-devel@...
          or file a bug report at: https://fedorahosted.org/fldigi/newticket

          ****** Stack trace:
          /usr/local/bin/fldigi[0x528d52]
          /usr/local/bin/fldigi[0x528ef3]
          /lib/x86_64-linux-gnu/libpthread.so.0(+0xfcb0)[0x7f597d9c4cb0]
          /usr/local/bin/fldigi[0x50ed36]
          /usr/local/bin/fldigi[0x4751ac]
          /usr/local/bin/fldigi[0x475395]
          /usr/local/bin/fldigi[0x48cb72]
          /usr/local/bin/fldigi[0x552738]
          /usr/lib/x86_64-linux-gnu/libfltk.so.1.3(_Z7fl_waitd+0x430)[0x7f597d507ac0]
          /usr/lib/x86_64-linux-gnu/libfltk.so.1.3(_ZN2Fl4waitEd+0x120)[0x7f597d4b17b0]
          /usr/lib/x86_64-linux-gnu/libfltk.so.1.3(_ZN2Fl3runEv+0x1d)[0x7f597d4b191d]
          /usr/local/bin/fldigi[0x419a22]
          /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xed)[0x7f597ace776d]
          /usr/local/bin/fldigi[0x41dacd]

          ****** Version information:
          fldigi 3.21.67
          Copyright (C) 2007-2010 Dave Freese, Stelios Bounanos, Leigh Klotz, Remi
          Chateauneu, and others.
          License GPLv3+: GNU GPL version 3 or later
          <http://www.gnu.org/licenses/gpl-3.0.html>
          This is free software: you are free to change and redistribute it.
          There is NO WARRANTY, to the extent permitted by law.

          ****** Build information:
          Build information:
          built : Sat Feb 2 20:30:08 GMT 2013 by darren@len on
          x86_64-unknown-linux-gnu for x86_64-unknown-linux-gnu

          configure flags: '--prefix=/usr/local' '--enable-optimizations=native'
          'PKG_CONFIG_PATH=/usr/local/lib64/pkgconfig'

          compiler : gcc version 4.7.2 (Ubuntu/Linaro 4.7.2-2ubuntu1)

          compiler flags : -I$(srcdir) -I$(srcdir)/include -I$(srcdir)/irrxml
          -I$(srcdir)/libtiniconv -I$(srcdir)/fileselector -I$(srcdir)/xmlrpcpp
          -pthread -I/usr/include/cairo -I/usr/include/glib-2.0
          -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1
          -I/usr/include/freetype2 -I/usr/include/libpng12
          -I/usr/include/freetype2 -I/usr/include/cairo -I/usr/include/glib-2.0
          -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1
          -I/usr/include/freetype2 -I/usr/include/libpng12 -D_LARGEFILE_SOURCE
          -D_LARGEFILE64_SOURCE -D_THREAD_SAFE -D_REENTRANT -D_REENTRANT
          -I/usr/include/libpng12 -I/usr/include -pipe -Wall -fexceptions -O2
          -ffast-math -finline-functions -march=native -mfpmath=sse -DNDEBUG

          linker flags : -lportaudio -lasound -lm -lpthread
          -L/usr/lib/x86_64-linux-gnu -Wl,-Bsymbolic-functions -lfltk_images
          -lfltk -lX11 -lsndfile -lsamplerate -lpulse-simple -lpulse -lhamlib -lm
          -lpng12 -L/usr/lib -lxmlrpc_server_abyss++ -lxmlrpc_server++
          -lxmlrpc_server_abyss -lxmlrpc_server -lxmlrpc_abyss -lxmlrpc++ -lxmlrpc
          -lxmlrpc_util -lxmlrpc_xmlparse -lxmlrpc_xmltok -ldl -lrt -lpthread

          libraries : FLTK 1.3.0
          libsamplerate 0.1.8
          libsndfile 1.0.25
          PortAudio 19
          PulseAudio 2.1
          Hamlib 1.2.15.2
          XMLRPC-C 1.16.33


          Runtime information:
          system : Linux len 3.5.0-22-generic #34-Ubuntu SMP Tue Jan 8
          21:47:00 UTC 2013 x86_64

          libraries : libsamplerate-0.1.8 (c) 2002-2008 Erik de Castro Lopo
          libsndfile-1.0.25
          PortAudio V19-devel (built Oct 8 2012 16:37:35) 1899
          Pulseaudio 2.1.0
          Hamlib 1.2.15.2




          On 03/02/13 14:01, Ed wrote:
          > Cannot repeat this here. 3.21.67 built from source on Lubuntu 12.10. I
          > used this syntax:: fldigi --wfall-only Did you have any problems
          > building fldigi ? What FLTK version did you use ? And on what distro ?
          > Ed W3NR
        • Ed
          ... Yep, typical build. Look and make sure you have libltk-dev installed and if so make sure its 1.3. You can use gdb to pinpoint the problem. Ed W3NR
          Message 4 of 14 , Feb 3, 2013
          • 0 Attachment
            On 02/03/2013 09:11 AM, Darren Long wrote:
            > I'm on Ubuntu 12.10 x86_64. Running
            >
            > /usr/bin/fldigi --wfall-only
            >
            > gets the desired behaviour from the distro default version. I used
            > "apt-get build-dep" to get the dependencies, and build for an install in
            > /usr/local. The build is unproblematic and fldigi otherwise runs
            > flawlessly, including use with jPSKmail v1.
            >
            > The full output from the failure is below. I could rebuild it for
            > debugging I guess.
            >
            > Cheers,
            >
            > Darren, G0HWW


            > ****** Stack trace:

            > /usr/lib/x86_64-linux-gnu/libfltk.so.1.3(_Z7fl_waitd+0x430)[0x7f597d507ac0]
            > /usr/lib/x86_64-linux-gnu/libfltk.so.1.3(_ZN2Fl4waitEd+0x120)[0x7f597d4b17b0]
            > /usr/lib/x86_64-linux-gnu/libfltk.so.1.3(_ZN2Fl3runEv+0x1d)[0x7f597d4b191d]

            Yep, typical build. Look and make sure you have libltk-dev installed and
            if so make sure its 1.3.

            You can use gdb to pinpoint the problem.

            Ed W3NR
          • Ed
            That should be libfltk-dev. Sorry
            Message 5 of 14 , Feb 3, 2013
            • 0 Attachment
              That should be libfltk-dev. Sorry
            • Darren Long
              Ah interesting: darren@len:~$ sudo apt-get install libfltk-dev Reading package lists... Done Building dependency tree Reading state information... Done Package
              Message 6 of 14 , Feb 3, 2013
              • 0 Attachment
                Ah interesting:

                darren@len:~$ sudo apt-get install libfltk-dev
                Reading package lists... Done
                Building dependency tree
                Reading state information... Done
                Package libfltk-dev is a virtual package provided by:
                libfltk1.3-dev 1.3.0-8
                libfltk1.1-dev 1.1.10-14
                You should explicitly select one to install.


                Darren, G0HWW

                On 03/02/13 14:23, Ed wrote:
                > That should be libfltk-dev. Sorry
                >
              • Darren Long
                Oh. Not interesting at all. libfltk1.3-dev was already installed, I was just being silly. On to the debug build. Darren
                Message 7 of 14 , Feb 3, 2013
                • 0 Attachment
                  Oh. Not interesting at all. libfltk1.3-dev was already installed, I was
                  just being silly. On to the debug build.

                  Darren

                  On 03/02/13 14:40, Darren Long wrote:
                  > Ah interesting:
                  >
                  > darren@len:~$ sudo apt-get install libfltk-dev
                  > Reading package lists... Done
                  > Building dependency tree
                  > Reading state information... Done
                  > Package libfltk-dev is a virtual package provided by:
                  > libfltk1.3-dev 1.3.0-8
                  > libfltk1.1-dev 1.1.10-14
                  > You should explicitly select one to install.
                  >
                  >
                  > Darren, G0HWW
                  >
                  > On 03/02/13 14:23, Ed wrote:
                  >> That should be libfltk-dev. Sorry
                  >>
                  >
                • Ed
                  ... Remove the 1.1 version. Ed
                  Message 8 of 14 , Feb 3, 2013
                  • 0 Attachment
                    On 02/03/2013 09:40 AM, Darren Long wrote:
                    > Ah interesting:
                    >
                    > darren@len:~$ sudo apt-get install libfltk-dev
                    > Reading package lists... Done
                    > Building dependency tree
                    > Reading state information... Done
                    > Package libfltk-dev is a virtual package provided by:
                    > libfltk1.3-dev 1.3.0-8
                    > libfltk1.1-dev 1.1.10-14
                    > You should explicitly select one to install.
                    >
                    >
                    > Darren, G0HWW
                    >
                    > On 03/02/13 14:23, Ed wrote:
                    >> That should be libfltk-dev. Sorry
                    >>
                    >
                    >

                    Remove the 1.1 version.

                    Ed
                  • Ed
                    ... I build fltk from source. Just because Ubuntu, all flavors, insist on having both versions. fldigi wants to see 1.3 Ed W3NR
                    Message 9 of 14 , Feb 3, 2013
                    • 0 Attachment
                      On 02/03/2013 09:43 AM, Darren Long wrote:
                      > Oh. Not interesting at all. libfltk1.3-dev was already installed, I was
                      > just being silly. On to the debug build.
                      >
                      > Darren

                      I build fltk from source. Just because Ubuntu, all flavors, insist on
                      having both versions. fldigi wants to see 1.3

                      Ed W3NR
                    • Darren Long
                      Some results from gdb. It seems that having Text Capture enabled is the culprit. If I disable that, wfall-only works fine. The back trace shows a null this
                      Message 10 of 14 , Feb 3, 2013
                      • 0 Attachment
                        Some results from gdb. It seems that having Text Capture enabled is the
                        culprit. If I disable that, wfall-only works fine. The back trace
                        shows a null this pointer which is bound to cause disappointment.
                        Debugger output below.

                        Darren, G0HWW

                        Program received signal SIGSEGV, Segmentation fault.
                        0x00000000006c6026 in cLogfile::log_to_file (this=0x0,
                        type=cLogfile::LOG_RX, s=...) at misc/log.cxx:63
                        63 if (!logfile || ferror(logfile) || s.empty())
                        (gdb) bt
                        #0 0x00000000006c6026 in cLogfile::log_to_file (this=0x0,
                        type=cLogfile::LOG_RX, s=...) at misc/log.cxx:63
                        #1 0x000000000061ba20 in display_rx_data (data=114 'r', style=0) at
                        dialogs/fl_digi.cxx:6101
                        #2 0x000000000061bb48 in rx_parser (data=114 'r', style=0) at
                        dialogs/fl_digi.cxx:6131
                        #3 0x000000000061bdb7 in put_rx_char_flmain (data=114, style=0) at
                        dialogs/fl_digi.cxx:6193
                        #4 0x00000000006249e8 in std::tr1::_Bind<void (*(unsigned int,
                        int))(unsigned int, int)>::__call<, 0, 1>(std::tr1::tuple<> const&,
                        std::tr1::_Index_tuple<0, 1>) (
                        this=0x7fffef105198, __args=...) at
                        /usr/include/c++/4.7/tr1/functional:1179
                        #5 0x0000000000622a6e in std::tr1::_Bind<void (*(unsigned int,
                        int))(unsigned int, int)>::operator()<>() (this=0x7fffef105198)
                        at /usr/include/c++/4.7/tr1/functional:1233
                        #6 0x00000000006297b5 in func_wrap<std::tr1::_Bind<void (*(unsigned
                        int, int))(unsigned int, int)> >::destroy(bool) (this=0x7fffef105190,
                        run=true)
                        at ./qrunner/fqueue.h:48
                        #7 0x0000000000719f33 in fqueue::pop (this=0xbafa60, exec=true) at
                        qrunner/fqueue.h:96
                        #8 0x0000000000719f71 in fqueue::execute (this=0xbafa60) at
                        qrunner/fqueue.h:102
                        #9 0x0000000000719db8 in qrunner::execute (fd=7, arg=0xbafa40) at
                        qrunner/qrunner.cxx:107
                        #10 0x00007ffff74e0ac0 in fl_wait(double) () from
                        /usr/lib/x86_64-linux-gnu/libfltk.so.1.3
                        #11 0x00007ffff748a7b0 in Fl::wait(double) () from
                        /usr/lib/x86_64-linux-gnu/libfltk.so.1.3
                        #12 0x00007ffff748a91d in Fl::run() () from
                        /usr/lib/x86_64-linux-gnu/libfltk.so.1.3
                        #13 0x0000000000681cd1 in main (argc=2, argv=0x7fffffffe0a8) at main.cxx:533


                        On 03/02/13 14:48, Ed wrote:
                        > On 02/03/2013 09:40 AM, Darren Long wrote:
                        >> Ah interesting:
                        >>
                        >> darren@len:~$ sudo apt-get install libfltk-dev
                        >> Reading package lists... Done
                        >> Building dependency tree
                        >> Reading state information... Done
                        >> Package libfltk-dev is a virtual package provided by:
                        >> libfltk1.3-dev 1.3.0-8
                        >> libfltk1.1-dev 1.1.10-14
                        >> You should explicitly select one to install.
                        >>
                        >>
                        >> Darren, G0HWW
                        >>
                        >> On 03/02/13 14:23, Ed wrote:
                        >>> That should be libfltk-dev. Sorry
                        >>>
                        >>
                        > Remove the 1.1 version.
                        >
                        > Ed
                        >
                      • Ed
                        ... Repeatable here. Fixing it will give Dave something to do...hi. Thanks Darren. Ed W3NR
                        Message 11 of 14 , Feb 3, 2013
                        • 0 Attachment
                          On 02/03/2013 09:57 AM, Darren Long wrote:
                          > Some results from gdb. It seems that having Text Capture enabled is the
                          > culprit. If I disable that, wfall-only works fine. The back trace
                          > shows a null this pointer which is bound to cause disappointment.
                          > Debugger output below.
                          >
                          > Darren, G0HWW

                          Repeatable here. Fixing it will give Dave something to do...hi. Thanks
                          Darren.

                          Ed W3NR
                        • John Phelps
                          Hi All, Found a possible bugfix for the waterfall-only mode crashing issue. (files attached) Works well here in testing. Attached is both a patch/fix and
                          Message 12 of 14 , Feb 3, 2013
                          Hi All,

                          Found a possible bugfix for the waterfall-only mode crashing issue. (files attached)
                          Works well here in testing.
                          Attached is both a patch/fix and screenshot of my debugger window (showing error and justifying why fix was placed here in program-flow)

                          My only question is: Do users want or need the Rx stream processed in waterfall-only mode?
                          ... guess I am asking for the technical definition of how waterfall-only should waterfall-only mode be, hihi.


                          Summary of the fix/patch.
                          This disables all processing of Rx text while in --wfall-only mode

                          +++ b/src/dialogs/fl_digi.cxx
                          @@ -6142,6 +6142,9 @@ static void put_rx_char_flmain(unsigned int data, int style)
                           {
                            ENSURE_THREAD(FLMAIN_TID);
                           
                          + // If in Waterfall Only mode: skip all processing of Rx characters
                          + if (bWF_only) return;



                          ~ John Phelps 
                          kl4yfd



                        • w1hkj
                          ... Thanks John ... I ll import your patch into both 3.21 and 3.22 branches. Waterfall only is supposed to be just that, but the text stream has to be
                          Message 13 of 14 , Feb 3, 2013
                          • 0 Attachment
                            On 02/03/2013 12:55 PM, John Phelps wrote:
                            Hi All,

                            Found a possible bugfix for the waterfall-only mode crashing issue. (files attached)
                            Works well here in testing.
                            Attached is both a patch/fix and screenshot of my debugger window (showing error and justifying why fix was placed here in program-flow)

                            My only question is: Do users want or need the Rx stream processed in waterfall-only mode?
                            ... guess I am asking for the technical definition of how waterfall-only should waterfall-only mode be, hihi.


                            Summary of the fix/patch.
                            This disables all processing of Rx text while in --wfall-only mode

                            +++ b/src/dialogs/fl_digi.cxx
                            @@ -6142,6 +6142,9 @@ static void put_rx_char_flmain(unsigned int data, int style)
                             {
                              ENSURE_THREAD(FLMAIN_TID);
                             
                            + // If in Waterfall Only mode: skip all processing of Rx characters
                            + if (bWF_only) return;



                            ~ John Phelps 
                            kl4yfd

                            Thanks John ... I'll import your patch into both 3.21 and 3.22 branches.

                            Waterfall only is supposed to be just that, but the text stream has to be available via the xmlrpc calls.

                            Dave
                          • w1hkj
                            JP almost had it right on the WF-only patch. Please apply this one to 3.21.67 to cure this seg fault. BTW, this is not a fault one would expect to encounter
                            Message 14 of 14 , Feb 3, 2013
                            • 1 Attachment
                            • 1 KB
                            JP almost had it right on the WF-only patch. Please apply this one to
                            3.21.67 to cure this seg fault.

                            BTW, this is not a fault one would expect to encounter unless:

                            You started fldigi in full screen mode.
                            Enabled the "File | Text capture | Log all RX/TX text" menu item
                            Exited fldigi

                            Started fldigi with the command line sequence "--wo" or "--waterfall-only"
                            Started decoding incoming data

                            Most users of the --wo command line switch are in MS world and use
                            ancillary programs to display the text, and other aspects of fldigi
                            operation. Those programs use fldigi as a modem engine with waterfall
                            display. They would rarely if ever have performed the above sequence of
                            operations.

                            73, Dave, W1HKJ
                          Your message has been successfully submitted and would be delivered to recipients shortly.