Loading ...
Sorry, an error occurred while loading the content.

Re: [linuxham] FTDI USB->Serial Adapter RTS Always High

Expand Messages
  • Ed
    ... Are you using flrig or rigCAT ? Does lsusb show the ftdi adapter ? Is there not a menu item to have the rig use the data port ? Ed
    Message 1 of 5 , Jan 2, 2013
    • 0 Attachment
      On 01/02/2013 11:23 AM, Mark Schoonover wrote:
      > Yes I have. I can read rig freq, make changes to modes, etc. It's just the
      > PTT part that's the problem.
      >
      >
      > 73 - Mark Schoonover - KA6WKE
      > http://www.ka6wke.net

      Are you using flrig or rigCAT ? Does lsusb show the ftdi adapter ? Is
      there not a menu item to have the rig use the data port ?

      Ed
    • Sergey UB9OAF
      Hi All! I m using UnicomDual interface based on FTDI chip (two serial ports for CAT and PTT) in Ubuntu 13.04 And I still had a similar problem with RTS level.
      Message 2 of 5 , Jul 22, 2013
      • 0 Attachment
        Hi All!

        I'm using UnicomDual interface based on FTDI chip (two serial ports for CAT and PTT) in Ubuntu 13.04
        And I still had a similar problem with RTS level. But RTS level off after a minute

        I found out the program which uses/lock new serial interfaces after connecting USB.

        I run command:

        sudo fuser -v /dev/ttyUSB0

        when RTS is up and I got output - modem-manager
        This program scan (one of steps) new serial-over-USB interfaces for searching GSM-modems etc.

        modem-manager is the subsystem of udev

        I add my device (USB ven_id and prod_id) to blacklist of udev rules
        Blacklist in path (or similar):
        /lib/udev/rules.d/77-mm-usb-device-blacklist.rules

        I add new string there:

        ATTRS{idVendor}=="0403", ATTRS{idProduct}=="6010", ENV{ID_MM_DEVICE_IGNORE}="1"

        ven_id and prod_id I found in output of "lsusb"

        so it should work fine

        PS: sorry for my ugly english


        On Tue, 1 Jan 2013 21:36:01 -0800
        Mark Schoonover <mark@...> wrote:

        > Thanks for reading. Neighbor of mine gave me a Dell Inspiron 2200 and I've
        > loaded Linux Mint XFCE on it. So far, it's all working great except for
        > using FLDigi to key the PTT using RTS; I need the IC-7000 to disconnect the
        > mic & use the data port. I'm using a homebrew interface from here:
        > http://www.qsl.net/g3vgr/civ.html . FLDigi worked FB on my 706 with the
        > same USB->Serial adapter because I was using software PTT.
        >
        > When I built the interface, for good measure I included the additional
        > transistor for PTT keying. My problem is, RTS is always -6.35v, no matter
        > what the setting is in FLDigi. RTS won't toggle to positive when I try to
        > transmit. Is this indicative of all USB adapters or is there some other
        > config that needs to happen? The remainder of the functionality works,
        > receives, transmits audio - sort of (using software PTT), communicates with
        > 7000 just fine too.
        >
        > Any ideas?
        >
        > 73 - Mark Schoonover - KA6WKE
        > http://www.ka6wke.net


        --
        Sergey UB9OAF <ub9oaf@...>
      Your message has been successfully submitted and would be delivered to recipients shortly.