Loading ...
Sorry, an error occurred while loading the content.

Re: gMFSK PTT problem - more

Expand Messages
  • Jerry W
    OK I have reinstalled Mepis 6.0 beta 2. With Synaptic pakcage manager installed hamlib3, hamlib3++c2, hamlib-perl, hamlib3-tcl, hamlib3-dev, hamlib++del,
    Message 1 of 14 , May 12, 2006
    • 0 Attachment
      OK I have reinstalled Mepis 6.0 beta 2.

      With Synaptic pakcage manager installed hamlib3, hamlib3++c2,
      hamlib-perl, hamlib3-tcl, hamlib3-dev, hamlib++del, hamlib-doc, hamlib
      utils, python2.3-hamlib3, sgcontrol, xlog, the fftw stuff.
      then after untaring ./configure --enable-hamlib
      All went well no depends or errors.

      When gMFSK started and did the Settings, Preferances, PTT selected
      /dev/ttyS1 - RTS. Clicked the bar "Test PTT", PTT keyed my interface.
      But when running gMFSK and press the TX button no PTT key or using a
      macro <TX> it dowes not key PTT. The CAT is working even the frequecy
      display on the waterfall, that uses /dev/ttyS0.

      Using KPSK and PTT set to /dev/ttyS1, I see no place to set RTS or
      DTR, but it keys KPSK PTT. On all my Windows programs Com2 RTS is PTT.

      Any suggestions as to a fix?

      TIA,

      Jerry


      --- In linuxham@yahoogroups.com, "Jerry W" <k0hzi.mn@...> wrote:

      Here is my apt sources list:

      # See sources.list(5) for more information
      # This file should be edited through synaptic
      # MEPIS improvements and overrides, the MEPIS magic
      deb http://apt.mepis.org/6.0/ mepis main
      # Ubuntu foundation packages
      deb http://archive.ubuntu.com/ubuntu/ breezy main restricted
      deb http://archive.ubuntu.com/ubuntu/ dapper main restricted
      deb http://security.ubuntu.com/ubuntu/ dapper-security main restricted
      # Packages from Debian
      deb http://archive.ubuntu.com/ubuntu/ dapper universe
      deb http://archive.ubuntu.com/ubuntu/ dapper multiverse
      # Penguin Liberation Front packages not available elsewhere
      # deb ftp://ftp.free.fr/pub/Distributions_Linux/plf/ubuntu/plf/ breezy
      free non-free

      TIA,

      Jerry - K0HZI

      --- In linuxham@yahoogroups.com, "Jerry W" <k0hzi.mn@> wrote:

      OK Ed and Dave,

      Like a dummy I installed Kunbuntu - KDE version of Ubuntu over Mepis
      last night. I had lots of issues with that distro as they don't
      require one to use a root password when installing programs, you use
      "sudo" instead, but was very difficult to use. I will reinstall
      Mepis this afternoon.

      Mepis 6.0 beta 2 has the most recent kernal and also is built on
      Ubuntu but uses the KDE desktop. http://www.mepis.org/

      What distro's is everyone else using? Maybe Dave can make up a poll
      with all the "popular" ones and have the group members choose the
      one they are using? Post the results say in a week?

      73,

      Jerry - K0HZI

      --- In linuxham@yahoogroups.com, Ed <autek@> wrote:
      Jerry, try ./configure --enable-hamlib. See if that doesn't work
      better. Please post your /etc/apt/sources.list here, hopefully Dave
      won't mind the extra bandwidth.

      Ed W3NR
    • Ed
      ... Jerry, the souces.list look OK to me, maybe someone else will care to comment. The only part that bothers me is you are mixing 2 different Ubuntu versions.
      Message 2 of 14 , May 12, 2006
      • 0 Attachment
        Jerry W wrote:
        > OK I have reinstalled Mepis 6.0 beta 2.
        >
        > With Synaptic pakcage manager installed hamlib3, hamlib3++c2,
        > hamlib-perl, hamlib3-tcl, hamlib3-dev, hamlib++del, hamlib-doc, hamlib
        > utils, python2.3-hamlib3, sgcontrol, xlog, the fftw stuff.
        > then after untaring ./configure --enable-hamlib
        > All went well no depends or errors.
        >
        > When gMFSK started and did the Settings, Preferances, PTT selected
        > /dev/ttyS1 - RTS. Clicked the bar "Test PTT", PTT keyed my interface.
        > But when running gMFSK and press the TX button no PTT key or using a
        > macro <TX> it dowes not key PTT. The CAT is working even the frequecy
        > display on the waterfall, that uses /dev/ttyS0.
        >
        > Using KPSK and PTT set to /dev/ttyS1, I see no place to set RTS or
        > DTR, but it keys KPSK PTT. On all my Windows programs Com2 RTS is PTT.
        >
        > Any suggestions as to a fix?
        >
        > TIA,
        >
        > Jerry
        >
        >
        > --- In linuxham@yahoogroups.com, "Jerry W" <k0hzi.mn@...> wrote:
        >
        > Here is my apt sources list:
        >
        > # See sources.list(5) for more information
        > # This file should be edited through synaptic
        > # MEPIS improvements and overrides, the MEPIS magic
        > deb http://apt.mepis.org/6.0/ mepis main
        > # Ubuntu foundation packages
        > deb http://archive.ubuntu.com/ubuntu/ breezy main restricted
        > deb http://archive.ubuntu.com/ubuntu/ dapper main restricted
        > deb http://security.ubuntu.com/ubuntu/ dapper-security main restricted
        > # Packages from Debian
        > deb http://archive.ubuntu.com/ubuntu/ dapper universe
        > deb http://archive.ubuntu.com/ubuntu/ dapper multiverse
        > # Penguin Liberation Front packages not available elsewhere
        > # deb ftp://ftp.free.fr/pub/Distributions_Linux/plf/ubuntu/plf/ breezy
        > free non-free
        >
        > TIA,
        >
        > Jerry - K0HZI

        Jerry, the souces.list look OK to me, maybe someone else will care to
        comment. The only part that bothers me is you are mixing 2 different
        Ubuntu versions. May never be a problem, but.....

        OK, lets move on to the PTT issue. You did install .7pre1 and then
        Dave's hacked version ?? Now open your file manager, go to the
        gmfsk.hkj.48 folder, open the src folder and scroll down to the gmfsk
        executable file. Probably a double click should start gmfsk.48. Try the
        PTT and macros from there. Let us know the results. You did preface the
        macros with a $tx ??? Also did you set the parameters in the
        hkj.config.h before make ???

        Ed W3NR

        Don't give up....the fun is just starting
      • Jerry W
        Ed, I installed Dave s from source file without first installing 7pre1. So what is the procedure now? Thanks, Jerry Jerry, the souces.list look OK to me, maybe
        Message 3 of 14 , May 12, 2006
        • 0 Attachment
          Ed,

          I installed Dave's from source file without first installing 7pre1.

          So what is the procedure now?

          Thanks,

          Jerry

          Jerry, the souces.list look OK to me, maybe someone else will care to
          comment. The only part that bothers me is you are mixing 2 different
          Ubuntu versions. May never be a problem, but.....

          OK, lets move on to the PTT issue. You did install .7pre1 and then
          Dave's hacked version ?? Now open your file manager, go to the
          gmfsk.hkj.48 folder, open the src folder and scroll down to the gmfsk
          executable file. Probably a double click should start gmfsk.48. Try the
          PTT and macros from there. Let us know the results. You did preface the
          macros with a $tx ??? Also did you set the parameters in the
          hkj.config.h before make ???

          Ed W3NR

          Don't give up....the fun is just starting
        Your message has been successfully submitted and would be delivered to recipients shortly.