Loading ...
Sorry, an error occurred while loading the content.

Re: [linuxham] Getting fldigi to PTT with a Kenwood D710 under OS X

Expand Messages
  • Ed
    ... Make sure you have the correct driver for the USB/serial adapter. This has been an ongoing problem with OS X. Ed W3NR
    Message 1 of 11 , Nov 9, 2012
    • 0 Attachment
      On 11/09/2012 05:00 AM, williaty43081 wrote:
      > I have a Kenwood D710 I'd like to connect to fldigi running under OS
      > X. I have the Kenwood PG-5H cable set to connect a computer to the
      > radio. The audio cable from the kit is connected via the computer's
      > mic and headphone ports to the Data port back of the radio body. The
      > control cable is connected to the COM port on the back of the radio
      > faceplate and then to the computer via a serial to USB adapter.
      >
      > With this setup, I can get audio out of the radio and into the
      > computer and it shows up on the waterfall. I can get audio to go down
      > the wire from the computer to the radio, but I can't make the radio
      > care.
      >
      > How do I get the radio to key up and use the audio I'm sending down
      > the cable that runs to the back of the base unit?
      >
      > Thanks, Ty (NR8Q)
      >
      >

      Make sure you have the correct driver for the USB/serial adapter. This
      has been an ongoing problem with OS X.

      Ed W3NR
    • Dick Kriss
      Ty NR8Q, Ed W3NR s assessment is correct. You failed to specify what Serial to USB Adapter you are using. Each adapter has its own driver. I no longer use a
      Message 2 of 11 , Nov 9, 2012
      • 0 Attachment
        Ty NR8Q,

        Ed W3NR's assessment is correct.  You failed to specify what Serial to USB Adapter you are using.  Each adapter has its own driver.  I no longer use a Serial to USB Adapter with my iMac but I recall issues when I had to use the old Keyspan adapter with a SignaLink USB. Keyspan was purchased by Triplite (sp) and they dropped driver support for some of the older Keyspan products.  I was lucky to find a Keyspan driver for OS X. 

        Please let us know what adapter you are using and maybe someone has an OS X driver.

        Dick AA5VU


        Fri Nov 9, 2012 4:58 am (PST) . Posted by:

        "Ed" edw3nr

        On 11/09/2012 05:00 AM, williaty43081 wrote:
        > I have a Kenwood D710 I'd like to connect to fldigi running under OS
        > X. I have the Kenwood PG-5H cable set to connect a computer to the
        > radio. The audio cable from the kit is connected via the computer's
        > mic and headphone ports to the Data port back of the radio body. The
        > control cable is connected to the COM port on the back of the radio
        > faceplate and then to the computer via a serial to USB adapter.
        >
        > With this setup, I can get audio out of the radio and into the
        > computer and it shows up on the waterfall. I can get audio to go down
        > the wire from the computer to the radio, but I can't make the radio
        > care.
        >
        > How do I get the radio to key up and use the audio I'm sending down
        > the cable that runs to the back of the base unit?
        >
        > Thanks, Ty (NR8Q)
        >
        >

        Make sure you have the correct driver for the USB/serial adapter. This 
        has been an ongoing problem with OS X.

        Ed W3NR















      • williaty43081
        ... USB to Serial adapter is the well-loved GUC-232A. Driver works just fine for it as I commonly use it for other applications on this computer. Oddly, those
        Message 3 of 11 , Nov 9, 2012
        • 0 Attachment
          --- In linuxham@yahoogroups.com, Ed <autek@...> wrote:
          >
          > On 11/09/2012 05:00 AM, williaty43081 wrote:
          > > I have a Kenwood D710 I'd like to connect to fldigi running under OS
          > > X. I have the Kenwood PG-5H cable set to connect a computer to the
          > > radio. The audio cable from the kit is connected via the computer's
          > > mic and headphone ports to the Data port back of the radio body. The
          > > control cable is connected to the COM port on the back of the radio
          > > faceplate and then to the computer via a serial to USB adapter.
          > >
          > > With this setup, I can get audio out of the radio and into the
          > > computer and it shows up on the waterfall. I can get audio to go down
          > > the wire from the computer to the radio, but I can't make the radio
          > > care.
          > >
          > > How do I get the radio to key up and use the audio I'm sending down
          > > the cable that runs to the back of the base unit?
          > >
          > > Thanks, Ty (NR8Q)
          > >
          > >
          >
          > Make sure you have the correct driver for the USB/serial adapter. This
          > has been an ongoing problem with OS X.
          >
          > Ed W3NR
          >
          USB to Serial adapter is the well-loved GUC-232A. Driver works just fine for it as I commonly use it for other applications on this computer. Oddly, those other applications see the serial adapter and list it as a choice for the port setting while fldigi does not.
        • Ed
          ... What are you using for PTT ? I m assuming the hardware ptt in fldigi. Ed w3NR
          Message 4 of 11 , Nov 9, 2012
          • 0 Attachment
            On 11/09/2012 03:52 PM, williaty43081 wrote:
            >
            >
            > --- In linuxham@yahoogroups.com, Ed <autek@...> wrote:
            >>
            >> On 11/09/2012 05:00 AM, williaty43081 wrote:
            >>> I have a Kenwood D710 I'd like to connect to fldigi running under
            >>> OS X. I have the Kenwood PG-5H cable set to connect a computer to
            >>> the radio. The audio cable from the kit is connected via the
            >>> computer's mic and headphone ports to the Data port back of the
            >>> radio body. The control cable is connected to the COM port on the
            >>> back of the radio faceplate and then to the computer via a serial
            >>> to USB adapter.
            >>>
            >>> With this setup, I can get audio out of the radio and into the
            >>> computer and it shows up on the waterfall. I can get audio to go
            >>> down the wire from the computer to the radio, but I can't make
            >>> the radio care.
            >>>
            >>> How do I get the radio to key up and use the audio I'm sending
            >>> down the cable that runs to the back of the base unit?
            >>>
            >>> Thanks, Ty (NR8Q)
            >>>
            >>>
            >>
            >> Make sure you have the correct driver for the USB/serial adapter.
            >> This has been an ongoing problem with OS X.
            >>
            >> Ed W3NR
            >>
            > USB to Serial adapter is the well-loved GUC-232A. Driver works just
            > fine for it as I commonly use it for other applications on this
            > computer. Oddly, those other applications see the serial adapter and
            > list it as a choice for the port setting while fldigi does not.
            >
            >

            What are you using for PTT ? I'm assuming the hardware ptt in fldigi.

            Ed w3NR
          • Ty Williams
            ... Yeah, hardware PTT in fldigi. I ve got it working in Windows, now, so at least I know that it can be made to work with the hardware I have. Now I just have
            Message 5 of 11 , Nov 9, 2012
            • 0 Attachment
              On Nov 9, 2012, at 4:06 PM, Ed wrote:
              > What are you using for PTT ? I'm assuming the hardware ptt in fldigi.
              >
              > Ed w3NR

              Yeah, hardware PTT in fldigi. I've got it working in Windows, now, so at least I know that it can be made to work with the hardware I have. Now I just have to figure out what to do to make it work under OS X. Here's what I had to do to get it to work under Windows:

              1) Put radio in EchoLink SYSOP mode
              2) Connect both cables to the back of the RADIO, NOT the faceplate
              3) Pink plug into mic port on laptop, green plug into headphone port
              4) fldigi>Configure>Rig Control>Hardware PTT>h/w ptt device-pin needs following settings:
              Use separate serial port PTT: YES
              Device: correct COM port for serial adapter
              Use RTS: YES
              Use DTS: YES
              5) Then hit Initialize
              6) Press Save then Close


              That allows fldigi to both hear the radio and key the radio for TX when done under Windows. Using the same instructions under OS X isn't getting it to key up, and I have no idea why. Under OS X, the Device box does have "/dev/tty.SLAB_USBtoUART" in it, which is what my serial adapter usually identifies itself as. However, using the same settings for the other fields as in the Windows example, I don't even get a twitch out of the radio when I hit the T/R button in the lower right corner of fldigi.

              Any ideas?

              Thanks,
              Ty
            • Ed
              ... Well you have it setup correctly. Only other suggestion is to look in the Audio tab and Right channel. Check the modem signals on left/right. Make sure
              Message 6 of 11 , Nov 9, 2012
              • 0 Attachment
                > That allows fldigi to both hear the radio and key the radio for TX when done under Windows. Using the same instructions under OS X isn't getting it to key up, and I have no idea why. Under OS X, the Device box does have "/dev/tty.SLAB_USBtoUART" in it, which is what my serial adapter usually identifies itself as. However, using the same settings for the other fields as in the Windows example, I don't even get a twitch out of the radio when I hit the T/R button in the lower right corner of fldigi.
                >
                > Any ideas?
                >
                > Thanks,
                > Ty
                >

                Well you have it setup correctly. Only other suggestion is to look in
                the Audio tab and Right channel. Check the modem signals on left/right.
                Make sure there is nothing else in that tab checked. We'll go from there.

                Ed W3NR
              • Cliff Scott
                ** Reply to message from Ty Williams on Fri, 9 Nov 2012 16:32:59 -0500 ... Ty, Try changing the driver name to cu.slab_USBtoUart . The
                Message 7 of 11 , Nov 9, 2012
                • 0 Attachment
                  ** Reply to message from Ty Williams <williaty@...> on Fri, 9 Nov 2012
                  16:32:59 -0500

                  > On Nov 9, 2012, at 4:06 PM, Ed wrote:
                  > > What are you using for PTT ? I'm assuming the hardware ptt in fldigi.
                  > >
                  > > Ed w3NR
                  >
                  > Yeah, hardware PTT in fldigi. I've got it working in Windows, now, so at
                  > least I know that it can be made to work with the hardware I have. Now I just
                  > have to figure out what to do to make it work under OS X. Here's what I had
                  > to do to get it to work under Windows:
                  >
                  > 1) Put radio in EchoLink SYSOP mode
                  > 2) Connect both cables to the back of the RADIO, NOT the faceplate
                  > 3) Pink plug into mic port on laptop, green plug into headphone port
                  > 4) fldigi>Configure>Rig Control>Hardware PTT>h/w ptt device-pin needs following settings:
                  > Use separate serial port PTT: YES
                  > Device: correct COM port for serial adapter
                  > Use RTS: YES
                  > Use DTS: YES
                  > 5) Then hit Initialize
                  > 6) Press Save then Close
                  >
                  >
                  > That allows fldigi to both hear the radio and key the radio for TX when done
                  > under Windows. Using the same instructions under OS X isn't getting it to key
                  > up, and I have no idea why. Under OS X, the Device box does have
                  > "/dev/tty.SLAB_USBtoUART" in it, which is what my serial adapter usually
                  > identifies itself as. However, using the same settings for the other fields
                  > as in the Windows example, I don't even get a twitch out of the radio when I
                  > hit the T/R button in the lower right corner of fldigi.
                  >
                  > Any ideas?

                  Ty,

                  Try changing the driver name to "cu.slab_USBtoUart". The tty version didn't
                  work here. I'm using a different adapter that uses the Prolific 2303 chip,
                  but the driver installed both the tty and cu versions.

                  Cliff
                • Ty Williams
                  ... Cliff, That wasn t quite it, but it did lead me to the solution. When I did an ls on /dev/, nothing USBtoUART appeared, which I thought was odd since the
                  Message 8 of 11 , Nov 9, 2012
                  • 0 Attachment
                    On Nov 9, 2012, at 9:40 PM, Cliff Scott wrote:
                    > Ty,
                    >
                    > Try changing the driver name to "cu.slab_USBtoUart". The tty version didn't
                    > work here. I'm using a different adapter that uses the Prolific 2303 chip,
                    > but the driver installed both the tty and cu versions.
                    >
                    > Cliff

                    Cliff,
                    That wasn't quite it, but it did lead me to the solution. When I did an ls on /dev/, nothing USBtoUART appeared, which I thought was odd since the adapter was connected. System Profiler couldn't see the adapter on the USB hub either. On a whim, I re-installed the driver even though the adapter was working in other programs. When it came back up, the device is called /dev/tty.PL2303-000014FA. Selecting that device in fldigi made everything work, but the behavior is different than in Windows. In Windows, when you hit Initialize, the radio reacts, an icon blinks, and the cooling fans cycle. Under OS X, absolutely nothing at all happens when you click Initialize but the hardware PTT works just fine anyway. So, the final solution to getting an Kenwood TM-D710 to work with fldigi is to use the Kenwood PG-5H cable set and the following instructions:

                    OS X Instructions:
                    1) Put radio in EchoLink SYSOP mode
                    2) Connect both cables to the back of the RADIO, NOT the faceplate
                    3) Pink plug into mic port on laptop, green plug into headphone port
                    4) fldigi>Configure>Rig Control>Hardware PTT>h/w ptt device-pin needs following settings:
                    Use separate serial port PTT: YES
                    Device: /dev/tty.PL2303-000014FA or similar
                    Use RTS: YES
                    Use DTS: YES
                    5) Then hit Initialize
                    6) Press Save then Close

                    Windows Instructions:
                    1) Put radio in EchoLink SYSOP mode
                    2) Connect both cables to the back of the RADIO, NOT the faceplate
                    3) Pink plug into mic port on laptop, green plug into headphone port
                    4) fldigi>Configure>Rig Control>Hardware PTT>h/w ptt device-pin needs following settings:
                    Use separate serial port PTT: YES
                    Device: correct COM port for GUC232A
                    Use RTS: YES
                    Use DTS: YES
                    5) Then hit Initialize
                    6) Press Save then Close



                    Thanks for leading me to the solution guys!
                    Ty (NR8Q)
                  • David A. Ranch
                    Hello Cliff, I recently wrote up how to use Svxlink (Echolink for Linux) with the D710 and though the D710 s Echolink mode gives you COS support, the one major
                    Message 9 of 11 , Nov 9, 2012
                    • 0 Attachment

                      Hello Cliff,

                      I recently wrote up how to use Svxlink (Echolink for Linux) with the D710 and though the D710's Echolink mode gives you COS support, the one major bummer about that mode is that you loose rig control via the RS232 port!  Though Flrig doesn't support the D710, the newest version of hamlib DOES!   I've used it and it works very well!

                      Unless you don't want rig control, I encourage you to NOT use Echolink mode, make up your own cables (the Kenwood cables offer you little more than a lighter wallet), and get the best of both worlds!

                      --David


                      On 11/09/2012 07:16 PM, Ty Williams wrote:
                      On Nov 9, 2012, at 9:40 PM, Cliff Scott wrote:
                      
                      Ty,
                      
                      Try changing the driver name to "cu.slab_USBtoUart". The tty version didn't
                      work here. I'm using a different adapter that uses the Prolific 2303 chip,
                      but the driver installed both the tty and cu versions.
                      
                      Cliff
                      
                      Cliff,
                      	That wasn't quite it, but it did lead me to the solution. When I did an ls on /dev/, nothing USBtoUART appeared, which I thought was odd since the adapter was connected. System Profiler couldn't see the adapter on the USB hub either. On a whim, I re-installed the driver even though the adapter was working in other programs. When it came back up, the device is called /dev/tty.PL2303-000014FA. Selecting that device in fldigi made everything work, but the behavior is different than in Windows. In Windows, when you hit Initialize, the radio reacts, an icon blinks, and the cooling fans cycle. Under OS X, absolutely nothing at all happens when you click Initialize but the hardware PTT works just fine anyway. So, the final solution to getting an Kenwood TM-D710 to work with fldigi is to use the Kenwood PG-5H cable set and the following instructions:
                      
                      OS X Instructions:
                      1) Put radio in EchoLink SYSOP mode
                      2) Connect both cables to the back of the RADIO, NOT the faceplate
                      3) Pink plug into mic port on laptop, green plug into headphone port
                      4) fldigi>Configure>Rig Control>Hardware PTT>h/w ptt device-pin needs following settings:
                      	Use separate serial port PTT: YES
                      	Device: /dev/tty.PL2303-000014FA or similar
                      	Use RTS: YES
                      	Use DTS: YES
                      5) Then hit Initialize
                      6) Press Save then Close
                      
                      Windows Instructions:
                      1) Put radio in EchoLink SYSOP mode
                      2) Connect both cables to the back of the RADIO, NOT the faceplate
                      3) Pink plug into mic port on laptop, green plug into headphone port
                      4) fldigi>Configure>Rig Control>Hardware PTT>h/w ptt device-pin needs following settings:
                      	Use separate serial port PTT: YES
                      	Device: correct COM port for GUC232A
                      	Use RTS: YES
                      	Use DTS: YES
                      5) Then hit Initialize
                      6) Press Save then Close
                      
                      
                      
                      Thanks for leading me to the solution guys!
                      	Ty (NR8Q)
                      
                      ------------------------------------
                      
                      Yahoo! Groups Links
                      
                      <*> To visit your group on the web, go to:
                          http://groups.yahoo.com/group/linuxham/
                      
                      <*> Your email settings:
                          Individual Email | Traditional
                      
                      <*> To change settings online go to:
                          http://groups.yahoo.com/group/linuxham/join
                          (Yahoo! ID required)
                      
                      <*> To change settings via email:
                          linuxham-digest@yahoogroups.com 
                          linuxham-fullfeatured@yahoogroups.com
                      
                      <*> To unsubscribe from this group, send an email to:
                          linuxham-unsubscribe@yahoogroups.com
                      
                      <*> Your use of Yahoo! Groups is subject to:
                          http://docs.yahoo.com/info/terms/
                      
                    • Cliff Scott
                      ** Reply to message from Ty Williams on Fri, 9 Nov 2012 22:16:55 -0500 ... Glad you found the solution. Cliff
                      Message 10 of 11 , Nov 10, 2012
                      • 0 Attachment
                        ** Reply to message from Ty Williams <williaty@...> on Fri, 9 Nov 2012
                        22:16:55 -0500

                        > On Nov 9, 2012, at 9:40 PM, Cliff Scott wrote:
                        > > Ty,
                        > >
                        > > Try changing the driver name to "cu.slab_USBtoUart". The tty version didn't
                        > > work here. I'm using a different adapter that uses the Prolific 2303 chip,
                        > > but the driver installed both the tty and cu versions.
                        > >
                        > > Cliff
                        >
                        > Cliff,
                        > That wasn't quite it, but it did lead me to the solution. When I did an ls
                        > on /dev/, nothing USBtoUART appeared, which I thought was odd since the
                        > adapter was connected. System Profiler couldn't see the adapter on the USB
                        > hub either. On a whim, I re-installed the driver even though the adapter was
                        > working in other programs. When it came back up, the device is called
                        > /dev/tty.PL2303-000014FA. Selecting that device in fldigi made everything
                        > work, but the behavior is different than in Windows. In Windows, when you hit
                        > Initialize, the radio reacts, an icon blinks, and the cooling fans cycle.
                        > Under OS X, absolutely nothing at all happens when you click Initialize but
                        > the hardware PTT works just fine anyway. So, the final solution to getting an
                        > Kenwood TM-D710 to work with fldigi is to use the Kenwood PG-5H cable set and
                        > the following instructions:
                        >
                        > OS X Instructions:
                        > 1) Put radio in EchoLink SYSOP mode
                        > 2) Connect both cables to the back of the RADIO, NOT the faceplate
                        > 3) Pink plug into mic port on laptop, green plug into headphone port
                        > 4) fldigi>Configure>Rig Control>Hardware PTT>h/w ptt device-pin needs following settings:
                        > Use separate serial port PTT: YES
                        > Device: /dev/tty.PL2303-000014FA or similar
                        > Use RTS: YES
                        > Use DTS: YES
                        > 5) Then hit Initialize
                        > 6) Press Save then Close
                        >
                        > Windows Instructions:
                        > 1) Put radio in EchoLink SYSOP mode
                        > 2) Connect both cables to the back of the RADIO, NOT the faceplate
                        > 3) Pink plug into mic port on laptop, green plug into headphone port
                        > 4) fldigi>Configure>Rig Control>Hardware PTT>h/w ptt device-pin needs following settings:
                        > Use separate serial port PTT: YES
                        > Device: correct COM port for GUC232A
                        > Use RTS: YES
                        > Use DTS: YES
                        > 5) Then hit Initialize
                        > 6) Press Save then Close
                        >
                        >
                        >
                        > Thanks for leading me to the solution guys!
                        > Ty (NR8Q)

                        Glad you found the solution.

                        Cliff
                      Your message has been successfully submitted and would be delivered to recipients shortly.