Loading ...
Sorry, an error occurred while loading the content.

Re: [linuxham] TLF-1.1.4 maintenance release

Expand Messages
  • Thomas Beierlein
    Hi Pierfrancesco, Am Wed, 31 Oct 2012 22:50:05 +0100 ... .. ... Tuning works *partially* with all three available cwdaemon versions (0.9.2, 0.9.4 and 0.9.6).
    Message 1 of 8 , Oct 31, 2012
    • 0 Attachment
      Hi Pierfrancesco,

      Am Wed, 31 Oct 2012 22:50:05 +0100
      schrieb Pierfrancesco Caci <ik5pvx@...>:

      > On Sun, Oct 28, 2012 at 5:31 PM, Thomas Beierlein <tb@...>
      > wrote:
      > > A new TLF bug maintenance release is available at
      > >
      > > https://github.com/downloads/Tlf/tlf/tlf-1.1.4.tar.gz
      > >
      ..
      > > - fix Alt-t (tune) function to switch tuning on for 6 seconds
      > > (can be stopped early with any key press).
      >
      > Does this require a minimum cwdaemon version? I can't get it to work
      > with 0.9.4
      >
      Tuning works *partially* with all three available cwdaemon versions
      (0.9.2, 0.9.4 and 0.9.6). The problem is always in the PTT line
      handling. If you use the full-BK without relying on PTT it should work
      ok.

      The observed problems are:

      - 0.9.2 and 0.9.4 switches PTT on and very immediately off again. The
      keying pin is handled properly, but 0.9.4 do not allow to stop the
      tuning earlier.

      - In 0.9.6 I can not get the PTT working at all.

      So the situation is bad for all actual versions if you have to use PTT
      for your rig.

      73, de Tom DL1JBE.

      --
      "Do what is needful!"
      Ursula LeGuin: Earthsea
      --
    • Pierfrancesco Caci
      Hi Thomas, ... I have cwdaemon talk to a microHAM USB Interface II. I could observe the PTT led flicker at beginning of tune, but the CW led doesn t turn up at
      Message 2 of 8 , Nov 3, 2012
      • 0 Attachment
        Hi Thomas,

        On Thu, Nov 1, 2012 at 6:59 AM, Thomas Beierlein <tb@...> wrote:
        > Hi Pierfrancesco,
        >

        > Tuning works *partially* with all three available cwdaemon versions
        > (0.9.2, 0.9.4 and 0.9.6). The problem is always in the PTT line
        > handling. If you use the full-BK without relying on PTT it should work
        > ok.
        >
        > The observed problems are:
        >
        > - 0.9.2 and 0.9.4 switches PTT on and very immediately off again. The
        > keying pin is handled properly, but 0.9.4 do not allow to stop the
        > tuning earlier.
        >
        > - In 0.9.6 I can not get the PTT working at all.
        >
        > So the situation is bad for all actual versions if you have to use PTT
        > for your rig.

        I have cwdaemon talk to a microHAM USB Interface II.
        I could observe the PTT led flicker at beginning of tune, but the
        CW led doesn't turn up at all.
        While sending cw messages instead, I can see PTT flicker, and then I
        have CW flash normally.
        Alt-P from tlf works correctly, toggling PTT on and off.

        The rigs themselves don't need PTT to send CW.

        Pf



        --
        Pierfrancesco Caci, ik5pvx
      • Thomas Beierlein
        Hi Pierfrancesco, sorry for the long delay. I was a little bit busy here :-).... In meantime I found the reason for the Tuning function not working at your
        Message 3 of 8 , Nov 20, 2012
        • 0 Attachment
          Hi Pierfrancesco,

          sorry for the long delay. I was a little bit busy here :-)....

          In meantime I found the reason for the Tuning function not working at
          your side. There is a further bug in cwdaemon which stops activation of
          the tune function if your sidetone frequency is set to 0. Please try it.

          So we have to find a way to mute the cw output from cwdaemon while
          still having the tuning function working.

          73, de Tom DL1JBE

          Am Sat, 3 Nov 2012 09:57:04 +0100
          schrieb Pierfrancesco Caci <ik5pvx@...>:

          > Hi Thomas,
          >
          > On Thu, Nov 1, 2012 at 6:59 AM, Thomas Beierlein <tb@...>
          > wrote:
          > > Hi Pierfrancesco,
          > >
          >
          > > Tuning works *partially* with all three available cwdaemon versions
          > > (0.9.2, 0.9.4 and 0.9.6). The problem is always in the PTT line
          > > handling. If you use the full-BK without relying on PTT it should
          > > work ok.
          > >
          > > The observed problems are:
          > >
          > > - 0.9.2 and 0.9.4 switches PTT on and very immediately off again.
          > > The keying pin is handled properly, but 0.9.4 do not allow to stop
          > > the tuning earlier.
          > >
          > > - In 0.9.6 I can not get the PTT working at all.
          > >
          > > So the situation is bad for all actual versions if you have to use
          > > PTT for your rig.
          >
          > I have cwdaemon talk to a microHAM USB Interface II.
          > I could observe the PTT led flicker at beginning of tune, but the
          > CW led doesn't turn up at all.
          > While sending cw messages instead, I can see PTT flicker, and then I
          > have CW flash normally.
          > Alt-P from tlf works correctly, toggling PTT on and off.
          >
          > The rigs themselves don't need PTT to send CW.
          >
          > Pf
          >
          >
          >



          --
          "Do what is needful!"
          Ursula LeGuin: Earthsea
          --
        • Pierfrancesco Caci
          Hey Thomas, no worries, I m having my share of crazy work schedules as well. I m a few timezones away from my radio now, will do this test when I get back. Pf
          Message 4 of 8 , Nov 21, 2012
          • 0 Attachment
            Hey Thomas, no worries, I'm having my share of crazy work schedules as
            well. I'm a few
            timezones away from my radio now, will do this test when I get back.

            Pf

            On Wed, Nov 21, 2012 at 8:38 AM, Thomas Beierlein <tb@...> wrote:
            > Hi Pierfrancesco,
            >
            > sorry for the long delay. I was a little bit busy here :-)....
            >
            > In meantime I found the reason for the Tuning function not working at
            > your side. There is a further bug in cwdaemon which stops activation of
            > the tune function if your sidetone frequency is set to 0. Please try it.
            >
            > So we have to find a way to mute the cw output from cwdaemon while
            > still having the tuning function working.
            >
            > 73, de Tom DL1JBE
            >
            > Am Sat, 3 Nov 2012 09:57:04 +0100
            > schrieb Pierfrancesco Caci <ik5pvx@...>:
            >
            >> Hi Thomas,
            >>
            >> On Thu, Nov 1, 2012 at 6:59 AM, Thomas Beierlein <tb@...>
            >> wrote:
            >> > Hi Pierfrancesco,
            >> >
            >>
            >> > Tuning works *partially* with all three available cwdaemon versions
            >> > (0.9.2, 0.9.4 and 0.9.6). The problem is always in the PTT line
            >> > handling. If you use the full-BK without relying on PTT it should
            >> > work ok.
            >> >
            >> > The observed problems are:
            >> >
            >> > - 0.9.2 and 0.9.4 switches PTT on and very immediately off again.
            >> > The keying pin is handled properly, but 0.9.4 do not allow to stop
            >> > the tuning earlier.
            >> >
            >> > - In 0.9.6 I can not get the PTT working at all.
            >> >
            >> > So the situation is bad for all actual versions if you have to use
            >> > PTT for your rig.
            >>
            >> I have cwdaemon talk to a microHAM USB Interface II.
            >> I could observe the PTT led flicker at beginning of tune, but the
            >> CW led doesn't turn up at all.
            >> While sending cw messages instead, I can see PTT flicker, and then I
            >> have CW flash normally.
            >> Alt-P from tlf works correctly, toggling PTT on and off.
            >>
            >> The rigs themselves don't need PTT to send CW.
            >>
            >> Pf
            >>
            >>
            >>
            >
            >
            >
            > --
            > "Do what is needful!"
            > Ursula LeGuin: Earthsea
            > --
            >
            >
            >
            > ------------------------------------
            >
            > Yahoo! Groups Links
            >
            >
            >



            --
            Pierfrancesco Caci, ik5pvx
          • Pierfrancesco Caci
            Thomas, I ve tested this, and setting TONE=1 from within TLF makes tune work. Same as CWTONE=1 from the config file. Looks like a viable workaround to me. Pf
            Message 5 of 8 , Dec 1, 2012
            • 0 Attachment
              Thomas,
              I've tested this, and setting TONE=1 from within TLF makes tune work. Same as CWTONE=1 from the config file.
              Looks like a viable workaround to me.

              Pf

              On Wed, Nov 21, 2012 at 8:38 AM, Thomas Beierlein <tb@...> wrote:
              Hi Pierfrancesco,

              sorry for the long delay. I was a little bit busy here :-)....

              In meantime I found the reason for the Tuning function not working at
              your side. There is a further bug in cwdaemon which stops activation of
              the tune function if your sidetone frequency is set to 0. Please try it.

              So we have to find a way to mute the cw output from cwdaemon while
              still having the tuning function working.

              73, de Tom DL1JBE

              Am Sat, 3 Nov 2012 09:57:04 +0100
              schrieb Pierfrancesco Caci <ik5pvx@...>:

              > Hi Thomas,
              >
              > On Thu, Nov 1, 2012 at 6:59 AM, Thomas Beierlein <tb@...>
              > wrote:
              > > Hi Pierfrancesco,
              > >
              >
              > > Tuning works *partially* with all three available cwdaemon versions
              > > (0.9.2, 0.9.4 and 0.9.6). The problem is always in the PTT line
              > > handling. If you use the full-BK without relying on PTT it should
              > > work ok.
              > >
              > > The observed problems are:
              > >
              > > - 0.9.2 and 0.9.4 switches PTT on and very immediately off again.
              > > The keying pin is handled properly, but 0.9.4 do not allow to stop
              > > the tuning earlier.
              > >
              > > - In 0.9.6 I can not get the PTT working at all.
              > >
              > > So the situation is bad for all actual versions if you have to use
              > > PTT for your rig.
              >
              > I have cwdaemon talk to a microHAM USB Interface II.
              > I could observe the PTT led flicker at beginning of tune, but the
              > CW led doesn't turn up at all.
              > While sending cw messages instead, I can see PTT flicker, and then I
              > have CW flash normally.
              > Alt-P from tlf works correctly, toggling PTT on and off.
              >
              > The rigs themselves don't need PTT to send CW.
              >
              > Pf
              >
              >
              >



              --
              "Do what is needful!"
              Ursula LeGuin: Earthsea
              --



              ------------------------------------

              Yahoo! Groups Links

              <*> To visit your group on the web, go to:
                  http://groups.yahoo.com/group/linuxham/

              <*> Your email settings:
                  Individual Email | Traditional

              <*> To change settings online go to:
                  http://groups.yahoo.com/group/linuxham/join
                  (Yahoo! ID required)

              <*> To change settings via email:
                  linuxham-digest@yahoogroups.com
                  linuxham-fullfeatured@yahoogroups.com

              <*> To unsubscribe from this group, send an email to:
                  linuxham-unsubscribe@yahoogroups.com

              <*> Your use of Yahoo! Groups is subject to:
                  http://docs.yahoo.com/info/terms/




              --
               Pierfrancesco Caci, ik5pvx
            Your message has been successfully submitted and would be delivered to recipients shortly.