Loading ...
Sorry, an error occurred while loading the content.

xbindkeys-config for FC17 x86_64

Expand Messages
  • Adrian
    Handy for setting up keycode/commands for usb devices like a logitech usb headset, such that volume buttons (on the headset) work as intended, or any other
    Message 1 of 2 , Oct 25, 2012
    Handy for setting up keycode/commands for usb devices like a logitech usb headset, such that volume buttons (on the headset) work as intended, or any other unmapped button. I rebuilt a source rpm from fc8 and it works wonderfully (attached). The outputs are used as below.


    $HOME/.xbindkeysrc

    # For the benefit of emacs users: -*- shell-script -*-
    ###########################
    # xbindkeys configuration #
    ###########################
    #
    # Version: 1.8.5
    #
    # If you edit this file, do not forget to uncomment any lines
    # that you change.
    # The pound(#) symbol may be used anywhere for comments.
    #
    # To specify a key, you can use 'xbindkeys --key' or
    # 'xbindkeys --multikey' and put one of the two lines in this file.
    #
    # The format of a command line is:
    # "command to start"
    # associated key
    #
    #
    # A list of keys is in /usr/include/X11/keysym.h and in
    # /usr/include/X11/keysymdef.h
    # The XK_ is not needed.
    #
    # List of modifier:
    # Release, Control, Shift, Mod1 (Alt), Mod2 (NumLock),
    # Mod3 (CapsLock), Mod4, Mod5 (Scroll).
    #

    # The release modifier is not a standard X modifier, but you can
    # use it if you want to catch release events instead of press events

    # By defaults, xbindkeys does not pay attention with the modifiers
    # NumLock, CapsLock and ScrollLock.
    # Uncomment the lines above if you want to pay attention to them.

    #keystate_numlock = enable
    #keystate_capslock = enable
    #keystate_scrolllock= enable

    # Examples of commands:

    "xbindkeys_show"
    control+shift + q

    # set directly keycode (here control + f with my keyboard)
    "xterm"
    c:41 + m:0x4

    # specify a mouse button
    "xterm"
    control + b:2

    #"xterm -geom 50x20+20+20"
    # Shift+Mod2+alt + s
    #
    ## set directly keycode (here control+alt+mod2 + f with my keyboard)
    #"xterm"
    # alt + c:0x29 + m:4 + mod2
    #
    ## Control+Shift+a release event starts rxvt
    #"rxvt"
    # release+control+shift + a
    #
    ## Control + mouse button 2 release event starts rxvt
    #"rxvt"
    # Control + b:2 + Release
    "amixer -c 2 set Speaker 1%+"
    m:0x0 + c:123
    #
    "amixer -c 2 set Speaker 1%-"
    m:0x0 + c:122
    #
    ##################################
    # End of xbindkeys configuration #
    ##################################

    & run xbindkeys eg (.kde(autostart )at boot.


    Note;

    # Control + b:2 + Release
    "amixer -c 2 set Speaker 1%+"
    m:0x0 + c:123
    #
    "amixer -c 2 set Speaker 1%-"
    m:0x0 + c:122

    is the Logitech usb headset config. Set -c x, x being soundcard id No for the headset.

    [root@fedora17desk ~]# cat /proc/asound/cards
    0 [Intel          ]: HDA-Intel - HDA Intel
                          HDA Intel at 0xfcefc000 irq 43
    1 [NVidia         ]: HDA-Intel - HDA NVidia
                          HDA NVidia at 0xfebfc000 irq 16
    2 [Headset        ]: USB-Audio - Logitech USB Headset
                          Logitech Logitech USB Headset at usb-0000:00:1d.2-1, full speed

    Installation of NVidia proprietary driver messed up xbind for me until I installed attached.

    vk4tux
Your message has been successfully submitted and would be delivered to recipients shortly.