Loading ...
Sorry, an error occurred while loading the content.

Re: [linuxham] KX3

Expand Messages
  • Holger Schurig
    Okay, now I m at home. I have a stereo cable going from the KX3 PHONES socket to the Line-In of my desktop PC. Currently I don t have any program running,
    Message 1 of 11 , Oct 4, 2012
    • 0 Attachment
      Okay, now I'm at home.

      I have a stereo cable going from the KX3 "PHONES" socket to the Line-In of my desktop PC.

      Currently I don't have any program running, but I can hear the KX3 sound via my desktop-PC loud speakers. It's a pure ALSA/chipset thingy for me.

      When I start "alsamixer", it comes up and shows the master gain of the virtual "PulseAudio" sound card.

      So I press F6 to select another sound card.. In the popup I select "0 HDA Intel". Now I sea loooots of gain setters, e.g. "Master", "Headphone" and so on. The important for me is the one labelled "Line". I select this one with Cursor-Right key. Now I press the "m" key (like mute) bar to toggle the "OO"/"MM" label  below line. If it it is "MM", then I can't hear the Line in, but if it's "OO", I can hear it.

      The sound chip mixes all the output (e.g. PCM, Beep, Line) together according the mute states and gain settings of the various inputs.

      73, Holger DH3HS
    • Henri Honda
      On 10/04/2012 08:50 PM, Matt Maguire wrote: Hi Matt: Thank you for your reply. I can now get my computer to communicate with KX3 like changing
      Message 2 of 11 , Oct 4, 2012
      • 0 Attachment
        On 10/04/2012 08:50 PM, Matt Maguire wrote:

        Hi Matt:

        Thank you for your reply.  I can now get my computer to communicate with KX3 like
        changing frequencies,modes, etc. but I cannot get anything on the fldigi waterfall
        window.  All I get is a black, blank window so I cannot see any incoming signals.
        Which indicates that I cannot RX or TX.  When I press the transmit button on fldigi.
        for instance in the RTTY mode, all KX3 transmits is a steady sound and not the
        familiar RTTY sound.

        I have connected a cable between the MIC and the sound input on the sound card
        and also using the USB cable provided by Elecraft.  I use the hamlib mode which
        seems to be able to comunicate with the KX3.

        BTW, I have no problems using my Kenwood TS-690 with fldigi.

        So that's the situation here.

        Thanks again, Matt.

        73 and have a great week-end!

        Hank
        7J9AAD
         

        Yes, works FB.

        For CAT control, I just enabled RigCAT, set up the port/parameters, and gave it a K3.xml Rig description file. (I forget whether I made any KX3-specific customisations to that K3.xml file).

        For audio, I just connected some audio cables between the Mic and Speaker ports and my sound card. Put the KX3 into DATA-A mode, and disable audio effects, compression, etc.. Set the mic gain to achieve 4 solid bars+one flickering bar on the ALC meter, and set the power output using the power control knob. Set the KX3 AF gain to achieve an appropriate audio drive level in FLdigi.

        Apart from the ALC meter setting and the stereo audio effects, it is all pretty standard.

        73, Matt VK2ACL.


        >
        >
        > ------------------------------------
        >
        > Yahoo! Groups Links
        >
        >
        >


      • Matt Maguire VK2ACL
        The sound input on the sound card needs to go to the KX3 Phones socket, not the KX3 Mic socket. 73, Matt VK2ACL
        Message 3 of 11 , Oct 4, 2012
        • 0 Attachment
          The sound input on the sound card needs to go to the KX3 Phones socket, not the KX3 Mic socket.

          73, Matt VK2ACL



          On 05/10/2012, at 1:01 PM, Henri Honda <k6don@...> wrote:

          On 10/04/2012 08:50 PM, Matt Maguire wrote:

          Hi Matt:

          Thank you for your reply.  I can now get my computer to communicate with KX3 like
          changing frequencies,modes, etc. but I cannot get anything on the fldigi waterfall
          window.  All I get is a black, blank window so I cannot see any incoming signals.
          Which indicates that I cannot RX or TX.  When I press the transmit button on fldigi.
          for instance in the RTTY mode, all KX3 transmits is a steady sound and not the
          familiar RTTY sound.

          I have connected a cable between the MIC and the sound input on the sound card
          and also using the USB cable provided by Elecraft.  I use the hamlib mode which
          seems to be able to comunicate with the KX3.

          BTW, I have no problems using my Kenwood TS-690 with fldigi.

          So that's the situation here.

          Thanks again, Matt.

          73 and have a great week-end!

          Hank
          7J9AAD
           

          Yes, works FB.

          For CAT control, I just enabled RigCAT, set up the port/parameters, and gave it a K3.xml Rig description file. (I forget whether I made any KX3-specific customisations to that K3.xml file).

          For audio, I just connected some audio cables between the Mic and Speaker ports and my sound card. Put the KX3 into DATA-A mode, and disable audio effects, compression, etc.. Set the mic gain to achieve 4 solid bars+one flickering bar on the ALC meter, and set the power output using the power control knob. Set the KX3 AF gain to achieve an appropriate audio drive level in FLdigi.

          Apart from the ALC meter setting and the stereo audio effects, it is all pretty standard.

          73, Matt VK2ACL.


          >
          >
          > ------------------------------------
          >
          > Yahoo! Groups Links
          >
          >
          >


        • Marty Hartwell
          Hi Matt I think the sound OUTPUT should go to the KX3 Mic input or an aux jack which has low level input for digital. If the KX3 has a built in sound card then
          Message 4 of 11 , Oct 5, 2012
          • 0 Attachment
            Hi Matt
            I think the sound OUTPUT should go to the KX3 Mic input or an aux
            jack which has low level input for digital.
            If the KX3 has a built in sound card then maybe it would require a
            USB cable to connect to the PC.


            Marty kd8bj


            On 10/04/2012 10:27 PM, Matt Maguire VK2ACL wrote:
            > The sound input on the sound card needs to go to the KX3 Phones socket,
            > not the KX3 Mic socket.
            >
            > 73, Matt VK2ACL
            >
            >
            >
            > On 05/10/2012, at 1:01 PM, Henri Honda <k6don@...
            > <mailto:k6don@...>> wrote:
            >
            >> On 10/04/2012 08:50 PM, Matt Maguire wrote:
            >>
            >> Hi Matt:
            >>
            >> Thank you for your reply. I can now get my computer to communicate
            >> with KX3 like
            >> changing frequencies,modes, etc. but I cannot get anything on the
            >> fldigi waterfall
            >> window. All I get is a black, blank window so I cannot see any
            >> incoming signals.
            >> Which indicates that I cannot RX or TX. When I press the transmit
            >> button on fldigi.
            >> for instance in the RTTY mode, all KX3 transmits is a steady sound and
            >> not the
            >> familiar RTTY sound.
            >>
            >> I have connected a cable between the MIC and the sound input on the
            >> sound card
            >> and also using the USB cable provided by Elecraft. I use the hamlib
            >> mode which
            >> /seems**/to be able to comunicate with the KX3.
            >>
            >> BTW, I have no problems using my Kenwood TS-690 with fldigi.
            >>
            >> So that's the situation here.
            >>
            >> Thanks again, Matt.
            >>
            >> 73 and have a great week-end!
            >>
            >> Hank
            >> 7J9AAD
            >>>
            >>> Yes, works FB.
            >>>
            >>> For CAT control, I just enabled RigCAT, set up the port/parameters,
            >>> and gave it a K3.xml Rig description file. (I forget whether I made
            >>> any KX3-specific customisations to that K3.xml file).
            >>>
            >>> For audio, I just connected some audio cables between the Mic and
            >>> Speaker ports and my sound card. Put the KX3 into DATA-A mode, and
            >>> disable audio effects, compression, etc.. Set the mic gain to achieve
            >>> 4 solid bars+one flickering bar on the ALC meter, and set the power
            >>> output using the power control knob. Set the KX3 AF gain to achieve
            >>> an appropriate audio drive level in FLdigi.
            >>>
            >>> Apart from the ALC meter setting and the stereo audio effects, it is
            >>> all pretty standard.
            >>>
            >>> 73, Matt VK2ACL.
            >>>
            >>>
            >>> >
            >>> >
            >>> > ------------------------------------
            >>> >
            >>> > Yahoo! Groups Links
            >>> >
            >>> >
            >>> >
            >>>
            >>
            >
          • Matt Maguire
            For transmit, you will want to connect a soundcard output to the KX3 Mic input, but the complaint below concerns lack of incoming signals on the waterfall, and
            Message 5 of 11 , Oct 5, 2012
            • 0 Attachment
              For transmit, you will want to connect a soundcard output to the KX3 Mic input, but the complaint below concerns lack of incoming signals on the waterfall, and for this you need to connect the KX3 phone output to the soundcard input.

              You mention AUX output jack, and built-in soundcards, but unfortunately the KX3 has neither. That however is getting a bit off topic for a Linux forum, so perhaps the OP is better off joining the KX3 yahoo group to follow up on any further KX3-specific questions.

              73, Matt VK2ACL.


              On 05/10/2012, at 10:07 PM, Marty Hartwell <mhartwe@...> wrote:

              >
              > Hi Matt
              > I think the sound OUTPUT should go to the KX3 Mic input or an aux
              > jack which has low level input for digital.
              > If the KX3 has a built in sound card then maybe it would require a
              > USB cable to connect to the PC.
              >
              >
              > Marty kd8bj
              >
              >
              > On 10/04/2012 10:27 PM, Matt Maguire VK2ACL wrote:
              >> The sound input on the sound card needs to go to the KX3 Phones socket,
              >> not the KX3 Mic socket.
              >>
              >> 73, Matt VK2ACL
              >>
              >>
              >>
              >> On 05/10/2012, at 1:01 PM, Henri Honda <k6don@...
              >> <mailto:k6don@...>> wrote:
              >>
              >>> On 10/04/2012 08:50 PM, Matt Maguire wrote:
              >>>
              >>> Hi Matt:
              >>>
              >>> Thank you for your reply. I can now get my computer to communicate
              >>> with KX3 like
              >>> changing frequencies,modes, etc. but I cannot get anything on the
              >>> fldigi waterfall
              >>> window. All I get is a black, blank window so I cannot see any
              >>> incoming signals.
              >>> Which indicates that I cannot RX or TX. When I press the transmit
              >>> button on fldigi.
              >>> for instance in the RTTY mode, all KX3 transmits is a steady sound and
              >>> not the
              >>> familiar RTTY sound.
              >>>
              >>> I have connected a cable between the MIC and the sound input on the
              >>> sound card
              >>> and also using the USB cable provided by Elecraft. I use the hamlib
              >>> mode which
              >>> /seems**/to be able to comunicate with the KX3.
              >>>
              >>> BTW, I have no problems using my Kenwood TS-690 with fldigi.
              >>>
              >>> So that's the situation here.
              >>>
              >>> Thanks again, Matt.
              >>>
              >>> 73 and have a great week-end!
              >>>
              >>> Hank
              >>> 7J9AAD
              >>>>
              >>>> Yes, works FB.
              >>>>
              >>>> For CAT control, I just enabled RigCAT, set up the port/parameters,
              >>>> and gave it a K3.xml Rig description file. (I forget whether I made
              >>>> any KX3-specific customisations to that K3.xml file).
              >>>>
              >>>> For audio, I just connected some audio cables between the Mic and
              >>>> Speaker ports and my sound card. Put the KX3 into DATA-A mode, and
              >>>> disable audio effects, compression, etc.. Set the mic gain to achieve
              >>>> 4 solid bars+one flickering bar on the ALC meter, and set the power
              >>>> output using the power control knob. Set the KX3 AF gain to achieve
              >>>> an appropriate audio drive level in FLdigi.
              >>>>
              >>>> Apart from the ALC meter setting and the stereo audio effects, it is
              >>>> all pretty standard.
              >>>>
              >>>> 73, Matt VK2ACL.
              >>>>
              >>>>
              >>>>>
              >>>>>
              >>>>> ------------------------------------
              >>>>>
              >>>>> Yahoo! Groups Links
              >>>>>
              >>>>>
              >>>>>
              >>>>
              >>>
              >>
              >
              >
              > ------------------------------------
              >
              > Yahoo! Groups Links
              >
              >
              >
            Your message has been successfully submitted and would be delivered to recipients shortly.