Loading ...
Sorry, an error occurred while loading the content.

KX3

Expand Messages
  • Henri Honda
    Hello! Is anyone out there using Elecraft s KX3?? If so, had any luck using fldigi to communicate with it?? I ve tried everything but no luck. Fldigi works
    Message 1 of 11 , Oct 4, 2012
    • 0 Attachment
      Hello!

      Is anyone out there using Elecraft's KX3??

      If so, had any luck using fldigi to communicate with it?? I've tried
      everything but
      no luck.

      Fldigi works AOK with my Kenwood TS690 with no problems. I just
      received my KX3
      several days ago and had my first SSB QSO with it today. Took a little
      tinkering to get
      it setup properly so it leads me to believe that in order to use fldigi
      it may take a little
      bit of tweaking here and there which is beyond this 91 year old ham.

      Any comments, suggestions would be greatly appreciated!

      Thank y'all and have a good one!

      73,

      Hank 7J9AAD/K6DON
    • vk4tux
      Contact Darren Long, G0HWW g0hww@mac.com for information how to set this up. Computer/Control Port (ACC1) The 3.5-mm stereo ACC1 jack allows firmware updates,
      Message 2 of 11 , Oct 4, 2012
      • 0 Attachment
        Contact Darren Long, G0HWW g0hww@...
        for information how to set this up.

        Computer/Control Port (ACC1)
        The 3.5-mm stereo ACC1 jack allows firmware
        updates, configuration, and remote control of the
        KX3 via a computer. The jack can be connected to
        a computer's USB port via the Elecraft model
        KXUSB cable, or to an RS232 port via the model
        KXSER cable. (The jack's tip connection is RX
        data from the computer. Ring is TX data to the PC.)

        --- In linuxham@yahoogroups.com, Henri Honda <k6don@...> wrote:
        >
        >
        > Hello!
        >
        > Is anyone out there using Elecraft's KX3??
        >
        > If so, had any luck using fldigi to communicate with it?? I've tried
        > everything but
        > no luck.
        >
        > Fldigi works AOK with my Kenwood TS690 with no problems. I just
        > received my KX3
        > several days ago and had my first SSB QSO with it today. Took a little
        > tinkering to get
        > it setup properly so it leads me to believe that in order to use fldigi
        > it may take a little
        > bit of tweaking here and there which is beyond this 91 year old ham.
        >
        > Any comments, suggestions would be greatly appreciated!
        >
        > Thank y'all and have a good one!
        >
        > 73,
        >
        > Hank 7J9AAD/K6DON
        >
      • Matt Maguire
        Yes, works FB. For CAT control, I just enabled RigCAT, set up the port/parameters, and gave it a K3.xml Rig description file. (I forget whether I made any
        Message 3 of 11 , Oct 4, 2012
        • 0 Attachment
          Yes, works FB.

          For CAT control, I just enabled RigCAT, set up the port/parameters, and gave it a K3.xml Rig description file. (I forget whether I made any KX3-specific customisations to that K3.xml file).

          For audio, I just connected some audio cables between the Mic and Speaker ports and my sound card. Put the KX3 into DATA-A mode, and disable audio effects, compression, etc.. Set the mic gain to achieve 4 solid bars+one flickering bar on the ALC meter, and set the power output using the power control knob. Set the KX3 AF gain to achieve an appropriate audio drive level in FLdigi.

          Apart from the ALC meter setting and the stereo audio effects, it is all pretty standard.

          73, Matt VK2ACL.


          On 04/10/2012, at 9:13 PM, Henri Honda <k6don@...> wrote:

          >
          > Hello!
          >
          > Is anyone out there using Elecraft's KX3??
          >
          > If so, had any luck using fldigi to communicate with it?? I've tried
          > everything but
          > no luck.
          >
          > Fldigi works AOK with my Kenwood TS690 with no problems. I just
          > received my KX3
          > several days ago and had my first SSB QSO with it today. Took a little
          > tinkering to get
          > it setup properly so it leads me to believe that in order to use fldigi
          > it may take a little
          > bit of tweaking here and there which is beyond this 91 year old ham.
          >
          > Any comments, suggestions would be greatly appreciated!
          >
          > Thank y'all and have a good one!
          >
          > 73,
          >
          > Hank 7J9AAD/K6DON
          >
          >
          > ------------------------------------
          >
          > Yahoo! Groups Links
          >
          >
          >
        • Harry Bloomberg
          Yes, the KX3 is a great little rig for digital and you ve been given good advice. I m using the TX cable available from Elecraft to connect from the KX3 s mic
          Message 4 of 11 , Oct 4, 2012
          • 0 Attachment
            Yes, the KX3 is a great little rig for digital and you've been given good advice.

            I'm using the TX cable available from Elecraft to connect from the KX3's mic connector to the computer's headphone jack.  One minor issue, with this cable you've got to go into the KX3's menu and disable Mic PTT, otherwise your rig will always be keyed.

            Another issue is the lack of an aux port on the KX3 for received audio.  This means that unless you take other steps, you will not be able to hear what's in your waterfall.  I solved this by purchasing a headphone "Y" connector and plugging a set of headphones into one side of the Y and running the other set to the computer's line in.  You can also plug a small powered speaker into 1/2 of the Y.  I tried a non-powered speaker, but it put too much of a load on the KX3's audio amp.

            73,
            Harry Bloomberg W3YJ
            hbloomb@...

            On Thu, Oct 4, 2012 at 7:50 AM, Matt Maguire <vk2acl@...> wrote:
             

            Yes, works FB.

            For CAT control, I just enabled RigCAT, set up the port/parameters, and gave it a K3.xml Rig description file. (I forget whether I made any KX3-specific customisations to that K3.xml file).

            For audio, I just connected some audio cables between the Mic and Speaker ports and my sound card. Put the KX3 into DATA-A mode, and disable audio effects, compression, etc.. Set the mic gain to achieve 4 solid bars+one flickering bar on the ALC meter, and set the power output using the power control knob. Set the KX3 AF gain to achieve an appropriate audio drive level in FLdigi.

            Apart from the ALC meter setting and the stereo audio effects, it is all pretty standard.

            73, Matt VK2ACL.



            On 04/10/2012, at 9:13 PM, Henri Honda <k6don@...> wrote:

            >
            > Hello!
            >
            > Is anyone out there using Elecraft's KX3??
            >
            > If so, had any luck using fldigi to communicate with it?? I've tried
            > everything but
            > no luck.
            >
            > Fldigi works AOK with my Kenwood TS690 with no problems. I just
            > received my KX3
            > several days ago and had my first SSB QSO with it today. Took a little
            > tinkering to get
            > it setup properly so it leads me to believe that in order to use fldigi
            > it may take a little
            > bit of tweaking here and there which is beyond this 91 year old ham.
            >
            > Any comments, suggestions would be greatly appreciated!
            >
            > Thank y'all and have a good one!
            >
            > 73,
            >
            > Hank 7J9AAD/K6DON
            >
            >
            > ------------------------------------
            >
            > Yahoo! Groups Links
            >
            >
            >


          • Holger Schurig
            Harry, I am able to hear what s in the waterfall, by using either pavucontrol or alsa-mixer to enable some monitor settings. That means that my sound-chip
            Message 5 of 11 , Oct 4, 2012
            • 0 Attachment
              Harry,

              I am able to hear what's in the waterfall, by using either pavucontrol or alsa-mixer to enable some monitor settings. That means that my sound-chip gives the received audio both the fldigi and to my computer-connected external speakers.

              I'm now at work and can't look exactly what I made ...   but maybe this helps you.

              Didn't need a Y-Cable. But this might be a feature of the sound-chip of the builtin sound of my desktop PC.



              Oh, and yes: I can control my KX3 from fldigi via hamlib via the setting "K3". The K3 hamlib definition isn't exactly correct (e.g. it has different memory registers than K3), but for the fldigi case it works. I'm in the process of separating K3 into K3 & KX3, but my patches aren't fully finished yet and I haven't sent them to the hamlib project yet.


            • Harry Bloomberg
              I am very interested in how to monitor the received audio through my computer, on which I m running Linux Mint 13. I will have to investigate how to use
              Message 6 of 11 , Oct 4, 2012
              • 0 Attachment
                I am very interested in how to monitor the received audio through my computer, on which I'm running Linux Mint 13.  I will have to investigate how to use pavucontrol and alsa-mixer to do this.  Thanks!

                73,
                Harry Bloomberg W3YJ
                hbloomb@...

                On Thu, Oct 4, 2012 at 8:38 AM, Holger Schurig <holgerschurig@...> wrote:
                 

                Harry,


                I am able to hear what's in the waterfall, by using either pavucontrol or alsa-mixer to enable some monitor settings. That means that my sound-chip gives the received audio both the fldigi and to my computer-connected external speakers.

                I'm now at work and can't look exactly what I made ...   but maybe this helps you.

                Didn't need a Y-Cable. But this might be a feature of the sound-chip of the builtin sound of my desktop PC.



                Oh, and yes: I can control my KX3 from fldigi via hamlib via the setting "K3". The K3 hamlib definition isn't exactly correct (e.g. it has different memory registers than K3), but for the fldigi case it works. I'm in the process of separating K3 into K3 & KX3, but my patches aren't fully finished yet and I haven't sent them to the hamlib project yet.



              • Holger Schurig
                Okay, now I m at home. I have a stereo cable going from the KX3 PHONES socket to the Line-In of my desktop PC. Currently I don t have any program running,
                Message 7 of 11 , Oct 4, 2012
                • 0 Attachment
                  Okay, now I'm at home.

                  I have a stereo cable going from the KX3 "PHONES" socket to the Line-In of my desktop PC.

                  Currently I don't have any program running, but I can hear the KX3 sound via my desktop-PC loud speakers. It's a pure ALSA/chipset thingy for me.

                  When I start "alsamixer", it comes up and shows the master gain of the virtual "PulseAudio" sound card.

                  So I press F6 to select another sound card.. In the popup I select "0 HDA Intel". Now I sea loooots of gain setters, e.g. "Master", "Headphone" and so on. The important for me is the one labelled "Line". I select this one with Cursor-Right key. Now I press the "m" key (like mute) bar to toggle the "OO"/"MM" label  below line. If it it is "MM", then I can't hear the Line in, but if it's "OO", I can hear it.

                  The sound chip mixes all the output (e.g. PCM, Beep, Line) together according the mute states and gain settings of the various inputs.

                  73, Holger DH3HS
                • Henri Honda
                  On 10/04/2012 08:50 PM, Matt Maguire wrote: Hi Matt: Thank you for your reply. I can now get my computer to communicate with KX3 like changing
                  Message 8 of 11 , Oct 4, 2012
                  • 0 Attachment
                    On 10/04/2012 08:50 PM, Matt Maguire wrote:

                    Hi Matt:

                    Thank you for your reply.  I can now get my computer to communicate with KX3 like
                    changing frequencies,modes, etc. but I cannot get anything on the fldigi waterfall
                    window.  All I get is a black, blank window so I cannot see any incoming signals.
                    Which indicates that I cannot RX or TX.  When I press the transmit button on fldigi.
                    for instance in the RTTY mode, all KX3 transmits is a steady sound and not the
                    familiar RTTY sound.

                    I have connected a cable between the MIC and the sound input on the sound card
                    and also using the USB cable provided by Elecraft.  I use the hamlib mode which
                    seems to be able to comunicate with the KX3.

                    BTW, I have no problems using my Kenwood TS-690 with fldigi.

                    So that's the situation here.

                    Thanks again, Matt.

                    73 and have a great week-end!

                    Hank
                    7J9AAD
                     

                    Yes, works FB.

                    For CAT control, I just enabled RigCAT, set up the port/parameters, and gave it a K3.xml Rig description file. (I forget whether I made any KX3-specific customisations to that K3.xml file).

                    For audio, I just connected some audio cables between the Mic and Speaker ports and my sound card. Put the KX3 into DATA-A mode, and disable audio effects, compression, etc.. Set the mic gain to achieve 4 solid bars+one flickering bar on the ALC meter, and set the power output using the power control knob. Set the KX3 AF gain to achieve an appropriate audio drive level in FLdigi.

                    Apart from the ALC meter setting and the stereo audio effects, it is all pretty standard.

                    73, Matt VK2ACL.


                    >
                    >
                    > ------------------------------------
                    >
                    > Yahoo! Groups Links
                    >
                    >
                    >


                  • Matt Maguire VK2ACL
                    The sound input on the sound card needs to go to the KX3 Phones socket, not the KX3 Mic socket. 73, Matt VK2ACL
                    Message 9 of 11 , Oct 4, 2012
                    • 0 Attachment
                      The sound input on the sound card needs to go to the KX3 Phones socket, not the KX3 Mic socket.

                      73, Matt VK2ACL



                      On 05/10/2012, at 1:01 PM, Henri Honda <k6don@...> wrote:

                      On 10/04/2012 08:50 PM, Matt Maguire wrote:

                      Hi Matt:

                      Thank you for your reply.  I can now get my computer to communicate with KX3 like
                      changing frequencies,modes, etc. but I cannot get anything on the fldigi waterfall
                      window.  All I get is a black, blank window so I cannot see any incoming signals.
                      Which indicates that I cannot RX or TX.  When I press the transmit button on fldigi.
                      for instance in the RTTY mode, all KX3 transmits is a steady sound and not the
                      familiar RTTY sound.

                      I have connected a cable between the MIC and the sound input on the sound card
                      and also using the USB cable provided by Elecraft.  I use the hamlib mode which
                      seems to be able to comunicate with the KX3.

                      BTW, I have no problems using my Kenwood TS-690 with fldigi.

                      So that's the situation here.

                      Thanks again, Matt.

                      73 and have a great week-end!

                      Hank
                      7J9AAD
                       

                      Yes, works FB.

                      For CAT control, I just enabled RigCAT, set up the port/parameters, and gave it a K3.xml Rig description file. (I forget whether I made any KX3-specific customisations to that K3.xml file).

                      For audio, I just connected some audio cables between the Mic and Speaker ports and my sound card. Put the KX3 into DATA-A mode, and disable audio effects, compression, etc.. Set the mic gain to achieve 4 solid bars+one flickering bar on the ALC meter, and set the power output using the power control knob. Set the KX3 AF gain to achieve an appropriate audio drive level in FLdigi.

                      Apart from the ALC meter setting and the stereo audio effects, it is all pretty standard.

                      73, Matt VK2ACL.


                      >
                      >
                      > ------------------------------------
                      >
                      > Yahoo! Groups Links
                      >
                      >
                      >


                    • Marty Hartwell
                      Hi Matt I think the sound OUTPUT should go to the KX3 Mic input or an aux jack which has low level input for digital. If the KX3 has a built in sound card then
                      Message 10 of 11 , Oct 5, 2012
                      • 0 Attachment
                        Hi Matt
                        I think the sound OUTPUT should go to the KX3 Mic input or an aux
                        jack which has low level input for digital.
                        If the KX3 has a built in sound card then maybe it would require a
                        USB cable to connect to the PC.


                        Marty kd8bj


                        On 10/04/2012 10:27 PM, Matt Maguire VK2ACL wrote:
                        > The sound input on the sound card needs to go to the KX3 Phones socket,
                        > not the KX3 Mic socket.
                        >
                        > 73, Matt VK2ACL
                        >
                        >
                        >
                        > On 05/10/2012, at 1:01 PM, Henri Honda <k6don@...
                        > <mailto:k6don@...>> wrote:
                        >
                        >> On 10/04/2012 08:50 PM, Matt Maguire wrote:
                        >>
                        >> Hi Matt:
                        >>
                        >> Thank you for your reply. I can now get my computer to communicate
                        >> with KX3 like
                        >> changing frequencies,modes, etc. but I cannot get anything on the
                        >> fldigi waterfall
                        >> window. All I get is a black, blank window so I cannot see any
                        >> incoming signals.
                        >> Which indicates that I cannot RX or TX. When I press the transmit
                        >> button on fldigi.
                        >> for instance in the RTTY mode, all KX3 transmits is a steady sound and
                        >> not the
                        >> familiar RTTY sound.
                        >>
                        >> I have connected a cable between the MIC and the sound input on the
                        >> sound card
                        >> and also using the USB cable provided by Elecraft. I use the hamlib
                        >> mode which
                        >> /seems**/to be able to comunicate with the KX3.
                        >>
                        >> BTW, I have no problems using my Kenwood TS-690 with fldigi.
                        >>
                        >> So that's the situation here.
                        >>
                        >> Thanks again, Matt.
                        >>
                        >> 73 and have a great week-end!
                        >>
                        >> Hank
                        >> 7J9AAD
                        >>>
                        >>> Yes, works FB.
                        >>>
                        >>> For CAT control, I just enabled RigCAT, set up the port/parameters,
                        >>> and gave it a K3.xml Rig description file. (I forget whether I made
                        >>> any KX3-specific customisations to that K3.xml file).
                        >>>
                        >>> For audio, I just connected some audio cables between the Mic and
                        >>> Speaker ports and my sound card. Put the KX3 into DATA-A mode, and
                        >>> disable audio effects, compression, etc.. Set the mic gain to achieve
                        >>> 4 solid bars+one flickering bar on the ALC meter, and set the power
                        >>> output using the power control knob. Set the KX3 AF gain to achieve
                        >>> an appropriate audio drive level in FLdigi.
                        >>>
                        >>> Apart from the ALC meter setting and the stereo audio effects, it is
                        >>> all pretty standard.
                        >>>
                        >>> 73, Matt VK2ACL.
                        >>>
                        >>>
                        >>> >
                        >>> >
                        >>> > ------------------------------------
                        >>> >
                        >>> > Yahoo! Groups Links
                        >>> >
                        >>> >
                        >>> >
                        >>>
                        >>
                        >
                      • Matt Maguire
                        For transmit, you will want to connect a soundcard output to the KX3 Mic input, but the complaint below concerns lack of incoming signals on the waterfall, and
                        Message 11 of 11 , Oct 5, 2012
                        • 0 Attachment
                          For transmit, you will want to connect a soundcard output to the KX3 Mic input, but the complaint below concerns lack of incoming signals on the waterfall, and for this you need to connect the KX3 phone output to the soundcard input.

                          You mention AUX output jack, and built-in soundcards, but unfortunately the KX3 has neither. That however is getting a bit off topic for a Linux forum, so perhaps the OP is better off joining the KX3 yahoo group to follow up on any further KX3-specific questions.

                          73, Matt VK2ACL.


                          On 05/10/2012, at 10:07 PM, Marty Hartwell <mhartwe@...> wrote:

                          >
                          > Hi Matt
                          > I think the sound OUTPUT should go to the KX3 Mic input or an aux
                          > jack which has low level input for digital.
                          > If the KX3 has a built in sound card then maybe it would require a
                          > USB cable to connect to the PC.
                          >
                          >
                          > Marty kd8bj
                          >
                          >
                          > On 10/04/2012 10:27 PM, Matt Maguire VK2ACL wrote:
                          >> The sound input on the sound card needs to go to the KX3 Phones socket,
                          >> not the KX3 Mic socket.
                          >>
                          >> 73, Matt VK2ACL
                          >>
                          >>
                          >>
                          >> On 05/10/2012, at 1:01 PM, Henri Honda <k6don@...
                          >> <mailto:k6don@...>> wrote:
                          >>
                          >>> On 10/04/2012 08:50 PM, Matt Maguire wrote:
                          >>>
                          >>> Hi Matt:
                          >>>
                          >>> Thank you for your reply. I can now get my computer to communicate
                          >>> with KX3 like
                          >>> changing frequencies,modes, etc. but I cannot get anything on the
                          >>> fldigi waterfall
                          >>> window. All I get is a black, blank window so I cannot see any
                          >>> incoming signals.
                          >>> Which indicates that I cannot RX or TX. When I press the transmit
                          >>> button on fldigi.
                          >>> for instance in the RTTY mode, all KX3 transmits is a steady sound and
                          >>> not the
                          >>> familiar RTTY sound.
                          >>>
                          >>> I have connected a cable between the MIC and the sound input on the
                          >>> sound card
                          >>> and also using the USB cable provided by Elecraft. I use the hamlib
                          >>> mode which
                          >>> /seems**/to be able to comunicate with the KX3.
                          >>>
                          >>> BTW, I have no problems using my Kenwood TS-690 with fldigi.
                          >>>
                          >>> So that's the situation here.
                          >>>
                          >>> Thanks again, Matt.
                          >>>
                          >>> 73 and have a great week-end!
                          >>>
                          >>> Hank
                          >>> 7J9AAD
                          >>>>
                          >>>> Yes, works FB.
                          >>>>
                          >>>> For CAT control, I just enabled RigCAT, set up the port/parameters,
                          >>>> and gave it a K3.xml Rig description file. (I forget whether I made
                          >>>> any KX3-specific customisations to that K3.xml file).
                          >>>>
                          >>>> For audio, I just connected some audio cables between the Mic and
                          >>>> Speaker ports and my sound card. Put the KX3 into DATA-A mode, and
                          >>>> disable audio effects, compression, etc.. Set the mic gain to achieve
                          >>>> 4 solid bars+one flickering bar on the ALC meter, and set the power
                          >>>> output using the power control knob. Set the KX3 AF gain to achieve
                          >>>> an appropriate audio drive level in FLdigi.
                          >>>>
                          >>>> Apart from the ALC meter setting and the stereo audio effects, it is
                          >>>> all pretty standard.
                          >>>>
                          >>>> 73, Matt VK2ACL.
                          >>>>
                          >>>>
                          >>>>>
                          >>>>>
                          >>>>> ------------------------------------
                          >>>>>
                          >>>>> Yahoo! Groups Links
                          >>>>>
                          >>>>>
                          >>>>>
                          >>>>
                          >>>
                          >>
                          >
                          >
                          > ------------------------------------
                          >
                          > Yahoo! Groups Links
                          >
                          >
                          >
                        Your message has been successfully submitted and would be delivered to recipients shortly.