Loading ...
Sorry, an error occurred while loading the content.

[SOLVED] Compile of flrig-1.3.07 on Fedora-17 64-bit

Expand Messages
  • w1hkj
    Received the following from Ernie regarding compiling flrig on a 64 bit Fedora-17 platform. 73, Dave ... Subject: [SOLVED] Compile of flrig-1.3.07 Date: Fri,
    Message 1 of 2 , Aug 18, 2012
    • 0 Attachment

      Received the following from Ernie regarding compiling flrig on a 64 bit Fedora-17 platform.

      73, Dave

      -------- Original Message --------
      Subject:[SOLVED] Compile of flrig-1.3.07
      Date:Fri, 17 Aug 2012 20:48:40 -0700
      From:Ernest Wagner <ewagner1223@...>
      To:w1hkj@...


      Dave,

      I searched the web and found what appeared to be a solution for the same error with a different application.

      In src/Makefile.in I changed  line 147 from:

      flrig_LINK = $(CXXLD) $(flrig_CXXFLAGS) $(CXXFLAGS) $(flrig_LDFLAGS) \

      to:

      flrig_LINK = $(CXXLD) $(flrig_CXXFLAGS) $(CXXFLAGS) -lX11 $(flrig_LDFLAGS) \

      and it compiled/linked with no errors.

      73
      Ernie

    • Brian Morrison
      On Sat, 18 Aug 2012 07:08:54 -0500 ... That looks to me as if libX11-devel is not installed, the -lX11 linker argument should come from the Libs: directives in
      Message 2 of 2 , Aug 18, 2012
      • 0 Attachment
        On Sat, 18 Aug 2012 07:08:54 -0500
        w1hkj <w1hkj@...> wrote:

        >
        > Received the following from Ernie regarding compiling flrig on a 64 bit
        > Fedora-17 platform.
        >
        > 73, Dave
        >
        > -------- Original Message --------
        > Subject: [SOLVED] Compile of flrig-1.3.07
        > Date: Fri, 17 Aug 2012 20:48:40 -0700
        > From: Ernest Wagner <ewagner1223@...>
        > To: w1hkj@...
        >
        >
        >
        > Dave,
        >
        > I searched the web and found what appeared to be a solution for the same
        > error with a different application.
        >
        > In src/Makefile.in I changed line 147 from:
        >
        > flrig_LINK = $(CXXLD) $(flrig_CXXFLAGS) $(CXXFLAGS) $(flrig_LDFLAGS) \
        >
        > to:
        >
        > flrig_LINK = $(CXXLD) $(flrig_CXXFLAGS) $(CXXFLAGS) -lX11 $(flrig_LDFLAGS) \
        >
        > and it compiled/linked with no errors.
        >
        > 73
        > Ernie
        >

        That looks to me as if libX11-devel is not installed, the -lX11 linker
        argument should come from the Libs: directives in
        /usr/lib64/pkgconfig/x11.pc but this doesn't seem to be picked up even if the
        -devel package is installed. Maybe it needs some changes to the configure.ac
        file to achieve that.

        I hacked up a spec file to build an flrig package, I have to add in the -lX11
        argument to the %configure statement in this file for flrig to build properly
        here too.

        --

        Brian Morrison G8SEZ
      Your message has been successfully submitted and would be delivered to recipients shortly.