Loading ...
Sorry, an error occurred while loading the content.

Re: [linuxham] font type when compiling

Expand Messages
  • Ed
    ... Try selecting the mono font. If it still does not look right, check and see what version of fltk you are using. Needs to be 1.3. The 10.04 default fltk was
    Message 1 of 8 , Aug 2, 2012
    • 0 Attachment
      On 08/02/2012 11:10 AM, mike.k0ter wrote:
      > system: Ubuntu 10.04 LTS
      > Laptop computer
      >
      > Recently I noticed that when I compile any of the
      > flxxx programs, the resulting font is less than
      > desirable. However, if I instead use the binary
      > version, the font looks O.K. With the binary
      > version I do get an error message when issuing
      > the --version option but the program(s) seem to
      > work O.K.
      >
      > Dave told me I need to add some fonts to my system
      > but I'm unsure how to do that.
      >
      > Any help appreciated.
      >
      > 73, Mike, K0TER
      >
      >
      >

      Try selecting the mono font. If it still does not look right, check and
      see what version of fltk you are using. Needs to be 1.3. The 10.04
      default fltk was 1.1.

      Ed W3NR
    • w1hkj
      ... Did you build fltk-1.3.0 from source or use a repository pre-built? You may need to build from source and make sure that your configure includes: $
      Message 2 of 8 , Aug 2, 2012
      • 0 Attachment
        On 08/02/2012 10:10 AM, mike.k0ter wrote:
        system:  Ubuntu 10.04 LTS
                 Laptop computer
        
        Recently I noticed that when I compile any of the 
        flxxx programs, the resulting font is less than
        desirable.  However, if I instead use the binary
        version, the font looks O.K.  With the binary
        version I do get an error message when issuing
        the --version option but the program(s) seem to
        work O.K.
        
        Dave told me I need to add some fonts to my system
        but I'm unsure how to do that.
        
        Any help appreciated.
        
        73, Mike, K0TER
        
        
        Did you build fltk-1.3.0 from source or use a repository pre-built?

        You may need to build from source and make sure that your configure includes:

          $ ./configure --enable-threads --enable-xft --enable-shared


        Dave
      • mike.k0ter
        ... I did build fltk-1.3.0 from source and did use the above options when compiling. Mike, K0TER
        Message 3 of 8 , Aug 3, 2012
        • 0 Attachment
          --- In linuxham@yahoogroups.com, w1hkj <w1hkj@...> wrote:
          >
          > On 08/02/2012 10:10 AM, mike.k0ter wrote:
          > > system: Ubuntu 10.04 LTS
          > > Laptop computer
          > >
          > > Recently I noticed that when I compile any of the
          > > flxxx programs, the resulting font is less than
          > > desirable. However, if I instead use the binary
          > > version, the font looks O.K. With the binary
          > >
          > Did you build fltk-1.3.0 from source or use a repository pre-built?

          >
          > You may need to build from source and make sure that your configure
          > includes:
          >
          > $ ./configure --enable-threads *--enable-xft* --enable-shared

          I did build fltk-1.3.0 from source and did use the above options
          when compiling.

          Mike, K0TER
        • mike.k0ter
          ... With some programs, such as flmsg, I don t see a way to select font. I have compiled and installed fltk-1.3.0. And again, when using the pre-compiled
          Message 4 of 8 , Aug 3, 2012
          • 0 Attachment
            --- In linuxham@yahoogroups.com, Ed <autek@...> wrote:
            >
            > On 08/02/2012 11:10 AM, mike.k0ter wrote:
            > > system: Ubuntu 10.04 LTS
            > > Laptop computer
            > >
            > > Recently I noticed that when I compile any of the
            > > flxxx programs, the resulting font is less than
            > > desirable.
            >
            > Try selecting the mono font. If it still does not look right, check and
            > see what version of fltk you are using. Needs to be 1.3. The 10.04
            > default fltk was 1.1.

            With some programs, such as flmsg, I don't see a way to
            select font.

            I have compiled and installed fltk-1.3.0.

            And again, when using the pre-compiled binaries for
            any of the programs, the font looks just fine; nothing
            to change.

            Thanks and 73,

            Mike, K0TER

            >
            > Ed W3NR
            >
          • w1hkj
            With some programs, such as flmsg, I don t see a way to select font. I have compiled and installed fltk-1.3.0. And again, when using the pre-compiled binaries
            Message 5 of 8 , Aug 3, 2012
            • 0 Attachment
              With some programs, such as flmsg, I don't see a way to select font. I have compiled and installed fltk-1.3.0. And again, when using the pre-compiled binaries for any of the programs, the font looks just fine; nothing to change.

              Thanks and 73, Mike, K0TER

              Mike,

              The pre-compiled binaries are built with the fltk libs statically linked in to the binary file.  I am guessing that you have more than one version of the fltk libs installed on your system.  Which Linux distro are you using?  Check in these directories for fltk libs:

              /usr/lib
              /usr/local/lib

              If you find fltk libs in both then it's a good bet that the /usr/lib one's are fltk-1.1 based.  If you're on a Debian based distro then use Synaptic to remove the offending fltk libs.  If RPM based then you probably need to use YAST2.  Then open a terminal and cd to the fltk-1.3.0 source directory.

              $ sudo make uninstall
              $ ./configure --enable-threads --enable-xft --enable-shared --enable static
              $ make
              $ sudo make install

              then cd to the fldigi source directory

              $ sudo make uninstall
              $ ./configure --enable-static
              $ make
              $ sudo make install

              And retest for font definition.  The fltk-1.3.0 library functions should now be statically linked the binary you just created.

              73, Dave, W1HKJ

            • Ed
              Don t overlook libfltk-dev. If you need to un-install 1.1 Ed W3NR
              Message 6 of 8 , Aug 3, 2012
              • 0 Attachment
                Don't overlook libfltk-dev. If you need to un-install 1.1

                Ed W3NR
              • mike.k0ter
                ... Dave, I found the problem. Somehow on this computer I had left off some of the -dev applications including libxft-dev. There were a couple others, too, I
                Message 7 of 8 , Aug 3, 2012
                • 0 Attachment
                  --- In linuxham@yahoogroups.com, w1hkj <w1hkj@...> wrote:
                  >
                  > On 08/02/2012 10:10 AM, mike.k0ter wrote:
                  > > system: Ubuntu 10.04 LTS
                  > > Laptop computer
                  > >
                  > > Recently I noticed that when I compile any of the
                  > > flxxx programs, the resulting font is less than
                  > > desirable.
                  > >
                  > Did you build fltk-1.3.0 from source or use a repository pre-built?
                  >
                  > You may need to build from source and make sure that your configure
                  > includes:
                  >
                  > $ ./configure --enable-threads *--enable-xft* --enable-shared
                  >


                  Dave, I found the problem. Somehow on this computer I had left
                  off some of the -dev applications including libxft-dev. There
                  were a couple others, too, I believe libpng-dev and libxext-dev.

                  After adding those, uninstalling and re-compiling fltk, fldigi
                  and flmsg, the fonts are great and look just as they did
                  in earlier versions.

                  I suspect I did something wrong with the change from fltk 1.1.0
                  to 1.3.0.

                  Thanks for your help.

                  73, Mike, K0TER
                Your message has been successfully submitted and would be delivered to recipients shortly.