Loading ...
Sorry, an error occurred while loading the content.

Re: [linuxham] Line in --- X ---> Audio Out

Expand Messages
  • Rick Kunath
    Comments inline... ... Make sure the Pulseaudio Volume Control is installed. This is not the speaker icon in the tray. Open that (PAVU) and look for the inputs
    Message 1 of 3 , Apr 3, 2012
    • 0 Attachment
      Comments inline...

      > This should be a simple question but for the life of me I haven't
      > figured it out yet. I'm running Ubuntu Oneiric (11.10) with fldigi
      > and a Soundblaster Live! card. When I hook up the audio interface
      > cable to my FT-857 and plug it into the sound card, the audio from
      > the radio goes into the line in jack as expected. However, it is then
      > echoed out through the audio out jack, which drives the transmit
      > audio. At best this is a nuisance which causes a bit of extra "noise"
      > in fldigi's waterfall; at worst it trips the VOX on the radio, which
      > cuts off the audio, which releases the VOX, which returns the audio,
      > which trips the VOX, which cuts off the audio . . . until I back off
      > or mute the audio out. And this choppy, discontinuous,
      > who-knows-what-it-sounds-life signal goes out on the air, which is a
      > Bad Thing.
      >
      > How can I disconnect the line in signal from the audio out? There's
      > probably something simple I'm overlooking.

      Make sure the Pulseaudio Volume Control is installed. This is not the
      speaker icon in the tray. Open that (PAVU) and look for the inputs
      (sources) tab. Make sure to have Fldigi running (the Pulse input won't
      show until an app is running and using Pulse) and set to use Pulse, and
      you will see the line-in level slider. Look for a "monitor" from the
      line-in and make sure it is off.

      I think there is a what-you-hear control on that card. I used to have
      that card a while back. That's a monitor function too. If you can't find
      this in the PAVU, fire up the command line alsamixer and see if you can
      set the level there or turn that off. alsactl store will save the
      settings once you are happy with them. You have to show all controls on
      the alsamixer. F6 and select the card itself.

      From then on manage levels from the PAVU.

      > And on a related note, can you set up fldigi to take input from one
      > sound card and output through a different one? This computer does
      > have a built-in sound chip that I could use if this is possible.

      Easily done using PAVU. Have Fldigi running and select the input
      (source) and output (sink) devices any way that you want them. Even to
      Pulse devices across the network. You can have any input and device and
      any output and device. Once you have this set, and the levels set, Pulse
      will remember them for Fldigi the next time you launch it.

      Rick Kunath, k9ao
    • Creede Lambard
      ... I think problem #1 is solved. alsamixer showed me two controls labeled AC97 when I selected All ; setting one of those to 0 did the trick. I haven t
      Message 2 of 3 , Apr 4, 2012
      • 0 Attachment
        On 04/03/2012 09:33 AM, Rick Kunath wrote:
         


        Make sure the Pulseaudio Volume Control is installed. This is not the
        speaker icon in the tray. Open that (PAVU) and look for the inputs
        (sources) tab. Make sure to have Fldigi running (the Pulse input won't
        show until an app is running and using Pulse) and set to use Pulse, and
        you will see the line-in level slider. Look for a "monitor" from the
        line-in and make sure it is off.

        I think there is a what-you-hear control on that card. I used to have
        that card a while back. That's a monitor function too. If you can't find
        this in the PAVU, fire up the command line alsamixer and see if you can
        set the level there or turn that off. alsactl store will save the
        settings once you are happy with them. You have to show all controls on
        the alsamixer. F6 and select the card itself.

        From then on manage levels from the PAVU.

        > And on a related note, can you set up fldigi to take input from one
        > sound card and output through a different one? This computer does
        > have a built-in sound chip that I could use if this is possible.

        Easily done using PAVU. Have Fldigi running and select the input
        (source) and output (sink) devices any way that you want them. Even to
        Pulse devices across the network. You can have any input and device and
        any output and device. Once you have this set, and the levels set, Pulse
        will remember them for Fldigi the next time you launch it.

        Rick Kunath, k9ao



        I think problem #1 is solved. alsamixer showed me two controls labeled "AC97" when I selected "All"; setting one of those to 0 did the trick.

        I haven't messed around with #2 yet but it shouldn't be too hard. Thanks for your help.

        73, Creede WA7KPK

      Your message has been successfully submitted and would be delivered to recipients shortly.