Loading ...
Sorry, an error occurred while loading the content.

Re: [linuxham] Re: Xmit screen retains text - more info

Expand Messages
  • Sergey UB9OAF
    On Fri, 30 Mar 2012 16:37:41 -0700 ... I have same trouble Ubuntu 10.04 up to date, last (.41) fldigi from ppa. Before update to .41 version everything was ok
    Message 1 of 22 , Apr 1, 2012
    • 0 Attachment
      On Fri, 30 Mar 2012 16:37:41 -0700
      Jack Heller <kb7no@...> wrote:

      > Dave,
      >
      > One more thing. Fiddled with this so long I forgot how some longer
      > macros work. After ten or so words of text {such as CQ) the same end
      > result displays.
      >
      > That is ^r with the ^ turned red and the r still displaying black.
      > Seems significant. Just a thought.
      >
      > By the way, the system does go to Receive. The complaint is the text is
      > still in the xmit pane and will transmit again when xmit is sent.
      >
      > Hope this helps. Jack KB7NO
      >
      I have same trouble

      Ubuntu 10.04 up to date, last (.41) fldigi from ppa. Before update to .41 version everything was ok

      --
      Sergey UB9OAF <ub9oaf@...>
    • Joel
      I either cannot see it or remember something that isn t there, but weren t there icons available for the various FLDigi programs (i.e. FLRig, etc.)? I ve got a
      Message 2 of 22 , Apr 1, 2012
      • 0 Attachment
        I either cannot see it or remember something that isn't there, but
        weren't there icons available for the various FLDigi programs (i.e.
        FLRig, etc.)?

        I've got a short-cut on my desktop to FLRig, but I'm having to use the
        default icon.

        Maybe I'm just crazy...

        73,
        Joel - W4JBB
      • David
        What font are you using Jack? Try changing the font to see if that makes a difference. Dave
        Message 3 of 22 , Apr 1, 2012
        • 0 Attachment
          What font are you using Jack? Try changing the font to see if that makes a difference.

          Dave
        • Jack Heller
          Hi Dave, I mulled all this some more and disabled a service utility for Firefox called X-Mark (originally fox-Mark, I think) which is out of control, but
          Message 4 of 22 , Apr 1, 2012
          • 0 Attachment
            Hi Dave,

            I mulled all this some more and disabled a "service utility" for
            Firefox called X-Mark (originally fox-Mark, I think) which is out of
            control, but this did not help. Need to find a way to remove it, but
            that will come if I think more straightly.

            Though not needed, I have KlamAV anti-virus. Got it turned off, but no
            help.

            More mulling and pondering. Then a logical idea -- Removed the 41 from
            the laptop, downloaded 39, built and installed. and:

            Whoopee! Clicked a couple of the generic macros and the problem was
            no longer. Whew! I don't know what I learned, but something
            unexplainable by us commoners happened here, and apparently only here.

            I will use a bit more care with the install of the 39 on the "machine I
            use" but I think I have a handle on it now. At least, the ugly results
            are erased.

            I will install the PPA for Kamal in the laptop and see what happens on
            the next update on the laptop first.

            This 10.04 has been such a good OS that I couldn't believe there was
            something causing such pain. This computer I assembled about a year ago
            with some care selecting components that provide not only some speed,
            but, believe it or not, a 9 pin serial port. No reason here for any USB
            serial adapter or other little box. Just control the rig and run audio
            cables direct from the accessory port on the 756PRO to the audio jacks
            on the motherboard. Way I have always done it since 1999.

            By the way, Dave, I used to write the Digital Port column for 73 Mag
            until the magazine imploded. Sure were a lot of Windows digital
            programs for a while. Glad to see Fldigi and I also use the Fllog.
            Great stuff. Pat on the back from Nevada, Dave.

            Thanks for your advice, Jack KB7NO

            On Sun, 2012-04-01 at 19:55 +0000, David wrote:
            >
            > What font are you using Jack? Try changing the font to see if that
            > makes a difference.
            >
            > Dave
            >
            >
            >
            >
            >
          • w1hkj
            From a terminal window what report is given by $ fltk-config --version ? Dave
            Message 5 of 22 , Apr 1, 2012
            • 0 Attachment
              From a terminal window what report is given by

              $ fltk-config --version

              ?

              Dave
            • Jack Heller
              Dave, 1.1.10 Jack KB7NO
              Message 6 of 22 , Apr 1, 2012
              • 0 Attachment
                Dave,

                1.1.10

                Jack KB7NO


                On Sun, 2012-04-01 at 19:16 -0500, w1hkj wrote:
                >
                > From a terminal window what report is given by
                >
                > $ fltk-config --version
                >
                > ?
                >
                > Dave
                >
                >
                >
                >
              • w1hkj
                ... That is your problem Jack. I m pretty sure that Kamal builds his ppa repository with Fltk-1.3.0 You need to remove 1.1.10 and download, build and install
                Message 7 of 22 , Apr 1, 2012
                • 0 Attachment
                  On 04/01/2012 08:10 PM, Jack Heller wrote:
                  > Dave,
                  >
                  > 1.1.10
                  >
                  > Jack KB7NO
                  That is your problem Jack. I'm pretty sure that Kamal builds his ppa
                  repository with Fltk-1.3.0 You need to remove 1.1.10 and download,
                  build and install 1.3.0 (see http://www.fltk.org)

                  Dave
                • JohnA
                  Well, I m having the same issue.. I ve also noticed that the xmit window will clear if you don t have at the end of your macro, but use the little T/R
                  Message 8 of 22 , Apr 2, 2012
                  • 0 Attachment
                    Well, I'm having the same issue..
                    I've also noticed that the xmit window will clear if you don't have <RX> at the end of your macro, but use the little T/R button instead. The xmit window will not clear if you have a macro with <RX> at the end.

                    --- In linuxham@yahoogroups.com, Ed <autek@...> wrote:
                    >
                    > On Fri, 30 Mar 2012 12:38:22 -0700
                    > Jack Heller <kb7no@...> wrote:
                    >
                    > > Ed,
                    > >
                    > > I renamed the .fldigi_def.xml
                    > >
                    > > Then started Fldigi and ignored all the setup -- Played the
                    > > macro and got the same result (except no sound) That is, the message
                    > > still displayed -- Hello ^r
                    > >
                    > > The About panel reads Fldigi 3.21.41 and it was installed
                    > > from the Kamal repository as an upgrade. Apparently this update goes
                    > > directly from 39 to 41 as though 40 did not exist.
                    > >
                    > > Thanks again, Jack KB7NO
                    > >
                    >
                    > .41 is the latest version. You can go ahead and put you old def.xml
                    > back.
                    >
                    > Where is the cursor ? Is it in the RX or TX window ? When you send a
                    > macro the cursor should be in and stay in the TX window.
                    >
                    > I'm using Ubuntu 10.04 and .41 and cannot duplicate your problem.
                    >
                    > Ed W3NR
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    > back.
                    >
                  • w1hkj
                    ... So ..... What window manager are you using? Please report the version of fldigi that you are using and whether it was built locally or installed from a
                    Message 9 of 22 , Apr 2, 2012
                    • 0 Attachment
                      On 04/02/2012 07:34 AM, JohnA wrote:
                      Well, I'm having the same issue.. 
                      I've also noticed that the xmit window will clear if you don't have <RX> at the end of your macro, but use the little T/R button instead. The xmit window will not clear if you have a macro with <RX> at the end.  
                      
                      So .....

                      What window manager are you using?  Please report the version of fldigi that you are using and whether it was built locally or installed from a binary / repository distribution.  Do you know what version of the Fltk library that is installed on your system?

                      The devil really is in the details.

                      The action of the T/R button is described in the on line documentation.

                      Excerpt from http://www.w1hkj.com/FldigiHelp-3.21/OperatingControls.html

                      The T/R button should be self-explanatory.  It's your transmit/receive button.  Action is immediate, so if you were transmitting some text and hit the button the PTT is disabled, the transmit text area cleared and the program returned to receive mode.  The T/R button is a "lighted button" that shows RED when transmitting.  All other lighted buttons show YELLOW when they are in the active state.

                      Like Ed, I cannot duplicate the behavior of the <RX> macro tag.  It functions correctly on all of the test systems available to me.

                      73, Dave, W1HKJ



                    • JohnA
                      Ok, I always thought hitting the T/R button when transmitting was the same as having a macro with just a command in it. The system I m using is running
                      Message 10 of 22 , Apr 2, 2012
                      • 0 Attachment
                        Ok, I always thought hitting the T/R button when transmitting was the same as having a macro with just a <rx> command in it.
                        The system I'm using is running Xubuntu 11.04. That's basically Ubuntu with XFce. Yes, I know there's a newer version of Xubuntu out there, but so far this version has been very stable for me.. Per our conversation on the air a couple of weeks ago, I've installed the kamalmostafa repository, and am currently using 3.21.41-1~kamal~natty. The issue began when I updated to the 3.21.41 version last week. I've got libfltk 1.1.10-3 installed.

                        Thanks,
                        John - AC0XY

                        --- In linuxham@yahoogroups.com, w1hkj <w1hkj@...> wrote:
                        >
                        > On 04/02/2012 07:34 AM, JohnA wrote:
                        > > Well, I'm having the same issue..
                        > > I've also noticed that the xmit window will clear if you don't have<RX> at the end of your macro, but use the little T/R button instead. The xmit window will not clear if you have a macro with<RX> at the end.
                        > So .....
                        >
                        > What window manager are you using? Please report the version of fldigi
                        > that you are using and whether it was built locally or installed from a
                        > binary / repository distribution. Do you know what version of the Fltk
                        > library that is installed on your system?
                        >
                        > The devil really is in the details.
                        >
                        > The action of the T/R button is described in the on line documentation.
                        >
                        > Excerpt from http://www.w1hkj.com/FldigiHelp-3.21/OperatingControls.html
                        >
                        > TheT/Rbutton should be self-explanatory. It's your transmit/receive
                        > button. Action is immediate, so if you were transmitting some text and
                        > hit the button the PTT is disabled, the transmit text area cleared and
                        > the program returned to receive mode. The T/R button is a "lighted
                        > button" that showsREDwhen transmitting. All other lighted buttons show
                        > YELLOW when they are in the active state.
                        >
                        > Like Ed, I cannot duplicate the behavior of the <RX> macro tag. It
                        > functions correctly on all of the test systems available to me.
                        >
                        > 73, Dave, W1HKJ
                        >
                      • w1hkj
                        ... You would need to check with Kamal, but I m pretty sure he has built his repository against fltk-1.3.0. Many of the library routines have changed from
                        Message 11 of 22 , Apr 2, 2012
                        • 0 Attachment
                          On 04/02/2012 01:51 PM, JohnA wrote:
                          >
                          > Ok, I always thought hitting the T/R button when transmitting was the same as having a macro with just a<rx> command in it.
                          > The system I'm using is running Xubuntu 11.04. That's basically Ubuntu with XFce. Yes, I know there's a newer version of Xubuntu out there, but so far this version has been very stable for me.. Per our conversation on the air a couple of weeks ago, I've installed the kamalmostafa repository, and am currently using 3.21.41-1~kamal~natty. The issue began when I updated to the 3.21.41 version last week. I've got libfltk 1.1.10-3 installed.
                          >
                          > Thanks,
                          > John - AC0XY
                          You would need to check with Kamal, but I'm pretty sure he has built his
                          repository against fltk-1.3.0. Many of the library routines have
                          changed from 1.1.10 to 1.3.0 and you are probably experiencing problems
                          due to those changes. You cannot rely on the Ubuntu fltk repository as
                          it is 1.1.10. You need to download the latest 1.3.0 source from
                          http://www.fltk.org/ and then build and install locally. Be sure to
                          remove fltk-1.1.10 before you complete the fltk "sudo make install"

                          Dave
                        Your message has been successfully submitted and would be delivered to recipients shortly.