Loading ...
Sorry, an error occurred while loading the content.

Re: [linuxham] Re: Digimaster PRO, Fldigi and Yaesu FT-897

Expand Messages
  • Marty Hartwell
    Hi I get that message when I don t have the radio turned on or if it the radio and PC aren t communicating. You do have the radio on don t you? Just asking.
    Message 1 of 14 , Oct 4, 2011
    • 0 Attachment
      Hi

      I get that message when I don't have the radio turned on or if it
      the radio and PC aren't communicating. You do have the radio on
      don't you?
      Just asking.

      Marty kd8bj

      On 10/04/2011 10:54 AM, David J. Ring, Jr. wrote:
      >
      > I've gotten this working under Windows - but not Linux / Ubuntu.
      >
      > I start fldigi from command line, I get fail to communicate with radio
      > for error.
      >
      > Do you know which kernel has the update that supports the USB chipset
      > in the Digimaster Pro?
      >
      > I don't see the USB when using lshw.
      >
      > David
      >
      >
    • Ed
      ... The correct syntax is lsusb. Any kernel 2.6 and above, so your covered. The error is usually caused by choosing the wrong port or the baud rates don t
      Message 2 of 14 , Oct 4, 2011
      • 0 Attachment
        On 10/04/2011 11:54 AM, David J. Ring, Jr. wrote:
        > I've gotten this working under Windows - but not Linux / Ubuntu.
        >
        > I start fldigi from command line, I get fail to communicate with
        > radio for error.
        >
        > Do you know which kernel has the update that supports the USB chipset
        > in the Digimaster Pro?
        >
        > I don't see the USB when using lshw.
        >
        > David
        >
        >


        The correct syntax is lsusb.

        Any kernel 2.6 and above, so your covered.

        The error is usually caused by choosing the wrong port or the baud rates
        don't match. Are you using hamlib, rigCAT or flrig ?

        Ed W3NR
      • Ed
        ... I would suggest using flrig, then you only need to select the port, as long as the baud rates agree. EdW3NR
        Message 3 of 14 , Oct 4, 2011
        • 0 Attachment
          On 10/04/2011 11:54 AM, David J. Ring, Jr. wrote:
          > I've gotten this working under Windows - but not Linux / Ubuntu.
          >
          > I start fldigi from command line, I get fail to communicate with
          > radio for error.
          >
          > Do you know which kernel has the update that supports the USB chipset
          > in the Digimaster Pro?
          >
          > I don't see the USB when using lshw.
          >
          > David
          >
          >

          I would suggest using flrig, then you only need to select the port, as
          long as the baud rates agree.

          EdW3NR
        • David J. Ring, Jr.
          Hi Ed, I tried using lsusb lspci and lshw. For some reason lsusb didn t list it or I didn t see it, but now it s there: ~$ lsusb Bus 008 Device 001: ID
          Message 4 of 14 , Oct 4, 2011
          • 0 Attachment
            Hi Ed,

            I tried using lsusb lspci and lshw.

            For some reason lsusb didn't list it or I didn't see it, but now it's there:

            ~$ lsusb
            Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
            Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
            Bus 006 Device 002: ID 0403:6010 Future Technology Devices International, Ltd FT2232C Dual USB-UART/FIFO IC
            Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
            Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
            Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
            Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
            Bus 002 Device 003: ID 04f2:b090 Chicony Electronics Co., Ltd
            Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
            Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


            dmesg supplies this informaation:

            5.270380] ftdi_sio 6-2:1.0: FTDI USB Serial Device converter detected
            [ 5.270410] usb 6-2: Detected FT2232C
            [ 5.270412] usb 6-2: Number of endpoints 2
            [ 5.270415] usb 6-2: Endpoint 1 MaxPacketSize 64
            [ 5.270417] usb 6-2: Endpoint 2 MaxPacketSize 64
            [ 5.270419] usb 6-2: Setting MaxPacketSize 64
            [ 5.272360] usb 6-2: FTDI USB Serial Device converter now attached to ttyUSB0
            [ 5.272384] ftdi_sio 6-2:1.1: FTDI USB Serial Device converter detected
            [ 5.272413] usb 6-2: Detected FT2232C
            [ 5.272416] usb 6-2: Number of endpoints 2
            [ 5.272418] usb 6-2: Endpoint 1 MaxPacketSize 64
            [ 5.272420] usb 6-2: Endpoint 2 MaxPacketSize 64
            [ 5.272422] usb 6-2: Setting MaxPacketSize 64
            [ 5.276519] Linux video capture interface: v2.00
            [ 5.276965] usb 6-2: FTDI USB Serial Device converter now attached to ttyUSB1
            [ 5.276990] usbcore: registered new interface driver ftdi_sio
            [ 5.276992] ftdi_sio: v1.5.0:USB FTDI Serial Converters Driver

            grig with correct port and correct radio file doesn't work.

            fldigi returns these errors - first trying hamlib with the beta ft-897 file and then with the rigcat system.

            ~$ fldigi
            E: show_error: hamlib_init: Rig not responding
            E: show_error: hamlib_init: Rig not responding

            ~$ fldigi
            E: rigCAT_getfreq: Hexout failed
            E: rigCAT_init: Xcvr Freq request not answered

            How this seems to work in Windows is that the first USB port is used to key the PTT command while the second USB port is used to control the CAT.

            It works fine on Windows XP with Ham Radio Deluxe. I just don't want to switch to Windows to use one program as I find Linux much better, stronger, more reliable and except for a very few things like OCR and Voice to Type, linux is either acceptable or much better. I know about Abbyy for Linux and I bet that is as good as my Windows $150 OCR - but I digress.

            73
            DR
          • Ed
            ... That is the correct version of the driver. ... I have never, ever had any luck with grig.. ... I still suggest using flrig. Looking the rigCAT error the
            Message 5 of 14 , Oct 4, 2011
            • 0 Attachment
              On 10/04/2011 03:49 PM, David J. Ring, Jr. wrote:
              > Hi Ed,
              >
              > I tried using lsusb lspci and lshw.
              >

              > 5.270380] ftdi_sio 6-2:1.0: FTDI USB Serial Device converter
              > detected [ 5.270410] usb 6-2: Detected FT2232C [ 5.270412] usb
              > 6-2: Number of endpoints 2 [ 5.270415] usb 6-2: Endpoint 1
              > MaxPacketSize 64 [ 5.270417] usb 6-2: Endpoint 2 MaxPacketSize 64
              > [ 5.270419] usb 6-2: Setting MaxPacketSize 64 [ 5.272360] usb
              > 6-2: FTDI USB Serial Device converter now attached to ttyUSB0 [
              > 5.272384] ftdi_sio 6-2:1.1: FTDI USB Serial Device converter
              > detected [ 5.272413] usb 6-2: Detected FT2232C [ 5.272416] usb
              > 6-2: Number of endpoints 2 [ 5.272418] usb 6-2: Endpoint 1
              > MaxPacketSize 64 [ 5.272420] usb 6-2: Endpoint 2 MaxPacketSize 64
              > [ 5.272422] usb 6-2: Setting MaxPacketSize 64 [ 5.276519] Linux
              > video capture interface: v2.00 [ 5.276965] usb 6-2: FTDI USB
              > Serial Device converter now attached to ttyUSB1 [ 5.276990]
              > usbcore: registered new interface driver ftdi_sio [ 5.276992]
              > ftdi_sio: v1.5.0:USB FTDI Serial Converters Driver

              That is the correct version of the driver.


              > grig with correct port and correct radio file doesn't work.

              I have never, ever had any luck with grig..


              > fldigi returns these errors - first trying hamlib with the beta
              > ft-897 file and then with the rigcat system.
              >
              > ~$ fldigi E: show_error: hamlib_init: Rig not responding E:
              > show_error: hamlib_init: Rig not responding
              >
              > ~$ fldigi E: rigCAT_getfreq: Hexout failed E: rigCAT_init: Xcvr Freq
              > request not answered


              I still suggest using flrig.

              Looking the rigCAT error the rig is not talking to rigCAT.

              Ed W3NR
            • David J. Ring, Jr.
              Hello Ed and others: I installed flrig from source no problem except I had to install a -dev file to be able to compile. That s expected. Compiled
              Message 6 of 14 , Oct 4, 2011
              • 0 Attachment
                Hello Ed and others:

                I installed flrig from source no problem except I had to install a -dev file to be able to compile. That's expected. Compiled flawlessly.

                I run flrig from CLI.

                It doesn't work, but I ran the program with the debug switch and here is the messages from the starting of flrig.

                W: main: FLRIG 1.2.2 log started on Tue Oct 4 16:46:10 2011

                W: init_port_combos: Searching /sys/class/tty/
                W: init_port_combos: Found serial port /dev/ttyS0
                W: init_port_combos: Found serial port /dev/ttyS1
                W: init_port_combos: Found serial port /dev/ttyS2
                W: init_port_combos: Found serial port /dev/ttyS3
                W: init_port_combos: Found serial port /dev/ttyUSB0
                W: init_port_combos: Found serial port /dev/ttyUSB1
                W:16:46:11: get vfo A failed 2 ms, cmd 00 00 00 00 03, ans
                W:16:46:11: select B, cmd 00 00 00 00 81, ans
                W:16:46:11: get vfo B failed 2 ms, cmd 00 00 00 00 03, ans
                W:16:46:11: set vfo B, cmd 01 40 70 00 01, ans
                W:16:46:11: set mode B, cmd 01 00 00 00 07, ans
                W:16:46:11: select A, cmd 00 00 00 00 81, ans
                W:16:46:11: set vfo A, cmd 01 40 70 00 01, ans
                W:16:46:11: set mode A, cmd 01 00 00 00 07, ans
                W: send_modes: rig.set_modes
                W: digi_loop: rig.take_control
                W: send_modes: rig.set_modes
                W: digi_loop: rig.take_control
                W: digi_loop: rig.take_control
                W:16:46:12: get vfo A failed 2 ms, cmd 00 00 00 00 03, ans
                W: digi_loop: rig.take_control
                W:16:46:13: get smeter failed 1 ms, cmd 00 00 00 00 E7W: send_modes: rig.set_modes
                W: digi_loop: rig.take_control
                W: digi_loop: rig.take_control
                W:16:46:12: get vfo A failed 2 ms, cmd 00 00 00 00 03, ans
                W: digi_loop: rig.take_control
                W:16:46:13: get smeter failed 1 ms, cmd 00 00 00 00 E7, ans
                , ans

                Puzzling because it runs in Windows.

                In my FT-897D in menu mode #019 CAT rate is set to 38400 bps
                menu mode #020 CAT/LIN/TUNER is set to CAT.

                I'm going to try again in Windows. Or maybe I'll try MixW under Wine.

                David N1EA
              • Ed
                ... Not much here I can help with. Sorry. ... Looking at the website I see it is primarily aimed at Windows users, there is no mention of Linux anywhere. Also
                Message 7 of 14 , Oct 4, 2011
                • 0 Attachment
                  On 10/04/2011 04:57 PM, David J. Ring, Jr. wrote:
                  > Hello Ed and others:
                  >
                  > I installed flrig from source no problem except I had to install a
                  > -dev file to be able to compile. That's expected. Compiled
                  > flawlessly.
                  >
                  > I run flrig from CLI.
                  >
                  > It doesn't work, but I ran the program with the debug switch and here
                  > is the messages from the starting of flrig.

                  Not much here I can help with. Sorry.



                  > Puzzling because it runs in Windows.
                  >
                  > In my FT-897D in menu mode #019 CAT rate is set to 38400 bps menu
                  > mode #020 CAT/LIN/TUNER is set to CAT.
                  >
                  > I'm going to try again in Windows. Or maybe I'll try MixW under
                  > Wine.
                  >
                  > David N1EA

                  Looking at the website I see it is primarily aimed at Windows users,
                  there is no mention of Linux anywhere.

                  Also the use of virtual comports may or may not work in Linux.

                  MixW may work with Wine, unless its written in VB, then you are out of luck.

                  Ed W3NR
                • David J. Ring, Jr.
                  Good news and bad news - bad news first. I decided to try Windows again. I saw that in addition to Ham Radio Deluxe I also had fldigi for Windows. So I tried
                  Message 8 of 14 , Oct 4, 2011
                  • 0 Attachment
                    Good news and bad news - bad news first.

                    I decided to try Windows again. I saw that in addition to Ham Radio Deluxe I also had fldigi for Windows.

                    So I tried it. No work!

                    Just probably settings, I thought.

                    So I try HRD (Ham Radio Deluxe) - also no work - but it used to work.

                    Reboot, Windows.

                    HRD starts working.
                    Fldigi works.

                    Reboot into Ubuntu Linux.

                    NOW Fldigi and I mean Flrig both work!

                    I have no idea why except for my standard explaination of the impossible: When it reset, something forced it extra hard to completely reset as it was not completely latching before.

                    Thanks gentlemen for the help.

                    One great little program for CLI console is tlf. As probably all of you know command line programs in the CONSOLE (press Alt plus Control plus F1) and you reveal the console.

                    For those who have blind friends you might tell them about www.vinuxproject.org We are trying to make a highly accessible Desktop for Vinux with speaking console and ORCA in X Windows Graphic User Interface.

                    73

                    David N1EA
                    =30=



                    --- In linuxham@yahoogroups.com, Ed <autek@...> wrote:
                    >
                    > On 10/04/2011 04:57 PM, David J. Ring, Jr. wrote:
                    > > Hello Ed and others:
                    > >
                    > > I installed flrig from source no problem except I had to install a
                    > > -dev file to be able to compile. That's expected. Compiled
                    > > flawlessly.
                    > >
                    > > I run flrig from CLI.
                    > >
                    > > It doesn't work, but I ran the program with the debug switch and here
                    > > is the messages from the starting of flrig.
                    >
                    > Not much here I can help with. Sorry.
                    >
                    >
                    >
                    > > Puzzling because it runs in Windows.
                    > >
                    > > In my FT-897D in menu mode #019 CAT rate is set to 38400 bps menu
                    > > mode #020 CAT/LIN/TUNER is set to CAT.
                    > >
                    > > I'm going to try again in Windows. Or maybe I'll try MixW under
                    > > Wine.
                    > >
                    > > David N1EA
                    >
                    > Looking at the website I see it is primarily aimed at Windows users,
                    > there is no mention of Linux anywhere.
                    >
                    > Also the use of virtual comports may or may not work in Linux.
                    >
                    > MixW may work with Wine, unless its written in VB, then you are out of luck.
                    >
                    > Ed W3NR
                    >
                  • Ed
                    ... Glad to hear you are up and running. Ed W3NR
                    Message 9 of 14 , Oct 5, 2011
                    • 0 Attachment
                      On 10/04/2011 06:32 PM, David J. Ring, Jr. wrote:
                      > Good news and bad news - bad news first.
                      >
                      > I decided to try Windows again. I saw that in addition to Ham Radio
                      > Deluxe I also had fldigi for Windows.
                      >
                      > So I tried it. No work!
                      >
                      > Just probably settings, I thought.
                      >
                      > So I try HRD (Ham Radio Deluxe) - also no work - but it used to
                      > work.
                      >
                      > Reboot, Windows.
                      >
                      > HRD starts working. Fldigi works.
                      >
                      > Reboot into Ubuntu Linux.
                      >
                      > NOW Fldigi and I mean Flrig both work!


                      Glad to hear you are up and running.

                      Ed W3NR
                    Your message has been successfully submitted and would be delivered to recipients shortly.