Loading ...
Sorry, an error occurred while loading the content.

Re: [linuxham] gMFSK.hkj.48 & Hamlib

Expand Messages
  • w1hkj
    ... Ed, Did you execute the command ./configure before doing the recompile? Dave (hkj)
    Message 1 of 6 , Apr 11, 2006
    • 0 Attachment
      Ed wrote:

      >I still am unable to configure .48 with Hamlib. I made the changes per
      >the readme. The error I get is:
      >
      >hamlib.o: In function 'riglist_get_list':
      >
      >Then I get undefined reference to various hamlib functions. gMFSK
      >compiles just fine with Hamlib using .7pre1, as well as .6,does anyone
      >know what I'm missing from .48 ??? or what I am not doing corredtly. ??
      >
      >Ed W3NR
      >
      >
      >
      >
      >Yahoo! Groups Links
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >.
      >
      >
      >
      Ed, Did you execute the command

      ./configure

      before doing the recompile?

      Dave (hkj)
    • edw3nr
      ... changes per ... anyone ... corredtly. ?? ... Dave, this is the basics that I did. 1. untarred the tarball (File Roller) 2. cd to the hkj folder 3.
      Message 2 of 6 , Apr 12, 2006
      • 0 Attachment
        --- In linuxham@yahoogroups.com, w1hkj <w1hkj@...> wrote:
        >
        > Ed wrote:
        >
        > >I still am unable to configure .48 with Hamlib. I made the
        changes per
        > >the readme. The error I get is:
        > >
        > >hamlib.o: In function 'riglist_get_list':
        > >
        > >Then I get undefined reference to various hamlib functions. gMFSK
        > >compiles just fine with Hamlib using .7pre1, as well as .6,does
        anyone
        > >know what I'm missing from .48 ??? or what I am not doing
        corredtly. ??
        > >
        > >Ed W3NR


        > Ed, Did you execute the command
        >
        > ./configure
        >
        > before doing the recompile?
        >
        > Dave (hkj)

        Dave, this is the basics that I did.

        1. untarred the tarball (File Roller)
        2. cd to the hkj folder
        3. ./configure
        4. make the necessary changes to the src hkj config file. Set tentec
        mod to zero and also the Kachina mod to zero.
        5. set the want_hamlib to 1 in config.h
        6. make (this is when the errors show up. I set the scrollback in
        Gterminal to 1500 lines and that still does not get me back to the
        command line "make" entry.

        As I said, .7pre1 compiled against Hamlib just fine. Now, after all
        this, I decided I may have a corrupted download. So, I moved the
        hkj.48 folder to the trash as well as the tarball. Started all over
        again fresh. What happened next is beyond my Linux knowledge, I
        ran ./configure from the hkj.48 folder, so far so good. Made the
        changes as above, then ran make. Well instead of make running in the
        folder, it changed (automagically) to the trash folder and compiled
        with zero (0) errors. I thought, oh OK lets run make install (as
        root)....again zero errors. This left me at the /trash/hkj.48
        folder. I typed in "gmfsk" and up came .48 complete with Hamlib. All
        of my settings,Hamlib settings,color,fonts,macros from .7pre1
        with .48 mods where there. I copied this back to my /home folder
        after renaming the existing .48 folder and it again just worked with
        Hamlib and all the settings from .7pre1. I checked my .7pre1 and it
        had not changed at all. Now, the only change I had made was to
        install all 4 versions of Automake as I was not sure exactly what
        version you used. And if I read it correctly the versions are not
        compatiable. I'll leave this up to all the gurus' to figure out, as
        I would be really interested how all this happened.

        Ed W3NR
      • w1hkj
        ... If you want hamlib support in the gmfsk program you need to configure as follows: ./configure --enable-hamlib I do not recommend you fool around with
        Message 3 of 6 , Apr 12, 2006
        • 0 Attachment
          edw3nr wrote:
          --- In linuxham@yahoogroups.com, w1hkj <w1hkj@...> wrote:
            
          Ed wrote:
          
              
          I still am unable to configure .48 with Hamlib. I made the 
                
          changes per
            
          the readme. The error I get is:
          
          hamlib.o: In function 'riglist_get_list':
          
          Then I get undefined reference to various hamlib functions. gMFSK
          compiles just fine with Hamlib using .7pre1, as well as .6,does 
                
          anyone
            
          know what I'm missing from .48 ??? or what I am not doing 
                
          corredtly. ??
            
          Ed W3NR
                
           
          
            
          Ed,  Did you execute the command
          
          ./configure
          
          before doing the recompile?
          
          Dave (hkj)
              
          Dave, this is the basics that I did. 
          
          1. untarred the tarball (File Roller)
          2. cd to the hkj folder
          3. ./configure
          4. make the necessary changes to the src hkj config file. Set tentec 
          mod to zero and also the Kachina mod to zero.
          5. set the want_hamlib to 1 in config.h
          6. make (this is when the errors show up. I set the scrollback in 
          Gterminal to 1500 lines and that still does not get me back to the 
          command line "make" entry.
          
          As I said, .7pre1 compiled against Hamlib just fine. Now, after all 
          this, I decided I may have a corrupted download. So, I moved the 
          hkj.48 folder to the trash as well as the tarball. Started all over 
          again fresh. What happened next is beyond my Linux knowledge, I 
          ran ./configure from the hkj.48 folder, so far so good. Made the 
          changes as above, then ran make. Well instead of make running in the 
          folder, it changed (automagically) to the trash folder and compiled 
          with zero (0) errors. I thought, oh OK lets run make install (as 
          root)....again zero errors. This left me at the /trash/hkj.48 
          folder. I typed in "gmfsk" and up came .48 complete with Hamlib. All 
          of my settings,Hamlib settings,color,fonts,macros from .7pre1 
          with .48 mods where there. I copied this back to my /home folder 
          after renaming the existing .48 folder and it again just worked with 
          Hamlib and all the settings from .7pre1. I checked my .7pre1 and it 
          had not changed at all. Now, the only change I had made was to 
          install all 4 versions of Automake as I was not sure exactly what 
          version you used. And if I read it correctly the versions are not 
          compatiable. I'll leave this up to all the gurus' to figure out, as 
          I would be really interested how all this happened. 
          
          Ed W3NR
          
          
          
          
          
          
          
           
          Yahoo! Groups Links
          
          <*> To visit your group on the web, go to:
              http://groups.yahoo.com/group/linuxham/
          
          <*> To unsubscribe from this group, send an email to:
              linuxham-unsubscribe@yahoogroups.com
          
          <*> Your use of Yahoo! Groups is subject to:
              http://docs.yahoo.com/info/terms/
           
          
          
          
          
          
            
          If you want hamlib support in the gmfsk program you need to "configure" as follows:

          ./configure --enable-hamlib

          I do not recommend you fool around with AutoConf or AutoMake Ed.  Those are primarily tools for use by the developers.  I always create a new "configure" script file with each distribution.  If you execute AutoConf then you will be overwriting the one that comes with the distributed source code.

          Dave (hkj)
        • Ed
          ... Dave, I did not run autimake, just made sure they were there. On to .48, success, it compiled just fine , I would say its all there and functioning
          Message 4 of 6 , Apr 12, 2006
          • 0 Attachment
            w1hkj wrote:
            > edw3nr wrote:
            >
            >> --- In linuxham@yahoogroups.com, w1hkj <w1hkj@...> wrote:
            >>
            >>
            >>> Ed wrote:
            >>>
            >>>
            >>>
            >>>> I still am unable to configure .48 with Hamlib. I made the
            >>
            >> changes per
            >>
            >>
            >>>> the readme. The error I get is:
            >>>>
            >>>> hamlib.o: In function 'riglist_get_list':
            >>>>
            >>>> Then I get undefined reference to various hamlib functions. gMFSK
            >>>> compiles just fine with Hamlib using .7pre1, as well as .6,does
            >>
            >> anyone
            >>
            >>
            >>>> know what I'm missing from .48 ??? or what I am not doing
            >>
            >> corredtly. ??
            >>
            >>
            >>>> Ed W3NR
            >>>>
            >>
            >>
            >>
            >>
            >>
            >>> Ed, Did you execute the command
            >>>
            >>> ./configure
            >>>
            >>> before doing the recompile?
            >>>
            >>> Dave (hkj)
            >>>
            >>
            >>
            >> Dave, this is the basics that I did.
            >> 1. untarred the tarball (File Roller)
            >> 2. cd to the hkj folder
            >> 3. ./configure
            >> 4. make the necessary changes to the src hkj config file. Set tentec
            >> mod to zero and also the Kachina mod to zero.
            >> 5. set the want_hamlib to 1 in config.h
            >> 6. make (this is when the errors show up. I set the scrollback in
            >> Gterminal to 1500 lines and that still does not get me back to the
            >> command line "make" entry.
            >>
            >> As I said, .7pre1 compiled against Hamlib just fine. Now, after all
            >> this, I decided I may have a corrupted download. So, I moved the
            >> hkj.48 folder to the trash as well as the tarball. Started all over
            >> again fresh. What happened next is beyond my Linux knowledge, I ran
            >> ./configure from the hkj.48 folder, so far so good. Made the changes
            >> as above, then ran make. Well instead of make running in the folder,
            >> it changed (automagically) to the trash folder and compiled with zero
            >> (0) errors. I thought, oh OK lets run make install (as root)....again
            >> zero errors. This left me at the /trash/hkj.48 folder. I typed in
            >> "gmfsk" and up came .48 complete with Hamlib. All of my
            >> settings,Hamlib settings,color,fonts,macros from .7pre1 with .48 mods
            >> where there. I copied this back to my /home folder after renaming the
            >> existing .48 folder and it again just worked with Hamlib and all the
            >> settings from .7pre1. I checked my .7pre1 and it had not changed at
            >> all. Now, the only change I had made was to install all 4 versions of
            >> Automake as I was not sure exactly what version you used. And if I
            >> read it correctly the versions are not compatiable. I'll leave this up
            >> to all the gurus' to figure out, as I would be really interested how
            >> all this happened.
            >> Ed W3NR
            >>


            >>
            > If you want hamlib support in the gmfsk program you need to "configure"
            > as follows:
            >
            > ./configure --enable-hamlib
            >
            > I do not recommend you fool around with AutoConf or AutoMake Ed. Those
            > are primarily tools for use by the developers. I always create a new
            > "configure" script file with each distribution. If you execute AutoConf
            > then you will be overwriting the one that comes with the distributed
            > source code.
            >
            > Dave (hkj)

            Dave, I did not run autimake, just made sure they were there. On to .48,
            success, it compiled just fine , I would say its all there and
            functioning properly. In .47 if I did ./configure --enable -hamlib, the
            hkj-config.h would have both the Tentec and Kachina mods set to zero and
            config.h would also have want_hamlib set to zero. This time around
            hkj-config.h had both set to 1 and config.h was also set to one for
            want_hamlib.

            Now on to a bigger problem, my HD is full. About 300 meg left. I'm going
            to go with Hamish's suggestion on apt-get dep-build. You would not
            beleive all the files I installed to get this and PA0Rs' TLF and PSKmail
            working. Thanks for all the tips and tricks, also for making a good
            program even better.

            Ed W3NR
          • Ed
            ... Dave, I did not run autimake, just made sure they were there. On to .48, success, it compiled just fine , I would say its all there and functioning
            Message 5 of 6 , Apr 12, 2006
            • 0 Attachment
              w1hkj wrote:
              > edw3nr wrote:
              >
              >> --- In linuxham@yahoogroups.com, w1hkj <w1hkj@...> wrote:
              >>
              >>
              >>> Ed wrote:
              >>>
              >>>
              >>>
              >>>> I still am unable to configure .48 with Hamlib. I made the
              >>
              >> changes per
              >>
              >>
              >>>> the readme. The error I get is:
              >>>>
              >>>> hamlib.o: In function 'riglist_get_list':
              >>>>
              >>>> Then I get undefined reference to various hamlib functions. gMFSK
              >>>> compiles just fine with Hamlib using .7pre1, as well as .6,does
              >>
              >> anyone
              >>
              >>
              >>>> know what I'm missing from .48 ??? or what I am not doing
              >>
              >> corredtly. ??
              >>
              >>
              >>>> Ed W3NR
              >>>>
              >>
              >>
              >>
              >>
              >>
              >>> Ed, Did you execute the command
              >>>
              >>> ./configure
              >>>
              >>> before doing the recompile?
              >>>
              >>> Dave (hkj)
              >>>
              >>
              >>
              >> Dave, this is the basics that I did.
              >> 1. untarred the tarball (File Roller)
              >> 2. cd to the hkj folder
              >> 3. ./configure
              >> 4. make the necessary changes to the src hkj config file. Set tentec
              >> mod to zero and also the Kachina mod to zero.
              >> 5. set the want_hamlib to 1 in config.h
              >> 6. make (this is when the errors show up. I set the scrollback in
              >> Gterminal to 1500 lines and that still does not get me back to the
              >> command line "make" entry.
              >>
              >> As I said, .7pre1 compiled against Hamlib just fine. Now, after all
              >> this, I decided I may have a corrupted download. So, I moved the
              >> hkj.48 folder to the trash as well as the tarball. Started all over
              >> again fresh. What happened next is beyond my Linux knowledge, I ran
              >> ./configure from the hkj.48 folder, so far so good. Made the changes
              >> as above, then ran make. Well instead of make running in the folder,
              >> it changed (automagically) to the trash folder and compiled with zero
              >> (0) errors. I thought, oh OK lets run make install (as root)....again
              >> zero errors. This left me at the /trash/hkj.48 folder. I typed in
              >> "gmfsk" and up came .48 complete with Hamlib. All of my
              >> settings,Hamlib settings,color,fonts,macros from .7pre1 with .48 mods
              >> where there. I copied this back to my /home folder after renaming the
              >> existing .48 folder and it again just worked with Hamlib and all the
              >> settings from .7pre1. I checked my .7pre1 and it had not changed at
              >> all. Now, the only change I had made was to install all 4 versions of
              >> Automake as I was not sure exactly what version you used. And if I
              >> read it correctly the versions are not compatiable. I'll leave this up
              >> to all the gurus' to figure out, as I would be really interested how
              >> all this happened.
              >> Ed W3NR
              >>


              >>
              > If you want hamlib support in the gmfsk program you need to "configure"
              > as follows:
              >
              > ./configure --enable-hamlib
              >
              > I do not recommend you fool around with AutoConf or AutoMake Ed. Those
              > are primarily tools for use by the developers. I always create a new
              > "configure" script file with each distribution. If you execute AutoConf
              > then you will be overwriting the one that comes with the distributed
              > source code.
              >
              > Dave (hkj)

              Dave, I did not run autimake, just made sure they were there. On to .48,
              success, it compiled just fine , I would say its all there and
              functioning properly. In .47 if I did ./configure --enable -hamlib, the
              hkj-config.h would have both the Tentec and Kachina mods set to zero and
              config.h would also have want_hamlib set to zero. This time around
              hkj-config.h had both set to 1 and config.h was also set to one for
              want_hamlib.

              Now on to a bigger problem, my HD is full. About 300 meg left. I'm going
              to go with Hamish's suggestion on apt-get dep-build. You would not
              beleive all the files I installed to get this and PA0Rs' TLF and PSKmail
              working. Thanks for all the tips and tricks, also for making a good
              program even better.

              Ed W3NR
            Your message has been successfully submitted and would be delivered to recipients shortly.