Loading ...
Sorry, an error occurred while loading the content.

error on fldigi

Expand Messages
  • Richard Dowty
    does anyone know what this error is: E: init_stream: could not find device , using default device This occurs upon FLdigi start-up... Rich/w7eet
    Message 1 of 15 , Apr 1, 2011
    • 0 Attachment
      does anyone know what this error is:
      E: init_stream: could not find device " " , using default device

      This occurs upon FLdigi start-up...

      Rich/w7eet


    • David A. Ranch
      I ve found this happens on Linux when the USB system has enumerated the sound card differently (ALSA #s, serial port ttyS*) than what was previous set in
      Message 2 of 15 , Apr 1, 2011
      • 0 Attachment

        I've found this happens on Linux when the USB system has enumerated the sound card differently (ALSA #s, serial port ttyS*)  than what was previous set in Fldigi.  Shutdown all the apps that might be using your soundcard or soundcard+serial ports, unplug the USB device (if that's what you have), and re-plug it in.

        --David


        Richard Dowty wrote:
        does anyone know what this error is:
        E: init_stream: could not find device " " , using default device

        This occurs upon FLdigi start-up...

        Rich/w7eet


      • Richard Dowty
        Thanks for the idea. I found the problem. I had a extra USB plugged in with nothing attached to it. Then another thing the audio set up changed to nothing so I
        Message 3 of 15 , Apr 1, 2011
        • 0 Attachment
          Thanks for the idea. I found the problem. I had a extra USB plugged in with nothing attached to it. Then another thing the audio set up changed to nothing so I had to change it back so the Signalink USB could be detected. With these two changes the error went away. Also, I unplugged the Signalink then re-plugged it back into the same port.
          Rich/W7EET

          --- On Sat, 4/2/11, David A. Ranch <linuxham-fld@...> wrote:

          From: David A. Ranch <linuxham-fld@...>
          Subject: Re: [linuxham] error on fldigi
          To: linuxham@yahoogroups.com
          Date: Saturday, April 2, 2011, 2:53 AM

           


          I've found this happens on Linux when the USB system has enumerated the sound card differently (ALSA #s, serial port ttyS*)  than what was previous set in Fldigi.  Shutdown all the apps that might be using your soundcard or soundcard+serial ports, unplug the USB device (if that's what you have), and re-plug it in.

          --David


          Richard Dowty wrote:

          does anyone know what this error is:
          E: init_stream: could not find device " " , using default device

          This occurs upon FLdigi start-up...

          Rich/w7eet



        • w1hkj
          I just posted a how-to file with instructions on setting the sound card device ordering on boot. Doing so will allow you to add / remove other sound devices
          Message 4 of 15 , Apr 2, 2011
          • 0 Attachment
            I just posted a how-to file with instructions on setting the sound card device ordering on boot.  Doing so will allow you to add / remove other sound devices such as a USB thumb codec without altering the device # for one like the USB SignaLink.

            Dave, W1HKJ

            Richard Dowty wrote:
            Thanks for the idea. I found the problem. I had a extra USB plugged in with nothing attached to it. Then another thing the audio set up changed to nothing so I had to change it back so the Signalink USB could be detected. With these two changes the error went away. Also, I unplugged the Signalink then re-plugged it back into the same port.
            Rich/W7EET

            --- On Sat, 4/2/11, David A. Ranch <linuxham-fld@...> wrote:

            From: David A. Ranch <linuxham-fld@...>
            Subject: Re: [linuxham] error on fldigi
            To: linuxham@yahoogroups.com
            Date: Saturday, April 2, 2011, 2:53 AM

             


            I've found this happens on Linux when the USB system has enumerated the sound card differently (ALSA #s, serial port ttyS*)  than what was previous set in Fldigi.  Shutdown all the apps that might be using your soundcard or soundcard+serial ports, unplug the USB device (if that's what you have), and re-plug it in.

            --David


          • David A. Ranch
            Hey Dave, Thanks for posting that. I m curious, how hard would it be for Fldigi to select it s soundcard based on the identifying string and NOT based on the
            Message 5 of 15 , Apr 2, 2011
            • 0 Attachment
              Hey Dave,

              Thanks for posting that. I'm curious, how hard would it be for Fldigi
              to select it's soundcard based on the identifying string and NOT based
              on the Alsa HW numbers? In your example:

              card 1: AudioPCI [Ensoniq AudioPCI], device 0: ES1371/1 [ES1371 DAC2/ADC

              Make Fldigi not care that this is "card 1, device 0" but just search and
              select the card that's listed as "Ensoniq AudioPCI". Now, if there are
              multiple of these, then maybe offer the user to understand and select
              based on what PCI address it received via dmidecode, etc. Dunno,
              enumeration in Linux has always been frustrating. Making it more
              friendly by name and not by enumeration ID might be a better approach.

              --David
            • Richard Dowty
              I am really green about linux in what to do... I have no idea what or how to do with what instructions you have applied. Rich/W7EET ... From: w1hkj
              Message 6 of 15 , Apr 2, 2011
              • 0 Attachment
                I am really green about linux in what to do... I have no idea what or how to do with what instructions you have applied.
                Rich/W7EET

                --- On Sat, 4/2/11, w1hkj <w1hkj@...> wrote:

                From: w1hkj <w1hkj@...>
                Subject: Re: [linuxham] error on fldigi
                To: linuxham@yahoogroups.com
                Date: Saturday, April 2, 2011, 11:58 AM

                 

                I just posted a how-to file with instructions on setting the sound card device ordering on boot.  Doing so will allow you to add / remove other sound devices such as a USB thumb codec without altering the device # for one like the USB SignaLink.

                Dave, W1HKJ

                Richard Dowty wrote:

                Thanks for the idea. I found the problem. I had a extra USB plugged in with nothing attached to it. Then another thing the audio set up changed to nothing so I had to change it back so the Signalink USB could be detected. With these two changes the error went away. Also, I unplugged the Signalink then re-plugged it back into the same port.
                Rich/W7EET

                --- On Sat, 4/2/11, David A. Ranch <linuxham-fld@...> wrote:

                From: David A. Ranch <linuxham-fld@...>
                Subject: Re: [linuxham] error on fldigi
                To: linuxham@yahoogroups.com
                Date: Saturday, April 2, 2011, 2:53 AM

                 


                I've found this happens on Linux when the USB system has enumerated the sound card differently (ALSA #s, serial port ttyS*)  than what was previous set in Fldigi.  Shutdown all the apps that might be using your soundcard or soundcard+serial ports, unplug the USB device (if that's what you have), and re-plug it in.

                --David



              • G6CKR
                If you don t make any changes you should be OK. If you do, you can just reselect the correct device from within Fldigi anyway. 73 Roger G6CKR
                Message 7 of 15 , Apr 2, 2011
                • 0 Attachment
                  If you don't make any changes you should be OK.
                  If you do, you can just reselect the correct device from within Fldigi
                  anyway.
                  73 Roger G6CKR

                  On 02/04/11 18:47, Richard Dowty wrote:
                  >
                  >
                  > I am really green about linux in what to do... I have no idea what or
                  > how to do with what instructions you have applied.
                  > Rich/W7EET
                  >
                  > --- On *Sat, 4/2/11, w1hkj /<w1hkj@...>/* wrote:
                  >
                  >
                  > From: w1hkj <w1hkj@...>
                  > Subject: Re: [linuxham] error on fldigi
                  > To: linuxham@yahoogroups.com
                  > Date: Saturday, April 2, 2011, 11:58 AM
                  >
                  >
                  >
                  > I just posted a how-to file with instructions on setting the sound
                  > card device ordering on boot. Doing so will allow you to add /
                  > remove other sound devices such as a USB thumb codec without
                  > altering the device # for one like the USB SignaLink.
                  >
                  > Dave, W1HKJ
                  >
                  > Richard Dowty wrote:
                  >
                  >> Thanks for the idea. I found the problem. I had a extra USB
                  >> plugged in with nothing attached to it. Then another thing the
                  >> audio set up changed to nothing so I had to change it back so the
                  >> Signalink USB could be detected. With these two changes the error
                  >> went away. Also, I unplugged the Signalink then re-plugged it back
                  >> into the same port.
                  >> Rich/W7EET
                  >>
                  >> --- On *Sat, 4/2/11, David A. Ranch /<linuxham-fld@...>
                  >> </mc/compose?to=linuxham-fld@...>/* wrote:
                  >>
                  >>
                  >> From: David A. Ranch <linuxham-fld@...>
                  >> </mc/compose?to=linuxham-fld@...>
                  >> Subject: Re: [linuxham] error on fldigi
                  >> To: linuxham@yahoogroups.com
                  >> </mc/compose?to=linuxham@yahoogroups.com>
                  >> Date: Saturday, April 2, 2011, 2:53 AM
                  >>
                  >>
                  >>
                  >>
                  >> I've found this happens on Linux when the USB system has
                  >> enumerated the sound card differently (ALSA #s, serial port
                  >> ttyS*) than what was previous set in Fldigi. Shutdown all
                  >> the apps that might be using your soundcard or
                  >> soundcard+serial ports, unplug the USB device (if that's what
                  >> you have), and re-plug it in.
                  >>
                  >> --David
                  >>
                  >
                  >
                  >
                • David A. Ranch
                  Hello Rich, Let me expand a little on Dave s document to make it more clear assuming your computer is using the ALSA sound system. I m not running the Pulse
                  Message 8 of 15 , Apr 2, 2011
                  • 0 Attachment
                    Hello Rich,
                    
                    Let me expand a little on Dave's document to make it more clear assuming 
                    your computer is using the ALSA sound system.  I'm not running the Pulse 
                    system which is found in the newest Ubuntus, etc.  (you never mentioned 
                    which Linux distribution you're running)
                    
                    --
                    In systems with multiple sound cards they might not always be in the 
                    same order on boot due to users inserting other USB devices, etc. 
                    over the use of that booting of Linux.  This may cause problems not 
                    only with fldigi, but other apps that depend on a certain sound card
                    to be found in a specific order.  
                    
                    The work around is not that difficult and will reliably place the preferred
                    sound card in the correct slot. With the ALSA sound system, sound cards are 
                    numbered from 0 on to however many cards you have in your computer. Usually 
                    its only 2. 
                    
                    The 1st step is to determine the correct id of the cards in your system.
                    
                    Open a terminal window (command prompt for you Windows people) once Linux is 
                    booted and issue the following command:
                    
                       aplay -l
                    
                    That command is short for "ALSA play" and will list out the detected soundcards.
                    Here is an example of what you may see:
                    
                    **** List of PLAYBACK Hardware Devices ****
                    card 0: ICH6 [Intel ICH6], device 0: Intel ICH [Intel ICH6]
                      Subdevices: 1/1
                      Subdevice #0: subdevice #0
                    card 0: ICH6 [Intel ICH6], device 4: Intel ICH - IEC958 [Intel ICH6 - IEC958]
                      Subdevices: 1/1
                      Subdevice #0: subdevice #0
                    card 1: AudioPCI [Ensoniq AudioPCI], device 0: ES1371/1 [ES1371 DAC2/ADC]
                      Subdevices: 1/1
                      Subdevice #0: subdevice #0
                    card 1: AudioPCI [Ensoniq AudioPCI], device 1: ES1371/2 [ES1371 DAC1]
                      Subdevices: 1/1
                      Subdevice #0: subdevice #0
                    
                    
                    With that list of soundcards, let's force the order that ALSA will detect
                    and use them.  If the file does not already exist, you will need to create the 
                    following file with your favorite editor (Vim, Emacs, nano, etc.).  For
                    this example, we'll assume vim for now:
                    
                       vim /etc/modprobe.d/alsa-options
                    
                    You will need root privileges to create the file, so a system such as
                    Ubuntu that depends on the "sudo" command to get root privs, you would 
                    enter:
                    
                    $ sudo vim /etc/modprobe.d/alsa-options
                    
                    
                    Using the above example hardware, you would edit that file so that it's 
                    contents contain the exact following:
                    
                    # Set preferred order of the sound cards
                    options snd-ICH6 index=0
                    options snd-AudioPCI index=1
                    
                    Close the file and exit the editor.  What the above says is basically that
                    the "ICH6" soundcard should always be first in the list (slot 0) and the 
                    "AudioPCI" card should be second.  If you have multiple "AudioPCI" cards
                    on your machine, there are additional options you could specify but that's
                    out of the scope of this help document.
                    
                    
                    To this new configuration, reboot your Linux computer, open a terminal and again 
                    issue the command: 
                    
                       aplay -l
                    
                    
                    You will normally find that your computer's default sounds, any sounds played via
                    your Internet browser and/or Flash, etc. typically default to "card 0".  To avoid
                    having these sounds sent over the amateur radio ways, you should really consider 
                    using any other ALSA detected "cards" other than "card 0" for fldigi.
                    --
                    
                    


                    Richard Dowty wrote:
                    I am really green about linux in what to do... I have no idea what or how to do with what instructions you have applied.
                    Rich/W7EET

                    --- On Sat, 4/2/11, w1hkj <w1hkj@...> wrote:

                    From: w1hkj <w1hkj@...>
                    Subject: Re: [linuxham] error on fldigi
                    To: linuxham@yahoogroups.com
                    Date: Saturday, April 2, 2011, 11:58 AM

                     

                    I just posted a how-to file with instructions on setting the sound card device ordering on boot.  Doing so will allow you to add / remove other sound devices such as a USB thumb codec without altering the device # for one like the USB SignaLink.

                    Dave, W1HKJ

                    Richard Dowty wrote:

                    Thanks for the idea. I found the problem. I had a extra USB plugged in with nothing attached to it. Then another thing the audio set up changed to nothing so I had to change it back so the Signalink USB could be detected. With these two changes the error went away. Also, I unplugged the Signalink then re-plugged it back into the same port.
                    Rich/W7EET

                    --- On Sat, 4/2/11, David A. Ranch <linuxham-fld@...> wrote:

                    From: David A. Ranch <linuxham-fld@...>
                    Subject: Re: [linuxham] error on fldigi
                    To: linuxham@yahoogroups.com
                    Date: Saturday, April 2, 2011, 2:53 AM

                     


                    I've found this happens on Linux when the USB system has enumerated the sound card differently (ALSA #s, serial port ttyS*)  than what was previous set in Fldigi.  Shutdown all the apps that might be using your soundcard or soundcard+serial ports, unplug the USB device (if that's what you have), and re-plug it in.

                    --David



                  • Richard Dowty
                    I am using Fedora 14 which is different than Ubuntu. Rich/W7EET ... From: David A. Ranch Subject: Re: [linuxham] error on fldigi To:
                    Message 9 of 15 , Apr 2, 2011
                    • 0 Attachment
                      I am using Fedora 14 which is different than Ubuntu.
                      Rich/W7EET

                      --- On Sat, 4/2/11, David A. Ranch <linuxham-fld@...> wrote:

                      From: David A. Ranch <linuxham-fld@...>
                      Subject: Re: [linuxham] error on fldigi
                      To: linuxham@yahoogroups.com
                      Date: Saturday, April 2, 2011, 6:13 PM

                       

                      Hello Rich,

                      Let me expand a little on Dave's document to make it more clear assuming
                      your computer is using the ALSA sound system. I'm not running the Pulse
                      system which is found in the newest Ubuntus, etc. (you never mentioned
                      which Linux distribution you're running)

                      --
                      In systems with multiple sound cards they might not always be in the
                      same order on boot due to users inserting other USB devices, etc.
                      over the use of that booting of Linux. This may cause problems not
                      only with fldigi, but other apps that depend on a certain sound card
                      to be found in a specific order.

                      The work around is not that difficult and will reliably place the preferred
                      sound card in the correct slot. With the ALSA sound system, sound cards are
                      numbered from 0 on to however many cards you have in your computer. Usually
                      its only 2.

                      The 1st step is to determine the correct id of the cards in your system.

                      Open a terminal window (command prompt for you Windows people) once Linux is
                      booted and issue the following command:

                      aplay -l

                      That command is short for "ALSA play" and will list out the detected soundcards.
                      Here is an example of what you may see:

                      **** List of PLAYBACK Hardware Devices ****
                      card 0: ICH6 [Intel ICH6], device 0: Intel ICH [Intel ICH6]
                      Subdevices: 1/1
                      Subdevice #0: subdevice #0
                      card 0: ICH6 [Intel ICH6], device 4: Intel ICH - IEC958 [Intel ICH6 - IEC958]
                      Subdevices: 1/1
                      Subdevice #0: subdevice #0
                      card 1: AudioPCI [Ensoniq AudioPCI], device 0: ES1371/1 [ES1371 DAC2/ADC]
                      Subdevices: 1/1
                      Subdevice #0: subdevice #0
                      card 1: AudioPCI [Ensoniq AudioPCI], device 1: ES1371/2 [ES1371 DAC1]
                      Subdevices: 1/1
                      Subdevice #0: subdevice #0


                      With that list of soundcards, let's force the order that ALSA will detect
                      and use them. If the file does not already exist, you will need to create the
                      following file with your favorite editor (Vim, Emacs, nano, etc.). For
                      this example, we'll assume vim for now:

                      vim /etc/modprobe.d/alsa-options

                      You will need root privileges to create the file, so a system such as
                      Ubuntu that depends on the "sudo" command to get root privs, you would
                      enter:

                      $ sudo vim /etc/modprobe.d/alsa-options


                      Using the above example hardware, you would edit that file so that it's
                      contents contain the exact following:

                      # Set preferred order of the sound cards
                      options snd-ICH6 index=0
                      options snd-AudioPCI index=1

                      Close the file and exit the editor. What the above says is basically that
                      the "ICH6" soundcard should always be first in the list (slot 0) and the
                      "AudioPCI" card should be second. If you have multiple "AudioPCI" cards
                      on your machine, there are additional options you could specify but that's
                      out of the scope of this help document.


                      To this new configuration, reboot your Linux computer, open a terminal and again
                      issue the command:

                      aplay -l


                      You will normally find that your computer's default sounds, any sounds played via
                      your Internet browser and/or Flash, etc. typically default to "card 0". To avoid
                      having these sounds sent over the amateur radio ways, you should really consider
                      using any other ALSA detected "cards" other than "card 0" for fldigi.
                      --



                      Richard Dowty wrote:
                      I am really green about linux in what to do... I have no idea what or how to do with what instructions you have applied.
                      Rich/W7EET

                      --- On Sat, 4/2/11, w1hkj <w1hkj@...> wrote:

                      From: w1hkj <w1hkj@...>
                      Subject: Re: [linuxham] error on fldigi
                      To: linuxham@yahoogroups.com
                      Date: Saturday, April 2, 2011, 11:58 AM

                       

                      I just posted a how-to file with instructions on setting the sound card device ordering on boot.  Doing so will allow you to add / remove other sound devices such as a USB thumb codec without altering the device # for one like the USB SignaLink.

                      Dave, W1HKJ

                      Richard Dowty wrote:

                      Thanks for the idea. I found the problem. I had a extra USB plugged in with nothing attached to it. Then another thing the audio set up changed to nothing so I had to change it back so the Signalink USB could be detected. With these two changes the error went away. Also, I unplugged the Signalink then re-plugged it back into the same port.
                      Rich/W7EET

                      --- On Sat, 4/2/11, David A. Ranch <linuxham-fld@...> wrote:

                      From: David A. Ranch <linuxham-fld@...>
                      Subject: Re: [linuxham] error on fldigi
                      To: linuxham@yahoogroups.com
                      Date: Saturday, April 2, 2011, 2:53 AM

                       


                      I've found this happens on Linux when the USB system has enumerated the sound card differently (ALSA #s, serial port ttyS*)  than what was previous set in Fldigi.  Shutdown all the apps that might be using your soundcard or soundcard+serial ports, unplug the USB device (if that's what you have), and re-plug it in.

                      --David




                    • David A. Ranch
                      Though Fedora is a different distribution than Ubuntu, most Linux distributions share 90%+ of the same Linux and other free software (licensed as GNU, GPL,
                      Message 10 of 15 , Apr 2, 2011
                      • 0 Attachment

                        Though Fedora is a different distribution than Ubuntu, most Linux distributions share 90%+ of the same Linux and other free software (licensed as GNU, GPL, LGPL, Apache, BSD, etc.).  Anyway, Fedora 14 uses PulseAudio just like Ubuntu 9.10+:

                           http://docs.fedoraproject.org/en-US/Fedora/14/html/Musicians_Guide/sect-Musicians_Guide-Sound_Servers_Section.html

                        PulseAudio fundamentally still uses most of the ALSA soundcard backend for it's hardware drivers and what not so those instructions that Dave provided should still hold true.

                        --David


                        Richard Dowty wrote:
                        I am using Fedora 14 which is different than Ubuntu.
                        Rich/W7EET

                        --- On Sat, 4/2/11, David A. Ranch <linuxham-fld@...> wrote:

                        From: David A. Ranch <linuxham-fld@...>
                        Subject: Re: [linuxham] error on fldigi
                        To: linuxham@yahoogroups.com
                        Date: Saturday, April 2, 2011, 6:13 PM

                         

                        Hello Rich,
                        
                        Let me expand a little on Dave's document to make it more clear assuming 
                        your computer is using the ALSA sound system.  I'm not running the Pulse 
                        system which is found in the newest Ubuntus, etc.  (you never mentioned 
                        which Linux distribution you're running)
                        
                        --
                        In systems with multiple sound cards they might not always be in the 
                        same order on boot due to users inserting other USB devices, etc. 
                        over the use of that booting of Linux.  This may cause problems not 
                        only with fldigi, but other apps that depend on a certain sound card
                        to be found in a specific order.  
                        
                        The work around is not that difficult and will reliably place the preferred
                        sound card in the correct slot. With the ALSA sound system, sound cards are 
                        numbered from 0 on to however many cards you have in your computer. Usually 
                        its only 2. 
                        
                        The 1st step is to determine the correct id of the cards in your
                         system.
                        
                        Open a terminal window (command prompt for you Windows people) once Linux is 
                        booted and issue the following command:
                        
                           aplay -l
                        
                        That command is short for "ALSA play" and will list out the detected soundcards.
                        Here is an example of what you may see:
                        
                        **** List of PLAYBACK Hardware Devices ****
                        card 0: ICH6 [Intel ICH6], device 0: Intel ICH [Intel ICH6]
                          Subdevices: 1/1
                          Subdevice #0: subdevice #0
                        card 0: ICH6 [Intel ICH6], device 4: Intel ICH - IEC958 [Intel ICH6 - IEC958]
                          Subdevices: 1/1
                          Subdevice #0: subdevice #0
                        card 1: AudioPCI [Ensoniq AudioPCI], device 0: ES1371/1 [ES1371 DAC2/ADC]
                          Subdevices: 1/1
                          Subdevice #0: subdevice #0
                        card 1: AudioPCI [Ensoniq AudioPCI], device 1: ES1371/2 [ES1371 DAC1]
                          Subdevices: 1/1
                          Subdevice #0: subdevice #0
                        
                        
                        With that list of soundcards, let's force the order that ALSA will detect
                        and use
                         them.  If the file does not already exist, you will need to create the 
                        following file with your favorite editor (Vim, Emacs, nano, etc.).  For
                        this example, we'll assume vim for now:
                        
                           vim /etc/modprobe.d/alsa-options
                        
                        You will need root privileges to create the file, so a system such as
                        Ubuntu that depends on the "sudo" command to get root privs, you would 
                        enter:
                        
                        $ sudo vim /etc/modprobe.d/alsa-options
                        
                        
                        Using the above example hardware, you would edit that file so that it's 
                        contents contain the exact following:
                        
                        # Set preferred order of the sound cards
                        options snd-ICH6 index=0
                        options snd-AudioPCI index=1
                        
                        Close the file and exit the editor.  What the above says is basically that
                        the "ICH6" soundcard should always be first in the list (slot 0) and the 
                        "AudioPCI" card should be second.  If you have multiple "AudioPCI" cards
                        on your machine, there are additional options you
                         could specify but that's
                        out of the scope of this help document.
                        
                        
                        To this new configuration, reboot your Linux computer, open a terminal and again 
                        issue the command: 
                        
                           aplay -l
                        
                        
                        You will normally find that your computer's default sounds, any sounds played via
                        your Internet browser and/or Flash, etc. typically default to "card 0".  To avoid
                        having these sounds sent over the amateur radio ways, you should really consider 
                        using any other ALSA detected "cards" other than "card 0" for fldigi.
                        --
                        
                                  


                        Richard Dowty wrote:
                        I am really green about linux in what to do... I have no idea what or how to do with what instructions you have applied.
                        Rich/W7EET

                        --- On Sat, 4/2/11, w1hkj <w1hkj@...> wrote:

                        From: w1hkj <w1hkj@...>
                        Subject: Re: [linuxham] error on fldigi
                        To: linuxham@yahoogroups.com
                        Date: Saturday, April 2, 2011, 11:58 AM

                         

                        I just posted a how-to file with instructions on setting the sound card device ordering on boot.  Doing so will allow you to add / remove other sound devices such as a USB thumb codec without altering the device # for one like the USB SignaLink.

                        Dave, W1HKJ

                        Richard Dowty wrote:

                        Thanks for the idea. I found the problem. I had a extra USB plugged in with nothing attached to it. Then another thing the audio set up changed to nothing so I had to change it back so the Signalink USB could be detected. With these two changes the error went away. Also, I unplugged the Signalink then re-plugged it back into the same port.
                        Rich/W7EET

                        --- On Sat, 4/2/11, David A. Ranch <linuxham-fld@...> wrote:

                        From: David A. Ranch <linuxham-fld@...>
                        Subject: Re: [linuxham] error on fldigi
                        To: linuxham@yahoogroups.com
                        Date: Saturday, April 2, 2011, 2:53 AM

                         


                        I've found this happens on Linux when the USB system has enumerated the sound card differently (ALSA #s, serial port ttyS*)  than what was previous set in Fldigi.  Shutdown all the apps that might be using your soundcard or soundcard+serial ports, unplug the USB device (if that's what you have), and re-plug it in.

                        --David




                      • Ed
                        On Sat, 2 Apr 2011 10:47:12 -0700 (PDT) ... My first suggestion is to buy a book on Linux. Probably a Linux bible. I m not sure what made you decide on Fedora,
                        Message 11 of 15 , Apr 2, 2011
                        • 0 Attachment
                          On Sat, 2 Apr 2011 10:47:12 -0700 (PDT)
                          Richard Dowty <w7eet@...> wrote:

                          > I am really green about linux in what to do... I have no idea what or
                          > how to do with what instructions you have applied. Rich/W7EET
                          >
                          > --- On Sat, 4/2/11, w1hkj <w1hkj@...> wrote:



                          My first suggestion is to buy a book on Linux. Probably a Linux bible.

                          I'm not sure what made you decide on Fedora, but as a Linux newbie it
                          would be at the bottom of the list.

                          I would suggest installing Ubuntu 10.04 which is more user friendly and
                          a lot easier to get around in for a newbie.

                          I sent the original how-to on sound to Dave. He added some
                          refinements, but I have to credit Hamish Moffatt, VK3SB for the
                          original help with this.

                          Ed W3NR
                        • David A. Ranch
                          Though not on topic for the Fldigi list but Fedora is a fine HAM shack Linux and there is no reason to abandon it and start all over. I would argue that
                          Message 12 of 15 , Apr 2, 2011
                          • 0 Attachment
                            Though not on topic for the Fldigi list but Fedora is a fine HAM shack
                            Linux and there is no reason to abandon it and start all over. I would
                            argue that Fedora is not any more difficult to use or learn than
                            Ubuntu. It comes down to personal preference and I encourage you to
                            try different distributions and come to your own conclusions. They all
                            have their unique strengths. With that said, for HAM specific uses,
                            you'll probably be best off with non-cutting edge versions of either
                            Ubuntu (only run the x.04 releases such as 9.04 or 10.04) , Fedora, or
                            say Puppy Linux.

                            Me? I run Centos (distantly related to Fedora) but I'm a masochist.
                            Nothing is easy HA M wise with this distribution other than I get
                            security updates for five yrs.

                            --David

                            > I'm not sure what made you decide on Fedora, but as a Linux newbie it
                            > would be at the bottom of the list.
                            >
                          • doc@kd4e.com
                            My personal recommendation is Puppy Linux. The Puppy Forum includes developers and users, most of whom are very helpful, and the archives are loaded with info.
                            Message 13 of 15 , Apr 2, 2011
                            • 0 Attachment
                              My personal recommendation is Puppy Linux.

                              The Puppy Forum includes developers and users, most of
                              whom are very helpful, and the archives are loaded with
                              info.

                              Also, there are lots of different sub-versions of Puppy,
                              each optimized for various purposes - but loosely based
                              on the same core.

                              The heart of Puppy is small, fast, efficient, and flexible.

                              I use "Fluppy" Linux. It is based on Puppy and flows from
                              the "Puppeee" project - an early effort to optimize Linux
                              for the eee-series of Netbooks.

                              Fluppy is more generic then "Puppeee" - we have it on four
                              notebook and two netbook PCs.

                              Here's the Pupeee homepage:
                              http://puppeee.com/web/

                              Here are various popular apps that have been compiled to
                              run well under Puppeee and Fluppy:
                              http://puppeee.com/web/petstore/

                              Here is the generic Puppy Linux homepage:
                              http://puppylinux.org/main/Overview and Getting Started.htm

                              HTH ...

                              --

                              Thanks! & 73, KD4E
                              David Colburn http://kd4e.com
                              SE-GA Tailgate - April 9th, 2011
                              Have an http://ultrafidian.com day
                              I don't google I SEARCH! http://ixquick.com
                              Shop Freedom-Friendly http://kd4e.com/of.html
                            • Ed
                              On Sat, 02 Apr 2011 17:13:14 -0700 ... I see the last release of Centos was May of 2010. To each his own. Ed W3NR
                              Message 14 of 15 , Apr 2, 2011
                              • 0 Attachment
                                On Sat, 02 Apr 2011 17:13:14 -0700
                                "David A. Ranch" <linuxham-fld@...> wrote:


                                >
                                > Me? I run Centos (distantly related to Fedora) but I'm a masochist.
                                > Nothing is easy HA M wise with this distribution other than I get
                                > security updates for five yrs.
                                >
                                > --David

                                I see the last release of Centos was May of 2010. To each his own.

                                Ed W3NR
                              • Rick Kunath
                                ... PulseAudio os designed to manage the audio devices for you, just as you expect. If you use the ALSA or ALSA/OSS (does Fedora 14 even have OSS emulation in
                                Message 15 of 15 , Apr 3, 2011
                                • 0 Attachment
                                  On Saturday, April 02, 2011 03:00:19 pm you wrote:
                                  > Though Fedora is a different distribution than Ubuntu, most Linux
                                  > distributions share 90%+ of the same Linux and other free software
                                  > (licensed as GNU, GPL, LGPL, Apache, BSD, etc.). Anyway, Fedora 14 uses
                                  > PulseAudio just like Ubuntu 9.10+:

                                  PulseAudio os designed to manage the audio devices for you, just as you
                                  expect. If you use the ALSA or ALSA/OSS (does Fedora 14 even have OSS
                                  emulation in the kernel any more?) or the PortAudio APIs then you bypass
                                  PulseAudio's already built-in way of handling this.

                                  Select Pulse from Fldigi, then start the PulseAudio Volume Control. Install it
                                  if it isn't there, but it should be, and find in the playback and recording
                                  tabs, the entry for Fldigi there. Select the sound device and input or output
                                  that you want Fldigi to use, and Pulse will remember it from then on. Pulse
                                  will handle any sample rate conversions for you.

                                  A typical sound card has *many* inputs and outputs and many modes of operation
                                  from stereo to surround sound to mono to various sample rates. There is no
                                  *one* entry that will work for a manually entered card setup using ALSA or
                                  ALSA/OSS or PortAudio. You need to know what to select. The changing numbering
                                  isn't just limited to Linux, Windows will sometimes do this too. It's one of
                                  the disadvantages to using USB for sound. Pulse helps a lot with this.

                                  Any modern distro should have a fully working PulseAudio system. Use it.
                                  That's why it is there, to handle the management of the sound devices and the
                                  inputs and outputs to and from applications for you. This is possible using
                                  Pulse on a single machine or across a network to another machine. Pulse has
                                  many features, such as stream redirection, i.e. sent the output to another
                                  machine across the room or around the world, or just to making the remembering
                                  of the preferred device for an application permanent.

                                  Pulse had a few rough edges when the change to it was first underway, but those
                                  days are long past.

                                  Rick Kunath, k9ao
                                Your message has been successfully submitted and would be delivered to recipients shortly.