Loading ...
Sorry, an error occurred while loading the content.

Re: Cwdaemon error

Expand Messages
  • t_ashland
    Hi Bob, Thanks for the excellent instructions! I now have it working with xlog. One little bugaboo. I still have to run cwdaemon as root. Do I need to chown
    Message 1 of 7 , Apr 3, 2007
    • 0 Attachment
      Hi Bob,
      Thanks for the excellent instructions! I now have it working with xlog.
      One little bugaboo. I still have to run cwdaemon as root. Do I need
      to chown or chgrp cwdaemon to my account or a group that I belong to?
      Thanks again for the help. I could have banged my head for days
      trying to figure this out.
      Terry

      --- In linuxham@yahoogroups.com, Bob Nielsen <nielsen@...> wrote:
      >
      >
      > On Apr 3, 2007, at 7:01 PM, t_ashland wrote:
      >
      > > Thanks for the quick reply. I should have mentioned I am running
      > > Ubuntu. I looked in the Synaptic Package Manager and found some
      > > references to parport, but nothing specific. Any ideas what
      > > particular package I need to install? Ubuntu is Debian based....
      > > 73,
      > > Terry, WK0F
      >
      > Fine (I am also running Ubuntu). The following information (from /
      > usr/share/doc/cwdaemon/README.gz) should help:
      >
      > Setting up parallel port(s) on linux for cwdaemon
      > -------------------------------------------------
      > You need the parport devices to use cwdaemon. Check if you have them:
      >
      > ls -al /dev/parport*
      >
      > If you don't see any files, create the with MAKEDEV (as root user):
      >
      > cd /dev; ./MAKEDEV parport
      >
      > Next, check whether the parport and parport_pc kernel modules are
      > loaded: when
      > you type 'lsmod', you should (on the i386 architecture) see something
      > like:
      >
      > parport_pc 23304 0 (autoclean)
      > parport 25992 0 (autoclean) [parport_pc]
      >
      > The lp module should not be loaded, it is only needed if you want to
      > use a
      > printer and it will block the parallel port if you use cwdaemon. You
      > can unload
      > it with the command 'rmmod lp' as root.
      >
      > If you don't see any parport modules please check whether you have
      > the line:
      >
      > alias parport_lowlevel parport_pc
      >
      > in your /etc/modules.conf file and load the modules with:
      >
      > modprobe parport
      > modprobe parport_pc
      >
      > Be sure that parallel port support is enabled in your BIOS! If you
      > use odd
      > ioports or interrupts, you can do things like:
      >
      > modprobe parport_pc io=0x3bc,0x378,0x278 irq=none,7,auto
      >
      > which configures 3 parallel ports with the second port using irq 7
      > and the
      > third port some auto-detected irq.
      >
      > When cwdaemon is run, the ppdev kernel module should be loaded
      > automatically.
      > In case it doesn't, just type:
      >
      > modprobe ppdev
      >
      > 73, Bob N7XY
      >
    • Bob Nielsen
      Since cwdaemon is a daemon, it is started automatically at boot time by /etc/init.d/cwdaemon. Try sudo /etc/init.d/cwdaemon start if it isn t already
      Message 2 of 7 , Apr 3, 2007
      • 0 Attachment
        Since cwdaemon is a daemon, it is started automatically at boot time
        by /etc/init.d/cwdaemon. Try 'sudo /etc/init.d/cwdaemon start' if it
        isn't already running.

        Take a look at /usr/share/doc/cwdaemon/README.Debian and README.gz
        for some additional information (probably a good idea with many
        packaged applications).

        Bob

        On Apr 3, 2007, at 8:05 PM, t_ashland wrote:

        > Hi Bob,
        > Thanks for the excellent instructions! I now have it working with
        > xlog.
        > One little bugaboo. I still have to run cwdaemon as root. Do I need
        > to chown or chgrp cwdaemon to my account or a group that I belong to?
        > Thanks again for the help. I could have banged my head for days
        > trying to figure this out.
        > Terry
        >
        > --- In linuxham@yahoogroups.com, Bob Nielsen <nielsen@...> wrote:
        >>
        >>
        >> On Apr 3, 2007, at 7:01 PM, t_ashland wrote:
        >>
        >>> Thanks for the quick reply. I should have mentioned I am running
        >>> Ubuntu. I looked in the Synaptic Package Manager and found some
        >>> references to parport, but nothing specific. Any ideas what
        >>> particular package I need to install? Ubuntu is Debian based....
        >>> 73,
        >>> Terry, WK0F
        >>
        >> Fine (I am also running Ubuntu). The following information (from /
        >> usr/share/doc/cwdaemon/README.gz) should help:
        >>
        >> Setting up parallel port(s) on linux for cwdaemon
        >> -------------------------------------------------
        >> You need the parport devices to use cwdaemon. Check if you have them:
        >>
        >> ls -al /dev/parport*
        >>
        >> If you don't see any files, create the with MAKEDEV (as root user):
        >>
        >> cd /dev; ./MAKEDEV parport
        >>
        >> Next, check whether the parport and parport_pc kernel modules are
        >> loaded: when
        >> you type 'lsmod', you should (on the i386 architecture) see something
        >> like:
        >>
        >> parport_pc 23304 0 (autoclean)
        >> parport 25992 0 (autoclean) [parport_pc]
        >>
        >> The lp module should not be loaded, it is only needed if you want to
        >> use a
        >> printer and it will block the parallel port if you use cwdaemon. You
        >> can unload
        >> it with the command 'rmmod lp' as root.
        >>
        >> If you don't see any parport modules please check whether you have
        >> the line:
        >>
        >> alias parport_lowlevel parport_pc
        >>
        >> in your /etc/modules.conf file and load the modules with:
        >>
        >> modprobe parport
        >> modprobe parport_pc
        >>
        >> Be sure that parallel port support is enabled in your BIOS! If you
        >> use odd
        >> ioports or interrupts, you can do things like:
        >>
        >> modprobe parport_pc io=0x3bc,0x378,0x278 irq=none,7,auto
        >>
        >> which configures 3 parallel ports with the second port using irq 7
        >> and the
        >> third port some auto-detected irq.
        >>
        >> When cwdaemon is run, the ppdev kernel module should be loaded
        >> automatically.
        >> In case it doesn't, just type:
        >>
        >> modprobe ppdev
        >>
        >> 73, Bob N7XY
        >>
        >
        >
        >
        >
        >
        > Yahoo! Groups Links
        >
        >
        >
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.