Loading ...
Sorry, an error occurred while loading the content.

SUMMARY: Kickstart question (how to force static IP after installation)

Expand Messages
  • vikassharma_del
    I found the solution to the problem by myself. :-) The problem was the backup file which I named as ifcfg- eth0.ORIG.060608 After some time investment, and in
    Message 1 of 4 , Jun 9, 2008
    • 0 Attachment
      I found the solution to the problem by myself. :-)

      The problem was the backup file which I named as ifcfg-
      eth0.ORIG.060608

      After some time investment, and in front of the system, I found that
      my system was taking following files in following sequence:

      ifcfg-eth0
      ifcfg-eth0.ORIG.060608

      I am wondering the way Linux was designed that it took the
      interface's actual + other junk file as well (when I renamed the
      second file to something else, which doesn't have ifcfg-eth0 in
      starting, it cameup fine). Definately it need to be modified by Linux
      engineers (I mean the RHEL guys) :-)




      --- In linux@yahoogroups.com, "Unix Admin" <unix.95054@...> wrote:
      >
      > Hello Linux gurus,
      >
      > I have a question related to Kickstart. I setup my kickstart + dhcp
      server
      > and finally installed the OS on a client.
      >
      > But, the client is still taking DHCP IP address which I want to
      turn to
      > static one.
      >
      > The help I need is:
      > 1) How to change the DHCP to static IP on client side?
      > 2) How to make sure that client will take static IP address after
      > installation?
      >
      > I am not very much into Linux (basically Solaris admin). Any help
      will be
      > appreciated.
      >
      > Thanks,
      > Unix Admin
      >
      >
      > [Non-text portions of this message have been removed]
      >
    • AMBARISH Sawant
      You can also assign FIXED IP ( like static IP ) with the help of MAC Bounding This setting can be done in dhcpd.conf file ... From: Unix Admin
      Message 2 of 4 , Jun 10, 2008
      • 0 Attachment
        You can also assign FIXED IP ( like static IP ) with the help of MAC Bounding
        This setting can be done in dhcpd.conf file

        --- On Mon, 9/6/08, Unix Admin <unix.95054@...> wrote:
        From: Unix Admin <unix.95054@...>
        Subject: [linux] Kickstart question (how to force static IP after installation)
        To: linux@yahoogroups.com
        Date: Monday, 9 June, 2008, 10:32 PM











        Hello Linux gurus,



        I have a question related to Kickstart. I setup my kickstart + dhcp server

        and finally installed the OS on a client.



        But, the client is still taking DHCP IP address which I want to turn to

        static one.



        The help I need is:

        1) How to change the DHCP to static IP on client side?

        2) How to make sure that client will take static IP address after

        installation?



        I am not very much into Linux (basically Solaris admin). Any help will be

        appreciated.



        Thanks,

        Unix Admin



        [Non-text portions of this message have been removed]



























        Explore your hobbies and interests. Go to http://in.promos.yahoo.com/groups/

        [Non-text portions of this message have been removed]
      • ed
        On Mon, 09 Jun 2008 19:11:21 -0000 ... /etc/rcN.d/ works a little like this. If you copied a symlink else where, but left it in that directory then it would be
        Message 3 of 4 , Jun 10, 2008
        • 0 Attachment
          On Mon, 09 Jun 2008 19:11:21 -0000
          "vikassharma_del" <unix.95054@...> wrote:

          > I found the solution to the problem by myself. :-)
          >
          > The problem was the backup file which I named as ifcfg-
          > eth0.ORIG.060608
          >
          > After some time investment, and in front of the system, I found that
          > my system was taking following files in following sequence:
          >
          > ifcfg-eth0
          > ifcfg-eth0.ORIG.060608
          >
          > I am wondering the way Linux was designed that it took the
          > interface's actual + other junk file as well (when I renamed the
          > second file to something else, which doesn't have ifcfg-eth0 in
          > starting, it cameup fine). Definately it need to be modified by Linux
          > engineers (I mean the RHEL guys) :-)

          /etc/rcN.d/ works a little like this. If you copied a symlink else
          where, but left it in that directory then it would be also be treated
          the same way.

          Generally you're going to benefit from putting backups in your home
          directory when automated scripts iterate a configuration directory.

          --
          The SCSI Controller to the Xbox is paging like Tristan because of All
          your base are belong to us. The Rebel Alliance is unaware that they
          lost their last system administrator. :: http://www.s5h.net/ ::
          http://www.s5h.net/gpg.html


          [Non-text portions of this message have been removed]
        Your message has been successfully submitted and would be delivered to recipients shortly.