Loading ...
Sorry, an error occurred while loading the content.

Re: [linux] ldconfig: Cannot lstat .....libmysqlclient.so.15.0.0: Permission denied

Expand Messages
  • Agnello George
    ... i kinda of solved this problem ( i think ) by diabling selinux using the command setenforce 0 i then did a #ldconf didnt get any error !! :-) but is
    Message 1 of 3 , Mar 31 5:57 AM
    • 0 Attachment
      On 3/31/08, Geert Geurts <begeert@...> wrote:
      >
      >
      >
      >
      >
      >
      > Hello Agnello,
      > did you run ldconfig?
      > I was looking in to your problem and found in the man pages ldconfig -v
      > run by root is used to rebuild the cache. Don't know if this cache is
      > rebuilded every boottime but could be your problem if the make didn't
      > call it.
      >
      > Greetings,
      > Geert
      >
      >
      > On Sat, 2008-03-29 at 22:26 +0530, Agnello George wrote:
      > > I am tring to install LAMP on fedora core 7
      > > i have installed mysql ( mysql-5.0.45 )
      > >
      > > ./configure --prefix=/usr/local/mysql
      > > --localstatedir=/usr/local/mysql/data
      > > --disable-maintainer-mode --with-mysqld-user=mysql
      > > --enable-large-files-without-debug
      > >
      > > make && make install
      > >
      > > and every thing went fine
      > >
      > > inorder to tell the system where ro find the dynamic libraries i added
      > > echo "/usr/local/mysql/lib/mysql" >> /etc/ld.so.conf
      > >
      > > when i ran the following command it gave me the this error
      > >
      > > # ldconfig
      > >
      > > [root@v3 bin]# ldconfig -v
      > >
      > > ldconfig: Cannot stat /usr/local/mysql/lib/mysql/libmysqlclient.so.15:
      > > Permission denied/usr/local/mysql/lib/mysql:
      > > ldconfig: Cannot stat /usr/local/mysql/lib/mysql/libmysqlclient.so:
      > > Permission denied
      > > ldconfig: Cannot
      > > lstat /usr/local/mysql/lib/mysql/libmysqlclient.so.15.0.0:
      > > Permission denied
      > >
      > > the permission in this direcory is as follows :
      > >
      > > [root@v3 bin]# ll /usr/local/mysql/lib/mysql/
      > > total 2384
      > > -rw-r--r-- 1 root mysql 12376 2008-03-29 20:18 libdbug.a
      > > -rw-r--r-- 1 root mysql 48896 2008-03-29 20:18 libheap.a
      > > -rw-r--r-- 1 root mysql 369964 2008-03-29 20:18 libmyisam.a
      > > -rw-r--r-- 1 root mysql 27578 2008-03-29 20:18 libmyisammrg.a
      > > -rw-r--r-- 1 root mysql 641264 2008-03-29 20:18 libmysqlclient.a
      > > -rwxr-xr-x 1 root mysql 875 2008-03-29 20:18 libmysqlclient.la
      > > lrwxrwxrwx 1 root root 24 2008-03-29 20:18 libmysqlclient.so ->
      > > libmysqlclient.so.15.0.0
      > > lrwxrwxrwx 1 root root 24 2008-03-29 20:18 libmysqlclient.so.15 ->
      > > libmysqlclient.so.15.0.0
      > > -rwxr-xr-x 1 root mysql 530840 2008-03-29 20:18
      > > libmysqlclient.so.15.0.0
      > > -rw-r--r-- 1 root mysql 289666 2008-03-29 20:18 libmystrings.a
      > > -rw-r--r-- 1 root mysql 315422 2008-03-29 20:18 libmysys.a
      > > -rw-r--r-- 1 root mysql 7582 2008-03-29 20:18 libvio.a
      > > -rw-r--r-- 1 root mysql 89036 2008-03-29 20:18 libz.a
      > > -rwxr-xr-x 1 root mysql 761 2008-03-29 20:18 libz.la
      > >
      > > can some one help me out why i am getting this Premission denied error
      > >
      > > Thanks a million!!
      >

      i kinda of solved this problem ( i think ) by diabling selinux using
      the command setenforce 0

      i then did a #ldconf

      didnt get any error !! :-)

      but is there a workaround for this incase i do not want to disable selinux ??

      --
      Regards
      Agnello Dsouza
      www.linux-vashi.blogspot.com
      www.bible-study-india.blogspot.com
    Your message has been successfully submitted and would be delivered to recipients shortly.