Loading ...
Sorry, an error occurred while loading the content.
 

Re: [linux] asking for help on setting up LAN at home. samba & Mandrake

Expand Messages
  • Mike Peters
    On Thu, 3 Feb 2005 05:36:18 -0800 (PST) ... Yes. ... smbclient -U username //LINUX1/username Might give you a better idea actually (I cut and pasted the
    Message 1 of 16 , Feb 3, 2005
      On Thu, 3 Feb 2005 05:36:18 -0800 (PST)
      tommyL <a1tommyl@...> wrote:

      >
      > Yanno? I'm not sure! I was doing something with the smbpasswd. I
      > think i looked at it when I was reading that part in the samba
      > website..... but I couldn't tell what to do with it. I remember
      > looking at in in ls -al and seeing that it had no size. <g>
      >
      > So the CLI command syntax is "smbasswd -a sambauser" ?? (without
      > quotes)
      >

      Yes.

      > > will add a new samba user called "sambauser" and ask for a
      > > password. Use
      > > the username and give the password from your Win98 account and then
      > > that
      > > user should be able to access the share from Windows.
      > >
      > > Also have you tried connecting locally on the Linux machine using
      > > smbclient:
      > > smbclient -U username //LINUX1/IPC$
      > > to see if that gives you any extra clues to the situation?
      >
      > no, that looks greek to me. but what the heck, i'll try it.
      > I'll look again at the instruction sheets and re-read about the
      > smbasswd and and the smbclient commands. THANKS !!!!
      >

      smbclient -U username //LINUX1/username

      Might give you a better idea actually (I cut and pasted the machine name
      from your earlier mail and forgot to edit it).

      --
      Mike
      Web Site: http://www.ice2o.com
      JabberID: mpeters@...
      Registered Linux User #247123

      Q: Do you know what the death rate around here is?
      A: One per person.
    • venkat raman
      hello sir, iam realy sad to know that my idea couldn t work. anyway i will try some other impressive things next time. ... i think that guy dosen t go in win98
      Message 2 of 16 , Feb 3, 2005
        hello sir,

        iam realy sad to know that my idea couldn't work. anyway i will try some
        other impressive things next time.

        >On Thursday 03 February 2005 12:49, tommyL wrote:
        > > It doesn't ask for a username. it just wants a password.
        > > maybe I need to look at some alternatives to putting
        > > the IP address in the "valid User" line in smb.conf, I'll
        > > read more about that.
        > >
        > > > if it is nt or 2000 series it would have
        > > > asked
        > > > for username and passwd.
        > >
        > > Win98.
        >
        >This IPC$ thing is very common, google should help. I think you have to log
        >on
        >win98 as a user, but I cant remember how to switch users on. Do you have a
        >'logon as user' thingy at the start menu? When you shutdown is there a 'log
        >off' that allows you to log in again as a different user?
        >All my win98 paritions show a login dialog when they boot up (and the
        >user/pwd
        >is already filled in).

        i think that guy dosen't go in win98 by the username and the log in i have
        that same experence. i got that error before ipc$ it due to the worng
        username and passwd.

        by the way error will not say "iam an error" we have to identify it as a
        error and rectify it.


        in your previous mail you said that your win98 network showed you:

        >I can
        >see, in my network neighborhood on the 98 machine, a new directory
        >with the label of the mandrake machines name on it, (linux1). (YAY
        >!!!)

        this is your workgroup name linux1 now you are saying your workgroup name is
        workgroup.


        >>have you created an seperate user (ie you specifed the user in
        >>/etc/samba/smb.conf valid user=" ")with an passwd and do the same
        >>for smbuseradd with the same user name and passwd.

        >yes I set the valid user as IP addresses and There is a linux user
        >with same password on the linux machine. I have tried both encrypted
        >settings and non encrypted settings in smb.conf too. the encrypt or
        >not encrypt didn't make a difference at all.

        you may have set an same username and passwd but you haven't login with it
        in win98.

        if you have done it you can able to see you share. see an other way is there
        is by go to run //<hostname>/<smb share name> or //<ipaddress> give it after
        logging with the linux username and passwd.

        thanking you
        raman

        _________________________________________________________________
        The real power of teamwork. Experience it in real time.
        http://www.microsoft.com/india/office/experience/ Experience MS Office
        System.
      Your message has been successfully submitted and would be delivered to recipients shortly.