Loading ...
Sorry, an error occurred while loading the content.

RE: [linux] asking for help on setting up LAN at home. samba & Mandrake

Expand Messages
  • venkat raman
    hello sir, ... sir see here configuring samba is an simple thing before asking to us u should have gone to google and searched for it.a documentation of samba
    Message 1 of 16 , Jan 31, 2005
    • 0 Attachment
      hello sir,


      >So the machines can ping each other. But I can't browse the shared
      >folders that i've set up on both machines. If I need to run samba, I
      >can't even tell if I have that application on my LINUX machine.
      >I have the mandrake 10.1 community version. I've been ALL OVER the
      >hardware setup and computer setup functions and can't find anything
      >that references SAMBA.


      sir see here configuring samba is an simple thing before asking to us u
      should have gone to google and searched for it.a documentation of samba is
      more than enough for a normal person to under stand. it is not that you
      should configure samba in tui u can configure use swats for that you gor to
      install swat. it is on your rh cd



      >And I saw where I need to set up a user account on the linux machine
      >that matches the login (and password) on the win98 machine. How do I
      >create a user without creating the /home/username place on the
      >hardrive? (or doesn't that matter??)


      i cannot understand your question how could be possiable to create user
      without an path. if you are sure in this you can create your user account on
      /root so that no extra disk place will be taken for a user.or create a user
      in /home/<username> and add all the users to that path. if you want to make
      linux as your server (ie., where I need to set up a user account on the
      linux machine
      that matches the login (and password) on the win98 machine)

      then you must configure nis to do


      i didn't give you all the smb doc providers being it is already provided by
      scottro@.... it is more than enough.

      >Can anyone help me here??
      >

      help is in your way

      thanking you
      raman

      _________________________________________________________________
      Try the all-new MSN Search! Find exactly what you want.
      http://search.msn.co.in Get more value for your time.
    • Harold Heckuba
      ... directories. ... up on both machines. If I need to run samba, I can t .even tell if I have that application on my ... WARNING: Serious Newbie running
      Message 2 of 16 , Feb 1, 2005
      • 0 Attachment
        --- tommyL <a1tommyl@...> wrote:

        > Now I'm trying to get the LINUX machine to talk to
        > the Win98 machine
        >
        > The problem in a nutshell: "I can't share
        directories."
        > But I can't browse the shared folders that i've set
        up on both machines. If I need to run samba, I can't
        .even tell if I have that application on my
        > LINUX machine.
        >
        >

        WARNING: Serious Newbie running SUSE 9.x so proceed
        with caution.

        First off, this was great help to me:
        http://www.brennan.id.au/18-Samba.html

        My Samba configuration file was located in etc/samba.
        It is below. The directory I am sharing is the ehs
        directory listed at the bottom of the file. I added
        the valid user because I only want one person loging
        into the share. I do not know how secure this really
        is. I often wonder if I should make it nonbrowesable.

        To start samba I type in rcsmb start and to stop it,
        rcsmb stop. If you make a change to the conf file,
        you will need to restart the service. That's what got
        me.


        # Date: 2003-09-23
        [global]
        workgroup = WORKGROUP
        os level = 2
        time server = Yes
        unix extensions = Yes
        encrypt passwords = yes
        map to guest = Bad User
        printing = CUPS
        printcap name = CUPS
        socket options = SO_KEEPALIVE IPTOS_LOWDELAY
        TCP_NODELAY
        wins support = No
        veto files = /*.eml/*.nws/riched20.dll/*.{*}/
        server string = Samba Server
        add user script =
        domain master = false
        domain logons = no
        local master = no
        preferred master = auto
        ;; ldap server = 127.0.0.1
        security = user
        [homes]
        comment = Home Directories
        valid users = %S
        browseable = no
        read only = No
        create mask = 0640
        directory mask = 0750
        guest ok = no
        printable = no
        [printers]
        comment = All Printers
        path = /var/tmp
        printable = yes
        create mask = 0600
        browseable = no
        guest ok = no
        [print$]
        comment = Printer Drivers
        path = /var/lib/samba/drivers
        write list = @ntadmin root
        force group = ntadmin
        create mask = 0664
        directory mask = 0775
        browseable = yes
        guest ok = no
        printable = no
        [ehs]
        comment = EHS Presentations
        path = /home/jmarcks/EHS/
        create mask = 0666
        directory mask = 0777
        valid users = jmarcks




        __________________________________________________
        Do You Yahoo!?
        Tired of spam? Yahoo! Mail has the best spam protection around
        http://mail.yahoo.com
      • TheMiyaca
        go to the linux documentation project (tldp.org) and search for the samba howto.
        Message 3 of 16 , Feb 1, 2005
        • 0 Attachment
          go to the linux documentation project (tldp.org) and search for the
          samba howto.

          --- In linux@yahoogroups.com, Harold Heckuba <harold_heckuba@y...>
          wrote:
          > --- tommyL <a1tommyl@y...> wrote:
          >
          > > Now I'm trying to get the LINUX machine to talk to
          > > the Win98 machine
          > >
          > > The problem in a nutshell: "I can't share
          > directories."
          > > But I can't browse the shared folders that i've set
          > up on both machines. If I need to run samba, I can't
          > .even tell if I have that application on my
          > > LINUX machine.
          > >
          > >
          >
          > WARNING: Serious Newbie running SUSE 9.x so proceed
          > with caution.
          >
          > First off, this was great help to me:
          > http://www.brennan.id.au/18-Samba.html
          >
          > My Samba configuration file was located in etc/samba.
          > It is below. The directory I am sharing is the ehs
          > directory listed at the bottom of the file. I added
          > the valid user because I only want one person loging
          > into the share. I do not know how secure this really
          > is. I often wonder if I should make it nonbrowesable.
          >
          > To start samba I type in rcsmb start and to stop it,
          > rcsmb stop. If you make a change to the conf file,
          > you will need to restart the service. That's what got
          > me.
          >
          >
          > # Date: 2003-09-23
          > [global]
          > workgroup = WORKGROUP
          > os level = 2
          > time server = Yes
          > unix extensions = Yes
          > encrypt passwords = yes
          > map to guest = Bad User
          > printing = CUPS
          > printcap name = CUPS
          > socket options = SO_KEEPALIVE IPTOS_LOWDELAY
          > TCP_NODELAY
          > wins support = No
          > veto files = /*.eml/*.nws/riched20.dll/*.{*}/
          > server string = Samba Server
          > add user script =
          > domain master = false
          > domain logons = no
          > local master = no
          > preferred master = auto
          > ;; ldap server = 127.0.0.1
          > security = user
          > [homes]
          > comment = Home Directories
          > valid users = %S
          > browseable = no
          > read only = No
          > create mask = 0640
          > directory mask = 0750
          > guest ok = no
          > printable = no
          > [printers]
          > comment = All Printers
          > path = /var/tmp
          > printable = yes
          > create mask = 0600
          > browseable = no
          > guest ok = no
          > [print$]
          > comment = Printer Drivers
          > path = /var/lib/samba/drivers
          > write list = @ntadmin root
          > force group = ntadmin
          > create mask = 0664
          > directory mask = 0775
          > browseable = yes
          > guest ok = no
          > printable = no
          > [ehs]
          > comment = EHS Presentations
          > path = /home/jmarcks/EHS/
          > create mask = 0666
          > directory mask = 0777
          > valid users = jmarcks
          >
          >
          >
          >
          > __________________________________________________
          > Do You Yahoo!?
          > Tired of spam? Yahoo! Mail has the best spam protection around
          > http://mail.yahoo.com
        • venkat raman
          hello sir, ... this piece can be realy good check it out. ... by these commands (rcsmb start) i know one thing you are not an redhat user may be mandrake. ok i
          Message 4 of 16 , Feb 2, 2005
          • 0 Attachment
            hello sir,

            >go to the linux documentation project (tldp.org) and search for the
            >samba howto.

            this piece can be realy good check it out.


            >--- In linux@yahoogroups.com, Harold Heckuba <harold_heckuba@y...>
            >wrote:
            > > --- tommyL <a1tommyl@y...> wrote:
            > >
            > > > Now I'm trying to get the LINUX machine to talk to
            > > > the Win98 machine
            > > >
            > > > The problem in a nutshell: "I can't share
            > > directories."
            > > > But I can't browse the shared folders that i've set
            > > up on both machines. If I need to run samba, I can't
            > > .even tell if I have that application on my
            > > > LINUX machine.
            > > >
            > > >
            > >
            > > WARNING: Serious Newbie running SUSE 9.x so proceed
            > > with caution.
            > >
            > > First off, this was great help to me:
            > > http://www.brennan.id.au/18-Samba.html
            > >
            > > My Samba configuration file was located in etc/samba.
            > > It is below. The directory I am sharing is the ehs
            > > directory listed at the bottom of the file. I added
            > > the valid user because I only want one person loging
            > > into the share. I do not know how secure this really
            > > is. I often wonder if I should make it nonbrowesable.
            > >
            > > To start samba I type in rcsmb start and to stop it,
            > > rcsmb stop. If you make a change to the conf file,
            > > you will need to restart the service. That's what got
            > > me.
            > >


            by these commands (rcsmb start) i know one thing you are not an redhat user
            may be mandrake.

            ok i dont care. smb conf is same for evey thing.

            you have done correct did you have a user jmarcks in ur system

            see first create a user in you system and add it to the smb user's list set
            a passwd in rh we use
            smbpadduser use it.

            restart you server how you ie jmarcks can only to inside you workgroup ie
            login win as jmarcks. if you are using win98 give just jmarcks and enter
            with the correct passwd on you gave on linux system(it is recomended to have
            both linux users passwd and the smb passwd same for a user)


            > >
            > > # Date: 2003-09-23
            > > [global]
            > > workgroup = WORKGROUP
            > > os level = 2
            > > time server = Yes
            > > unix extensions = Yes
            > > encrypt passwords = yes
            > > map to guest = Bad User
            > > printing = CUPS
            > > printcap name = CUPS
            > > socket options = SO_KEEPALIVE IPTOS_LOWDELAY
            > > TCP_NODELAY
            > > wins support = No
            > > veto files = /*.eml/*.nws/riched20.dll/*.{*}/
            > > server string = Samba Server
            > > add user script =
            > > domain master = false
            > > domain logons = no
            > > local master = no
            > > preferred master = auto
            > > ;; ldap server = 127.0.0.1
            > > security = user
            > > [homes]
            > > comment = Home Directories
            > > valid users = %S
            > > browseable = no
            > > read only = No
            > > create mask = 0640
            > > directory mask = 0750
            > > guest ok = no
            > > printable = no
            > > [printers]
            > > comment = All Printers
            > > path = /var/tmp
            > > printable = yes
            > > create mask = 0600
            > > browseable = no
            > > guest ok = no
            > > [print$]
            > > comment = Printer Drivers
            > > path = /var/lib/samba/drivers
            > > write list = @ntadmin root
            > > force group = ntadmin
            > > create mask = 0664
            > > directory mask = 0775
            > > browseable = yes
            > > guest ok = no
            > > printable = no
            > > [ehs]
            > > comment = EHS Presentations
            > > path = /home/jmarcks/EHS/
            > > create mask = 0666
            > > directory mask = 0777
            > > valid users = jmarcks


            i hope u have lot of info here

            thanking you
            raman

            _________________________________________________________________
            65,000 jobs listings. http://www.naukri.com/tieups/tieups.php?othersrcp=534
            Post your CV on Naukri.com today.
          • tommyL
            Thank you to all that have tried to help me with Samba. The first time I wrote, I had the two machines (a win98 and a mandrake 10.1 community) able to ping
            Message 5 of 16 , Feb 2, 2005
            • 0 Attachment
              Thank you to all that have tried to help me with Samba.
              The first time I wrote, I had the two machines (a win98 and
              a mandrake 10.1 community) able to ping each other. Now I have
              done a few things with the smb.conf file and started it and I can
              see, in my network neighborhood on the 98 machine, a new directory
              with the label of the mandrake machines name on it, (linux1). (YAY
              !!!)
              the problem is: when I click on it, I get a request for a password.
              It wants a password for: "Resource: \\LINUX1\IPC$ " (without the
              quotes)
              no password that I have set up on the LINUX1 machine works.

              I do not have NETBIOS set up.
              I have permissions on the win98 machine set as Share permissions not
              user permissions. The win98 machine wants to get a users list from
              the name of the win98 machine: "LEMMEN" and I get a "shared
              directories will no longer be shared. you can reshare them after you
              restart your computer."

              1. (should I do this and go for the USER level share??)
              2. What is this Resource \\LINUX1\IPC$ problem??? how can I fix
              that.??

              any help is sincerely and gratefully appreciated !!!
              tom





              __________________________________
              Do you Yahoo!?
              Yahoo! Mail - Easier than ever with enhanced search. Learn more.
              http://info.mail.yahoo.com/mail_250
            • venkat raman
              hello sir ... i think the connection problem solved worked in my way (i hope i can say like that), the problem or the error is simple. first you said you can
              Message 6 of 16 , Feb 2, 2005
              • 0 Attachment
                hello sir

                >Thank you to all that have tried to help me with Samba.
                >The first time I wrote, I had the two machines (a win98 and
                >a mandrake 10.1 community) able to ping each other. Now I have
                >done a few things with the smb.conf file and started it and I can
                >see, in my network neighborhood on the 98 machine, a new directory
                >with the label of the mandrake machines name on it, (linux1). (YAY
                >!!!)
                >the problem is: when I click on it, I get a request for a password.
                >It wants a password for: "Resource: \\LINUX1\IPC$ " (without the
                >quotes)
                >no password that I have set up on the LINUX1 machine works.

                >I do not have NETBIOS set up.
                >I have permissions on the win98 machine set as Share permissions not
                >user permissions. The win98 machine wants to get a users list from
                >the name of the win98 machine: "LEMMEN" and I get a "shared
                >directories will no longer be shared. you can reshare them after you
                >restart your computer."
                >
                >1. (should I do this and go for the USER level share??)
                >2. What is this Resource \\LINUX1\IPC$ problem??? how can I fix
                >that.??

                i think the connection problem solved worked in my way (i hope i can say
                like that), the problem or the error is simple.

                first you said you can able to see linux1 (mandrake) on your net
                neibourhood.. it the name of the workgroup which you entered in samba.

                about the errors:
                have you created an seperate user (ie you specifed the user in
                /etc/samba/smb.conf valid user=" ")with an passwd and do the same for
                smbuseradd with the same user name and passwd.

                the problem of the error \\LINUX1\IPC$ is you should log on as the username
                and with the same passwd. IPC$ error will always come when you have no
                username and passwd given. if it is nt or 2000 series it would have asked
                for username and passwd.

                it is simple you can solve it.

                thanking you
                raman

                _________________________________________________________________
                The MS Office product suite. Make efficiency a habit.
                http://www.microsoft.com/india/office/experience/ Simplify your life.
              • tommyL
                ... errrr..... no. I couldn t use the info you gave. I went back to the links that scott gave me and studied the info at the samba website and also his
                Message 7 of 16 , Feb 3, 2005
                • 0 Attachment
                  --- venkat raman <venkat83_2010@...> wrote:
                  > hello sir
                  >
                  > >Thank you to all that have tried to help me with Samba.
                  > >The first time I wrote, I had the two machines (a win98 and
                  > >a mandrake 10.1 community) able to ping each other. Now I have
                  > >done a few things with the smb.conf file and started it and I can
                  > >see, in my network neighborhood on the 98 machine, a new directory
                  > >with the label of the mandrake machines name on it, (linux1).
                  > (YAY
                  > >!!!)
                  > >the problem is: when I click on it, I get a request for a
                  > password.
                  > >It wants a password for: "Resource: \\LINUX1\IPC$ " (without the
                  > >quotes)
                  > >no password that I have set up on the LINUX1 machine works.
                  >
                  > >I do not have NETBIOS set up.
                  > >I have permissions on the win98 machine set as Share permissions
                  > not
                  > >user permissions. The win98 machine wants to get a users list
                  > from
                  > >the name of the win98 machine: "LEMMEN" and I get a "shared
                  > >directories will no longer be shared. you can reshare them after
                  > you
                  > >restart your computer."
                  > >
                  > >1. (should I do this and go for the USER level share??)
                  > >2. What is this Resource \\LINUX1\IPC$ problem??? how can I fix
                  > >that.??
                  >
                  > i think the connection problem solved worked in my way (i hope i
                  > can say
                  > like that),

                  errrr..... no. I couldn't use the info you gave. I went back
                  to the links that scott gave me and studied the info at
                  the samba website and also his rr.nyc site.

                  > the problem or the error is simple.
                  > first you said you can able to see linux1 (mandrake) on your net
                  > neibourhood.. it the name of the workgroup which you entered in
                  > samba.

                  no. the name of the workgroup in samba is "workgroup" the
                  name of the MACHINE is "LINUX1"


                  > about the errors:

                  There aren't any errors. it's asking for a password. this is
                  not an error but it is asking for a password to a resource on
                  the linux machine //linux1/IPC$
                  None of the passwords work.

                  > have you created an seperate user (ie you specifed the user in
                  > /etc/samba/smb.conf valid user=" ")with an passwd and do the same
                  > for
                  > smbuseradd with the same user name and passwd.

                  yes I set the valid user as IP addresses and There is a linux user
                  with same password on the linux machine. I have tried both encrypted
                  settings and non encrypted settings in smb.conf too. the encrypt or
                  not encrypt didn't make a difference at all.



                  > the problem of the error \\LINUX1\IPC$ is you should log on as the
                  > username
                  > and with the same passwd. IPC$ error will always come when you have
                  > no
                  > username and passwd given.


                  It doesn't ask for a username. it just wants a password.
                  maybe I need to look at some alternatives to putting
                  the IP address in the "valid User" line in smb.conf, I'll
                  read more about that.


                  > if it is nt or 2000 series it would have
                  > asked
                  > for username and passwd.

                  Win98.


                  tom

                  __________________________________________________
                  Do You Yahoo!?
                  Tired of spam? Yahoo! Mail has the best spam protection around
                  http://mail.yahoo.com
                • Shawn Tan
                  Hi Tommy, Setting up SAMBA is a PITA.. especially so if you have multiple Windows versions (98+2K+XP) in the same environment.. I ve had experience where it
                  Message 8 of 16 , Feb 3, 2005
                  • 0 Attachment
                    Hi Tommy,

                    Setting up SAMBA is a PITA.. especially so if you have multiple Windows
                    versions (98+2K+XP) in the same environment.. I've had experience where it
                    worked on some windows machines and not on some others... Microsoft likes to
                    change/break it's own protocol from time-to-time.. It's usually a problem
                    with the encryption/decryption and also with the permission settings.. but
                    since you've tried those, you could try other things..

                    1) Make sure it's the latest version of SAMBA.. in case some protocols are
                    broken..

                    2) Maybe your windows machine is just not seeing it.. You can try entering the
                    ip of the SAMBA server directly by "\\xxx.yyy.zzz.www\SHARENAME" to see if
                    you can get it.. I've had some experience with machines that cannot see the
                    share but can still access it this way..

                    3) Don't use SAMBA... for example, you can use FTP to transfer files to/from
                    the server and the windows desktop.. You can just type "ftp://user@.../"
                    into explorer and it'll nicely show you the files and folders.. You can then
                    drag and drop the files with the local client..

                    cheers..

                    with metta,
                    shawn tan.

                    --
                    "Engineering is the Art of making what you Want from what you can Get."
                    - Dave Tweed
                  • Brendan Bispham
                    ... This IPC$ thing is very common, google should help. I think you have to log on win98 as a user, but I cant remember how to switch users on. Do you have a
                    Message 9 of 16 , Feb 3, 2005
                    • 0 Attachment
                      On Thursday 03 February 2005 12:49, tommyL wrote:
                      > It doesn't ask for a username. it just wants a password.
                      > maybe I need to look at some alternatives to putting
                      > the IP address in the "valid User" line in smb.conf, I'll
                      > read more about that.
                      >
                      > > if it is nt or 2000 series it would have
                      > > asked
                      > > for username and passwd.
                      >
                      > Win98.

                      This IPC$ thing is very common, google should help. I think you have to log on
                      win98 as a user, but I cant remember how to switch users on. Do you have a
                      'logon as user' thingy at the start menu? When you shutdown is there a 'log
                      off' that allows you to log in again as a different user?
                      All my win98 paritions show a login dialog when they boot up (and the user/pwd
                      is already filled in).
                    • Mike Peters
                      On Thu, 3 Feb 2005 04:49:01 -0800 (PST) ... I haven t been following this thread so I m sorry if this info has been covered already. Have you set up the samba
                      Message 10 of 16 , Feb 3, 2005
                      • 0 Attachment
                        On Thu, 3 Feb 2005 04:49:01 -0800 (PST)
                        tommyL <a1tommyl@...> wrote:
                        >
                        > > have you created an seperate user (ie you specifed the user in
                        > > /etc/samba/smb.conf valid user=" ")with an passwd and do the same
                        > > for
                        > > smbuseradd with the same user name and passwd.
                        >
                        > yes I set the valid user as IP addresses and There is a linux user
                        > with same password on the linux machine. I have tried both encrypted
                        > settings and non encrypted settings in smb.conf too. the encrypt or
                        > not encrypt didn't make a difference at all.
                        >
                        I haven't been following this thread so I'm sorry if this info has been
                        covered already. Have you set up the samba user on the Linux machine
                        through smbpasswd? This is different to a user account on the linux
                        machine. To create a new user, as root:

                        smbpasswd -a sambauser

                        will add a new samba user called "sambauser" and ask for a password. Use
                        the username and give the password from your Win98 account and then that
                        user should be able to access the share from Windows.

                        Also have you tried connecting locally on the Linux machine using
                        smbclient:

                        smbclient -U username //LINUX1/IPC$

                        to see if that gives you any extra clues to the situation?

                        --
                        Mike
                        Web Site: http://www.ice2o.com
                        JabberID: mpeters@...
                        Registered Linux User #247123

                        This login session: $13.99, but for you $11.88
                      • tommyL
                        ... During boot, I have the option of logging on as a user (with password) or not. And, knowing what I was doing,(which was in itself amazing.. ) I did log
                        Message 11 of 16 , Feb 3, 2005
                        • 0 Attachment
                          --- Brendan Bispham <egroups@...> wrote:

                          >
                          > On Thursday 03 February 2005 12:49, tommyL wrote:
                          > > It doesn't ask for a username. it just wants a password.
                          > > maybe I need to look at some alternatives to putting
                          > > the IP address in the "valid User" line in smb.conf, I'll
                          > > read more about that.
                          > >
                          > > > if it is nt or 2000 series it would have
                          > > > asked
                          > > > for username and passwd.
                          > >
                          > > Win98.
                          >
                          > This IPC$ thing is very common, google should help. I think you
                          > have to log on
                          > win98 as a user, but I cant remember how to switch users on. Do you
                          > have a
                          > 'logon as user' thingy at the start menu?

                          During boot, I have the option of logging on as a user (with
                          password) or not. And, knowing what I was doing,(which was in
                          itself amazing.. <g>) I did log in.


                          > When you shutdown is there a 'log
                          > off' that allows you to log in again as a different user?
                          > All my win98 paritions show a login dialog when they boot up (and
                          > the user/pwd
                          > is already filled in).

                          Yes, Username is filled in and all I do is type the password.
                          I don't know if there is a shutdown dialog for logging in as
                          a different user. I never looked. <g>

                          I'm gonna google the IPC$ - thanks for the hints!!

                          tom



                          __________________________________
                          Do you Yahoo!?
                          The all-new My Yahoo! - What will yours do?
                          http://my.yahoo.com
                        • tommyL
                          ... Yanno? I m not sure! I was doing something with the smbpasswd. I think i looked at it when I was reading that part in the samba website..... but I
                          Message 12 of 16 , Feb 3, 2005
                          • 0 Attachment
                            --- Mike Peters <mike@...> wrote:

                            >
                            > On Thu, 3 Feb 2005 04:49:01 -0800 (PST)
                            > tommyL <a1tommyl@...> wrote:
                            > >
                            > > > have you created an seperate user (ie you specifed the user in
                            > > > /etc/samba/smb.conf valid user=" ")with an passwd and do the
                            > same
                            > > > for
                            > > > smbuseradd with the same user name and passwd.
                            > >
                            > > yes I set the valid user as IP addresses and There is a linux
                            > user
                            > > with same password on the linux machine. I have tried both
                            > encrypted
                            > > settings and non encrypted settings in smb.conf too. the
                            > encrypt or
                            > > not encrypt didn't make a difference at all.
                            > >

                            > I haven't been following this thread so I'm sorry if this info has
                            > been
                            > covered already. Have you set up the samba user on the Linux
                            > machine
                            > through smbpasswd? This is different to a user account on the linux
                            > machine. To create a new user, as root:
                            >
                            > smbpasswd -a sambauser

                            Yanno? I'm not sure! I was doing something with the smbpasswd. I
                            think i looked at it when I was reading that part in the samba
                            website..... but I couldn't tell what to do with it. I remember
                            looking at in in ls -al and seeing that it had no size. <g>

                            So the CLI command syntax is "smbasswd -a sambauser" ?? (without
                            quotes)

                            > will add a new samba user called "sambauser" and ask for a
                            > password. Use
                            > the username and give the password from your Win98 account and then
                            > that
                            > user should be able to access the share from Windows.
                            >
                            > Also have you tried connecting locally on the Linux machine using
                            > smbclient:
                            > smbclient -U username //LINUX1/IPC$
                            > to see if that gives you any extra clues to the situation?

                            no, that looks greek to me. but what the heck, i'll try it.
                            I'll look again at the instruction sheets and re-read about the
                            smbasswd and and the smbclient commands. THANKS !!!!

                            tom



                            __________________________________
                            Do you Yahoo!?
                            The all-new My Yahoo! - Get yours free!
                            http://my.yahoo.com
                          • Mike Peters
                            On Thu, 3 Feb 2005 05:36:18 -0800 (PST) ... Yes. ... smbclient -U username //LINUX1/username Might give you a better idea actually (I cut and pasted the
                            Message 13 of 16 , Feb 3, 2005
                            • 0 Attachment
                              On Thu, 3 Feb 2005 05:36:18 -0800 (PST)
                              tommyL <a1tommyl@...> wrote:

                              >
                              > Yanno? I'm not sure! I was doing something with the smbpasswd. I
                              > think i looked at it when I was reading that part in the samba
                              > website..... but I couldn't tell what to do with it. I remember
                              > looking at in in ls -al and seeing that it had no size. <g>
                              >
                              > So the CLI command syntax is "smbasswd -a sambauser" ?? (without
                              > quotes)
                              >

                              Yes.

                              > > will add a new samba user called "sambauser" and ask for a
                              > > password. Use
                              > > the username and give the password from your Win98 account and then
                              > > that
                              > > user should be able to access the share from Windows.
                              > >
                              > > Also have you tried connecting locally on the Linux machine using
                              > > smbclient:
                              > > smbclient -U username //LINUX1/IPC$
                              > > to see if that gives you any extra clues to the situation?
                              >
                              > no, that looks greek to me. but what the heck, i'll try it.
                              > I'll look again at the instruction sheets and re-read about the
                              > smbasswd and and the smbclient commands. THANKS !!!!
                              >

                              smbclient -U username //LINUX1/username

                              Might give you a better idea actually (I cut and pasted the machine name
                              from your earlier mail and forgot to edit it).

                              --
                              Mike
                              Web Site: http://www.ice2o.com
                              JabberID: mpeters@...
                              Registered Linux User #247123

                              Q: Do you know what the death rate around here is?
                              A: One per person.
                            • venkat raman
                              hello sir, iam realy sad to know that my idea couldn t work. anyway i will try some other impressive things next time. ... i think that guy dosen t go in win98
                              Message 14 of 16 , Feb 3, 2005
                              • 0 Attachment
                                hello sir,

                                iam realy sad to know that my idea couldn't work. anyway i will try some
                                other impressive things next time.

                                >On Thursday 03 February 2005 12:49, tommyL wrote:
                                > > It doesn't ask for a username. it just wants a password.
                                > > maybe I need to look at some alternatives to putting
                                > > the IP address in the "valid User" line in smb.conf, I'll
                                > > read more about that.
                                > >
                                > > > if it is nt or 2000 series it would have
                                > > > asked
                                > > > for username and passwd.
                                > >
                                > > Win98.
                                >
                                >This IPC$ thing is very common, google should help. I think you have to log
                                >on
                                >win98 as a user, but I cant remember how to switch users on. Do you have a
                                >'logon as user' thingy at the start menu? When you shutdown is there a 'log
                                >off' that allows you to log in again as a different user?
                                >All my win98 paritions show a login dialog when they boot up (and the
                                >user/pwd
                                >is already filled in).

                                i think that guy dosen't go in win98 by the username and the log in i have
                                that same experence. i got that error before ipc$ it due to the worng
                                username and passwd.

                                by the way error will not say "iam an error" we have to identify it as a
                                error and rectify it.


                                in your previous mail you said that your win98 network showed you:

                                >I can
                                >see, in my network neighborhood on the 98 machine, a new directory
                                >with the label of the mandrake machines name on it, (linux1). (YAY
                                >!!!)

                                this is your workgroup name linux1 now you are saying your workgroup name is
                                workgroup.


                                >>have you created an seperate user (ie you specifed the user in
                                >>/etc/samba/smb.conf valid user=" ")with an passwd and do the same
                                >>for smbuseradd with the same user name and passwd.

                                >yes I set the valid user as IP addresses and There is a linux user
                                >with same password on the linux machine. I have tried both encrypted
                                >settings and non encrypted settings in smb.conf too. the encrypt or
                                >not encrypt didn't make a difference at all.

                                you may have set an same username and passwd but you haven't login with it
                                in win98.

                                if you have done it you can able to see you share. see an other way is there
                                is by go to run //<hostname>/<smb share name> or //<ipaddress> give it after
                                logging with the linux username and passwd.

                                thanking you
                                raman

                                _________________________________________________________________
                                The real power of teamwork. Experience it in real time.
                                http://www.microsoft.com/india/office/experience/ Experience MS Office
                                System.
                              Your message has been successfully submitted and would be delivered to recipients shortly.