Loading ...
Sorry, an error occurred while loading the content.
 

bootsplash.org on 2.6.3 kernel

Expand Messages
  • Karol Krizka
    Hi, I am triing to add bootsplash to my computer running gentoo linux and the 2.6.3 kernel. I downloaded the patch from
    Message 1 of 12 , Feb 29, 2004
      Hi,

      I am triing to add bootsplash to my computer running gentoo linux and
      the 2.6.3 kernel. I downloaded the patch from
      ftp://ftp.suse.com/pub/people/stepan/bootsplash/kernel/bootsplash-3.1.4-2.6.3.diff
      and applied it with 'patch -p1 < /root/bootsplash-3.1.4-2.6.3.diff '.
      It didn't give me any errors:
      patching file drivers/char/keyboard.c
      patching file drivers/char/n_tty.c
      patching file drivers/char/vt.c
      Hunk #1 succeeded at 3108 (offset -24 lines).
      patching file drivers/video/bootsplash/bootsplash.c
      patching file drivers/video/bootsplash/bootsplash.h
      patching file drivers/video/bootsplash/decode-jpg.c
      patching file drivers/video/bootsplash/decode-jpg.h
      patching file drivers/video/bootsplash/Kconfig
      patching file drivers/video/bootsplash/Makefile
      patching file drivers/video/bootsplash/render.c
      patching file drivers/video/console/fbcon.c
      patching file drivers/video/console/fbcon.h
      patching file drivers/video/Kconfig
      patching file drivers/video/Makefile
      patching file drivers/video/vesafb.c
      patching file include/linux/console_struct.h
      patching file include/linux/fb.h
      Hunk #1 succeeded at 470 (offset -36 lines).
      patching file kernel/panic.c

      I turned off Boot-Up Logo and turned on the Bootsplash. I checked for
      the other stuff that bootsplast said to, and they were on. I cound't
      find the "Use splash screen instead of boot logo", so I assumed that
      boot-up logo off and bootsplash on did that. When I tried to compile
      it with make, I get the following error:
      LD arch/i386/lib/built-in.o
      AS arch/i386/lib/checksum.o
      CC arch/i386/lib/dec_and_lock.o
      CC arch/i386/lib/delay.o
      AS arch/i386/lib/getuser.o
      CC arch/i386/lib/memcpy.o
      CC arch/i386/lib/strstr.o
      CC arch/i386/lib/usercopy.o
      AR arch/i386/lib/lib.a
      GEN .version
      CHK include/linux/compile.h
      UPD include/linux/compile.h
      CC init/version.o
      LD init/built-in.o
      LD .tmp_vmlinux1
      drivers/built-in.o(.text+0xd3a49): In function `splash_getraw':
      : undefined reference to `con2fb_map'
      drivers/built-in.o(.text+0xd4262): In function `splash_verbose':
      : undefined reference to `con2fb_map'
      drivers/built-in.o(.text+0xd4770): In function `splash_status':
      : undefined reference to `con2fb_map'
      drivers/built-in.o(.text+0xd48b0): In function `splash_read_proc':
      : undefined reference to `con2fb_map'
      drivers/built-in.o(.text+0xd4a97): In function `splash_write_proc':
      : undefined reference to `con2fb_map'
      make: *** [.tmp_vmlinux1] Error 1

      Anyone know what the problem is?

      Cheers,
      Karol Krizka
    • Michael Kjorling
      ... Hash: SHA1 ... What about framebuffer support? Is that compiled into the kernel? Given the function name it seems to me like that is the problem. You also
      Message 2 of 12 , Mar 1, 2004
        -----BEGIN PGP SIGNED MESSAGE-----
        Hash: SHA1

        On Feb 29 2004, kkrizka_z000z000z@... wrote:

        > LD init/built-in.o
        > LD .tmp_vmlinux1
        > drivers/built-in.o(.text+0xd3a49): In function `splash_getraw':
        > : undefined reference to `con2fb_map'

        What about framebuffer support? Is that compiled into the kernel? Given the
        function name it seems to me like that is the problem.

        You also might want to try a make mrproper (but make sure to back up your
        .config first!!!!) before trying to build the kernel again.

        - --
        () Michael Kjörling - michael@... - SM0YBY QTH JO89XI ^..^
        /\ OpenPGP: 3723 9372 c245 d6a8 18a6 36ac 758f 8749 bde9 ada6 \/
        ASCII Ribbon Campaign - Against HTML Mail, Proprietary Attachments.
        -----BEGIN PGP SIGNATURE-----
        Version: GnuPG v1.2.3 (GNU/Linux)

        iD8DBQFAQv5xdY+HSb3praYRAobmAJkBRP37DfPv9soyYsi2KPuLAzpctgCgiVQe
        ipDts4BL1ZbO8HIGnuilQ7c=
        =3Ss+
        -----END PGP SIGNATURE-----
      • Ajay Gautam
        ... My suggestion: forget these separate patches. Gentoo already has all you need. Just enable framebuffer, and use genkernel to compile your kernel. The
        Message 3 of 12 , Mar 1, 2004
          --- Karol Krizka <kkrizka_z000z000z@...> wrote:
          > Hi,
          >
          > I am triing to add bootsplash to my computer running gentoo linux and
          > the 2.6.3 kernel. I downloaded the patch from

          My suggestion: forget these separate patches. Gentoo already has all you need. Just enable
          framebuffer, and use "genkernel" to compile your kernel. The "--bootsplash" option to genkernel
          generates the bootsplash. Also be sure to set "vga=791" in you grub.conf.

          I had this setup, but had to disable framebuffer to run "rivatv".

          genkernel is much better at compiling the kernel that the old method.

          HTH

          Ajay

          > ftp://ftp.suse.com/pub/people/stepan/bootsplash/kernel/bootsplash-3.1.4-2.6.3.diff
          > and applied it with 'patch -p1 < /root/bootsplash-3.1.4-2.6.3.diff '.
          > It didn't give me any errors:
          > patching file drivers/char/keyboard.c
          > patching file drivers/char/n_tty.c
          > patching file drivers/char/vt.c
          > Hunk #1 succeeded at 3108 (offset -24 lines).
          > patching file drivers/video/bootsplash/bootsplash.c
          > patching file drivers/video/bootsplash/bootsplash.h
          > patching file drivers/video/bootsplash/decode-jpg.c
          > patching file drivers/video/bootsplash/decode-jpg.h
          > patching file drivers/video/bootsplash/Kconfig
          > patching file drivers/video/bootsplash/Makefile
          > patching file drivers/video/bootsplash/render.c
          > patching file drivers/video/console/fbcon.c
          > patching file drivers/video/console/fbcon.h
          > patching file drivers/video/Kconfig
          > patching file drivers/video/Makefile
          > patching file drivers/video/vesafb.c
          > patching file include/linux/console_struct.h
          > patching file include/linux/fb.h
          > Hunk #1 succeeded at 470 (offset -36 lines).
          > patching file kernel/panic.c
          >
          > I turned off Boot-Up Logo and turned on the Bootsplash. I checked for
          > the other stuff that bootsplast said to, and they were on. I cound't
          > find the "Use splash screen instead of boot logo", so I assumed that
          > boot-up logo off and bootsplash on did that. When I tried to compile
          > it with make, I get the following error:
          > LD arch/i386/lib/built-in.o
          > AS arch/i386/lib/checksum.o
          > CC arch/i386/lib/dec_and_lock.o
          > CC arch/i386/lib/delay.o
          > AS arch/i386/lib/getuser.o
          > CC arch/i386/lib/memcpy.o
          > CC arch/i386/lib/strstr.o
          > CC arch/i386/lib/usercopy.o
          > AR arch/i386/lib/lib.a
          > GEN .version
          > CHK include/linux/compile.h
          > UPD include/linux/compile.h
          > CC init/version.o
          > LD init/built-in.o
          > LD .tmp_vmlinux1
          > drivers/built-in.o(.text+0xd3a49): In function `splash_getraw':
          > : undefined reference to `con2fb_map'
          > drivers/built-in.o(.text+0xd4262): In function `splash_verbose':
          > : undefined reference to `con2fb_map'
          > drivers/built-in.o(.text+0xd4770): In function `splash_status':
          > : undefined reference to `con2fb_map'
          > drivers/built-in.o(.text+0xd48b0): In function `splash_read_proc':
          > : undefined reference to `con2fb_map'
          > drivers/built-in.o(.text+0xd4a97): In function `splash_write_proc':
          > : undefined reference to `con2fb_map'
          > make: *** [.tmp_vmlinux1] Error 1
          >
          > Anyone know what the problem is?
          >
          > Cheers,
          > Karol Krizka
          >
          >
          >


          =====
          Ajay Gautam
          Linux User #252843 http://counter.li.org
          root:$7$PtTXhqkQ$NRqKj5dfroE0z2Dj1GOaG.:0:0::/root:/bin/bash

          __________________________________
          Do you Yahoo!?
          Get better spam protection with Yahoo! Mail.
          http://antispam.yahoo.com/tools
        • Ajay Gautam
          ... Forgot to mention, genkernel runs make mrproper , so save your .config file somewhere, and pass it genkernel using --kernel-config flag. Here is my last
          Message 4 of 12 , Mar 1, 2004
            --- Ajay Gautam <ajaygautam@...> wrote:
            >
            > --- Karol Krizka <kkrizka_z000z000z@...> wrote:
            > > Hi,
            > >
            > > I am triing to add bootsplash to my computer running gentoo linux and
            > > the 2.6.3 kernel. I downloaded the patch from
            >
            > My suggestion: forget these separate patches. Gentoo already has all you need. Just enable
            > framebuffer, and use "genkernel" to compile your kernel. The "--bootsplash" option to genkernel
            > generates the bootsplash. Also be sure to set "vga=791" in you grub.conf.
            >
            > I had this setup, but had to disable framebuffer to run "rivatv".
            >
            > genkernel is much better at compiling the kernel that the old method.

            Forgot to mention, genkernel runs "make mrproper", so save your .config file somewhere, and pass
            it genkernel using "--kernel-config" flag. Here is my last genkernel command:

            genkernel --kernel-config=/usr/src/linux/config-from-2.6.3-r1 --bootsplash all

            HTH

            Ajay

            >
            > HTH
            >
            > Ajay
            >
            > > ftp://ftp.suse.com/pub/people/stepan/bootsplash/kernel/bootsplash-3.1.4-2.6.3.diff
            > > and applied it with 'patch -p1 < /root/bootsplash-3.1.4-2.6.3.diff '.
            > > It didn't give me any errors:
            > > patching file drivers/char/keyboard.c
            > > patching file drivers/char/n_tty.c
            > > patching file drivers/char/vt.c
            > > Hunk #1 succeeded at 3108 (offset -24 lines).
            > > patching file drivers/video/bootsplash/bootsplash.c
            > > patching file drivers/video/bootsplash/bootsplash.h
            > > patching file drivers/video/bootsplash/decode-jpg.c
            > > patching file drivers/video/bootsplash/decode-jpg.h
            > > patching file drivers/video/bootsplash/Kconfig
            > > patching file drivers/video/bootsplash/Makefile
            > > patching file drivers/video/bootsplash/render.c
            > > patching file drivers/video/console/fbcon.c
            > > patching file drivers/video/console/fbcon.h
            > > patching file drivers/video/Kconfig
            > > patching file drivers/video/Makefile
            > > patching file drivers/video/vesafb.c
            > > patching file include/linux/console_struct.h
            > > patching file include/linux/fb.h
            > > Hunk #1 succeeded at 470 (offset -36 lines).
            > > patching file kernel/panic.c
            > >
            > > I turned off Boot-Up Logo and turned on the Bootsplash. I checked for
            > > the other stuff that bootsplast said to, and they were on. I cound't
            > > find the "Use splash screen instead of boot logo", so I assumed that
            > > boot-up logo off and bootsplash on did that. When I tried to compile
            > > it with make, I get the following error:
            > > LD arch/i386/lib/built-in.o
            > > AS arch/i386/lib/checksum.o
            > > CC arch/i386/lib/dec_and_lock.o
            > > CC arch/i386/lib/delay.o
            > > AS arch/i386/lib/getuser.o
            > > CC arch/i386/lib/memcpy.o
            > > CC arch/i386/lib/strstr.o
            > > CC arch/i386/lib/usercopy.o
            > > AR arch/i386/lib/lib.a
            > > GEN .version
            > > CHK include/linux/compile.h
            > > UPD include/linux/compile.h
            > > CC init/version.o
            > > LD init/built-in.o
            > > LD .tmp_vmlinux1
            > > drivers/built-in.o(.text+0xd3a49): In function `splash_getraw':
            > > : undefined reference to `con2fb_map'
            > > drivers/built-in.o(.text+0xd4262): In function `splash_verbose':
            > > : undefined reference to `con2fb_map'
            > > drivers/built-in.o(.text+0xd4770): In function `splash_status':
            > > : undefined reference to `con2fb_map'
            > > drivers/built-in.o(.text+0xd48b0): In function `splash_read_proc':
            > > : undefined reference to `con2fb_map'
            > > drivers/built-in.o(.text+0xd4a97): In function `splash_write_proc':
            > > : undefined reference to `con2fb_map'
            > > make: *** [.tmp_vmlinux1] Error 1
            > >
            > > Anyone know what the problem is?
            > >
            > > Cheers,
            > > Karol Krizka
            > >
            > >
            > >
            >
            >
            > =====
            > Ajay Gautam
            > Linux User #252843 http://counter.li.org
            > root:$7$PtTXhqkQ$NRqKj5dfroE0z2Dj1GOaG.:0:0::/root:/bin/bash
            >
            > __________________________________
            > Do you Yahoo!?
            > Get better spam protection with Yahoo! Mail.
            > http://antispam.yahoo.com/tools
            >


            =====
            Ajay Gautam
            Linux User #252843 http://counter.li.org
            root:$7$PtTXhqkQ$NRqKj5dfroE0z2Dj1GOaG.:0:0::/root:/bin/bash

            __________________________________
            Do you Yahoo!?
            Get better spam protection with Yahoo! Mail.
            http://antispam.yahoo.com/tools
          • Karol Krizka
            OK, I did that with 2.6.4 kernel, but it fails when compiling modules with the following: Copying config for successful build to
            Message 5 of 12 , Mar 2, 2004
              OK, I did that with 2.6.4 kernel, but it fails when compiling modules
              with the following:
              Copying config for successful build to
              /etc/kernels/kernel-config-x86-2.6.4-rc1
              * Dietlibc: Found bincache at
              /usr/share/genkernel/pkg/x86/dietlibc-0.24-x86.tar.bz2
              * gen_die(): Could not find busybox source tarball:
              /usr/share/genkernel/pkg/busybox-1.00-pre7-crypto-losetup-2.tar.bz2
              * Please see /var/log/genkernel.log for more info on failures

              On Mon, 2004-03-01 at 12:25, Ajay Gautam wrote:
              > --- Ajay Gautam <ajaygautam@...> wrote:
              > >
              > > --- Karol Krizka <kkrizka_z000z000z@...> wrote:
              > > > Hi,
              > > >
              > > > I am triing to add bootsplash to my computer running gentoo linux
              > and
              > > > the 2.6.3 kernel. I downloaded the patch from
              > >
              > > My suggestion: forget these separate patches. Gentoo already has all
              > you need. Just enable
              > > framebuffer, and use "genkernel" to compile your kernel. The
              > "--bootsplash" option to genkernel
              > > generates the bootsplash. Also be sure to set "vga=791" in you
              > grub.conf.
              > >
              > > I had this setup, but had to disable framebuffer to run "rivatv".
              > >
              > > genkernel is much better at compiling the kernel that the old
              > method.
              >
              > Forgot to mention, genkernel runs "make mrproper", so save your
              > .config file somewhere, and pass
              > it genkernel using "--kernel-config" flag. Here is my last genkernel
              > command:
              >
              > genkernel --kernel-config=/usr/src/linux/config-from-2.6.3-r1
              > --bootsplash all
              >
              > HTH
              >
              > Ajay
              >
              > >
              > > HTH
              > >
              > > Ajay
              > >
              > > >
              > ftp://ftp.suse.com/pub/people/stepan/bootsplash/kernel/bootsplash-3.1.4-2.6.3.diff
              > > > and applied it with 'patch -p1 < /root/bootsplash-3.1.4-2.6.3.diff
              > '.
              > > > It didn't give me any errors:
              > > > patching file drivers/char/keyboard.c
              > > > patching file drivers/char/n_tty.c
              > > > patching file drivers/char/vt.c
              > > > Hunk #1 succeeded at 3108 (offset -24 lines).
              > > > patching file drivers/video/bootsplash/bootsplash.c
              > > > patching file drivers/video/bootsplash/bootsplash.h
              > > > patching file drivers/video/bootsplash/decode-jpg.c
              > > > patching file drivers/video/bootsplash/decode-jpg.h
              > > > patching file drivers/video/bootsplash/Kconfig
              > > > patching file drivers/video/bootsplash/Makefile
              > > > patching file drivers/video/bootsplash/render.c
              > > > patching file drivers/video/console/fbcon.c
              > > > patching file drivers/video/console/fbcon.h
              > > > patching file drivers/video/Kconfig
              > > > patching file drivers/video/Makefile
              > > > patching file drivers/video/vesafb.c
              > > > patching file include/linux/console_struct.h
              > > > patching file include/linux/fb.h
              > > > Hunk #1 succeeded at 470 (offset -36 lines).
              > > > patching file kernel/panic.c
              > > >
              > > > I turned off Boot-Up Logo and turned on the Bootsplash. I checked
              > for
              > > > the other stuff that bootsplast said to, and they were on. I
              > cound't
              > > > find the "Use splash screen instead of boot logo", so I assumed
              > that
              > > > boot-up logo off and bootsplash on did that. When I tried to
              > compile
              > > > it with make, I get the following error:
              > > > LD arch/i386/lib/built-in.o
              > > > AS arch/i386/lib/checksum.o
              > > > CC arch/i386/lib/dec_and_lock.o
              > > > CC arch/i386/lib/delay.o
              > > > AS arch/i386/lib/getuser.o
              > > > CC arch/i386/lib/memcpy.o
              > > > CC arch/i386/lib/strstr.o
              > > > CC arch/i386/lib/usercopy.o
              > > > AR arch/i386/lib/lib.a
              > > > GEN .version
              > > > CHK include/linux/compile.h
              > > > UPD include/linux/compile.h
              > > > CC init/version.o
              > > > LD init/built-in.o
              > > > LD .tmp_vmlinux1
              > > > drivers/built-in.o(.text+0xd3a49): In function `splash_getraw':
              > > > : undefined reference to `con2fb_map'
              > > > drivers/built-in.o(.text+0xd4262): In function `splash_verbose':
              > > > : undefined reference to `con2fb_map'
              > > > drivers/built-in.o(.text+0xd4770): In function `splash_status':
              > > > : undefined reference to `con2fb_map'
              > > > drivers/built-in.o(.text+0xd48b0): In function `splash_read_proc':
              > > > : undefined reference to `con2fb_map'
              > > > drivers/built-in.o(.text+0xd4a97): In function
              > `splash_write_proc':
              > > > : undefined reference to `con2fb_map'
              > > > make: *** [.tmp_vmlinux1] Error 1
              > > >
              > > > Anyone know what the problem is?
              > > >
              > > > Cheers,
              > > > Karol Krizka
              > > >
              > > >
              > > >
              > >
              > >
              > > =====
              > > Ajay Gautam
              > > Linux User #252843 http://counter.li.org
              > > root:$7$PtTXhqkQ$NRqKj5dfroE0z2Dj1GOaG.:0:0::/root:/bin/bash
              > >
              > > __________________________________
              > > Do you Yahoo!?
              > > Get better spam protection with Yahoo! Mail.
              > > http://antispam.yahoo.com/tools
              > >
              >
              >
              > =====
              > Ajay Gautam
              > Linux User #252843 http://counter.li.org
              > root:$7$PtTXhqkQ$NRqKj5dfroE0z2Dj1GOaG.:0:0::/root:/bin/bash
              >
              > __________________________________
              > Do you Yahoo!?
              > Get better spam protection with Yahoo! Mail.
              > http://antispam.yahoo.com/tools
              >
              >
              > To unsubscribe, email linux-unsubscribe@yahoogroups.com, or visit
              > http://www.yahoogroups.com
              >
              >
              >
              > ______________________________________________________________________
              > Yahoo! Groups Links
              > * To visit your group on the web, go to:
              > http://groups.yahoo.com/group/linux/
              >
              > * To unsubscribe from this group, send an email to:
              > linux-unsubscribe@yahoogroups.com
              >
              > * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
              > Service.
              >
            • Karol Krizka
              The last lines in the log file were: (this time I tried it without the --with-bootloader) INSTALL drivers/md/xor.ko INSTALL drivers/usb/input/xpad.ko INSTALL
              Message 6 of 12 , Mar 2, 2004
                The last lines in the log file were: (this time I tried it without the
                --with-bootloader)

                INSTALL drivers/md/xor.ko
                INSTALL drivers/usb/input/xpad.ko
                INSTALL sound/oss/ymfpci.ko
                INSTALL drivers/net/znet.ko
                if [ -r System.map ]; then /sbin/depmod -ae -F System.map 2.6.4-rc1; fi
                WARNING: /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/jedec_probe.ko
                needs unknown symbol __raw_readll
                WARNING: /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/jedec_probe.ko
                needs unknown symbol __raw_writell
                WARNING: /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/cfi_probe.ko
                needs unknown symbol __raw_readll
                WARNING: /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/cfi_probe.ko
                needs unknown symbol __raw_writell
                WARNING:
                /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/cfi_cmdset_0020.ko needs
                unknown symbol __raw_readll
                WARNING:
                /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/cfi_cmdset_0020.ko needs
                unknown symbol __raw_writell
                WARNING:
                /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/cfi_cmdset_0002.ko needs
                unknown symbol __raw_readll
                WARNING:
                /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/cfi_cmdset_0002.ko needs
                unknown symbol __raw_writell
                WARNING:
                /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/cfi_cmdset_0001.ko needs
                unknown symbol __raw_readll
                WARNING:
                /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/cfi_cmdset_0001.ko needs
                unknown symbol __raw_writell
                * Copying config for successful build to
                /etc/kernels/kernel-config-x86-2.6.4-rc1
                * Dietlibc: Found bincache at
                /usr/share/genkernel/pkg/x86/dietlibc-0.24-x86.tar.bz2
                * gen_die(): Could not find busybox source tarball:
                /usr/share/genkernel/pkg/busybox-1.00-pre7-crypto-losetup-2.tar.bz2
                * Please see /var/log/genkernel.log for more info on failures
                *
                * DO NOT REPORT KERNEL COMPILE FAILURES AS GENKERNEL BUGS!
                *
                * Report real genkernel bugs to bugs.gentoo.org


                [Non-text portions of this message have been removed]
              • Ajay Gautam
                ... Please do not top-post. What does the log file say ? Ajay ===== Ajay Gautam Linux User #252843 http://counter.li.org
                Message 7 of 12 , Mar 2, 2004
                  --- Karol Krizka <kkrizka_z000z000z@...> wrote:
                  > OK, I did that with 2.6.4 kernel, but it fails when compiling modules
                  > with the following:
                  > Copying config for successful build to
                  > /etc/kernels/kernel-config-x86-2.6.4-rc1
                  > * Dietlibc: Found bincache at
                  > /usr/share/genkernel/pkg/x86/dietlibc-0.24-x86.tar.bz2
                  > * gen_die(): Could not find busybox source tarball:
                  > /usr/share/genkernel/pkg/busybox-1.00-pre7-crypto-losetup-2.tar.bz2
                  > * Please see /var/log/genkernel.log for more info on failures

                  Please do not top-post.

                  What does the log file say ?

                  Ajay

                  =====
                  Ajay Gautam
                  Linux User #252843 http://counter.li.org
                  root:$7$PtTXhqkQ$NRqKj5dfroE0z2Dj1GOaG.:0:0::/root:/bin/bash

                  __________________________________
                  Do you Yahoo!?
                  Yahoo! Search - Find what you�re looking for faster
                  http://search.yahoo.com
                • yuva raj
                  Hi I did kernel compilation in RedhLinux 9.0 with kernel2.6.3. I followed those steps. #make menudconfig #make dep #make clean #make bzImage #make modules
                  Message 8 of 12 , Mar 2, 2004
                    Hi

                    I did kernel compilation in RedhLinux 9.0 with
                    kernel2.6.3. I followed those steps.

                    #make menudconfig
                    #make dep
                    #make clean
                    #make bzImage
                    #make modules
                    #make modules_install

                    I enabled iptables,nfs,NIC,NTFS while compile the
                    kernel 2.6.3. After booting to new kernel
                    version(2.6.3). Those modules are not working. I mean
                    not enabled. Please tell me the solution for the same.

                    Regards

                    Yuvaraj.K


                    __________________________________
                    Do you Yahoo!?
                    Yahoo! Search - Find what you�re looking for faster
                    http://search.yahoo.com
                  • Scott
                    ... I haven t been following this thread, but do you have the new version of modutils? (I m in FreeBSD at this instant, and can t recall the exact
                    Message 9 of 12 , Mar 2, 2004
                      On Tue, Mar 02, 2004 at 09:58:10PM +0000, Karol Krizka wrote:
                      > The last lines in the log file were: (this time I tried it without the
                      > --with-bootloader)
                      >
                      > INSTALL drivers/md/xor.ko
                      > INSTALL drivers/usb/input/xpad.ko
                      > INSTALL sound/oss/ymfpci.ko
                      > INSTALL drivers/net/znet.ko
                      > if [ -r System.map ]; then /sbin/depmod -ae -F System.map 2.6.4-rc1; fi
                      > WARNING: /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/jedec_probe.ko
                      > needs unknown symbol __raw_readll
                      > WARNING: /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/jedec_probe.ko


                      I haven't been following this thread, but do you have the new version of
                      modutils?

                      (I'm in FreeBSD at this instant, and can't recall the exact
                      name--mod-init-tools or something similar.

                      IIRC, that was the sort of error I was getting when playing with 2.6
                      kernels and didn't have that installed.

                      (Actually, I think somewhere just before the messages you pasted,
                      there's a warning about it, which will give the correct program name.) :)



                      --

                      Scott Robbins

                      PGP keyID EB3467D6
                      ( 1B48 077D 66F6 9DB0 FDC2 A409 FA54 D575 EB34 67D6 )
                      gpg --keyserver pgp.mit.edu --recv-keys EB3467D6

                      (After finding Spike outside her house.)
                      Buffy: What are you doing here, Spike? Five words or less!
                      Spike: (counting on fingers) Out... for... a... walk... bitch.
                    • Ajay Gautam
                      ... Please verify that you have busybox-1.00-pre7, else emerge busybox. You did use emerge to download and unpack the kernel, did you not ? Ajay ===== Ajay
                      Message 10 of 12 , Mar 3, 2004
                        --- Karol Krizka <kkrizka_z000z000z@...> wrote:
                        > The last lines in the log file were: (this time I tried it without the
                        > --with-bootloader)
                        >
                        > INSTALL drivers/md/xor.ko
                        > INSTALL drivers/usb/input/xpad.ko
                        > INSTALL sound/oss/ymfpci.ko
                        > INSTALL drivers/net/znet.ko
                        > if [ -r System.map ]; then /sbin/depmod -ae -F System.map 2.6.4-rc1; fi
                        > WARNING: /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/jedec_probe.ko
                        > needs unknown symbol __raw_readll
                        > WARNING: /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/jedec_probe.ko
                        > needs unknown symbol __raw_writell
                        > WARNING: /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/cfi_probe.ko
                        > needs unknown symbol __raw_readll
                        > WARNING: /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/cfi_probe.ko
                        > needs unknown symbol __raw_writell
                        > WARNING:
                        > /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/cfi_cmdset_0020.ko needs
                        > unknown symbol __raw_readll
                        > WARNING:
                        > /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/cfi_cmdset_0020.ko needs
                        > unknown symbol __raw_writell
                        > WARNING:
                        > /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/cfi_cmdset_0002.ko needs
                        > unknown symbol __raw_readll
                        > WARNING:
                        > /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/cfi_cmdset_0002.ko needs
                        > unknown symbol __raw_writell
                        > WARNING:
                        > /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/cfi_cmdset_0001.ko needs
                        > unknown symbol __raw_readll
                        > WARNING:
                        > /lib/modules/2.6.4-rc1/kernel/drivers/mtd/chips/cfi_cmdset_0001.ko needs
                        > unknown symbol __raw_writell
                        > * Copying config for successful build to
                        > /etc/kernels/kernel-config-x86-2.6.4-rc1
                        > * Dietlibc: Found bincache at
                        > /usr/share/genkernel/pkg/x86/dietlibc-0.24-x86.tar.bz2
                        > * gen_die(): Could not find busybox source tarball:
                        > /usr/share/genkernel/pkg/busybox-1.00-pre7-crypto-losetup-2.tar.bz2
                        > * Please see /var/log/genkernel.log for more info on failures
                        > *
                        > * DO NOT REPORT KERNEL COMPILE FAILURES AS GENKERNEL BUGS!
                        > *
                        > * Report real genkernel bugs to bugs.gentoo.org

                        Please verify that you have busybox-1.00-pre7, else emerge busybox. You did use emerge to download
                        and unpack the kernel, did you not ?

                        Ajay


                        =====
                        Ajay Gautam
                        Linux User #252843 http://counter.li.org
                        root:$7$PtTXhqkQ$NRqKj5dfroE0z2Dj1GOaG.:0:0::/root:/bin/bash

                        __________________________________
                        Do you Yahoo!?
                        Yahoo! Search - Find what you�re looking for faster
                        http://search.yahoo.com
                      • Ajay Gautam
                        Always create a new mail for new problems. No piggybacking... ... How do you know that they are not working ? And which modules are not working ? What are
                        Message 11 of 12 , Mar 3, 2004
                          Always create a "new" mail for new problems. No piggybacking...

                          --- yuva raj <yuva_mca@...> wrote:
                          > Hi
                          >
                          > I did kernel compilation in RedhLinux 9.0 with
                          > kernel2.6.3. I followed those steps.
                          >
                          > #make menudconfig
                          > #make dep
                          > #make clean
                          > #make bzImage
                          > #make modules
                          > #make modules_install
                          >
                          > I enabled iptables,nfs,NIC,NTFS while compile the
                          > kernel 2.6.3. After booting to new kernel
                          > version(2.6.3). Those modules are not working. I mean
                          > not enabled. Please tell me the solution for the same.

                          How do you know that they are not working ? And which modules are not working ? What are the error
                          messages ?

                          Ajay

                          =====
                          Ajay Gautam
                          Linux User #252843 http://counter.li.org
                          root:$7$PtTXhqkQ$NRqKj5dfroE0z2Dj1GOaG.:0:0::/root:/bin/bash

                          __________________________________
                          Do you Yahoo!?
                          Yahoo! Search - Find what you�re looking for faster
                          http://search.yahoo.com
                        • yuva raj
                          Hi Pleae tell me the correct solution . If any one face this problem , please let me know. .......... Regards Yuvaraj.K ... __________________________________
                          Message 12 of 12 , Mar 3, 2004
                            Hi

                            Pleae tell me the correct solution . If any one face
                            this problem , please let me know. ..........

                            Regards
                            Yuvaraj.K
                            --- Thirugnanam Vimalraj <vimalraj_t@...> wrote:
                            >
                            > --- yuva raj <yuva_mca@...> wrote:
                            > > Hi
                            > >
                            > > I did kernel compilation in RedhLinux 9.0 with
                            > > kernel2.6.3. I followed those steps.
                            > >
                            > > #make menudconfig
                            > > #make dep
                            > > #make clean
                            > > #make bzImage
                            > > #make modules
                            > > #make modules_install
                            > >
                            > > I enabled iptables,nfs,NIC,NTFS while compile the
                            > > kernel 2.6.3. After booting to new kernel
                            > > version(2.6.3). Those modules are not working. I
                            > > mean
                            > > not enabled. Please tell me the solution for the
                            > > same.
                            > >
                            > > Regards
                            > >
                            > > Yuvaraj.K
                            > >
                            > >
                            > > __________________________________
                            > > Do you Yahoo!?
                            > > Yahoo! Search - Find what you�re looking for
                            > faster
                            > > http://search.yahoo.com
                            >
                            >
                            > =====
                            >
                            > +++++++++++++++++++++++++++++++++++++++++|||||
                            >
                            > "I care not what others think of what I do, but
                            > I care very much about what I think of what I do.
                            > That is character!"
                            >
                            > "WINNER'S NEVER QUIT, QUITTER'S NEVER WIN"
                            >
                            > ||||||+++++++++++++++++++++++++++++++++++++++++
                            >
                            >
                            > __________________________________
                            > Do you Yahoo!?
                            > Yahoo! Search - Find what you�re looking for faster
                            > http://search.yahoo.com


                            __________________________________
                            Do you Yahoo!?
                            Yahoo! Search - Find what you�re looking for faster
                            http://search.yahoo.com
                          Your message has been successfully submitted and would be delivered to recipients shortly.