Loading ...
Sorry, an error occurred while loading the content.

configure ssh to login without typeing password

Expand Messages
  • Juraj Fedel
    I have made tiny network of my two computers useing parallel port and plip. I am working with alfa (name of comuter, and network is juraj.fedel) and can use
    Message 1 of 3 , Mar 1 10:19 AM
    • 0 Attachment
      I have made tiny network of my two computers useing parallel port and plip.
      I am working with 'alfa' (name of comuter, and network is juraj.fedel) and
      can use services provided be 'beta' such as http, ftp, dns etc. I would like
      to be able to login from alfa to beta without typeing password. I have read
      man pages for ssh anc company but am not able to configure it properlly. I
      have generated keys with ssh-keygen (rsa1, rsa and dsa) on alfa and copyed
      public keys to beta, with no result.
      Can You please help me configure this?
      Juraj
    • B. L. Jilek
      Hi Juraj! ... If I remember correctly you need to put the key from the machine you want to log in with (/home/you/.ssh/id_dsa.pub) into
      Message 2 of 3 , Mar 3 4:21 AM
      • 0 Attachment
        Hi Juraj!

        On Sat, 01 Mar 2003, Juraj Fedel wrote:

        > I have made tiny network of my two computers useing parallel port and plip.
        > I am working with 'alfa' (name of comuter, and network is juraj.fedel) and
        > can use services provided be 'beta' such as http, ftp, dns etc. I would like
        > to be able to login from alfa to beta without typeing password. I have read
        > man pages for ssh anc company but am not able to configure it properlly. I
        > have generated keys with ssh-keygen (rsa1, rsa and dsa) on alfa and copyed
        > public keys to beta, with no result.
        > Can You please help me configure this?
        > Juraj
        >

        If I remember correctly you need to put the key from the machine you
        want to log in with (/home/you/.ssh/id_dsa.pub) into
        (/home/you/.ssh/known_hosts) on the machine you want to log into.

        Just copy the key line into known_hosts. It will look something like
        this:

        alfa ssh-rsa AAAAB3NzaC1yc2EAAA;LSDFHGLAKSDFJ;ALSDFKJALDSKJFAHGA;LSKDHOIEHet NYppbtEbjrFce155FyGteuJ7hII03CQdQxzMsvqT1BXv6jziLIy+6/XdfnypiF5BjR9g04E0jyDCRcZi Xrt2W7hMmFYU/c3j+c9j/VeoSRlWh5mJlcMerczO3QBJs8zKzdrm8vTE=

        --
        B. L. Jilek <bljilek@...>
        PGP keys on my website --> http://crowbyte.dnsalias.com/~tcrow/
        Linux user: 163800 | Debian Rules! | Slackware Rocks!
        -----------------------------------------------------------


        [Non-text portions of this message have been removed]
      • mpetersun <mpeters@aktifkablo.net>
        ... You also need to enable it in ssh_config IIRC. Mike
        Message 3 of 3 , Mar 3 2:40 PM
        • 0 Attachment
          --- In linux@yahoogroups.com, "B. L. Jilek" <bljilek@y...> wrote:
          > Hi Juraj!
          >
          > On Sat, 01 Mar 2003, Juraj Fedel wrote:
          >
          > > I have made tiny network of my two computers useing parallel port and plip.
          > > I am working with 'alfa' (name of comuter, and network is juraj.fedel) and
          > > can use services provided be 'beta' such as http, ftp, dns etc. I would like
          > > to be able to login from alfa to beta without typeing password. I have read
          > > man pages for ssh anc company but am not able to configure it properlly. I
          > > have generated keys with ssh-keygen (rsa1, rsa and dsa) on alfa and copyed
          > > public keys to beta, with no result.
          > > Can You please help me configure this?
          > > Juraj
          > >
          >
          > If I remember correctly you need to put the key from the machine you
          > want to log in with (/home/you/.ssh/id_dsa.pub) into
          > (/home/you/.ssh/known_hosts) on the machine you want to log into.
          >
          > Just copy the key line into known_hosts. It will look something like
          > this:
          >
          > alfa ssh-rsa AAAAB3NzaC1yc2EAAA;LSDFHGLAKSDFJ;ALSDFKJALDSKJFAHGA;LSKDHOIEHet NYppbtEbjrFce155FyGteuJ7hII03CQdQxzMsvqT1BXv6jziLIy+6/XdfnypiF5BjR9g04E0jyDCRcZi Xrt2W7hMmFYU/c3j+c9j/VeoSRlWh5mJlcMerczO3QBJs8zKzdrm8vTE=

          You also need to enable it in ssh_config IIRC.

          Mike
        Your message has been successfully submitted and would be delivered to recipients shortly.