Loading ...
Sorry, an error occurred while loading the content.

Kernel 2.6 - Twinview not working

Expand Messages
  • ralf_hd
    Hello, after 2 years, I updated my Notebook from Suse 8.2 to Suse 9.3 (kernel 2.6.11). Therefore a new nvidia driver for my notebook was installed (graphics
    Message 1 of 4 , Jul 3, 2005
    View Source
    • 0 Attachment
      Hello,
      after 2 years, I updated my Notebook from Suse 8.2 to Suse 9.3 (kernel
      2.6.11). Therefore a new nvidia driver for my notebook was installed
      (graphics card GeForce4 4200 Go).
      Under Suse 8.2 (Kernel 2.4.20) I had twinView working such that I had
      my screen resolution of 1920x1200 and externally 1024x768 (using
      MetaModes and Ctrl-Alt-Fn +/- to switch through the screen resolutions).
      In those times, my special key Fn-F8 had no function.

      Now, with kernel 2.6.11, and suse 9.3, the key Fn-F8 show "some
      function" (a crazy image on an external monitor) AND the
      TWINVIEW option is NOT working any more.
      How can I reactive TwinView? I do not need the Fn-F8 key.

      I recognized this, since I can swtich 6 times through the screen
      resoltuions until my 1920x1200 comes back. But my xorg.conf file just
      lists two different configurations"

      (by the way, WLAN and the scrolling with the touch pad
      works out of the box with Suse 9.3 ...)

      Here is my now xorg.conf file (I modified the automatically
      generated sax-file, which was even worse).

      Thanks a lot,
      Ralf


      # /.../
      # SaX generated X11 config file
      # Created on: 2005-06-30T11:42:51+0200.
      #
      # Version: 4.8
      # Contact: Marcus Schaefer <sax@...>, 2002
      #
      # Automatically generated by [ISaX] (4.8)
      # PLEASE DO NOT EDIT THIS FILE!
      #
      Section "Files"
      FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
      FontPath "/usr/X11R6/lib/X11/fonts/local"
      FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
      FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
      FontPath "/usr/X11R6/lib/X11/fonts/Type1"
      FontPath "/usr/X11R6/lib/X11/fonts/URW"
      FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
      FontPath "/usr/X11R6/lib/X11/fonts/PEX"
      FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
      FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
      FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
      FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
      FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
      FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
      FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
      FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
      FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
      FontPath "/usr/X11R6/lib/X11/fonts/truetype"
      FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
      FontPath "/usr/X11R6/lib/X11/fonts/CID"
      FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
      FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
      FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
      FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
      FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
      FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
      FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
      FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
      FontPath "/usr/X11R6/lib/X11/fonts/xtest"
      FontPath "/opt/kde3/share/fonts"
      InputDevices "/dev/ttyS0"
      InputDevices "/dev/ttyS1"
      InputDevices "/dev/ttyS2"
      InputDevices "/dev/ttyS3"
      InputDevices "/dev/ttyS4"
      InputDevices "/dev/ttyS5"
      InputDevices "/dev/ttyS6"
      InputDevices "/dev/ttyS7"
      InputDevices "/dev/ttyS8"
      InputDevices "/dev/psaux"
      InputDevices "/dev/logibm"
      ## InputDevices "/dev/sunmouse"
      InputDevices "/dev/atibm"
      ## InputDevices "/dev/amigamouse"
      ## InputDevices "/dev/atarimouse"
      InputDevices "/dev/inportbm"
      InputDevices "/dev/gpmdata"
      InputDevices "/dev/mouse"
      InputDevices "/dev/usbmouse"
      InputDevices "/dev/adbmouse"
      InputDevices "/dev/input/mice"
      InputDevices "/dev/input/event0"
      InputDevices "/dev/pointer0"
      InputDevices "/dev/pointer1"
      InputDevices "/dev/pointer2"
      InputDevices "/dev/pointer3"
      EndSection

      Section "ServerFlags"
      Option "AllowMouseOpenFail"
      Option "RandR" "on"
      EndSection

      Section "Module"
      Load "dbe"
      Load "type1"
      Load "freetype"
      Load "extmod"
      Load "glx"
      Load "v4l"
      Load "speedo"
      EndSection

      Section "InputDevice"
      Driver "kbd"
      Identifier "Keyboard[0]"
      Option "Protocol" "Standard"
      Option "XkbLayout" "de"
      Option "XkbModel" "pc105"
      Option "XkbRules" "xfree86"
      Option "XkbVariant" "nodeadkeys"
      EndSection

      Section "InputDevice"
      Driver "synaptics"
      Identifier "Mouse[1]"
      Option "AccelFactor" "0.04"
      Option "BottomEdge" "650"
      Option "CircScrollDelta" "0.1"
      Option "CircScrollTrigger" "2"
      Option "CircularScrolling" "1"
      Option "Device" "/dev/input/mice"
      Option "EdgeMotionMaxSpeed" "15"
      Option "EdgeMotionMinSpeed" "15"
      Option "Emulate3Buttons" "on"
      Option "EmulateMidButtonTime" "75"
      Option "FingerHigh" "15"
      Option "FingerLow" "14"
      Option "HorizScrollDelta" "20"
      Option "InputFashion" "Mouse"
      Option "LeftEdge" "120"
      Option "MaxSpeed" "0.5"
      Option "MaxTapMove" "110"
      Option "MaxTapTime" "180"
      Option "MinSpeed" "0.2"
      Option "Name" "ALPS;Touchpad"
      Option "Protocol" "auto-dev"
      Option "RightEdge" "830"
      Option "SHMConfig" "on"
      Option "TopEdge" "120"
      Option "UpDownScrolling" "1"
      Option "Vendor" "Sysp"
      Option "VertScrollDelta" "20"
      Option "ZAxisMapping" "4 5"
      EndSection

      Section "Monitor"
      Option "CalcAlgorithm" "CheckDesktopGeometry"
      DisplaySize 330 210
      HorizSync 28-110
      Identifier "Monitor[0]"
      ModelName "WUXGA"
      Option "DPMS"
      VendorName "Unprobed Monitor"
      VertRefresh 43-90
      UseModes "Modes[0]"
      EndSection

      Section "Modes"
      Identifier "Modes[0]"
      Modeline "1920x1200" 162.00 1920 1984 2176 2480 1200 1201 1204 1250
      EndSection

      Section "Screen"
      Device "Device[0]"
      Identifier "Screen[0]"
      Monitor "Monitor[0]"
      DefaultDepth 24
      SubSection "Display"
      Depth 24
      Modes "1920x1200" "1600x1200" "1400x1050" "1280x1024"
      "1280X960" "1024x768" "800x600"
      EndSubSection
      SubSection "Display"
      Depth 16
      Modes "1920x1200" "1600x1200" "1280x1024" "1024x768"
      EndSubSection
      SubSection "Display"
      Depth 8
      Modes "1024x768"
      EndSubSection
      EndSection

      Section "Device"
      BoardName "GeForce4 4200 Go"
      BusID "1:0:0"
      Driver "nv"
      Identifier "Device[0]"
      Option "NoLogo" "true"
      Option "NvAgp" "3"
      Option "RenderAccel" "off"
      # nvidia specific options from dsanta i8500
      ##Option "UseEdidFreqs" "yes" # Use DCC
      Option "FlatPanelProperties" "Scaling = aspect-scaled"
      # Internal flatpanel does not provide freqs, use
      # some sensible values (from Dell 1600x1200 flat panel display).
      Option "TwinView" "true"
      ## Option "TwinViewOrientation" "Clone"
      Option "TwinViewOrientation" "LeftOf"
      Option "SecondMonitorHorizSync" "28-100"
      Option "SecondMonitorVertRefresh" "43-90"
      Option "MetaModes" "CRT-0:NULL, DFP-0:1920x1200;
      CRT-0:1024x768, DFP-0:1920x1200"
      # from bender.yahoo:
      Option "ConnectedMonitor" "CRT-0, DFP-0"
      ## Screen 0
      ## Option "Rotate" "off"
      VendorName "NVidia"
      EndSection

      Section "ServerLayout"
      Identifier "Layout[all]"
      InputDevice "Keyboard[0]" "CoreKeyboard"
      InputDevice "Mouse[1]" "CorePointer"
      ## InputDevice "Mouse[3]" "SendCoreEvents"
      ## Option "Clone" "off"
      Option "Xinerama" "off"
      Screen "Screen[0]"
      EndSection

      Section "DRI"
      Group "video"
      Mode 0660
      EndSection

      Section "Extensions"
      EndSection
    • ralf_hd
      Hi, it s me again. In the meantime, I found out, that my Xorg.0.log has some errors. Obviously, some options in the device section are not accepted (e.g.
      Message 2 of 4 , Jul 5, 2005
      View Source
      • 0 Attachment
        Hi,
        it's me again. In the meantime, I found out, that my
        Xorg.0.log has some errors. Obviously, some options
        in the device section are not accepted (e.g. TwinView).
        I also changed my xorg.conf in the meantime (see below)
        and I use now Driver "nvidia" (earlier: "nv").
        Does somebody know, why the options below are not accepted?
        It shows NV(0), shouldn't it be NVIDIA(0) ?

        ----------------------
        Errors I found in the Xorg.0.log file:
        ----------------------
        :/var/log> grep WW /var/log/Xorg.0.log
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
        (WW) Open APM failed (/dev/apm_bios) (No such device)
        (WW) NV(0): Option "NvAGP" is not used
        (WW) NV(0): Option "RenderAccel" is not used
        (WW) NV(0): Option "FlatPanelProperties" is not used
        (WW) NV(0): Option "NoLogo" is not used
        (WW) NV(0): Option "NoTwinViewXineramaInfo" is not used
        (WW) NV(0): Option "TwinView" is not used
        (WW) NV(0): Option "TwinViewOrientation" is not used
        (WW) NV(0): Option "SecondMonitorHorizSync" is not used
        (WW) NV(0): Option "SecondMonitorVertRefresh" is not used
        (WW) NV(0): Option "MetaModes" is not used
        (WW) NV(0): Option "ConnectedMonitor" is not used
        (WW) NV(0): Option "CalcAlgorithm" is not used

        ----------------------------------
        My (current) new xorg.conf :
        ----------------------------------
        Section "Files"
        FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
        FontPath "/usr/X11R6/lib/X11/fonts/local"
        FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
        FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
        FontPath "/usr/X11R6/lib/X11/fonts/Type1"
        FontPath "/usr/X11R6/lib/X11/fonts/URW"
        # FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
        # FontPath "/usr/X11R6/lib/X11/fonts/PEX"
        FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
        FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
        # FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
        # FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
        # FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
        # FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
        FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
        FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
        # FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
        FontPath "/usr/X11R6/lib/X11/fonts/truetype"
        FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
        FontPath "/usr/X11R6/lib/X11/fonts/CID"
        # FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
        # FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
        # FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
        # FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
        # FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
        # FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
        # FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
        FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
        # FontPath "/usr/X11R6/lib/X11/fonts/xtest"
        FontPath "/opt/kde3/share/fonts"
        InputDevices "/dev/ttyS0"
        InputDevices "/dev/ttyS1"
        InputDevices "/dev/ttyS2"
        InputDevices "/dev/ttyS3"
        InputDevices "/dev/ttyS4"
        InputDevices "/dev/ttyS5"
        InputDevices "/dev/ttyS6"
        InputDevices "/dev/ttyS7"
        InputDevices "/dev/ttyS8"
        InputDevices "/dev/psaux"
        InputDevices "/dev/logibm"
        InputDevices "/dev/sunmouse"
        InputDevices "/dev/atibm"
        InputDevices "/dev/amigamouse"
        InputDevices "/dev/atarimouse"
        InputDevices "/dev/inportbm"
        InputDevices "/dev/gpmdata"
        InputDevices "/dev/mouse"
        InputDevices "/dev/usbmouse"
        InputDevices "/dev/adbmouse"
        InputDevices "/dev/input/mice"
        InputDevices "/dev/input/event0"
        InputDevices "/dev/pointer0"
        InputDevices "/dev/pointer1"
        InputDevices "/dev/pointer2"
        InputDevices "/dev/pointer3"
        EndSection

        Section "ServerFlags"
        Option "AllowMouseOpenFail"
        Option "RandR" "on"
        EndSection

        Section "Module"
        # Load "speedo"
        Load "extmod"
        Load "glx"
        Load "freetype"
        Load "type1"
        Load "v4l"
        Load "dbe"
        EndSection

        Section "InputDevice"
        Driver "kbd"
        Identifier "Keyboard[0]"
        Option "Protocol" "Standard"
        Option "XkbLayout" "de"
        Option "XkbModel" "pc105"
        Option "XkbRules" "xfree86"
        Option "XkbVariant" "nodeadkeys"
        EndSection


        Section "InputDevice"
        Driver "synaptics"
        Identifier "Mouse[1]"
        Option "AccelFactor" "0.04"
        Option "BottomEdge" "650"
        Option "ButtonNumber" "5"
        Option "CircScrollDelta" "0.1"
        Option "CircScrollTrigger" "2"
        Option "CircularScrolling" "1"
        Option "Device" "/dev/mouse"
        Option "EdgeMotionMaxSpeed" "15"
        Option "EdgeMotionMinSpeed" "15"
        Option "EmulateMidButtonTime" "75"
        Option "FingerHigh" "15"
        Option "FingerLow" "14"
        Option "HorizScrollDelta" "20"
        Option "InputFashion" "Mouse"
        Option "LeftEdge" "120"
        Option "MaxSpeed" "0.5"
        Option "MaxTapMove" "110"
        Option "MaxTapTime" "180"
        Option "MinSpeed" "0.2"
        Option "Name" "ALPS;Touchpad"
        Option "Protocol" "imps/2"
        Option "RightEdge" "830"
        Option "SHMConfig" "on"
        Option "TopEdge" "120"
        Option "UpDownScrolling" "1"
        Option "Vendor" "Sysp"
        Option "VertScrollDelta" "20"
        Option "ZAxisMapping" "4 5"
        EndSection

        ## my usb mouse
        #Section "InputDevice"
        # Driver "mouse"
        # Identifier "Mouse[3]"
        ### Option "Device" "/dev/psaux"
        # Option "InputFashion" "Mouse"
        ### Option "Name" "PS/2-Mouse;PS/2"
        ### Option "Protocol" "PS/2"

        ### von Georg
        # Option "Device" "/dev/mouse"
        # Option "Name" "Autodetection"
        # Option "Protocol" "PS/2"
        # Option "Protocol" "imps/2"
        ### -------------

        # Option "ButtonNumber" "5"
        # Option "ZAxisMapping" "4 5"
        #EndSection

        Section "InputDevice"
        ## Identifier "USBmouse"
        Driver "mouse"
        Identifier "Mouse[3]"
        Option "Protocol" "IMPS/2"
        Option "Device" "/dev/input/mice"
        Option "ZAxisMapping" "4 5"
        Option "Buttons" "5"
        EndSection


        Section "Monitor"
        Option "CalcAlgorithm" "CheckDesktopGeometry"
        DisplaySize 330 210
        HorizSync 28-110
        Identifier "Monitor[0]"
        ModelName "WUXGA"
        Option "DPMS"
        VendorName "Unprobed Monitor"
        VertRefresh 43-90
        UseModes "Modes[0]"
        EndSection


        Section "Modes"
        Identifier "Modes[0]"
        Modeline "1920x1200" 162.00 1920 1984 2176 2480 1200 1201 1204 1250
        EndSection


        Section "Screen"
        Device "Device[0]"
        Identifier "Screen[0]"
        Monitor "Monitor[0]"
        DefaultDepth 24
        SubSection "Display"
        Depth 24
        Modes "1920x1200" "1600x1200" "1400x1050" "1280x1024"
        "1280X960" "1024x768" "800x600"
        EndSubSection
        SubSection "Display"
        Depth 16
        Modes "1920x1200" "1600x1200" "1280x1024" "1024x768"
        EndSubSection
        SubSection "Display"
        Depth 8
        Modes "1024x768"
        EndSubSection
        EndSection


        Section "Device"
        BoardName "GeForce4 4200 Go"
        Identifier "Device[0]"
        ## Driver "nv"
        ### nvidia-README.txt : replace nv by nvidia, no dri und no GLCore
        Driver "nvidia"
        BusID "1:0:0"
        Option "NvAGP" "2"
        Option "RenderAccel" "off"
        Option "FlatPanelProperties" "Scaling"
        Option "NoLogo" "true"
        ## try this now, to check if TwinView works then....:
        Option "NoTwinViewXineramaInfo" "true"
        ## Screen 0
        Option "TwinView" "true"
        Option "TwinViewOrientation" "Clone"
        ## Option "TwinViewOrientation" "LeftOf"
        Option "SecondMonitorHorizSync" "28-100"
        Option "SecondMonitorVertRefresh" "43-90"
        Option "MetaModes" "NULL, 1920x1200; 1024x768, 1920x1200; 800x600,
        1920x1200; NULL, 1280x960"
        # from bender.yahoo:
        Option "ConnectedMonitor" "CRT, DFP"
        VendorName "NVidia"
        EndSection


        Section "ServerLayout"
        Identifier "Layout[all]"
        InputDevice "Keyboard[0]" "CoreKeyboard"
        InputDevice "Mouse[1]" "CorePointer"
        InputDevice "Mouse[3]" "SendCoreEvents"
        # Option "Clone" "off"
        # Option "Xinerama" "off"
        Screen "Screen[0]"
        EndSection

        #Section "DRI"
        # Group "video"
        # Mode 0660
        #EndSection


        ----------------------------------

        --- In linux-latitude-d800@yahoogroups.com, "ralf_hd"
        <ralf.srama@w...> wrote:
        > Hello,
        > after 2 years, I updated my Notebook from Suse 8.2 to Suse 9.3 (kernel
        > 2.6.11). Therefore a new nvidia driver for my notebook was installed
        > (graphics card GeForce4 4200 Go).
        > Under Suse 8.2 (Kernel 2.4.20) I had twinView working such that I had
        > my screen resolution of 1920x1200 and externally 1024x768 (using
        > MetaModes and Ctrl-Alt-Fn +/- to switch through the screen resolutions).
        > In those times, my special key Fn-F8 had no function.
        >
        > Now, with kernel 2.6.11, and suse 9.3, the key Fn-F8 show "some
        > function" (a crazy image on an external monitor) AND the
        > TWINVIEW option is NOT working any more.
        > How can I reactive TwinView? I do not need the Fn-F8 key.
        >
        > I recognized this, since I can swtich 6 times through the screen
        > resoltuions until my 1920x1200 comes back. But my xorg.conf file just
        > lists two different configurations"
        >
        > (by the way, WLAN and the scrolling with the touch pad
        > works out of the box with Suse 9.3 ...)
        >
        > Here is my now xorg.conf file (I modified the automatically
        > generated sax-file, which was even worse).
        >
        > Thanks a lot,
        > Ralf
        >
      • mark5taylor
        ... Yes, I think it should be NVIDIA, not NV, so it appears you are still using the nv driver. your xorg.conf clearly specifies nvidia, so that is very
        Message 3 of 4 , Jul 6, 2005
        View Source
        • 0 Attachment
          --- In linux-latitude-d800@yahoogroups.com, "ralf_hd"
          <ralf.srama@w...> wrote:
          > Hi,
          > it's me again. In the meantime, I found out, that my
          > Xorg.0.log has some errors. Obviously, some options
          > in the device section are not accepted (e.g. TwinView).
          > I also changed my xorg.conf in the meantime (see below)
          > and I use now Driver "nvidia" (earlier: "nv").
          > Does somebody know, why the options below are not accepted?
          > It shows NV(0), shouldn't it be NVIDIA(0) ?
          >
          > ----------------------
          > Errors I found in the Xorg.0.log file:
          > ----------------------
          > :/var/log> grep WW /var/log/Xorg.0.log
          > (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
          > (WW) Open APM failed (/dev/apm_bios) (No such device)
          > (WW) NV(0): Option "NvAGP" is not used
          > (WW) NV(0): Option "RenderAccel" is not used
          > (WW) NV(0): Option "FlatPanelProperties" is not used
          > (WW) NV(0): Option "NoLogo" is not used
          > (WW) NV(0): Option "NoTwinViewXineramaInfo" is not used
          > (WW) NV(0): Option "TwinView" is not used
          > (WW) NV(0): Option "TwinViewOrientation" is not used
          > (WW) NV(0): Option "SecondMonitorHorizSync" is not used
          > (WW) NV(0): Option "SecondMonitorVertRefresh" is not used
          > (WW) NV(0): Option "MetaModes" is not used
          > (WW) NV(0): Option "ConnectedMonitor" is not used
          > (WW) NV(0): Option "CalcAlgorithm" is not used
          >

          Yes, I think it should be NVIDIA, not NV, so it appears you are still
          using the nv driver. your xorg.conf clearly specifies nvidia, so that
          is very strange. Here are the similar lines from my Xorg.0.log file:



          (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
          (==) NVIDIA(0): RGB weight 888
          (==) NVIDIA(0): Default visual is TrueColor
          (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
          (**) NVIDIA(0): Option "NvAGP" "1"
          (**) NVIDIA(0): Option "ConnectedMonitor" "DFP-0,DFP-1"
          (**) NVIDIA(0): Option "UseEdidFreqs" "true"
          (**) NVIDIA(0): Option "FlatPanelProperties" "Scaling = aspect-scaled"
          (**) NVIDIA(0): Option "TwinView" "true"
          (**) NVIDIA(0): Option "TwinViewOrientation" "Clone"
          (**) NVIDIA(0): Option "SecondMonitorHorizSync" "28-110"
          (**) NVIDIA(0): Option "SecondMonitorVertRefresh" "50-60"
          (**) NVIDIA(0): Option "MetaModes"
          "1600x1200,1600x1200;NULL,1600x1200;1600x120$
          (**) NVIDIA(0): Use of NVIDIA internal AGP requested
          (**) NVIDIA(0): ConnectedMonitor string: "DFP-0,DFP-1"
          (**) NVIDIA(0): FlatPanelProperties string: "Scaling = aspect-scaled"
          (**) NVIDIA(0): TwinView enabled


          Mark
        • ralf_hd
          Hi Mark, yes - now I fixed the problem!! What happend is the following: I installed Suse. During the installation process (before booting the first time), I
          Message 4 of 4 , Jul 6, 2005
          View Source
          • 0 Attachment
            Hi Mark,
            yes - now I fixed the problem!!
            What happend is the following:
            I installed Suse.
            During the installation process (before booting the first time),
            I was asked to look for updates. So I made an online-update
            of all patches AND the nvidia driver.
            But this installation did not fully succeed, the the system
            still took the "nv" drivere, not the "nvidia" driver, although
            it was installed correctly.

            I fixed the now problem by SIMPLY INSTALLING the nvidia
            driver again (using YOU).
            Now, everything is fine and I see also NVIDIA(0) in my
            Xorg.0.log file!

            So I think the installation procedure of Suse 9.3 is not fully
            correct in this regard. I wandered about the update anyway:
            In one step, a new kernel, all the software patches and
            the nvidia driver were installed....problably better to
            do this at least in two or three steps.

            Thanks,
            Ralf

            --- In linux-latitude-d800@yahoogroups.com, "mark5taylor"
            <mtaylor@n...> wrote:
            > --- In linux-latitude-d800@yahoogroups.com, "ralf_hd"
            > <ralf.srama@w...> wrote:
            > > Hi,
            > > it's me again. In the meantime, I found out, that my
            > > Xorg.0.log has some errors. Obviously, some options
            > > in the device section are not accepted (e.g. TwinView).
            > > I also changed my xorg.conf in the meantime (see below)
            > > and I use now Driver "nvidia" (earlier: "nv").
            > > Does somebody know, why the options below are not accepted?
            > > It shows NV(0), shouldn't it be NVIDIA(0) ?
            > >
            > > ----------------------
            > > Errors I found in the Xorg.0.log file:
            > > ----------------------
            > > :/var/log> grep WW /var/log/Xorg.0.log
            > > (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
            > > (WW) Open APM failed (/dev/apm_bios) (No such device)
            > > (WW) NV(0): Option "NvAGP" is not used
            > > (WW) NV(0): Option "RenderAccel" is not used
            > > (WW) NV(0): Option "FlatPanelProperties" is not used
            > > (WW) NV(0): Option "NoLogo" is not used
            > > (WW) NV(0): Option "NoTwinViewXineramaInfo" is not used
            > > (WW) NV(0): Option "TwinView" is not used
            > > (WW) NV(0): Option "TwinViewOrientation" is not used
            > > (WW) NV(0): Option "SecondMonitorHorizSync" is not used
            > > (WW) NV(0): Option "SecondMonitorVertRefresh" is not used
            > > (WW) NV(0): Option "MetaModes" is not used
            > > (WW) NV(0): Option "ConnectedMonitor" is not used
            > > (WW) NV(0): Option "CalcAlgorithm" is not used
            > >
            >
            > Yes, I think it should be NVIDIA, not NV, so it appears you are still
            > using the nv driver. your xorg.conf clearly specifies nvidia, so that
            > is very strange. Here are the similar lines from my Xorg.0.log file:
            >
            >
            >
            > (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
            > (==) NVIDIA(0): RGB weight 888
            > (==) NVIDIA(0): Default visual is TrueColor
            > (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
            > (**) NVIDIA(0): Option "NvAGP" "1"
            > (**) NVIDIA(0): Option "ConnectedMonitor" "DFP-0,DFP-1"
            > (**) NVIDIA(0): Option "UseEdidFreqs" "true"
            > (**) NVIDIA(0): Option "FlatPanelProperties" "Scaling = aspect-scaled"
            > (**) NVIDIA(0): Option "TwinView" "true"
            > (**) NVIDIA(0): Option "TwinViewOrientation" "Clone"
            > (**) NVIDIA(0): Option "SecondMonitorHorizSync" "28-110"
            > (**) NVIDIA(0): Option "SecondMonitorVertRefresh" "50-60"
            > (**) NVIDIA(0): Option "MetaModes"
            > "1600x1200,1600x1200;NULL,1600x1200;1600x120$
            > (**) NVIDIA(0): Use of NVIDIA internal AGP requested
            > (**) NVIDIA(0): ConnectedMonitor string: "DFP-0,DFP-1"
            > (**) NVIDIA(0): FlatPanelProperties string: "Scaling = aspect-scaled"
            > (**) NVIDIA(0): TwinView enabled
            >
            >
            > Mark
          Your message has been successfully submitted and would be delivered to recipients shortly.