Loading ...
Sorry, an error occurred while loading the content.

Updating lilo

Expand Messages
  • roman melns
    Hi After updating /etc/lilo.conf, running /sbin/lilo as root will give the following error message: Reading boot sector from current root Fatal: Can t put the
    Message 1 of 7 , Jan 30, 2002
    • 0 Attachment
      Hi

      After updating /etc/lilo.conf, running /sbin/lilo as
      root will give the following error message:
      Reading boot sector from current root
      Fatal: Can't put the boot sector on logical partition
      0x306

      Updating lilo has worked several times before. Spects:
      i8000, dual boot WinME + Mandrake 8.1

      Any help would be appreciated.

      Roman

      __________________________________________________________________

      Gesendet von Yahoo! Mail - http://mail.yahoo.de
      Ihre E-Mail noch individueller? - http://domains.yahoo.de
    • Invent Yourself
      I have found grub works better than lilo on my i8k WinME/8.1. Specifically, under 8.0, lilo would not dual boot! grub works fine, with 8.1 ... -- The tao that
      Message 2 of 7 , Jan 30, 2002
      • 0 Attachment
        I have found grub works better than lilo on my i8k WinME/8.1.
        Specifically, under 8.0, lilo would not dual boot! grub works fine, with
        8.1




        On Wed, 30 Jan 2002, [iso-8859-1] roman melns wrote:

        > Hi
        >
        > After updating /etc/lilo.conf, running /sbin/lilo as
        > root will give the following error message:
        > Reading boot sector from current root
        > Fatal: Can't put the boot sector on logical partition
        > 0x306
        >
        > Updating lilo has worked several times before. Spects:
        > i8000, dual boot WinME + Mandrake 8.1
        >
        > Any help would be appreciated.
        >
        > Roman
        >
        > __________________________________________________________________
        >
        > Gesendet von Yahoo! Mail - http://mail.yahoo.de
        > Ihre E-Mail noch individueller? - http://domains.yahoo.de
        >
        > Yahoo! Groups Sponsor
        > ADVERTISEMENT
        >
        > --------------------------------------------------------------
        > Please post your X config files in the group links or database
        > FAQ: http://www.whacked.net/ldl/faq
        >
        > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
        >

        --
        The tao that can be tar(1)ed
        is not the entire Tao.
        The path that can be specified
        is not the Full Path.
      • michael carr
        check your bios for any reference to MBR write or security. it may not be allowing you to write there for security/virus reasons. mikey ;) ...
        Message 3 of 7 , Jan 30, 2002
        • 0 Attachment
          check your bios for any reference to MBR write or security. it may not
          be allowing you to write there for security/virus reasons.

          mikey >;)

          --- Invent Yourself <xod@...> wrote:
          > I have found grub works better than lilo on my i8k WinME/8.1.
          > Specifically, under 8.0, lilo would not dual boot! grub works fine,
          > with
          > 8.1
          >
          >
          >
          >
          > On Wed, 30 Jan 2002, [iso-8859-1] roman melns wrote:
          >
          > > Hi
          > >
          > > After updating /etc/lilo.conf, running /sbin/lilo as
          > > root will give the following error message:
          > > Reading boot sector from current root
          > > Fatal: Can't put the boot sector on logical partition
          > > 0x306
          > >
          > > Updating lilo has worked several times before. Spects:
          > > i8000, dual boot WinME + Mandrake 8.1
          > >
          > > Any help would be appreciated.
          > >
          > > Roman
          > >
          > > __________________________________________________________________
          > >
          > > Gesendet von Yahoo! Mail - http://mail.yahoo.de
          > > Ihre E-Mail noch individueller? - http://domains.yahoo.de
          > >
          > > Yahoo! Groups Sponsor
          > > ADVERTISEMENT
          > >
          > > --------------------------------------------------------------
          > > Please post your X config files in the group links or database
          > > FAQ: http://www.whacked.net/ldl/faq
          > >
          > > Your use of Yahoo! Groups is subject to the Yahoo! Terms of
          > Service.
          > >
          >
          > --
          > The tao that can be tar(1)ed
          > is not the entire Tao.
          > The path that can be specified
          > is not the Full Path.
          >
          >


          __________________________________________________
          Do You Yahoo!?
          Great stuff seeking new owners in Yahoo! Auctions!
          http://auctions.yahoo.com
        • melns01
          I think the idea with the Bios would be right because I can t write lilo since I upgraded to BiosA18. However, I can t find a parameter in the Bios menu (enter
          Message 4 of 7 , Jan 31, 2002
          • 0 Attachment
            I think the idea with the Bios would be right because I can't write
            lilo since I upgraded to BiosA18. However, I can't find a parameter in
            the Bios menu (enter with F2) that could be related to a "write
            protection". Are there any other way to enter Bios or does
            someone other know a workaround? I wouldn't like to switch to grub
            since I make good experiences with lilo.

            Thanks
            Roman

            --- In linux-dell-laptops@y..., michael carr <pweiproduct@y...> wrote:
            > check your bios for any reference to MBR write or security. it may
            not
            > be allowing you to write there for security/virus reasons.
            >
            > mikey >;)
            >
            > --- Invent Yourself <xod@s...> wrote:
            > > I have found grub works better than lilo on my i8k WinME/8.1.
            > > Specifically, under 8.0, lilo would not dual boot! grub works
            fine,
            > > with
            > > 8.1
            > >
            > >
            > >
            > >
            > > On Wed, 30 Jan 2002, [iso-8859-1] roman melns wrote:
            > >
            > > > Hi
            > > >
            > > > After updating /etc/lilo.conf, running /sbin/lilo as
            > > > root will give the following error message:
            > > > Reading boot sector from current root
            > > > Fatal: Can't put the boot sector on logical partition
            > > > 0x306
            > > >
            > > > Updating lilo has worked several times before. Spects:
            > > > i8000, dual boot WinME + Mandrake 8.1
            > > >
            > > > Any help would be appreciated.
            > > >
            > > > Roman
            > > >
            > > >
            __________________________________________________________________
            > > >
            > > > Gesendet von Yahoo! Mail - http://mail.yahoo.de
            > > > Ihre E-Mail noch individueller? - http://domains.yahoo.de
            > > >
            > > > Yahoo! Groups Sponsor
            > > > ADVERTISEMENT
            > > >
            > > > --------------------------------------------------------------
            > > > Please post your X config files in the group links or database
            > > > FAQ: http://www.whacked.net/ldl/faq
            > > >
            > > > Your use of Yahoo! Groups is subject to the Yahoo! Terms of
            > > Service.
            > > >
            > >
            > > --
            > > The tao that can be tar(1)ed
            > > is not the entire Tao.
            > > The path that can be specified
            > > is not the Full Path.
            > >
            > >
            >
            >
            > __________________________________________________
            > Do You Yahoo!?
            > Great stuff seeking new owners in Yahoo! Auctions!
            > http://auctions.yahoo.com
          • michael carr
            you can t even switch to grub if you can t write to the MBR. :( my suggestion, look in the bios again, real hard. if you still cant find it break out the
            Message 5 of 7 , Jan 31, 2002
            • 0 Attachment
              you can't even switch to grub if you can't write to the MBR. :( my
              suggestion, look in the bios again, real hard. if you still cant find
              it break out the manual or call dell.

              mikey >;)

              --- melns01 <melns01@...> wrote:
              > I think the idea with the Bios would be right because I can't write
              > lilo since I upgraded to BiosA18. However, I can't find a parameter
              > in
              > the Bios menu (enter with F2) that could be related to a "write
              > protection". Are there any other way to enter Bios or does
              > someone other know a workaround? I wouldn't like to switch to grub
              > since I make good experiences with lilo.
              >
              > Thanks
              > Roman
              >
              > --- In linux-dell-laptops@y..., michael carr <pweiproduct@y...>
              > wrote:
              > > check your bios for any reference to MBR write or security. it may
              > not
              > > be allowing you to write there for security/virus reasons.
              > >
              > > mikey >;)
              > >
              > > --- Invent Yourself <xod@s...> wrote:
              > > > I have found grub works better than lilo on my i8k WinME/8.1.
              > > > Specifically, under 8.0, lilo would not dual boot! grub works
              > fine,
              > > > with
              > > > 8.1
              > > >
              > > >
              > > >
              > > >
              > > > On Wed, 30 Jan 2002, [iso-8859-1] roman melns wrote:
              > > >
              > > > > Hi
              > > > >
              > > > > After updating /etc/lilo.conf, running /sbin/lilo as
              > > > > root will give the following error message:
              > > > > Reading boot sector from current root
              > > > > Fatal: Can't put the boot sector on logical partition
              > > > > 0x306
              > > > >
              > > > > Updating lilo has worked several times before. Spects:
              > > > > i8000, dual boot WinME + Mandrake 8.1
              > > > >
              > > > > Any help would be appreciated.
              > > > >
              > > > > Roman
              > > > >
              > > > >
              > __________________________________________________________________
              > > > >
              > > > > Gesendet von Yahoo! Mail - http://mail.yahoo.de
              > > > > Ihre E-Mail noch individueller? - http://domains.yahoo.de
              > > > >
              > > > > Yahoo! Groups Sponsor
              > > > > ADVERTISEMENT
              > > > >
              > > > > --------------------------------------------------------------
              > > > > Please post your X config files in the group links or database
              > > > > FAQ: http://www.whacked.net/ldl/faq
              > > > >
              > > > > Your use of Yahoo! Groups is subject to the Yahoo! Terms of
              > > > Service.
              > > > >
              > > >
              > > > --
              > > > The tao that can be tar(1)ed
              > > > is not the entire Tao.
              > > > The path that can be specified
              > > > is not the Full Path.
              > > >
              > > >
              > >
              > >
              > > __________________________________________________
              > > Do You Yahoo!?
              > > Great stuff seeking new owners in Yahoo! Auctions!
              > > http://auctions.yahoo.com
              >
              >


              __________________________________________________
              Do You Yahoo!?
              Great stuff seeking new owners in Yahoo! Auctions!
              http://auctions.yahoo.com
            • Mike Hicks
              ... 0x306 would be /dev/hda6, if I m not mistaken. Does that partition actually exist on your computer? -- _ _ _ _ _ ___ _ _ _ ___ _ _ __ HUP / /
              Message 6 of 7 , Feb 1, 2002
              • 0 Attachment
                roman melns <melns01@...> wrote:
                >
                > Hi
                >
                > After updating /etc/lilo.conf, running /sbin/lilo as
                > root will give the following error message:
                > Reading boot sector from current root
                > Fatal: Can't put the boot sector on logical partition
                > 0x306

                0x306 would be /dev/hda6, if I'm not mistaken. Does that partition
                actually exist on your computer?

                --
                _ _ _ _ _ ___ _ _ _ ___ _ _ __ HUP
                / \/ \(_)| ' // ._\ / - \(_)/ ./| ' /(__
                \_||_/|_||_|_\\___/ \_-_/|_|\__\|_|_\ __)
                [ Mike Hicks | http://umn.edu/~hick0088/ | mailto:hick0088@... ]
              • melns01
                Sorry for answering that late, but here it comes: Yes I /dev/hda6 exist on my I8000. Here is the complete partition table: hda1: fat32 7.5 GB WinME
                Message 7 of 7 , Feb 4, 2002
                • 0 Attachment
                  Sorry for answering that late, but here it comes:
                  Yes I /dev/hda6 exist on my I8000. Here is the complete partition
                  table:
                  hda1: fat32 7.5 GB WinME (/mnt/win_c)
                  hda2: - hda5 swap 502 MB
                  - hda6 ext2 4.6 GB /
                  - hda7 fat32 5.8 GB Data (/mnt/win_d)

                  lilo should write to /dev/hda6 (as mentioned in lilo.conf) and before
                  the upgrade to biosA18 it does (I believe).



                  --- In linux-dell-laptops@y..., Mike Hicks <hick0088@t...> wrote:
                  > roman melns <melns01@Y...> wrote:
                  > >
                  > > Hi
                  > >
                  > > After updating /etc/lilo.conf, running /sbin/lilo as
                  > > root will give the following error message:
                  > > Reading boot sector from current root
                  > > Fatal: Can't put the boot sector on logical partition
                  > > 0x306
                  >
                  > 0x306 would be /dev/hda6, if I'm not mistaken. Does that partition
                  > actually exist on your computer?
                  >
                  > --
                  > _ _ _ _ _ ___ _ _ _ ___ _ _ __ HUP
                  > / \/ \(_)| ' // ._\ / - \(_)/ ./| ' /(__
                  > \_||_/|_||_|_\\___/ \_-_/|_|\__\|_|_\ __)
                  > [ Mike Hicks | http://umn.edu/~hick0088/ | mailto:hick0088@t... ]
                Your message has been successfully submitted and would be delivered to recipients shortly.