Loading ...
Sorry, an error occurred while loading the content.

key-bindings on a Inspiron 8100

Expand Messages
  • Paul Waserbrot
    Hi! Like others, i have installed and struggled with key-bindings for the volume/mute/play/stop/next/previous keys in Linux. And since i found a bug in the
    Message 1 of 1 , Jan 11, 2002
    • 0 Attachment
      Hi!

      Like others, i have installed and struggled with key-bindings for the
      volume/mute/play/stop/next/previous keys in Linux.

      And since i found a bug in the configurations for XFree86-4.1.0 and
      use fvwm1 as window-manager, i thought you would appreciate if i share
      my knowledge with you. So what have I done then? Well most of it
      is as it is described in the FAQ, but there are some neat-ies worth
      mention.

      My system is debian woody running XFree86 4.1.0 + fvwm1. (of course =) )
      (/usr/lib/X11/xkb is a symbolic link to /etc/X11 on debian)

      1) The debian keycodes file /etc/X11/xkb/keycodes/xfree86 has two
      errors. The keycodes for <I01> - <I04> are added and correct but <I01>
      and <I03> are there as aliases to <XFER> and <NFER> and they are
      twisted in the file. So in order to get it right change the lines

      alias <XFER> = <I01>;
      alias <NFER> = <I03>;

      to

      alias <I01> = <XFER>;
      alias <I03> = <NFER>;

      2) I added the following key-symbols to the end of
      /etc/X11/xkb/symbols/inet. (I thought it more neat to do it this way)

      partial alphanumeric_keys
      xkb_symbols "dell" {

      // Describes some the extra keys on a Dell Inspiron 8100

      name[Group1]= "i8100";
      key <I01> { [ XF86AudioPlay, XF86AudioPause ] };
      key <I02> { [ XF86AudioStop ] };
      key <I03> { [ XF86AudioPrev ] };
      key <I04> { [ XF86AudioNext ] };
      key <I20> { [ XF86AudioMute ] };
      key <I2E> { [ XF86AudioLowerVolume ] };
      key <I30> { [ XF86AudioRaiseVolume ] };
      };

      3) I edited my XF86Config-4 and added the line

      Option "XkbSymbols" "us(pc104)+inet(dell)"

      in the InputDevice (Keyboard) section. This means that i use
      us(pc104) with my dell-symbols defined above.

      4) And then i used parts of the Dell scripts ldl has on its homepage
      and added the following to my .fvwmrc

      # Adding audio-keys on Dell Insprion 8100
      Key XF86AudioRaiseVolume A N Exec "RaiseVolume" /usr/bin/aumix -v +10
      Key XF86AudioLowerVolume A N Exec "LowerVolume" /usr/bin/aumix -v -10
      Key XF86AudioMute A N Exec "MuteVolume" /home/pw/dell/dell_volmute.sh
      Key XF86AudioPrev A N Exec "PreviousTrack" /usr/bin/cdcd prev
      Key XF86AudioNext A N Exec "NextTrack" /usr/bin/cdcd next
      Key XF86AudioPause A N Exec "PauseCD" /usr/bin/cdcd pause
      Key XF86AudioPlay A N Exec "PlayCD" /home/pw/dell/dell_play.sh
      Key XF86AudioStop A N Exec "StopCD" /usr/bin/cdcd stop


      Bugs:

      1) I found that i couldn't get the pause-button (shift-play as i
      defined XF86AudioPause) to work with fvwm. It is correctly configured
      since xev shows the right symbols and codes. That is why i used
      the dell_play.sh script as it is has pause implemented so one can
      play/pause with the play-button instead. =/

      2) When cdcd is situated in Stopped mode and one presses previous and then
      next track the cd starts. =/

      Well, that was it. I can now not just listen to but maneuver my Beethoven CDs
      on the laptoy. Tomorrow i will try to get DVD + TV-out going... =)


      Cheers,

      // Paul - time for bed
    Your message has been successfully submitted and would be delivered to recipients shortly.