Loading ...
Sorry, an error occurred while loading the content.
 

Re: [linux-dell-laptops] Volume-Keys on C600

Expand Messages
  • Stephen Lau
    Hi Daniel, Ahhh...that would be the problem. :) I, living in my America-centric world, only made changes to the us symbols. You will want to diff MY us
    Message 1 of 10 , Dec 2, 2001
      Hi Daniel,
      Ahhh...that would be the problem. :) I, living in my
      America-centric world, only made changes to the 'us' symbols. You will
      want to diff MY 'us' file versus the XFree default 'us' symbols and see
      the differences - and then copy these into /etc/X11/xkb/symbols/de

      cheers,
      steve


      On Sun, Dec 02, 2001 at 06:53:19PM +0100, Daniel von Devivere wrote:
      > Hmm...
      > I've only copied the us to /etc/X11/xkb/symbols and xfree86 to
      > /etc/X11/xkb/keymap
      > I'm using a german keyboard and in my XF86Config-4 there are the following
      > options enabled:
      > Option "XkbRules" "xfree86"
      > Option "XkbModel" "pc105"
      > Option "XkbLayout" "de"
      >
      > What do I need to change?
      >
      > Daniel
      >
      >
      >
      >
      >
      > --------------------------------------------------------------
      > Please post your X config files in the group links or database
      > FAQ: http://www.whacked.net/ldl-faq
      >
      > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
      >

      --
      stephen lau :: [slau@...] :: www.whacked.net :: ucsd/cse grad student
      gpg key id: 0x09E5CD21 via keyservers, or on my website
    • Stephen Lau
      Send me your symbols and keycodes files and I ll take a look... (send me your XF86Config-4 too while you re at it) ... -- stephen lau :: [slau@ucsd.edu] ::
      Message 2 of 10 , Dec 3, 2001
        Send me your symbols and keycodes files and I'll take a look... (send me
        your XF86Config-4 too while you're at it)

        On Mon, Dec 03, 2001 at 08:30:06PM +0100, Daniel von Devivere wrote:
        > hmmm...
        > I can't get it to work:
        > I've copied this to my "nodeadkys" section in my /etc/X11/xkb/symbols/de:
        >
        > key <I01> { [F13] };
        > key <I02> { [F14] };
        > key <I03> { [F15] };
        > key <I04> { [F16] };
        >
        > changed my XF86Config-4 to
        > Option "XbkModel" "nodeadkeys"
        >
        > restarted the X-Server and.... nothing hapended... xev still says "noSymbol"
        > if I press the "i" button (keycode 129) and says nothing if I press
        > Fn+Volum-Up or -Down.
        > I'm getting frustrated here... please help...
        >
        > Thank you,
        >
        > Daniel
        >
        >
        >
        >
        > --------------------------------------------------------------
        > Please post your X config files in the group links or database
        > FAQ: http://www.whacked.net/ldl-faq
        >
        > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
        >

        --
        stephen lau :: [slau@...] :: www.whacked.net :: ucsd/cse grad student
        gpg key id: 0x09E5CD21 via keyservers, or on my website
      • Daniel von Devivere
        hmmm... I can t get it to work: I ve copied this to my nodeadkys section in my /etc/X11/xkb/symbols/de: key { [F13] }; key { [F14] }; key {
        Message 3 of 10 , Dec 3, 2001
          hmmm...
          I can't get it to work:
          I've copied this to my "nodeadkys" section in my /etc/X11/xkb/symbols/de:

          key <I01> { [F13] };
          key <I02> { [F14] };
          key <I03> { [F15] };
          key <I04> { [F16] };

          changed my XF86Config-4 to
          Option "XbkModel" "nodeadkeys"

          restarted the X-Server and.... nothing hapended... xev still says "noSymbol"
          if I press the "i" button (keycode 129) and says nothing if I press
          Fn+Volum-Up or -Down.
          I'm getting frustrated here... please help...

          Thank you,

          Daniel
        • Ryurick M. Hristev
          ... I don t know if this is the best idea. I suggest you modify/create an /etc/X11/Xmodmap for your keyboard. The relevant section would be something like:
          Message 4 of 10 , Dec 3, 2001
            On Mon, 3 Dec 2001, Daniel von Devivere wrote:

            > hmmm...
            > I can't get it to work:
            > I've copied this to my "nodeadkys" section in my /etc/X11/xkb/symbols/de:
            >
            > key <I01> { [F13] };
            > key <I02> { [F14] };
            > key <I03> { [F15] };
            > key <I04> { [F16] };
            >
            > changed my XF86Config-4 to
            > Option "XbkModel" "nodeadkeys"
            >

            I don't know if this is the best idea.

            I suggest you modify/create an /etc/X11/Xmodmap for your keyboard.
            The relevant section would be something like:
            keycode 0x81 = F13
            keycode 0x82 = F14
            keycode 0x83 = F15
            keycode 0x84 = F16
            (for my english keyboard on a I8K)

            You could use the xkeycaps utility to generate it if you want.

            Cheers,
            --
            Ryurick M. Hristev mailto:r.hristev@...
            Computer Systems Manager
            University of Canterbury, Physics & Astronomy Dept., New Zealand
          • Daniel von Devivere
            Hi, as requested, here are my config-files - it would be so cool if I could get those keys working... Regards, Daniel # XF86Config-4 (XFree86 server
            Message 5 of 10 , Dec 4, 2001
              Hi,

              as requested, here are my config-files - it would be so cool if I could get
              those keys working...

              Regards,

              Daniel
            Your message has been successfully submitted and would be delivered to recipients shortly.