Loading ...
Sorry, an error occurred while loading the content.
 

Please help me with Grub..cant load XP

Expand Messages
  • kiran_balsa@hotmail.com
    Hi everyone I installed redhat 7.2 this afternoon and installed grub into my mbr. I thought it would rechoginize my ntfs partation of xp. To my suprise, when
    Message 1 of 9 , Dec 2, 2001
      Hi everyone

      I installed redhat 7.2 this afternoon and installed grub into my
      mbr. I thought it would rechoginize my ntfs partation of xp. To my
      suprise, when i booted my computer, the only option grub gave me was
      to boot into linux. I have tried to look up how to add my xp
      partation for booting and all i could come up with is the following.
      I found some information on computing.net that said to add the
      following to my /boot/grub/menu.lst.

      title = XP
      chainloader = (hd0,0)+1

      I did that and when i selected the xp option, the only thing that
      would happen is that the computer would display the first startup
      graphics. The ones displaying the software licenses screen and
      service tag and express service code screen. The computer then
      reboots back to grub. If anyone can help me out, I would appreciate
      it. I really need to get back into windows. Thanks!
    • Stephen Lau
      read the faq... i address this in it. cheers, steve ... -- stephen lau :: [slau@ucsd.edu] :: www.whacked.net :: ucsd/cse grad student gpg key id: 0x09E5CD21
      Message 2 of 9 , Dec 2, 2001
        read the faq... i address this in it.

        cheers,
        steve

        On Sun, Dec 02, 2001 at 08:10:02AM -0000, kiran_balsa@... wrote:
        > Hi everyone
        >
        > I installed redhat 7.2 this afternoon and installed grub into my
        > mbr. I thought it would rechoginize my ntfs partation of xp. To my
        > suprise, when i booted my computer, the only option grub gave me was
        > to boot into linux. I have tried to look up how to add my xp
        > partation for booting and all i could come up with is the following.
        > I found some information on computing.net that said to add the
        > following to my /boot/grub/menu.lst.
        >
        > title = XP
        > chainloader = (hd0,0)+1
        >
        > I did that and when i selected the xp option, the only thing that
        > would happen is that the computer would display the first startup
        > graphics. The ones displaying the software licenses screen and
        > service tag and express service code screen. The computer then
        > reboots back to grub. If anyone can help me out, I would appreciate
        > it. I really need to get back into windows. Thanks!
        >
        >
        >
        >
        > --------------------------------------------------------------
        > Please post your X config files in the group links or database
        > FAQ: http://www.whacked.net/ldl-faq
        >
        > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
        >

        --
        stephen lau :: [slau@...] :: www.whacked.net :: ucsd/cse grad student
        gpg key id: 0x09E5CD21 via keyservers, or on my website
      • stuart@bh90210.net
        Mr. Balsa: I have not yet read the FAQ in a while, but perhaps this subject has been added, I do not know. What I do know is that I use grub to boot XP, and it
        Message 3 of 9 , Dec 2, 2001
          Mr. Balsa:

          I have not yet read the FAQ in a while, but perhaps this subject has
          been added, I do not know. What I do know is that I use grub to boot
          XP, and it works fine. How you ask?


          Predicated upon XP being the FIRST OS on the harddrive of the
          computer, the following works:

          title win-xp
          root (hd0,0)
          makeactive
          chainloader +1


          --- In linux-dell-laptops@y..., kiran_balsa@h... wrote:
          > Hi everyone
          >
          > I installed redhat 7.2 this afternoon and installed grub into my
          > mbr. I thought it would rechoginize my ntfs partation of xp. To my
          > suprise, when i booted my computer, the only option grub gave me was
          > to boot into linux. I have tried to look up how to add my xp
          > partation for booting and all i could come up with is the
          following.
          > I found some information on computing.net that said to add the
          > following to my /boot/grub/menu.lst.
          >
          > title = XP
          > chainloader = (hd0,0)+1
          >
          > I did that and when i selected the xp option, the only thing that
          > would happen is that the computer would display the first startup
          > graphics. The ones displaying the software licenses screen and
          > service tag and express service code screen. The computer then
          > reboots back to grub. If anyone can help me out, I would appreciate
          > it. I really need to get back into windows. Thanks!
        • kiran_balsa@hotmail.com
          ... Thank You Sir! That did the trick. Kiran
          Message 4 of 9 , Dec 2, 2001
            --- In linux-dell-laptops@y..., stuart@b... wrote:
            > Mr. Balsa:
            >
            > I have not yet read the FAQ in a while, but perhaps this subject has
            > been added, I do not know. What I do know is that I use grub to boot
            > XP, and it works fine. How you ask?
            >
            >
            > Predicated upon XP being the FIRST OS on the harddrive of the
            > computer, the following works:
            >
            > title win-xp
            > root (hd0,0)
            > makeactive
            > chainloader +1
            >


            Thank You Sir! That did the trick.

            Kiran
          • zdimcovic
            Hi Kiran, Glad to see that your problem has been solved ... still, for your information: this is all explained, along with the exact file format (and well
            Message 5 of 9 , Jan 2, 2002
              Hi Kiran,

              Glad to see that your problem has been solved ... still,
              for your information: this is all explained, along with the
              exact file format (and well explained) in the info-manual.
              You can type 'info grub' at the command prompt (for example)
              and search through it. (To see how to use 'info' -- in case
              you haven't s far -- maybe the easiest way is to simply start
              it -- just 'info' -- and look around, you'll find the basic
              commands right away. It is a very good tool.)

              Zlatko

              PS.
              Sorry if I am telling you something you already know ... I
              assumed you haven't had a chance to use it, since I had a
              related problem and found the mentioned information there
              (along with *much* more info).


              --- In linux-dell-laptops@y..., kiran_balsa@h... wrote:
              > --- In linux-dell-laptops@y..., stuart@b... wrote:
              > > Mr. Balsa:
              > >
              > > I have not yet read the FAQ in a while, but perhaps this subject
              has
              > > been added, I do not know. What I do know is that I use grub to
              boot
              > > XP, and it works fine. How you ask?
              > >
              > >
              > > Predicated upon XP being the FIRST OS on the harddrive of the
              > > computer, the following works:
              > >
              > > title win-xp
              > > root (hd0,0)
              > > makeactive
              > > chainloader +1
              > >
              >
              >
              > Thank You Sir! That did the trick.
              >
              > Kiran
            • antispamissues
              Hello Kiran: sorri to bug u. I also installed 7.3 and am getting the error u got with ur install. i alread have the additional info for xp added into my grub
              Message 6 of 9 , May 24 7:54 PM
                Hello Kiran:
                sorri to bug u. I also installed 7.3 and am getting the error u got
                with ur install. i alread have the additional info for xp added into
                my grub file but i am sill getting the license screen. can u offer
                some advise?
                thxs
                --- In linux-dell-laptops@y..., kiran_balsa@h... wrote:
                Hi everyone
                >
                > I installed redhat 7.2 this afternoon and installed grub into my
                > mbr. I thought it would rechoginize my ntfs partation of xp. To
                my
                > suprise, when i booted my computer, the only option grub gave me
                was
                > to boot into linux. I have tried to look up how to add my xp
                > partation for booting and all i could come up with is the
                following.
                > I found some information on computing.net that said to add the
                > following to my /boot/grub/menu.lst.
                >
                > title = XP
                > chainloader = (hd0,0)+1
                >
                > I did that and when i selected the xp option, the only thing that
                > would happen is that the computer would display the first startup
                > graphics. The ones displaying the software licenses screen and
                > service tag and express service code screen. The computer then
                > reboots back to grub. If anyone can help me out, I would
                appreciate
                > it. I really need to get back into windows. Thanks!
              • Paul
                If you re getting the license screen, you must be trying to boot the utility partition. Try the next partition.
                Message 7 of 9 , May 25 12:57 AM
                  If you're getting the license screen, you must be trying to boot the
                  utility partition. Try the next partition.


                  antispamissues wrote:

                  >Hello Kiran:
                  >sorri to bug u. I also installed 7.3 and am getting the error u got
                  >with ur install. i alread have the additional info for xp added into
                  >my grub file but i am sill getting the license screen. can u offer
                  >some advise?
                  >thxs
                  >--- In linux-dell-laptops@y..., kiran_balsa@h... wrote:
                  > Hi everyone
                  >
                  >>
                  >>I installed redhat 7.2 this afternoon and installed grub into my
                  >>mbr. I thought it would rechoginize my ntfs partation of xp. To
                  >>
                  >my
                  >
                  >>suprise, when i booted my computer, the only option grub gave me
                  >>
                  >was
                  >
                  >>to boot into linux. I have tried to look up how to add my xp
                  >>partation for booting and all i could come up with is the
                  >>
                  >following.
                  >
                  >>I found some information on computing.net that said to add the
                  >>following to my /boot/grub/menu.lst.
                  >>
                  >>title = XP
                  >>chainloader = (hd0,0)+1
                  >>
                  >>I did that and when i selected the xp option, the only thing that
                  >>would happen is that the computer would display the first startup
                  >>graphics. The ones displaying the software licenses screen and
                  >>service tag and express service code screen. The computer then
                  >>reboots back to grub. If anyone can help me out, I would
                  >>
                  >appreciate
                  >
                  >>it. I really need to get back into windows. Thanks!
                  >>
                  >
                  >
                  >
                  >--------------------------------------------------------------
                  >Please post your X config files in the group links or database
                  >To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                  >FAQ: http://www.whacked.net/ldl/faq
                  >
                  >Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                  >
                  >
                  >
                  >
                  >
                • antispamissues
                  It works!!!!!!!!!!!!!!!!!! SIlli me.. thxs :) ... the ... got ... into ... offer ... my ... To ... that ... startup ... http://docs.yahoo.com/info/terms/
                  Message 8 of 9 , May 25 3:31 AM
                    It works!!!!!!!!!!!!!!!!!! SIlli me.. thxs :)


                    --- In linux-dell-laptops@y..., Paul <paul@d...> wrote:
                    > If you're getting the license screen, you must be trying to boot
                    the
                    > utility partition. Try the next partition.
                    >
                    >
                    > antispamissues wrote:
                    >
                    > >Hello Kiran:
                    > >sorri to bug u. I also installed 7.3 and am getting the error u
                    got
                    > >with ur install. i alread have the additional info for xp added
                    into
                    > >my grub file but i am sill getting the license screen. can u
                    offer
                    > >some advise?
                    > >thxs
                    > >--- In linux-dell-laptops@y..., kiran_balsa@h... wrote:
                    > > Hi everyone
                    > >
                    > >>
                    > >>I installed redhat 7.2 this afternoon and installed grub into
                    my
                    > >>mbr. I thought it would rechoginize my ntfs partation of xp.
                    To
                    > >>
                    > >my
                    > >
                    > >>suprise, when i booted my computer, the only option grub gave me
                    > >>
                    > >was
                    > >
                    > >>to boot into linux. I have tried to look up how to add my xp
                    > >>partation for booting and all i could come up with is the
                    > >>
                    > >following.
                    > >
                    > >>I found some information on computing.net that said to add the
                    > >>following to my /boot/grub/menu.lst.
                    > >>
                    > >>title = XP
                    > >>chainloader = (hd0,0)+1
                    > >>
                    > >>I did that and when i selected the xp option, the only thing
                    that
                    > >>would happen is that the computer would display the first
                    startup
                    > >>graphics. The ones displaying the software licenses screen and
                    > >>service tag and express service code screen. The computer then
                    > >>reboots back to grub. If anyone can help me out, I would
                    > >>
                    > >appreciate
                    > >
                    > >>it. I really need to get back into windows. Thanks!
                    > >>
                    > >
                    > >
                    > >
                    > >--------------------------------------------------------------
                    > >Please post your X config files in the group links or database
                    > >To unsubscribe, email: linux-dell-laptops-unsubscribe@y...
                    > >FAQ: http://www.whacked.net/ldl/faq
                    > >
                    > >Your use of Yahoo! Groups is subject to
                    http://docs.yahoo.com/info/terms/
                    > >
                    > >
                    > >
                    > >
                    > >
                  • Paul
                    Here s my config: title Windows XP rootnoverify (hd0,1) chainloader +1 Make sure you are actually pointing to the XP partition, not the utility, s2d, or any
                    Message 9 of 9 , May 27 12:20 PM
                      Here's my config:

                      title Windows XP
                      rootnoverify (hd0,1)
                      chainloader +1

                      Make sure you are actually pointing to the XP partition, not the
                      utility, s2d, or any other partition. fdisk -l (as root) will show
                      you the partition table.


                      antispamissues wrote:
                      >
                      > Hello Kiran:
                      > sorri to bug u. I also installed 7.3 and am getting the error u got
                      > with ur install. i alread have the additional info for xp added into
                      > my grub file but i am sill getting the license screen. can u offer
                      > some advise?
                    Your message has been successfully submitted and would be delivered to recipients shortly.