Loading ...
Sorry, an error occurred while loading the content.

Mount HD in modular bay?

Expand Messages
  • markverschuren@netscape.net
    I ve got this problem mounting a Linux partition on an 18Gb HD in the modular bay of my CPi XT. I ve looked in lots of other places for info, and hope you can
    Message 1 of 1 , Apr 14, 2000
    • 0 Attachment
      I've got this problem mounting a Linux partition on an 18Gb HD in the
      modular bay of my CPi XT. I've looked in lots of other places for
      info, and hope you can help me.

      During automount at start-up as well as if I try manually, mount says:
      QUOTE
      VFS: Can't find an ext2 filesystem on dev ide1(22,3).
      mount: wrong fs type, bad option, bad superblock on /dev/hdc3,
      or too many mounted file systems
      UNQUOTE

      Created this primary hdc3 partition with fdisk (/hda part not shown):
      # fdisk -l
      Disk /dev/hdc: 255 heads, 63 sectors, 2205 cylinders
      Units = cylinders of 16065 * 512 bytes

      Device Boot Start End Blocks Id System
      /dev/hdc1 1 1020 8193118+ b Win95 FAT32
      /dev/hdc3 1021 2190 9398025 83 Linux

      My entire fstab, with the hdc3 line that somehow doesn't work:
      # cat /etc/fstab
      /dev/hda6 / ext2 defaults 1 1
      /dev/hda1 /win/c vfat umask=000 0 0
      /dev/hda5 /win/d vfat umask=000 0 0
      /dev/hda7 swap swap defaults 0 0
      /dev/hda8 swap swap defaults 0 0
      /dev/hdc1 /win/e vfat umask=000 0 0
      /dev/hdc3 /mnt/bay ext2 noauto 0 0
      /dev/fd0 /mnt/floppy ext2 noauto 0 0
      /dev/cdrom /mnt/cdrom iso9660 noauto,ro 0 0
      none /proc proc defaults 0 0
      none /dev/pts devpts gid=5,mode=620 0 0

      What's the fix?
      Thanks,
      Mark
    Your message has been successfully submitted and would be delivered to recipients shortly.