Loading ...
Sorry, an error occurred while loading the content.

Quake 3 demo

Expand Messages
  • tim2@bavister.org
    I have recently upgraded from RH7.0 - RH7.1. I was hoping that I could now run the Quake 3 demo but no luck; the menu screen come up corrupted so I assume it
    Message 1 of 1 , Jun 28 1:03 AM
    • 0 Attachment
      I have recently upgraded from RH7.0 -> RH7.1.

      I was hoping that I could now run the Quake 3 demo but no luck; the
      menu screen come up corrupted so I assume it is a video problem.

      Hardware is a Inspiron 8000 with the 32Mb ATI Rage Mobility card.

      I did try installing the ATI-4.0.2.i386.tar.gz files but nothing
      seems to have changed. Have searched the web for further instructions
      but apart from issuing 'modprobe agpgart' and 'modprobe r128' (still
      no change) and editing my XF86Config-4 file to have:

      Section "Module"
      Load "type1"
      Load "speedo"
      Load "extmod"
      Load "freetype"
      Load "pex5"
      Load "record"
      Load "glx"
      Load "dri"
      EndSection

      Section "DRI"
      Mode 0666
      EndSection

      I am wondering if all I need is an extra modeline for the Quake
      screen resolution. But I don't think I have hw accelaration running
      yet as the OpenGL screensavers still crawl.

      I have some additional questions:

      1. Whats the difference between the XF86Config & XF86Config-4 files?
      Are they both used?
      2. Is it worth upgrading to XFree86 4.1?
      3. I have read people reporting the number of FPS they get before
      and after getting hardware accelaration from 'gears'. I assume
      this is an OpenGL screensaver type app; I found 2 versions though
      one via xscreensaver-demo & one through the Gnome screensaver
      config utility. But how do I get the FPS info?

      Now I am at a bit of a loss. Please help - I need to start fragging...
    Your message has been successfully submitted and would be delivered to recipients shortly.