Loading ...
Sorry, an error occurred while loading the content.

[linux-dell-laptops] CDROM

Expand Messages
  • anguyen@ee.gatech.edu
    My CDROM doesn t seem to work. I ve mounted it but still get the same error messages like: Could not read file:/auto/cdrom File does not exist or access
    Message 1 of 12 , Aug 12, 1999
    • 0 Attachment
      My CDROM doesn't seem to work. I've mounted it but still get the same
      error messages like: Could not read
      file:/auto/cdrom
      File does not exist or access denied.

      I've checked /dev and /etc.
      In /dev:

      lrwxrwxrwx 1 root root 3 Aug 1 22:55 cdrom -> hdc
      brw-r--r-- 1 root operator 22, 3 Aug 1 22:55 hdc

      In /etc/fstab:

      /dev/hda3 / ext2 defaults 1 1
      /dev/hda2 swap swap defaults 0 0
      /proc /proc proc defaults 0 0
      /dev/fd0 /mnt/floppy msdos defaults,user,noauto 0 0
      /dev/hdc /mnt/cdrom iso9660 ro,user,noauto 0 0

      My notebook is Dell Lattitude CPi A366xt. The cdrom is in one of the
      modular bay. It's a Samsung CDROM.

      Any suggestion is appreciated.

      Sincerely,
      Anh Nguyen
    • Steve Haslam
      ... These aren t entirely consistent- where are you mounting the cdrom onto? Are you getting any kernel errors, or a VFS: detected media change message? The
      Message 2 of 12 , Aug 12, 1999
      • 0 Attachment
        On Thu, Aug 12, 1999 at 08:59:11AM -0700, anguyen@... wrote:
        > My CDROM doesn't seem to work. I've mounted it but still get the same
        > error messages like: Could not read
        > file:/auto/cdrom
        > File does not exist or access denied.
        >
        > In /etc/fstab:
        >
        > /dev/hdc /mnt/cdrom iso9660 ro,user,noauto 0 0

        These aren't entirely consistent- where are you mounting the cdrom
        onto? Are you getting any kernel errors, or a "VFS: detected media
        change" message?

        The flow ought to be

        $ mount /mnt/cdrom
        $ ls -l /mnt/cdrom

        /auto/cdrom could be for an automounting setup...

        SRH
        --
        Steve Haslam, Production Engineer, Excite UK shaslam@...
      • Anh Van Nguyen
        I think the /auto/cdrom is the auto mounting by KDE. The result when I tried mount /mnt/cdrom is: mount: the kernel does not recognize /dev/hdc as a block
        Message 3 of 12 , Aug 13, 1999
        • 0 Attachment
          I think the /auto/cdrom is the auto mounting by KDE.
          The result when I tried 'mount /mnt/cdrom' is:

          mount: the kernel does not recognize /dev/hdc as a block device
          (maybe `insmod driver'?)

          anh

          Steve Haslam wrote:

          > On Thu, Aug 12, 1999 at 08:59:11AM -0700, anguyen@... wrote:
          > > My CDROM doesn't seem to work. I've mounted it but still get the same
          > > error messages like: Could not read
          > > file:/auto/cdrom
          > > File does not exist or access denied.
          > >
          > > In /etc/fstab:
          > >
          > > /dev/hdc /mnt/cdrom iso9660 ro,user,noauto 0 0
          >
          > These aren't entirely consistent- where are you mounting the cdrom
          > onto? Are you getting any kernel errors, or a "VFS: detected media
          > change" message?
          >
          > The flow ought to be
          >
          > $ mount /mnt/cdrom
          > $ ls -l /mnt/cdrom
          >
          > /auto/cdrom could be for an automounting setup...
          >
          > SRH
          > --
          > Steve Haslam, Production Engineer, Excite UK shaslam@...
          >
          > ------------------------------------------------------------------------
          > Click here for 4 FREE TRIAL ISSUES of Sports Illustrated! If you're
          > satisfied, your subscription will continue at the guaranteed lowest rate
          > of $.75 an issue for 52 issues! http://clickhere.egroups.com/click/678
          >
          > eGroups.com home: http://www.egroups.com/group/linux-dell-laptops
          > http://www.egroups.com - Simplifying group communications
        • Steve Haslam
          ... Hm, do you get something like this at bootup? hda: FUJITSU MHE2064AT, ATA DISK drive hdc: SAMSUNG CD-ROM SCR-2438, ATAPI CDROM drive ide0 at
          Message 4 of 12 , Aug 13, 1999
          • 0 Attachment
            On Fri, Aug 13, 1999 at 09:23:56AM -0400, Anh Van Nguyen wrote:
            > Steve Haslam wrote:
            > > The flow ought to be
            > >
            > > $ mount /mnt/cdrom
            > > $ ls -l /mnt/cdrom
            > >
            > > /auto/cdrom could be for an automounting setup...

            > I think the /auto/cdrom is the auto mounting by KDE.
            > The result when I tried 'mount /mnt/cdrom' is:
            >
            > mount: the kernel does not recognize /dev/hdc as a block device
            > (maybe `insmod driver'?)

            Hm, do you get something like this at bootup?

            hda: FUJITSU MHE2064AT, ATA DISK drive
            hdc: SAMSUNG CD-ROM SCR-2438, ATAPI CDROM drive
            ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
            ide1 at 0x170-0x177,0x376 on irq 15

            (Use 'dmesg' to get the bootup messages...)

            SRH
            --
            Steve Haslam, Production Engineer, Excite UK shaslam@...
          • Anh Van Nguyen
            Steve, No, I don t see my cdrom in the bootup. I guess my linux doesn t know it exist yet. How do I do this? Lisa? ... PIIX4: IDE controller on PCI bus 00
            Message 5 of 12 , Aug 13, 1999
            • 0 Attachment
              Steve,

              No, I don't see my cdrom in the bootup. I guess my linux doesn't know it
              exist yet. How do I do this? Lisa?
              The following is part of what I saw at bootup:
              --------------------
              PIIX4: IDE controller on PCI bus 00 dev 39
              PIIX4: not 100% native mode: will probe irqs later
              ide0: BM-DMA at 0x0860-0x0867, BIOS settings: hda:DMA, hdb:pio
              ide1: BM-DMA at 0x0868-0x086f, BIOS settings: hdc:pio, hdd:pio
              hda: IBM-DADA-26480, ATA DISK drive
              ide2: ports already in use, skipping probe
              ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
              hda: IBM-DADA-26480, 6194MB w/460kB Cache, CHS=789/255/63, (U)DMA
              Floppy drive(s): fd0 is 1.44M
              FDC 0 is a post-1991 82077
              md driver 0.36.6 MAX_MD_DEV=4, MAX_REAL=8
              Partition check:
              hda: hda1 hda2 hda3
              -----------------

              Anh

              Steve Haslam wrote:

              > On Fri, Aug 13, 1999 at 09:23:56AM -0400, Anh Van Nguyen wrote:
              > > Steve Haslam wrote:
              > > > The flow ought to be
              > > >
              > > > $ mount /mnt/cdrom
              > > > $ ls -l /mnt/cdrom
              > > >
              > > > /auto/cdrom could be for an automounting setup...
              >
              > > I think the /auto/cdrom is the auto mounting by KDE.
              > > The result when I tried 'mount /mnt/cdrom' is:
              > >
              > > mount: the kernel does not recognize /dev/hdc as a block device
              > > (maybe `insmod driver'?)
              >
              > Hm, do you get something like this at bootup?
              >
              > hda: FUJITSU MHE2064AT, ATA DISK drive
              > hdc: SAMSUNG CD-ROM SCR-2438, ATAPI CDROM drive
              > ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
              > ide1 at 0x170-0x177,0x376 on irq 15
              >
              > (Use 'dmesg' to get the bootup messages...)
              >
              > SRH
              > --
              > Steve Haslam, Production Engineer, Excite UK shaslam@...
              >
              > ------------------------------------------------------------------------
              > GET WHAT YOU DESERVE! A NextCard Platinum VISA: DOUBLE Rewards points,
              > NO annual fee & rates as low as 9.9% FIXED APR. Apply online today!
              > http://clickhere.egroups.com/click/606
              >
              > eGroups.com home: http://www.egroups.com/group/linux-dell-laptops
              > http://www.egroups.com - Simplifying group communications
            • anguyen@ee.gatech.edu
              Hello, I ve reinstalled Caldera Linux on my laptop. The CDROM worked a few times after instatllation. At those times, when there is a CD in the drive, Linux
              Message 6 of 12 , Aug 17, 1999
              • 0 Attachment
                Hello,

                I've reinstalled Caldera Linux on my laptop. The CDROM worked a few
                times after instatllation. At those times, when there is a CD in the
                drive, Linux recognizes it at bootup in hdc (similar to below). But
                now it doesn't see the drive at all, even with a CD in the drive.

                How can I make Linux recognizes the drive at bootup?

                Sincerely,
                Anh


                anguye-@... wrote:
                original article:http://www.egroups.com/group/linux-dell-laptops/?start
                =53
                > Steve,
                >
                > No, I don't see my cdrom in the bootup. I guess my linux doesn't
                know it
                > exist yet. How do I do this? Lisa?
                > The following is part of what I saw at bootup:
                > --------------------
                > PIIX4: IDE controller on PCI bus 00 dev 39
                > PIIX4: not 100% native mode: will probe irqs later
                > ide0: BM-DMA at 0x0860-0x0867, BIOS settings: hda:DMA, hdb:pio
                > ide1: BM-DMA at 0x0868-0x086f, BIOS settings: hdc:pio, hdd:pio
                > hda: IBM-DADA-26480, ATA DISK drive
                > ide2: ports already in use, skipping probe
                > ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
                > hda: IBM-DADA-26480, 6194MB w/460kB Cache, CHS=789/255/63, (U)DMA
                > Floppy drive(s): fd0 is 1.44M
                > FDC 0 is a post-1991 82077
                > md driver 0.36.6 MAX_MD_DEV=4, MAX_REAL=8
                > Partition check:
                > hda: hda1 hda2 hda3
                > -----------------
                >
                > Anh
                >
                > Steve Haslam wrote:
                >
                > > On Fri, Aug 13, 1999 at 09:23:56AM -0400, Anh Van Nguyen wrote:
                > > > Steve Haslam wrote:
                > > > > The flow ought to be
                > > > >
                > > > > $ mount /mnt/cdrom
                > > > > $ ls -l /mnt/cdrom
                > > > >
                > > > > /auto/cdrom could be for an automounting setup...
                > >
                > > > I think the /auto/cdrom is the auto mounting by KDE.
                > > > The result when I tried 'mount /mnt/cdrom' is:
                > > >
                > > > mount: the kernel does not recognize /dev/hdc as a block device
                > > > (maybe `insmod driver'?)
                > >
                > > Hm, do you get something like this at bootup?
                > >
                > > hda: FUJITSU MHE2064AT, ATA DISK drive
                > > hdc: SAMSUNG CD-ROM SCR-2438, ATAPI CDROM drive
                > > ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
                > > ide1 at 0x170-0x177,0x376 on irq 15
                > >
                > > (Use 'dmesg' to get the bootup messages...)
                > >
                > > SRH
                > > --
                > > Steve Haslam, Production Engineer, Excite UK
                shaslam@...
                > >
              • Anh Van Nguyen
                Well, it is about my DELL lattitude Cpi A366XT which i am trying to get Linux to work on.
                Message 7 of 12 , Aug 17, 1999
                • 0 Attachment
                  Well, it is about my DELL lattitude Cpi A366XT which i am trying to get
                  Linux to work on.


                  neil@... wrote:

                  > On Tue, 17 Aug 1999 anguyen@... wrote:
                  >
                  > > How can I make Linux recognizes the drive at bootup?
                  >
                  > Can you ask these kinds of questions on comp.os.linux.misc please. You'll
                  > probably find a lot of the answers you need from www.deja.com.
                  >
                  > This mailing list is about problems relating directly to DELL hardware &
                  > linux, not a support list for general linux questions.
                  >
                  > thanks
                  >
                  > Neil (List censor)
                  >
                  > ------------------------------------------------------------------------
                  > ebates.com. Earn up to 25% cash back for shopping online at 75 stores
                  > like Borders, CDNow and Beyond.com. Refer a friend and earn even more!
                  > http://clickhere.egroups.com/click/690
                  >
                  > eGroups.com home: http://www.egroups.com/group/linux-dell-laptops
                  > http://www.egroups.com - Simplifying group communications
                • neil@thump.org
                  ... Can you ask these kinds of questions on comp.os.linux.misc please. You ll probably find a lot of the answers you need from www.deja.com. This mailing list
                  Message 8 of 12 , Aug 17, 1999
                  • 0 Attachment
                    On Tue, 17 Aug 1999 anguyen@... wrote:

                    > How can I make Linux recognizes the drive at bootup?

                    Can you ask these kinds of questions on comp.os.linux.misc please. You'll
                    probably find a lot of the answers you need from www.deja.com.

                    This mailing list is about problems relating directly to DELL hardware &
                    linux, not a support list for general linux questions.

                    thanks

                    Neil (List censor)
                  • neil@thump.org
                    ... It seems to me you are asking how to mount your CD rom drive ? That s in the CD ROM Howto which I presume you ve studied. Try deja news then post a query
                    Message 9 of 12 , Aug 17, 1999
                    • 0 Attachment
                      On Tue, 17 Aug 1999, Anh Van Nguyen wrote:

                      > Well, it is about my DELL lattitude Cpi A366XT which i am trying to get
                      > Linux to work on.

                      It seems to me you are asking how to mount your CD rom drive ? That's in
                      the CD ROM Howto which I presume you've studied.

                      Try deja news then post a query to a newsgroup then if that fails come
                      back and ask here.

                      If I'm not mistaken you are asking how to edit /ect/fstab ? Or trying get
                      mount command to work or am I completely wrong ?

                      Neil
                    • Anh Van Nguyen
                      It is not about mounting the device. I see it in /etc/fstab files. I think it may be a hardware problem For example, I just turned my notebook on and it
                      Message 10 of 12 , Aug 17, 1999
                      • 0 Attachment
                        It is not about mounting the device. I see it in /etc/fstab files. I think
                        it may be a hardware problem

                        For example, I just turned my notebook on and it seems to recognize the
                        cdrom. I see in the bootup message dmesg.

                        neil@... wrote:

                        > On Tue, 17 Aug 1999 anguyen@... wrote:
                        >
                        > > How can I make Linux recognizes the drive at bootup?
                        >
                        > Can you ask these kinds of questions on comp.os.linux.misc please. You'll
                        > probably find a lot of the answers you need from www.deja.com.
                        >
                        > This mailing list is about problems relating directly to DELL hardware &
                        > linux, not a support list for general linux questions.
                        >
                        > thanks
                        >
                        > Neil (List censor)
                        >
                        > ------------------------------------------------------------------------
                        > ebates.com. Earn up to 25% cash back for shopping online at 75 stores
                        > like Borders, CDNow and Beyond.com. Refer a friend and earn even more!
                        > http://clickhere.egroups.com/click/690
                        >
                        > eGroups.com home: http://www.egroups.com/group/linux-dell-laptops
                        > http://www.egroups.com - Simplifying group communications
                      • Ed Psycho
                        I am having this exact same problem, on a Dell Latitude CPt. I am running RH 6.1 (Cartman). I did not see a resolution to this issue... anyone else figure this
                        Message 11 of 12 , Mar 13, 2000
                        • 0 Attachment
                          I am having this exact same problem, on a Dell Latitude CPt. I
                          am running RH 6.1 (Cartman). I did not see a resolution to this
                          issue... anyone else figure this out?

                          TIA,

                          ed_psycho


                          anh van nguyen <anguye-@...> wrote:
                          original article:http://www.egroups.com/group/linux-dell-laptops/?start
                          =51
                          > I think the /auto/cdrom is the auto mounting by KDE.
                          > The result when I tried 'mount /mnt/cdrom' is:
                          >
                          > mount: the kernel does not recognize /dev/hdc as a block device
                          > (maybe `insmod driver'?)
                          >
                          > anh
                          >
                          > Steve Haslam wrote:
                          >
                          > > On Thu, Aug 12, 1999 at 08:59:11AM -0700, anguyen@...
                          wrote:
                          > > > My CDROM doesn't seem to work. I've mounted it but still get the
                          same
                          > > > error messages like: Could not read
                          > > > file:/auto/cdrom
                          > > > File does not exist or access denied.
                          > > >
                          > > > In /etc/fstab:
                          > > >
                          > > > /dev/hdc /mnt/cdrom iso9660 ro,user,noauto 0 0
                          > >
                          > > These aren't entirely consistent- where are you mounting the cdrom
                          > > onto? Are you getting any kernel errors, or a "VFS: detected media
                          > > change" message?
                          > >
                          > > The flow ought to be
                          > >
                          > > $ mount /mnt/cdrom
                          > > $ ls -l /mnt/cdrom
                          > >
                          > > /auto/cdrom could be for an automounting setup...
                          > >
                          > > SRH
                          > > --
                          > > Steve Haslam, Production Engineer, Excite UK
                          shaslam@...
                          > >
                        • sm0le@netzero.net
                          The thing with mnt the cd rom is that u type mount dev/cdrom not mnt/cdrom Download NeoPlanet at http://www.neoplanet.com
                          Message 12 of 12 , Mar 13, 2000
                          • 0 Attachment
                            The thing with mnt the cd rom is that u type mount dev/cdrom not mnt/cdrom

                            Download NeoPlanet at http://www.neoplanet.com
                          Your message has been successfully submitted and would be delivered to recipients shortly.