Loading ...
Sorry, an error occurred while loading the content.

Alsa sound with Mandrake 7.2 on i8K

Expand Messages
  • andy_bush@yahoo.com
    After a lot of reading around I ve managed to install Mandrake 7.2 on my Inspiron 8000. I m having problems with the sound set up. I followed the instructions
    Message 1 of 5 , Apr 2, 2001
    • 0 Attachment
      After a lot of reading around I've managed to install Mandrake 7.2 on
      my Inspiron 8000.

      I'm having problems with the sound set up. I followed the instructions
      from: http://orion.chem.vt.edu/i8000/
      ....
      cd alsa-driver-0.5.10; ./configure; make; make install
      cd alsa-lib-0.5.10; ./configure; make; make install
      cd alsa-utils-0.5.10; ./configure; make; make install

      etc.....

      As a newbie I'm following them blindly as I'm not really sure what I'm
      doing. There were some errors as it installed.

      On boot I'm getting an error message:

      Starting Alsasound device.... Can't locate module snd-card-maestro

      Any ideas anyone ?

      Thanks
    • stevejeynes@yahoo.co.uk
      ... on ... instructions ... I m ... Yeah, I was trying to get Alsa 0.5.10 to work on my I8K with Mandrake 7.2, but never managed it. After trawling the web for
      Message 2 of 5 , Apr 4, 2001
      • 0 Attachment
        --- In linux-dell-laptops@y..., andy_bush@y... wrote:
        > After a lot of reading around I've managed to install Mandrake 7.2
        on
        > my Inspiron 8000.
        >
        > I'm having problems with the sound set up. I followed the
        instructions
        > from: http://orion.chem.vt.edu/i8000/
        > ....
        > cd alsa-driver-0.5.10; ./configure; make; make install
        > cd alsa-lib-0.5.10; ./configure; make; make install
        > cd alsa-utils-0.5.10; ./configure; make; make install
        >
        > etc.....
        >
        > As a newbie I'm following them blindly as I'm not really sure what
        I'm
        > doing. There were some errors as it installed.
        >
        > On boot I'm getting an error message:
        >
        > Starting Alsasound device.... Can't locate module snd-card-maestro
        >
        > Any ideas anyone ?
        >
        > Thanks

        Yeah, I was trying to get Alsa 0.5.10 to work on my I8K with Mandrake
        7.2, but never managed it. After trawling the web for some time, came
        across an item that states that Mandrake have patched the kernel they
        use, and subsequently Alsa 0.5.10 would not work. The author
        suggested compiling a new kernel, not a Mandrake one, or waiting for
        Mandrake to produce Alsa rpms to get around the problem.

        If you do get Alsa 0.5.10 working with Mandrake 7.2 then let me know.

        Good Luck
      • andy_bush@yahoo.com
        I found this: http://www.alsa-project.org/archive/alsa-user/msg10597.html ... I tried building drivers 0.5.10a on my 7.2 box and had a compile error on the
        Message 3 of 5 , Apr 4, 2001
        • 0 Attachment
          I found this:

          http://www.alsa-project.org/archive/alsa-user/msg10597.html

          of which the key bit is:
          -----------------
          I tried building drivers 0.5.10a on my 7.2 box and had a compile error
          on the same file with similar error messages. (However, I did not get
          the error messags about PID, etc.)

          I was able to get a clean compile by changing the line 7 of
          include/compat_22.h like:

          #if LINUX_VERSION_CODE < KERNEL_VERSION(2,2,17) /*
          KERNEL_VERSION(2,2,18) */

          I guess the Mandrake kernel was heavily patched and closer to the 2.18
          kernel. A better fix would be to add another check for the Mandrake
          kernel.
          ------------------
          I've tried the suggestion and it allowed me to configure, make and
          make install. All seemed to go as it should but still no sound. I
          found a mixer which displayed the Maestro card and unmuted it and
          turned the volume up but still no sound. I'm not sure where to go
          next. Perhaps some sound system is still running as a result of the
          original installation ?



          --- In linux-dell-laptops@y..., stevejeynes@y... wrote:
          > --- In linux-dell-laptops@y..., andy_bush@y... wrote:
          > > After a lot of reading around I've managed to install Mandrake 7.2
          > on
          > > my Inspiron 8000.
          > >
          > > I'm having problems with the sound set up. I followed the
          > instructions
          > > from: http://orion.chem.vt.edu/i8000/
          > > ....
          > > cd alsa-driver-0.5.10; ./configure; make; make install
          > > cd alsa-lib-0.5.10; ./configure; make; make install
          > > cd alsa-utils-0.5.10; ./configure; make; make install
          > >
          > > etc.....
          > >
          > > As a newbie I'm following them blindly as I'm not really sure what
          > I'm
          > > doing. There were some errors as it installed.
          > >
          > > On boot I'm getting an error message:
          > >
          > > Starting Alsasound device.... Can't locate module snd-card-maestro
          > >
          > > Any ideas anyone ?
          > >
          > > Thanks
          >
          > Yeah, I was trying to get Alsa 0.5.10 to work on my I8K with
          Mandrake
          > 7.2, but never managed it. After trawling the web for some time,
          came
          > across an item that states that Mandrake have patched the kernel
          they
          > use, and subsequently Alsa 0.5.10 would not work. The author
          > suggested compiling a new kernel, not a Mandrake one, or waiting for
          > Mandrake to produce Alsa rpms to get around the problem.
          >
          > If you do get Alsa 0.5.10 working with Mandrake 7.2 then let me
          know.
          >
          > Good Luck
        • sidechannelattack@yahoo.com
          This is pretty unhelpful but I couldn t get sound working on i8k/ LM 7.2 with alsa .5.10a either. Upgrading to kernel 2.4.2 didn t help either, although I did
          Message 4 of 5 , Apr 9, 2001
          • 0 Attachment
            This is pretty unhelpful but I couldn't get sound working on i8k/ LM
            7.2 with alsa .5.10a either. Upgrading to kernel 2.4.2 didn't help
            either, although I did notice an awesome improvement in system speed.
            One of the links from the linux/laptop page is for a guy who put
            slackware on his inspiron 8000. He gives a link for a custom written
            driver that's a kernel patch, not a module IIRC. You may want to give
            that a try.

            --- In linux-dell-laptops@y..., andy_bush@y... wrote:
            > I found this:
            >
            > http://www.alsa-project.org/archive/alsa-user/msg10597.html
            >
            > of which the key bit is:
            > -----------------
            > I tried building drivers 0.5.10a on my 7.2 box and had a compile
            error
            > on the same file with similar error messages. (However, I did not
            get
            > the error messags about PID, etc.)
            >
            > I was able to get a clean compile by changing the line 7 of
            > include/compat_22.h like:
            >
            > #if LINUX_VERSION_CODE < KERNEL_VERSION(2,2,17) /*
            > KERNEL_VERSION(2,2,18) */
            >
            > I guess the Mandrake kernel was heavily patched and closer to the
            2.18
            > kernel. A better fix would be to add another check for the Mandrake
            > kernel.
            > ------------------
            > I've tried the suggestion and it allowed me to configure, make and
            > make install. All seemed to go as it should but still no sound. I
            > found a mixer which displayed the Maestro card and unmuted it and
            > turned the volume up but still no sound. I'm not sure where to go
            > next. Perhaps some sound system is still running as a result of the
            > original installation ?
            >
            >
            >
            > --- In linux-dell-laptops@y..., stevejeynes@y... wrote:
            > > --- In linux-dell-laptops@y..., andy_bush@y... wrote:
            > > > After a lot of reading around I've managed to install Mandrake
            7.2
            > > on
            > > > my Inspiron 8000.
            > > >
            > > > I'm having problems with the sound set up. I followed the
            > > instructions
            > > > from: http://orion.chem.vt.edu/i8000/
            > > > ....
            > > > cd alsa-driver-0.5.10; ./configure; make; make install
            > > > cd alsa-lib-0.5.10; ./configure; make; make install
            > > > cd alsa-utils-0.5.10; ./configure; make; make install
            > > >
            > > > etc.....
            > > >
            > > > As a newbie I'm following them blindly as I'm not really sure
            what
            > > I'm
            > > > doing. There were some errors as it installed.
            > > >
            > > > On boot I'm getting an error message:
            > > >
            > > > Starting Alsasound device.... Can't locate module
            snd-card-maestro
            > > >
            > > > Any ideas anyone ?
            > > >
            > > > Thanks
            > >
            > > Yeah, I was trying to get Alsa 0.5.10 to work on my I8K with
            > Mandrake
            > > 7.2, but never managed it. After trawling the web for some time,
            > came
            > > across an item that states that Mandrake have patched the kernel
            > they
            > > use, and subsequently Alsa 0.5.10 would not work. The author
            > > suggested compiling a new kernel, not a Mandrake one, or waiting
            for
            > > Mandrake to produce Alsa rpms to get around the problem.
            > >
            > > If you do get Alsa 0.5.10 working with Mandrake 7.2 then let me
            > know.
            > >
            > > Good Luck
          • Harish Murthy
            Hi, I happened to get a copy of Caldera OpenLinux 2.4 ( workstation ) at Cebit and installed it last night. The setup went smooth with the installation wizard
            Message 5 of 5 , Apr 10, 2001
            • 0 Attachment
              Hi,

              I happened to get a copy of Caldera OpenLinux 2.4 (
              workstation ) at Cebit and installed it last night.
              The setup went smooth with the installation wizard
              called
              "Lizard" . Its a good one and has a game ( solitaire)
              that you can play when the packages are installed.
              It probed the video card and I cud get 1024x768
              running.
              I was suprised by the quality of the sound, its
              CRYSTAL CLEAR ! All this on the first go.
              For those who want to use linux as a normal desktop,
              and want a hassel free installation of Linux with
              Audio and Video, I wud recommend this distro.

              I cud not check the Network elements though.

              Regards
              Harish




              __________________________________________________
              Do You Yahoo!?
              Get email at your own domain with Yahoo! Mail.
              http://personal.mail.yahoo.com/
            Your message has been successfully submitted and would be delivered to recipients shortly.