Loading ...
Sorry, an error occurred while loading the content.

[linux-dell-laptops] Re: Help with building kernel 2.2.14 Del CPi

Expand Messages
  • Shiwu Gao
    ... Have you tried bzlilo? I can boot with bzImage and bzlilo. It works for my case. However I have problem with module loading. It seems not load the modules.
    Message 1 of 8 , Feb 2, 2000
    • 0 Attachment
      Paul D Gilligan wrote:
      Hello,

      I have a Dell CPi running redhat 6.1 which comes with kernel 2.2.12.

      Now of cause Neomagic sound card not working, and I want more than
      800x600 for the display so I read the laptop info about Dell and they
      talk about using kernel 2.2.14 at least.

      So I have downloaded the kernel, I can compile it BUT:

      I am using LILO and it says that the kernel is too big to use zlilo, I
      have played and got the new kernel to boot, but there are module lists
      missing and other things in the LILO setup so I would like to use zlilo
      with a small enouth kernel. (or should I delete the Windows 98 on the
      other partition and forget LILO?)

      So this must mean that the generic config with the kernel that I
      downloaded(?) has too many enabled functions.

      So the question is has anyonne got the kernel 2.2.14 installed with a
      CPi/LILO and can I have a copy of there kernel config?

      or can someone suggest another way, I would not prefer to path the
      existing kernel.

      or where can I find the RPM for this kernel version? I have looked.

      Paul

      ------------------------------------------------------------------------
      GET A NEXTCARD VISA, in 30 seconds!  Get rates as low as 2.9%
      Intro or 9.9% Fixed APR and no hidden fees.  Apply NOW!
      http://click.egroups.com/1/915/3/_/4243/_/949491826/

      -- Create a poll/survey for your group!
      -- http://www.egroups.com/vote?listname=linux-dell-laptops&m=1

      Have you tried bzlilo? I can boot with bzImage and bzlilo. It works for
      my case.

      However I have problem with module loading. It seems not load the
      modules.

      Shiwu

    • Neil
      ... have you compiled in loadable module support ? Neil
      Message 2 of 8 , Feb 2, 2000
      • 0 Attachment
        On Wed, 02 Feb 2000 12:55:24 +0100, you wrote:

        >However I have problem with module loading. It seems not load the
        >module

        have you compiled in loadable module support ?

        Neil
      • Paul D Gilligan
        Super shiwu, I will have a go when I get home. Yes Neil is having problems with modules. Paul shiwu gao wrote: original
        Message 3 of 8 , Feb 2, 2000
        • 0 Attachment
          Super shiwu,

          I will have a go when I get home.

          Yes Neil is having problems with modules.


          Paul

          shiwu gao <tfys-@...> wrote:
          original article:http://www.egroups.com/group/linux-dell-laptops/?start
          =343
          > Paul D Gilligan wrote:
          >
          > > Hello,
          > >
          > > I have a Dell CPi running redhat 6.1 which comes with kernel 2.2.12.
          > >
          > > Now of cause Neomagic sound card not working, and I want more than
          > > 800x600 for the display so I read the laptop info about Dell and
          they
          > > talk about using kernel 2.2.14 at least.
          > >
          > > So I have downloaded the kernel, I can compile it BUT:
          > >
          > > I am using LILO and it says that the kernel is too big to use
          zlilo, I
          > > have played and got the new kernel to boot, but there are module
          lists
          > > missing and other things in the LILO setup so I would like to use
          zlilo
          > > with a small enouth kernel. (or should I delete the Windows 98 on
          the
          > > other partition and forget LILO?)
          > >
          > > So this must mean that the generic config with the kernel that I
          > > downloaded(?) has too many enabled functions.
          > >
          > > So the question is has anyonne got the kernel 2.2.14 installed with
          a
          > > CPi/LILO and can I have a copy of there kernel config?
          > >
          > > or can someone suggest another way, I would not prefer to path the
          > > existing kernel.
          > >
          > > or where can I find the RPM for this kernel version? I have looked.
          > >
          > > Paul
          > >
        • Paul D Gilligan
          Ok I have tried the 2.2.14 kernel with the sony 2.2.13 patch and no luck. I saw the 2.3.22 sony patch, so down loaded it and the patch scripts runs ok. BUT
          Message 4 of 8 , Feb 2, 2000
          • 0 Attachment
            Ok I have tried the 2.2.14 kernel with the sony 2.2.13 patch and no
            luck.


            I saw the 2.3.22 sony patch, so down loaded it and the patch scripts
            runs ok.

            BUT when I do the make bzlilo it gives an error whereby a struct called
            dev in mn256audio.c does not have the member baseaddress.

            Also in the make xconfig stage the NeoMagic driver can not be found in
            the list of options with the 2.3.22 kernel...?

            Also I am having a real time getting the x-windows running at anything
            other than 800x600.

            Has anyone got a kernel config file for the CPi and a working
            XF86Config?

            Paul


            "paul d gilligan" <pdgilliga-@...> wrote:
            original article:http://www.egroups.com/group/linux-dell-laptops/?start
            =346
            > Super shiwu,
            >
            > I will have a go when I get home.
            >
            > Yes Neil is having problems with modules.
            >
            >
            > Paul
            >
            > shiwu gao <tfys-@...> wrote:
            > original article:http://www.egroups.com/group/linux-dell-laptops/?sta
            rt
            > =343
            > > Paul D Gilligan wrote:
            > >
            > > > Hello,
            > > >
            > > > I have a Dell CPi running redhat 6.1 which comes with kernel
            2.2.12.
            > > >
            > > > Now of cause Neomagic sound card not working, and I want more than
            > > > 800x600 for the display so I read the laptop info about Dell and
            > they
            > > > talk about using kernel 2.2.14 at least.
            > > >
            > > > So I have downloaded the kernel, I can compile it BUT:
            > > >
            > > > I am using LILO and it says that the kernel is too big to use
            > zlilo, I
            > > > have played and got the new kernel to boot, but there are module
            > lists
            > > > missing and other things in the LILO setup so I would like to use
            > zlilo
            > > > with a small enouth kernel. (or should I delete the Windows 98 on
            > the
            > > > other partition and forget LILO?)
            > > >
            > > > So this must mean that the generic config with the kernel that I
            > > > downloaded(?) has too many enabled functions.
            > > >
            > > > So the question is has anyonne got the kernel 2.2.14 installed
            with
            > a
            > > > CPi/LILO and can I have a copy of there kernel config?
            > > >
            > > > or can someone suggest another way, I would not prefer to path the
            > > > existing kernel.
            > > >
            > > > or where can I find the RPM for this kernel version? I have
            looked.
            > > >
            > > > Paul
            > > >
            >
          • Alan Harding
            I also have a Dell CPi (R-Series PII 400) I downloaded the 2.2.14-1.3.0 Kernel RPM from rpmfind.doc.ic.ac.uk and installed it. I also loaded the latest
            Message 5 of 8 , Feb 10, 2000
            • 0 Attachment
              I also have a Dell CPi (R-Series PII 400)

              I downloaded the 2.2.14-1.3.0 Kernel RPM from rpmfind.doc.ic.ac.uk and
              installed it. I also loaded the latest PCMCIA-cs rpm
              (names are kernel-2.2.14-1.3.0.i686.rpm and kernel-pcmcia-cs.2.2.14-1.3
              .0.i386.rpm)

              The Pcmcia rpm renames pcmcia in /etc/sysconfig to pcmcia.rpmsave. I mv
              this file back, rebooted and Hey presto.

              I have to say though that the original problem of the sound not working
              and video resolution (under kde) was resolveable unde 2.2.12. The sound
              required 'insmod nm256' being added to the rc.local file in /etc/rc.d.
              I also have the resolution at 1024x768x16bpp and I can supply the
              XF86Config if you (or anyone emails me direct)

              Good Luck!!!


              shiwu gao <tfys-@...> wrote:
              original article:http://www.egroups.com/group/linux-dell-laptops/?start
              =343
              > Paul D Gilligan wrote:
              >
              > > Hello,
              > >
              > > I have a Dell CPi running redhat 6.1 which comes with kernel 2.2.12.
              > >
              > > Now of cause Neomagic sound card not working, and I want more than
              > > 800x600 for the display so I read the laptop info about Dell and
              they
              > > talk about using kernel 2.2.14 at least.
              > >
              > > So I have downloaded the kernel, I can compile it BUT:
              > >
              > > I am using LILO and it says that the kernel is too big to use
              zlilo, I
              > > have played and got the new kernel to boot, but there are module
              lists
              > > missing and other things in the LILO setup so I would like to use
              zlilo
              > > with a small enouth kernel. (or should I delete the Windows 98 on
              the
              > > other partition and forget LILO?)
              > >
              > > So this must mean that the generic config with the kernel that I
              > > downloaded(?) has too many enabled functions.
              > >
              > > So the question is has anyonne got the kernel 2.2.14 installed with
              a
              > > CPi/LILO and can I have a copy of there kernel config?
              > >
              > > or can someone suggest another way, I would not prefer to path the
              > > existing kernel.
              > >
              > > or where can I find the RPM for this kernel version? I have looked.
              > >
              > > Paul
              > >
            • Neil
              ... Can you mail the config to the List with your laptop model number/type in the subject please. I m hoping we can get as many different configs gathered
              Message 6 of 8 , Feb 11, 2000
              • 0 Attachment
                On Thu, 10 Feb 2000 14:53:08 -0800, you wrote:

                >I have to say though that the original problem of the sound not working
                >and video resolution (under kde) was resolveable unde 2.2.12. The sound
                >required 'insmod nm256' being added to the rc.local file in /etc/rc.d.
                >I also have the resolution at 1024x768x16bpp and I can supply the
                >XF86Config if you (or anyone emails me direct)

                Can you mail the config to the List with your laptop model number/type in the
                subject please. I'm hoping we can get as many different configs gathered
                together as possible.

                Also see the group home page, and perhaps if anyone has time we could add some
                links to the links page. I added in a few.

                The list is a really invaluable source of knowledge for dell laptop owners and
                it makes sense to try and structure our collective knowledge & experience.

                Neil
                (ps - I'm the list owner !)
              • Paul D Gilligan
                Hi again, Well Using Del CPiA, I have not had too much time to play with the sony patch, the Free XF86 stuff and such, I did try and if it did not work
                Message 7 of 8 , Feb 11, 2000
                • 0 Attachment
                  Hi again,

                  Well Using Del CPiA, I have not had too much time to play with the sony
                  patch, the Free XF86 stuff and such, I did try and if it did not work
                  (compile, make,etc) first time then I did not go much further.

                  I have now all running under 2.2.14mdk (Mandrake, sunite.uio.no v7.0)
                  but I did notice that I have to use the correct sndconfig (from
                  Mandrake)otherwise it kept going on about this drive crashes with Dell
                  something 5000 do you want to continue....
                  ... but continuing , nothing happends.

                  So I now have music. video. and discovered kde x-windows. (Although as
                  you know I cheated with the xwindows. using xig.com laptop software.)

                  I think that all these comments were very helpful for the dedicated at
                  kernel 2.2.13 and below. If you move to 2.2.14 all of the fixes here
                  are in the kernel and so no playing around.

                  Also very good of the Oslo uni site to provide RPM's read for the lazy
                  people like me.... no compiling :)


                  Paul






                  neil <nei-@...> wrote:
                  original article:http://www.egroups.com/group/linux-dell-laptops/?start
                  =367
                  > On Thu, 10 Feb 2000 14:53:08 -0800, you wrote:
                  >
                  > >I have to say though that the original problem of the sound not
                  working
                  > >and video resolution (under kde) was resolveable unde 2.2.12. The
                  sound
                  > >required 'insmod nm256' being added to the rc.local file in
                  /etc/rc.d.
                  > >I also have the resolution at 1024x768x16bpp and I can supply the
                  > >XF86Config if you (or anyone emails me direct)
                  >
                  > Can you mail the config to the List with your laptop model
                  number/type in the
                  > subject please. I'm hoping we can get as many different configs
                  gathered
                  > together as possible.
                  >
                  > Also see the group home page, and perhaps if anyone has time we could
                  add some
                  > links to the links page. I added in a few.
                  >
                  > The list is a really invaluable source of knowledge for dell laptop
                  owners and
                  > it makes sense to try and structure our collective knowledge &
                  experience.
                  >
                  > Neil
                  > (ps - I'm the list owner !)
                  >
                  >
                Your message has been successfully submitted and would be delivered to recipients shortly.