Loading ...
Sorry, an error occurred while loading the content.

5000e & APM: system time wrong after suspend+resume

Expand Messages
  • klogv@yahoo.com
    Hi, My 5000e system time becomes incorrect after a suspend and a resume. The OS acts as though no time has passed between the suspend and the resume, even if
    Message 1 of 8 , Mar 4, 2001
    • 0 Attachment
      Hi,

      My 5000e system time becomes incorrect after a suspend and a resume.
      The OS acts as though no time has passed between the suspend and the
      resume, even if hours have in fact passed. (As if the OS doesn't
      bother to reset the software time using the hardware clock when
      resuming.)

      Anyone know what might be causing this, and how to fix it? Any advice
      would be appreciated.

      [Configuration: Inspiron 5000e running RH 7.0 kernel 2.2.17-14, A04
      (Dell) BIOS]

      Thanks.

      Adam
    • Michael P. O'Connor
      ... suspend+resume ... 2.2.17-14, A04 ... there is your problem [Dell BIOS], as soon as I got the tux-top bios on my system that problem also vanished. ... --
      Message 2 of 8 , Mar 5, 2001
      • 0 Attachment
        > Date: Sun, 04 Mar 2001 18:36:30 -0000
        > From: klogv@...
        > Subject: 5000e & APM: system time wrong after
        suspend+resume
        >
        > snip <
        > [Configuration: Inspiron 5000e running RH 7.0 kernel
        2.2.17-14, A04
        > (Dell) BIOS]
        >
        there is your problem [Dell BIOS], as soon as I got
        the tux-top bios on my system that problem also vanished.
        > Thanks.
        >
        > Adam
        >
        >
        >

        --
        Get your free email from www.linuxmail.org


        Powered by Outblaze
      • throop@colorado.edu
        Hi, I found that on my system, the hardware clock and the system clock were not being properly sync d to each other after a resume. It had something to do
        Message 3 of 8 , Mar 5, 2001
        • 0 Attachment
          Hi,

          I found that on my system, the hardware clock and the system clock
          were not being properly sync'd to each other after a resume. It had
          something to do with time zone issues.

          To solve it, I switched everything to UTC rather than local time.
          Change the UTC="no" entry to "yes" in /etc/sysconfig/clock file and
          see if that does it for you. I believe that you also need to set the
          clock in the BIOS (at startup) to UTC.

          Good luck,
          -Henry

          > My 5000e system time becomes incorrect after a suspend and a resume.
          > The OS acts as though no time has passed between the suspend and the
          > resume, even if hours have in fact passed. (As if the OS doesn't
          > bother to reset the software time using the hardware clock when
          > resuming.)
        • klogv@yahoo.com
          ... Thanks Michael! Yet another reason to flash in the new bios. I was kind of waiting around for the blessing from Dell... By the way, with the tuxtops
          Message 4 of 8 , Mar 6, 2001
          • 0 Attachment
            > there is your problem [Dell BIOS], as soon as I got
            > the tux-top bios on my system that problem also vanished.

            Thanks Michael! Yet another reason to flash in the new bios. I was
            kind of waiting around for the blessing from Dell...

            By the way, with the tuxtops bios, do you still get screen-meltdown if
            you suspend & resume while in X? Or do you have to switch to a
            virtual console before suspending?

            Adam
          • throop@colorado.edu
            Have you tried putting a VGA=794 line in /etc/lilo.conf? This solved the suspend-resume meltdown issue for me (on my 1400x1050 5000e). Apparently it doesn t
            Message 5 of 8 , Mar 6, 2001
            • 0 Attachment
              Have you tried putting a 'VGA=794' line in /etc/lilo.conf?
              This solved the suspend-resume meltdown issue for me (on my 1400x1050
              5000e). Apparently it doesn't work for everyone, but you might try
              it.

              -Henry


              --- In linux-dell-laptops@y..., klogv@y... wrote:
              > > there is your problem [Dell BIOS], as soon as I got
              > > the tux-top bios on my system that problem also vanished.
              >
              > Thanks Michael! Yet another reason to flash in the new bios. I
              was
              > kind of waiting around for the blessing from Dell...
              >
              > By the way, with the tuxtops bios, do you still get screen-meltdown
              if
              > you suspend & resume while in X? Or do you have to switch to a
              > virtual console before suspending?
              >
              > Adam
            • throop@colorado.edu
              Have you tried putting a VGA=794 line in /etc/lilo.conf? Works on my 1400x1050 5000e, but apparently doesn t work for everyone. Suspend/resume now work
              Message 6 of 8 , Mar 6, 2001
              • 0 Attachment
                Have you tried putting a VGA=794 line in /etc/lilo.conf? Works on my
                1400x1050 5000e, but apparently doesn't work for everyone.
                Suspend/resume now work normally for me.

                -Henry

                --- In linux-dell-laptops@y..., klogv@y... wrote:
                > > there is your problem [Dell BIOS], as soon as I got
                > > the tux-top bios on my system that problem also vanished.
                >
                > Thanks Michael! Yet another reason to flash in the new bios. I
                was
                > kind of waiting around for the blessing from Dell...
                >
                > By the way, with the tuxtops bios, do you still get screen-meltdown
                if
                > you suspend & resume while in X? Or do you have to switch to a
                > virtual console before suspending?
                >
                > Adam
              • Allan Gottlieb
                ... Is the magic number still 794 if you have UXGA 1600x1200? thanks, allan
                Message 7 of 8 , Mar 6, 2001
                • 0 Attachment
                  throop@... writes:

                  > Have you tried putting a VGA=794 line in /etc/lilo.conf? Works on my
                  > 1400x1050 5000e, but apparently doesn't work for everyone.
                  > Suspend/resume now work normally for me.

                  Is the magic number still 794 if you have UXGA 1600x1200?

                  thanks,
                  allan
                • scott_dixon@yahoo.com
                  I also found with my I4000 that the time was wrong after coming out of a suspend. I think there are two ways to fix this. One is, as mentioned below, to
                  Message 8 of 8 , Mar 14, 2001
                  • 0 Attachment
                    I also found with my I4000 that the time was wrong after coming out of
                    a suspend. I think there are two ways to fix this. One is, as
                    mentioned below, to switch over to UTC for your hardware clock. The
                    only potential problem with this is that if you dual boot, your
                    Windows installation may not know how to handle this. The other
                    possiblility, which is what I did, was to change the kernel
                    configuration option, "RTC stores time in GMT" to off (part of the APM
                    configuration). This was set on by default in my RedHat 6.2
                    configuration. This solved the problem for me. However, it does
                    require that you generate a new kernel and install it.
                    Scott
                    --- In linux-dell-laptops@y..., throop@c... wrote:
                    > Hi,
                    >
                    > I found that on my system, the hardware clock and the system clock
                    > were not being properly sync'd to each other after a resume. It had
                    > something to do with time zone issues.
                    >
                    > To solve it, I switched everything to UTC rather than local time.
                    > Change the UTC="no" entry to "yes" in /etc/sysconfig/clock file and
                    > see if that does it for you. I believe that you also need to set
                    the
                    > clock in the BIOS (at startup) to UTC.
                    >
                    > Good luck,
                    > -Henry
                    >
                    > > My 5000e system time becomes incorrect after a suspend and a
                    resume.
                    > > The OS acts as though no time has passed between the suspend and
                    the
                    > > resume, even if hours have in fact passed. (As if the OS doesn't
                    > > bother to reset the software time using the hardware clock when
                    > > resuming.)
                  Your message has been successfully submitted and would be delivered to recipients shortly.