Loading ...
Sorry, an error occurred while loading the content.

Re: latitude LS redhat 7.0 apm

Expand Messages
  • yschoe@my-deja.com
    ... Okay folks, I solved the problem. I upgraded the kernel to 2.4.2 and pcmcia-cs to 3.1.24, and all went well. The APM options that I used were similar to
    Message 1 of 2 , Feb 27, 2001
    • 0 Attachment
      --- In linux-dell-laptops@y..., yschoe@m... wrote:
      > Hi all,
      >
      > I am having problems with APM on latitude LS running
      > redhat 7.0.
      >
      > It suspends well almost always, but occasionally it doesn't
      > resume when the lid is open. I have tried all these things
      > before suspending:
      >
      > 1. turn off pcmcia
      > 2. turn off networking (ifconfig eth0 down)
      > 3. turn off X11
      > 4. unplug AC
      >
      > but none of these seem to help. What happens is, when the
      > lid is closed or Fn-Suspend is pressed, the LED blinks
      > and goes out. When resuming, it either
      >
      > 1. comes up just fine
      > 2. comes up just fine, but after some keyboard/mouse
      > events, it freezes, or
      > 3. doesn't come up (black screen).
      >
      > The problem is that the whole thing is not reproducable,
      > and it doesn't leave any sensible log message, so it's hard to
      > determine what is the problem.
      >
      > The stock kernel and a rebuilt kernel with reasonable APM
      > options both work in a similar manner.
      >
      > I have seen on the web that installing linmodem patches could
      > actually help. Have anyone tried this?
      >
      > Any idea?
      >
      > Thanks,
      >
      > Yoon

      Okay folks, I solved the problem.

      I upgraded the kernel to 2.4.2 and pcmcia-cs to 3.1.24,
      and all went well.

      The APM options that I used were similar to

      http://www.divisionbyzero.com/laptop/

      Don't forget to use kgcc instead of gcc.

      After recompile/reboot, it came up okay, and it suspended/
      resumed from all possible situations: with w/o AC,
      console vs. X11, network connected/not connected,
      pcmcia up/down, etc.

      However, the problem was that the fan didn't ever turn
      off even when nothing was running. I ran 'top' to
      see if there was any process, and klogd was running at
      around 98% usage. This was odd, and since I couldn't
      find any relevant message, I just decided to recompile
      the kernel with different APM options.

      I turned on the CONFIG_APM_CPU_IDLE flag
      and recompiled and rebooted, but it the fan didn't
      go off. However, klogd was not running at such a high load.
      I noticed that going into single user mode `init 1`
      immediately turned off the fan, so I suspected that there must
      be some system process causing the CPU to heat up.

      I finally turned off the rhnsd service from
      /etc/rc.d/init.d/ and also disabled it from /etc/rc.d/rc[35].d
      and now everything works just beautifully.
      I somehow believe that both of these (CPU_IDLE flag, and
      turning off rhnsd) was necessary.

      If you need any question regarding the latitude LS, let
      me know. Send me email yschoe at my-deja dot com.
    Your message has been successfully submitted and would be delivered to recipients shortly.