Loading ...
Sorry, an error occurred while loading the content.

SOLVED: Dell Latitude D600 wireless problem with kubuntu 7.10

Expand Messages
  • Abdon RAZAFIMAHEFA
    Chad, ... Yes, I have to hardswitch on the keyboard... abdon@dell:~$ sudo iwconfig eth0 txpower on [sudo] password for abdon: Error for wireless request Set
    Message 1 of 3 , Nov 9, 2007
    • 0 Attachment
      Chad,

      > Dells there is usually a FN key you can use, and
      > sometimes there is an actual switch you have to switch.

      Yes, I have to hardswitch on the keyboard...

      abdon@dell:~$ sudo iwconfig eth0 txpower on
      [sudo] password for abdon:
      Error for wireless request "Set Tx Power" (8B26) :
      SET failed on device eth0 ; Input/output error.

      Means that my wireless card is hardset to OFF.

      I just turn it on with the keybord:
      <Fn> + <F2> which is equivalent to the wireless blue sign.
      And this key is a switch Turning ON/OFF of the wireless card.

      And that's it ... everything works smouthly.

      Many thanks for your help.
      Abdon.


      --- In linux-dell-laptops@yahoogroups.com, Chad Sutton <csutton@...>
      wrote:
      >
      > This card is very well supported out of the box with Ubuntu so there
      > must be some kind of configuration issue going on.
      >
      > It looks to me like you don't have a driver loaded for your card. You
      > only have an eth0 and no eth1. You should check to see if the driver is
      > being loaded.
      >
      > Use the following command:
      > lsmod |grep ipw2200
      >
      > If it doesn't return anything they you probably don't have the driver
      > loaded. Try loading the driver manually by using the following command:
      >
      > sudo modprobe ipw2200
      >
      > Hopefully you should see your wireless light go on. One thing that you
      > should try is the following command to see if your wireless card can
      see
      > wireless networks.
      >
      > iwlist eth1 scan
      >
      > Replace eth1 with the network card name you have. If you don't get
      > anything back then I would check that your wireless card is turned on.
      > It seems silly but I can't tell you how often I've made that
      mistake. On
      > Dells there is usually a FN key you can use, and sometimes there is an
      > actual switch you have to switch. But if your wireless light isn't
      > lighting up then its either off, or the driver isn't loading.
      >
      > Are you using knetworkmanager to manage your network connections? If so
      > I would check /etc/network/interfaces and make sure that you remark out
      > any eth0 and eth1 settings.
      >
      > This is my interfaces file
      > ---Begin File---
      > auto lo
      > iface lo inet loopback
      > address 127.0.0.1
      > netmask 255.0.0.0
      >
      > #iface eth0 inet dhcp
      > #auto eth0
      >
      > #iface eth1 inet dhcp
      > #auto eth1
      > ---End File---
      >
      > knetworkmanager will not manage any network cards that it finds listed
      > in your interfaces file. It thinks they are being manually managed
      so it
      > leaves them alone.
      >
      > Hope some of my ramblings help!
      >
      >
      >
      >
      > --
      > Later,
      > Chad Sutton
      > csutton@...
      > http://chadarius.com
      > http://stephandchadsutton.com
      >
      >
      >
      >
      > Abdon RAZAFIMAHEFA wrote:
      > >
      > > Hi All,
      > >
      > > I have a Dell latitude D600 laptop and the wireless connection is
      > > working fine with kubuntu 6.06 LTS. I upgraded to kubuntu 7.04 then
      > > the wireless connection is working for while then , somehow, the
      > > signal dropped down for some reason .. I have no clue.
      > >
      > > Then I tried to install kubuntu 7.10 (Feisty - Gibbon). The wiless is
      > > not working at all. Note that the dhcp parametrs are set correctly:
      > > SSID, WEP, etc...
      > >
      > > And, I'm getting some strange connection (see the output for ifconfig
      > > command).
      > > My router is a Dlink and my network IP address is 192.168.0.*
      > >
      > > Any help on how to make this Pro/wireless 2200BG working ?
      > >
      > > Thanks.
      > > Abdon.
      > >
      > > ------------ actual output on the Dell
      > >
      > > abdon@dell:~$ lspci | grep -i network
      > > 02:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG
      > > Network Connection (rev 05)
      > >
      > > abdon@dell:~$ ifconfig
      > >
      > > eth0 Link encap:Ethernet HWaddr 00:0E:35:21:27:49
      > > UP BROADCAST MULTICAST MTU:1500 Metric:1
      > > RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      > > TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      > > collisions:0 txqueuelen:1000
      > > RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
      > > Interrupt:5 Base address:0x4000 Memory:fafff000-faffffff
      > >
      > > eth0:avah Link encap:Ethernet HWaddr 00:0E:35:21:27:49
      > > inet addr:169.254.2.229 Bcast:169.254.255.255 Mask:255.255.0.0
      > > UP BROADCAST MULTICAST MTU:1500 Metric:1
      > > Interrupt:5 Base address:0x4000 Memory:fafff000-faffffff
      > >
      > > lo Link encap:Local Loopback
      > > inet addr:127.0.0.1 Mask:255.0.0.0
      > > inet6 addr: ::1/128 Scope:Host
      > > UP LOOPBACK RUNNING MTU:16436 Metric:1
      > > RX packets:1744 errors:0 dropped:0 overruns:0 frame:0
      > > TX packets:1744 errors:0 dropped:0 overruns:0 carrier:0
      > > collisions:0 txqueuelen:0
      > > RX bytes:140000 (136.7 KB) TX bytes:140000 (136.7 KB)
      > >
      > > abdon@dell:~$ uname -a
      > > Linux dell 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686
      > > GNU/Linux
      > > __________________
      > >
      > >
      >
    • Chad Sutton
      This card is very well supported out of the box with Ubuntu so there must be some kind of configuration issue going on. It looks to me like you don t have a
      Message 2 of 3 , Nov 10, 2007
      • 0 Attachment
        This card is very well supported out of the box with Ubuntu so there must be some kind of configuration issue going on.

        It looks to me like you don't have a driver loaded for your card. You only have an eth0 and no eth1. You should check to see if the driver is being loaded.

        Use the following command:
        lsmod |grep ipw2200

        If it doesn't return anything they you probably don't have the driver loaded. Try loading the driver manually by using the following command:

        sudo modprobe ipw2200

        Hopefully you should see your wireless light go on. One thing that you should try is the following command to see if your wireless card can see wireless networks.

        iwlist eth1 scan

        Replace eth1 with the network card name you have. If you don't get anything back then I would check that your wireless card is turned on. It seems silly but I can't tell you how often I've made that mistake. On Dells there is usually a FN key you can use, and sometimes there is an actual switch you have to switch. But if your wireless light isn't lighting up then its either off, or the driver isn't loading.

        Are you using knetworkmanager to manage your network connections? If so I would check /etc/network/interfaces and make sure that you remark out any eth0 and eth1 settings.

        This is my interfaces file
        ---Begin File---
        auto lo
        iface lo inet loopback
        address 127.0.0.1
        netmask 255.0.0.0

        #iface eth0 inet dhcp
        #auto eth0

        #iface eth1 inet dhcp
        #auto eth1
        ---End File---

        knetworkmanager will not manage any network cards that it finds listed in your interfaces file. It thinks they are being manually managed so it leaves them alone.

        Hope some of my ramblings help!


         

        -- 
        Later,
        Chad Sutton
        csutton@...
        http://chadarius.com
        http://stephandchadsutton.com



        Abdon RAZAFIMAHEFA wrote:

        Hi All,

        I have a Dell latitude D600 laptop and the wireless connection is
        working fine with kubuntu 6.06 LTS. I upgraded to kubuntu 7.04 then
        the wireless connection is working for while then , somehow, the
        signal dropped down for some reason .. I have no clue.

        Then I tried to install kubuntu 7.10 (Feisty - Gibbon). The wiless is
        not working at all. Note that the dhcp parametrs are set correctly:
        SSID, WEP, etc...

        And, I'm getting some strange connection (see the output for ifconfig
        command).
        My router is a Dlink and my network IP address is 192.168.0.*

        Any help on how to make this Pro/wireless 2200BG working ?

        Thanks.
        Abdon.

        ------------ actual output on the Dell

        abdon@dell:~ $ lspci | grep -i network
        02:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG
        Network Connection (rev 05)

        abdon@dell:~ $ ifconfig

        eth0 Link encap:Ethernet HWaddr 00:0E:35:21: 27:49
        UP BROADCAST MULTICAST MTU:1500 Metric:1
        RX packets:0 errors:0 dropped:0 overruns:0 frame:0
        TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:1000
        RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
        Interrupt:5 Base address:0x4000 Memory:fafff000- faffffff

        eth0:avah Link encap:Ethernet HWaddr 00:0E:35:21: 27:49
        inet addr:169.254. 2.229 Bcast:169.254. 255.255 Mask:255.255. 0.0
        UP BROADCAST MULTICAST MTU:1500 Metric:1
        Interrupt:5 Base address:0x4000 Memory:fafff000- faffffff

        lo Link encap:Local Loopback
        inet addr:127.0.0. 1 Mask:255.0.0. 0
        inet6 addr: ::1/128 Scope:Host
        UP LOOPBACK RUNNING MTU:16436 Metric:1
        RX packets:1744 errors:0 dropped:0 overruns:0 frame:0
        TX packets:1744 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:0
        RX bytes:140000 (136.7 KB) TX bytes:140000 (136.7 KB)

        abdon@dell:~ $ uname -a
        Linux dell 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686
        GNU/Linux
        ____________ ______


      Your message has been successfully submitted and would be delivered to recipients shortly.