Loading ...
Sorry, an error occurred while loading the content.
 

Re: [linux-dell-laptops] Latitude D600 Wireless disabled - Please help.

Expand Messages
  • Chad Sutton
    ... You might want to try poking around https://help.ubuntu.com/community/WifiDocs/WirelessCardsSupported. This card is fully supported in Ubuntu. To see if
    Message 1 of 5 , Mar 17, 2007
      James wrote:

      Hi. I'm so glad I found this group and hope that someone has already
      overcome the only obstacle I've found that I can't seem to fix.

      Here's my issue:

      The Intel 2100 wireless card is detected and setup fine. However, it's
      disabled in Linux only.

      I have the 2100 enabled in the BIOS. I've installed both Ubuntu 6.10
      and SuSE 10 using Gnome with the same results, so it's definitely a
      hardware issue. It even works in the Windows XP Pro OS that is dual
      booted with Linux.

      The Fn+F2 button combo does nothing. When I press that, I see unknown
      key pressed messages in the message log under SuSE, and something very
      similar in Ubuntu.

      Anyone know how to enable the Intel 2100 card in Linux? Again, the
      driver is loaded just fine. The Network Connections Panel icon shows
      Disconnected, and Wireless disabled.

      I've searched all over the Net looking for the solution to this issue
      to no avail.

      Thanks for any ideas!

      You might want to try poking around https://help.ubuntu.com/community/WifiDocs/WirelessCardsSupported.

      This card is fully supported in Ubuntu. To see if the driver is loaded you should type "lsmod |grep ipw2100"in a terminal. It should return that the card's module is loaded.

      Your card in Ubuntu is most likely listed as eth1 (perhaps wlan0). See if you can see any wireless networks by typing "iwlist scan". If wireless network information is returned then the card is active and working.

      Have you tried any of that yet?

      A simple search at http://ubuntuforums.org on intel 2100 brought me the following results

      http://ubuntuforums.org/showthread.php?t=298798&highlight=intel+2100

      https://help.ubuntu.com/community/WifiDocs/NetworkManager?highlight=%28network%29%7C%28manager%29

      https://help.ubuntu.com/community/WifiDocs/WirelessTroubleShootingGuide

      http://ubuntuforums.org/showthread.php?t=327067&highlight=intel+2100

      http://ipw2100.sourceforge.net/#issues



      -- 
      Later,
      Chad Sutton
      csutton@...
      http://chadarius.com
      http://stephandchadsutton.com
    • carter_brey
      James, Have you tried: modprobe ipw2100 and then, as superuser: dhclient && ifup eth0 (or eth1) Just a thought, Good luck, CB
      Message 2 of 5 , Mar 18, 2007
        James,

        Have you tried:

        modprobe ipw2100

        and then, as superuser:

        dhclient && ifup eth0 (or eth1)

        Just a thought,

        Good luck,
        CB

        --- In linux-dell-laptops@yahoogroups.com, "James" <james@...> wrote:
        >
        > Hi. I'm so glad I found this group and hope that someone has already
        > overcome the only obstacle I've found that I can't seem to fix.
        >
        > Here's my issue:
        >
        > The Intel 2100 wireless card is detected and setup fine. However, it's
        > disabled in Linux only.
        >
        > I have the 2100 enabled in the BIOS. I've installed both Ubuntu 6.10
        > and SuSE 10 using Gnome with the same results, so it's definitely a
        > hardware issue. It even works in the Windows XP Pro OS that is dual
        > booted with Linux.
        >
        > The Fn+F2 button combo does nothing. When I press that, I see unknown
        > key pressed messages in the message log under SuSE, and something very
        > similar in Ubuntu.
        >
        > Anyone know how to enable the Intel 2100 card in Linux? Again, the
        > driver is loaded just fine. The Network Connections Panel icon shows
        > Disconnected, and Wireless disabled.
        >
        > I've searched all over the Net looking for the solution to this issue
        > to no avail.
        >
        > Thanks for any ideas!
        >
      • foundprophet87
        Core 6 and Red Hat Enterprise required a firmware update to be applied to get the cards to work. This rpm was included in their respective Extras
        Message 3 of 5 , Mar 27, 2007
          Core 6 and Red Hat Enterprise required a firmware update to be
          applied to get the cards to work. This rpm was included in their
          respective "Extras" repositories. I would assume that Suse and
          Ubuntu would have something similar in their apt repositories.

          I couldn't ever get the Fn+F2 key sequence to work, however.
          Enabling and disabling had to be done through the OS (ifup and ifdown
          at the command line).

          See here for details on the project:
          http://ipw2100.sourceforge.net/


          --- In linux-dell-laptops@yahoogroups.com, "James" <james@...> wrote:
          >
          > Hi. I'm so glad I found this group and hope that someone has already
          > overcome the only obstacle I've found that I can't seem to fix.
          >
          > Here's my issue:
          >
          > The Intel 2100 wireless card is detected and setup fine. However,
          > it's disabled in Linux only.
          >
          > I have the 2100 enabled in the BIOS. I've installed both Ubuntu 6.10
          > and SuSE 10 using Gnome with the same results, so it's definitely a
          > hardware issue. It even works in the Windows XP Pro OS that is dual
          > booted with Linux.
          >
          > The Fn+F2 button combo does nothing. When I press that, I see
          > unknown key pressed messages in the message log under SuSE, and
          > something very similar in Ubuntu.
          >
          > Anyone know how to enable the Intel 2100 card in Linux? Again, the
          > driver is loaded just fine. The Network Connections Panel icon shows
          > Disconnected, and Wireless disabled.
          >
          > I've searched all over the Net looking for the solution to this
          > issue to no avail.
          >
          > Thanks for any ideas!
          >
        • Jack
          There is firmware that MUST be loaded into the wireless card by the OS (linux kernel). See if the DMESG |grep ipw2100 produces message saying that there was
          Message 4 of 5 , Apr 9, 2007
            There is firmware that MUST be loaded into the wireless card by the OS
            (linux kernel). See if the DMESG |grep ipw2100 produces message
            saying that there was a load failure of a .bss or similar module. For
            security a wpa-supplicant module MUST be also loaded and ndiswrapper
            is also needed. I have a DELL 9200 with 2200BG card almost identical
            to 2100 card in your dell. Is the light showing the WiFI LED on? Make
            sure that the kernel is 2.6.18 or higher. There are some kernel
            complation options that will cause a failure of wireless
            communication. CHECK http://oss.intel.com/en-us/

            Try these and you may get somewhere. I can't understand why LINUX
            programmers have not gotten the message that CENTRINO+LAPTOP is a
            huge supply of computers that HAVE to be relegated to WINDOWS
            because WINDOWS can connect easily!!!
            Good Luck
            Jack
            Toms River,NJ



            --- In linux-dell-laptops@yahoogroups.com, Chad Sutton <csutton@...>
            wrote:
            >
            > James wrote:
            > >
            > > Hi. I'm so glad I found this group and hope that someone has
            already
            > > overcome the only obstacle I've found that I can't seem to fix.
            > >
            > > Here's my issue:
            > >
            > > The Intel 2100 wireless card is detected and setup fine. However,
            it's
            > > disabled in Linux only.
            > >
            > > I have the 2100 enabled in the BIOS. I've installed both Ubuntu
            6.10
            > > and SuSE 10 using Gnome with the same results, so it's definitely
            a
            > > hardware issue. It even works in the Windows XP Pro OS that is
            dual
            > > booted with Linux.
            > >
            > > The Fn+F2 button combo does nothing. When I press that, I see
            unknown
            > > key pressed messages in the message log under SuSE, and something
            very
            > > similar in Ubuntu.
            > >
            > > Anyone know how to enable the Intel 2100 card in Linux? Again, the
            > > driver is loaded just fine. The Network Connections Panel icon
            shows
            > > Disconnected, and Wireless disabled.
            > >
            > > I've searched all over the Net looking for the solution to this
            issue
            > > to no avail.
            > >
            > > Thanks for any ideas!
            > >
            > >
            > You might want to try poking around
            > https://help.ubuntu.com/community/WifiDocs/WirelessCardsSupported.
            >
            > This card is fully supported in Ubuntu. To see if the driver is
            loaded
            > you should type "lsmod |grep ipw2100"in a terminal. It should
            return
            > that the card's module is loaded.
            >
            > Your card in Ubuntu is most likely listed as eth1 (perhaps wlan0).
            See
            > if you can see any wireless networks by typing "iwlist scan". If
            > wireless network information is returned then the card is active
            and
            > working.
            >
            > Have you tried any of that yet?
            >
            > A simple search at http://ubuntuforums.org on intel 2100 brought me
            the
            > following results
            >
            > http://ubuntuforums.org/showthread.php?t=298798&highlight=intel+2100
            >
            > https://help.ubuntu.com/community/WifiDocs/NetworkManager?
            highlight=%28network%29%7C%28manager%29
            >
            >
            https://help.ubuntu.com/community/WifiDocs/WirelessTroubleShootingGuid
            e
            >
            > http://ubuntuforums.org/showthread.php?t=327067&highlight=intel+2100
            >
            > http://ipw2100.sourceforge.net/#issues
            >
            >
            >
            > --
            > Later,
            > Chad Sutton
            > csutton@...
            > http://chadarius.com
            > http://stephandchadsutton.com
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.