Loading ...
Sorry, an error occurred while loading the content.

Re: [linux-dell-laptops] Re: Latitude CP M233ST and ALSA sound

Expand Messages
  • Alexander Toresson
    The documents in /usr/share/doc/pnpbios-tools should tell you how.
    Message 1 of 17 , Dec 7, 2006
    • 0 Attachment
      The documents in /usr/share/doc/pnpbios-tools should tell you how.

      On 12/7/06, John Tetreault <blkthorn30@...> wrote:
      > Okay... I recompiled my kernel, and I think I've made some progress...
      > here's what I've accomplished so far.
      >
      > lspnp -v shows my sound card as
      >
      > 0f CSC0000 Crystal PnP audio system CODEC
      > io disabled
      > io disabled
      > io disabled
      > irq disabled
      > dma disabled
      > dma disabled
      >
      > 10 CSC0010 Crystal PnP audio system control registers
      > io 0x0210-0x0217
      >
      > so after setpnp 0f on it changes to:
      >
      > 0f CSC0000 Crystal PnP audio system CODEC
      > io 0x0530-0x0537
      > io 0x0388-0x038b
      > io 0x0220-0x022f
      > irq 5
      > dma 1
      > dma 0
      >
      > 10 CSC0010 Crystal PnP audio system control registers
      > io 0x0210-0x0217
      >
      > Okay, so far so good.... so I run alsaconf
      > and it detects the cs-4232 right away without probing legacy
      > hardware.... great...... not.... when it tries to set the mixer, it
      > comes up with.
      >
      > Running update-modules...
      > Loading driver...
      > /usr/sbin/alsaconf: line 915: /etc/init.d/alsa: No such file or directory
      > Setting default volumes...
      >
      > I think the problem here is, I've got /etc/init.d/alsasound not
      > /etc/init.d/alsa So I created a symbolic link to fix that problem
      >
      > run speaker-test and I do have sound..... wonderful.
      >
      > So I reboot..... NOTHING.
      >
      > So my question is.... how do I make setpnp 0f on before alsa tries to
      > load..... man setpnp doesn't give any indication
      >
      > --- In linux-dell-laptops@yahoogroups.com, "Alexander Toresson"
      > <alexander.toresson@...> wrote:
      > >
      > > On 11/21/06, John Tetreault <blkthorn30@...> wrote:
      > > > Okay, so this machine is an antique, but in hopes of getting a few
      > > > more years of use out of it, I have successfully installed the
      > > > Xubuntu distro, and have been quite pleased with the results so far.
      > > >
      > > > The only problem I´m having is getting sound to work.
      > > >
      > > > According to the BIOS screen, this laptop uses the CS-4237B chipset.
      > > > ALSA supposedly supports it, but how to get it to work. From my
      > > > research on the subject, it seems there are two flavors of this
      > > > chipset, a pnp version, and a non-pnp version.... I´m guessing I´ve
      > > > got the non-pnp version.
      > > >
      > > > This is my first attempt at installing a linux distro on any machine,
      > > > so I am still learning here, so please, if you´re able to offer
      > > > assistance, be very specific.
      > > >
      > >
      > > Hello,
      > >
      > > The following page might help you: http://eulex.0nyx.com/cs4237b.html .
      > >
      > > If you've got any question on how to do anything described on that
      > > page, just ask.
      > >
      > > Regards, Alexander Toresson
      > >
      >
      >
      >
      >
      > --------------------------------------------------------------
      > Please post your X config files in the group links or database
      > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
      > FAQ: http://www.whacked.net/ldl/faq
      > Yahoo! Groups Links
      >
      >
      >
      >
    • brian
      John -- If you check the bug track at ALSA, you ll see I had similar issues with this exact sound chip on my Dell Inspiron 3200. The sound chip is not
      Message 2 of 17 , Dec 7, 2006
      • 0 Attachment
        John --

        If you check the bug track at ALSA, you'll see I had similar issues
        with this exact sound chip on my Dell Inspiron 3200. The sound chip is
        not properly detected most of the time (with or without PnP enabled),
        and when I "force" the proper module to load, it won't connect correctly
        to the ports as specified in the BIOS. I filed three or four bug
        reports, but that was probably a year or so ago...

        I ended up installing DSL on the machine instead of Fedora Core. DSL
        is based on a 2.4.x kernel, and the CS4232 driver in ALSA runs the chip
        just fine. As far as I've been able to test, the CS4237B driver for
        ALSA has never worked properly (at least not on my laptop). If you
        don't mind running a 2.4 kernel, you might give that option a try -- I
        did have to write a small script (based on a post I found while
        searching Google for a solution) to unload and then reload the drivers
        after I boot up the machine... I just added the necessary lines to my
        user login script, and have had sound working ever since.


        On Thu, 2006-12-07 at 18:53 +0100, Alexander Toresson wrote:
        > The documents in /usr/share/doc/pnpbios-tools should tell you how.
        >
        > On 12/7/06, John Tetreault <blkthorn30@...> wrote:
        > > Okay... I recompiled my kernel, and I think I've made some progress...
        > > here's what I've accomplished so far.
        > >
        > > lspnp -v shows my sound card as
        > >
        > > 0f CSC0000 Crystal PnP audio system CODEC
        > > io disabled
        > > io disabled
        > > io disabled
        > > irq disabled
        > > dma disabled
        > > dma disabled
        > >
        > > 10 CSC0010 Crystal PnP audio system control registers
        > > io 0x0210-0x0217
        > >
        > > so after setpnp 0f on it changes to:
        > >
        > > 0f CSC0000 Crystal PnP audio system CODEC
        > > io 0x0530-0x0537
        > > io 0x0388-0x038b
        > > io 0x0220-0x022f
        > > irq 5
        > > dma 1
        > > dma 0
        > >
        > > 10 CSC0010 Crystal PnP audio system control registers
        > > io 0x0210-0x0217
        > >
        > > Okay, so far so good.... so I run alsaconf
        > > and it detects the cs-4232 right away without probing legacy
        > > hardware.... great...... not.... when it tries to set the mixer, it
        > > comes up with.
        > >
        > > Running update-modules...
        > > Loading driver...
        > > /usr/sbin/alsaconf: line 915: /etc/init.d/alsa: No such file or directory
        > > Setting default volumes...
        > >
        > > I think the problem here is, I've got /etc/init.d/alsasound not
        > > /etc/init.d/alsa So I created a symbolic link to fix that problem
        > >
        > > run speaker-test and I do have sound..... wonderful.
        > >
        > > So I reboot..... NOTHING.
        > >
        > > So my question is.... how do I make setpnp 0f on before alsa tries to
        > > load..... man setpnp doesn't give any indication
        > >
        > > --- In linux-dell-laptops@yahoogroups.com, "Alexander Toresson"
        > > <alexander.toresson@...> wrote:
        > > >
        > > > On 11/21/06, John Tetreault <blkthorn30@...> wrote:
        > > > > Okay, so this machine is an antique, but in hopes of getting a few
        > > > > more years of use out of it, I have successfully installed the
        > > > > Xubuntu distro, and have been quite pleased with the results so far.
        > > > >
        > > > > The only problem I´m having is getting sound to work.
        > > > >
        > > > > According to the BIOS screen, this laptop uses the CS-4237B chipset.
        > > > > ALSA supposedly supports it, but how to get it to work. From my
        > > > > research on the subject, it seems there are two flavors of this
        > > > > chipset, a pnp version, and a non-pnp version.... I´m guessing I´ve
        > > > > got the non-pnp version.
        > > > >
        > > > > This is my first attempt at installing a linux distro on any machine,
        > > > > so I am still learning here, so please, if you´re able to offer
        > > > > assistance, be very specific.
        > > > >
        > > >
        > > > Hello,
        > > >
        > > > The following page might help you: http://eulex.0nyx.com/cs4237b.html .
        > > >
        > > > If you've got any question on how to do anything described on that
        > > > page, just ask.
        > > >
        > > > Regards, Alexander Toresson
        > > >
        > >
        > >
        > >
        > >
        > > --------------------------------------------------------------
        > > Please post your X config files in the group links or database
        > > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
        > > FAQ: http://www.whacked.net/ldl/faq
        > > Yahoo! Groups Links
        > >
        > >
        > >
        > >
        >
        >
        > --------------------------------------------------------------
        > Please post your X config files in the group links or database
        > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
        > FAQ: http://www.whacked.net/ldl/faq
        > Yahoo! Groups Links
        >
        >
        >
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.