Loading ...
Sorry, an error occurred while loading the content.

Inspiron 6000 xterm resize

Expand Messages
  • John Logsdon
    I have been running Kubuntu 6.06 Dapper fully updated on my i6000 for some time now and pretty nearly everything works out of the box - sleep, wireless etc
    Message 1 of 3 , Aug 28, 2006
    • 0 Attachment
      I have been running Kubuntu 6.06 Dapper fully updated on my i6000 for some
      time now and pretty nearly everything works out of the box - sleep,
      wireless etc etc. However I have an issue with xterm resizing.

      The PCI bridge is Mobility 915GM and the video hardware is ATI Radeon
      Mobility M300. I have xserver-xorg-driver-i810 display driver which
      should deal with i8xx and i9xx. I also have the i128 and i740 drivers -
      you can't remove them without removing xserver-xorg-driver-all which
      sounds rather dangerous.

      The problem is that under an ordinary user, I can't resize an xterm. The
      prompt (Huge etc) comes up but nothing happens. I can do it under root (I
      have enabled that as a user) but not under an ordinary user. This is most
      annoying as I have the system set on micro-font to get the maximum
      information on the screen (1680x1050 - anyone got more than that?) but
      just occasionally I like to be able to read it without a magnifying glass!
      The xterm resize worked nicely on the previous Kubuntu (Breezy Badger) but
      not on Dapper 6.06.

      The fact that I cannot do it under an ordinary user but can under root
      suggests that it is a permissions problem somewhere.

      Anyone got a clue?

      Best wishes

      John

      John Logsdon "Try to make things as simple
      Quantex Research Ltd, Manchester UK as possible but not simpler"
      j.logsdon@... a.einstein@...
      +44(0)161 445 4951/G:+44(0)7717758675 www.quantex-research.com
    • Gabriel
      Hi John, From your description, my first idea is an xterm/fonts config issue, try: - can you access fonts, try to compare output of xlsfonts (should be the
      Message 2 of 3 , Aug 30, 2006
      • 0 Attachment
        Hi John,

        From your description, my first idea is an xterm/fonts config issue, try:
        - can you access fonts, try to compare output of xlsfonts (should be the same between user and root)
        - has your xterm Xressources been redefined under your account, check: xrdb -query and lines line
        *xterm
        *VT100
        Also check the default ressources file, normally under:
        /usr/X11R6/lib/X11/app-defaults/XTerm
        Can you read the file?
        In that file you should find lines like:
        *VT100*font5: 9x15
        (font5 is large)
        then check you have a font 9x15 with:
        xlsfonts | grep 9x15
        if nothing appears that's where your problem is ...

        Hope this helps,
        Good luck,

        Gabriel.


        On Monday 28 August 2006 21:39, John Logsdon wrote:
        > I have been running Kubuntu 6.06 Dapper fully updated on my i6000 for some
        > time now and pretty nearly everything works out of the box - sleep,
        > wireless etc etc. However I have an issue with xterm resizing.
        >
        > The PCI bridge is Mobility 915GM and the video hardware is ATI Radeon
        > Mobility M300. I have xserver-xorg-driver-i810 display driver which
        > should deal with i8xx and i9xx. I also have the i128 and i740 drivers -
        > you can't remove them without removing xserver-xorg-driver-all which
        > sounds rather dangerous.
        >
        > The problem is that under an ordinary user, I can't resize an xterm. The
        > prompt (Huge etc) comes up but nothing happens. I can do it under root (I
        > have enabled that as a user) but not under an ordinary user. This is most
        > annoying as I have the system set on micro-font to get the maximum
        > information on the screen (1680x1050 - anyone got more than that?) but
        > just occasionally I like to be able to read it without a magnifying glass!
        > The xterm resize worked nicely on the previous Kubuntu (Breezy Badger) but
        > not on Dapper 6.06.
        >
        > The fact that I cannot do it under an ordinary user but can under root
        > suggests that it is a permissions problem somewhere.
        >
        > Anyone got a clue?
        >
        > Best wishes
        >
        > John
        >
        > John Logsdon "Try to make things as simple
        > Quantex Research Ltd, Manchester UK as possible but not simpler"
        > j.logsdon@... a.einstein@...
        > +44(0)161 445 4951/G:+44(0)7717758675 www.quantex-research.com
        >
        >
        >
      • John Logsdon
        Results so far from Gabriels suggestions: Location of default Xresources is /etc/X11/app-defaults/XTerm and ./XTerm-color. These all are 0:0 and 0644 so they
        Message 3 of 3 , Aug 30, 2006
        • 0 Attachment
          Results so far from Gabriels suggestions:

          Location of default Xresources is /etc/X11/app-defaults/XTerm and
          ./XTerm-color. These all are 0:0 and 0644 so they can be read by any
          user.

          The expected xterm and VT100 lines are there and

          xlsfonts | grep 9x15

          produces the same for root and user.

          There is no .Xdefaults in root whereas there was in the user.

          So I removed that file (which I used to configure things like the nedit
          skin) and the resizing works now. ISTR I inherited the .Xdefaults file
          from a RH-based system and this is a Debian based system so it clearly
          didn't work! So I will have to put up with the nedit default for the
          moment until I can work out how to change the skin...

          Many thanks - your help directed me to the issue!

          Best wishes

          John

          John Logsdon "Try to make things as simple
          Quantex Research Ltd, Manchester UK as possible but not simpler"
          j.logsdon@... a.einstein@...
          +44(0)161 445 4951/G:+44(0)7717758675 www.quantex-research.com


          On Wed, 30 Aug 2006, Gabriel wrote:

          > Hi John,
          >
          > >From your description, my first idea is an xterm/fonts config issue, try:
          > - can you access fonts, try to compare output of xlsfonts (should be the same between user and root)
          > - has your xterm Xressources been redefined under your account, check: xrdb -query and lines line
          > *xterm
          > *VT100
          > Also check the default ressources file, normally under:
          > /usr/X11R6/lib/X11/app-defaults/XTerm
          > Can you read the file?
          > In that file you should find lines like:
          > *VT100*font5: 9x15
          > (font5 is large)
          > then check you have a font 9x15 with:
          > xlsfonts | grep 9x15
          > if nothing appears that's where your problem is ...
          >
          > Hope this helps,
          > Good luck,
          >
          > Gabriel.
          >
          >
          > On Monday 28 August 2006 21:39, John Logsdon wrote:
          > > I have been running Kubuntu 6.06 Dapper fully updated on my i6000 for some
          > > time now and pretty nearly everything works out of the box - sleep,
          > > wireless etc etc. However I have an issue with xterm resizing.
          > >
          > > The PCI bridge is Mobility 915GM and the video hardware is ATI Radeon
          > > Mobility M300. I have xserver-xorg-driver-i810 display driver which
          > > should deal with i8xx and i9xx. I also have the i128 and i740 drivers -
          > > you can't remove them without removing xserver-xorg-driver-all which
          > > sounds rather dangerous.
          > >
          > > The problem is that under an ordinary user, I can't resize an xterm. The
          > > prompt (Huge etc) comes up but nothing happens. I can do it under root (I
          > > have enabled that as a user) but not under an ordinary user. This is most
          > > annoying as I have the system set on micro-font to get the maximum
          > > information on the screen (1680x1050 - anyone got more than that?) but
          > > just occasionally I like to be able to read it without a magnifying glass!
          > > The xterm resize worked nicely on the previous Kubuntu (Breezy Badger) but
          > > not on Dapper 6.06.
          > >
          > > The fact that I cannot do it under an ordinary user but can under root
          > > suggests that it is a permissions problem somewhere.
          > >
          > > Anyone got a clue?
          > >
          > > Best wishes
          > >
          > > John
          > >
          > > John Logsdon "Try to make things as simple
          > > Quantex Research Ltd, Manchester UK as possible but not simpler"
          > > j.logsdon@... a.einstein@...
          > > +44(0)161 445 4951/G:+44(0)7717758675 www.quantex-research.com
          > >
          > >
          > >
          >
          >
          > --------------------------------------------------------------
          > Please post your X config files in the group links or database
          > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
          > FAQ: http://www.whacked.net/ldl/faq
          > Yahoo! Groups Links
          >
          >
          >
          >
          >
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.