Loading ...
Sorry, an error occurred while loading the content.

Kubuntu 6.06 on i6000

Expand Messages
  • John Logsdon
    Following the recent thread on ubuntu, I have just installed 6.06 on my Inspiron 6000. Everything works - wireless in WEP128 mode, screen has nice small fonts
    Message 1 of 6 , Jun 13, 2006
    • 0 Attachment
      Following the recent thread on ubuntu, I have just installed 6.06 on my
      Inspiron 6000. Everything works - wireless in WEP128 mode, screen has
      nice small fonts so I can get >200 characters across it. The installation
      was quite painless except the disk didn't allow me to reformat a partition
      in another filesystem.

      It has KDE 3.5.2 and is running a 2.6.15.23 kernel. As I say it is quite
      clean. I previously tried Kubuntu 5.10 which was OK but the sleep didn't
      work and that is important so that I have been using native XP for some
      time.

      I was looking for a RH-based system but none work properly IMHO at least
      out of the box and I really haven't got time to fiddle around too much.

      For the record:

      Mnadriva 10.1 - well it wasn't that bad but the full screen resolution
      wasn't available and I couldn't get the wireless to work.

      Scientific Linux 4.3 (a RHEL 4.3 derived distro) - again the full screen
      resolution wasn't available and the wireless wouldn't handle 128WEP - it
      would probably do 64WEP. It would connect (I could ping) then drop out.

      FC5 - a pretty recent toy but oh my! The screen was even worse at 800x600
      and it didn't even find the wireless card... don't bother at all.

      So I have decided to stick to Kubuntu - no point in going Gentoo if
      Kubuntu is almost working.

      The main problem I have - before I get add in the software I really want,
      include CodeWeavers and put all my MS Office stuff on it - is that after
      it goes to sleep/hibernates and I wake it up, the wireless does not
      reconnect.:-((( Everything else looks OK - screen and sessions are
      restored from disk etc.

      I have to go through setting it up including adding the key. I tried to
      use ifconfig/iwconfig but it didn't like the 128 WEP key so I had to use
      wlassistant which is graphical. It does connect then and stay up - until
      it goes to sleep again then it disconnects of course and doesn't
      reconnect!

      Not being familiar at all with Debian-based boxen - or KDE laptops come to
      that, can anyone suggest how to automate the reconnection? I need to
      specify the access point MAC as I have a bridge as well that broadcasts
      the same ESSID etc. on the same channel (which is very annoying - why
      doesn't wlassistant display the MAC address so you can differentiate?).
      I have tried just disabling the interface and enabling it again but this
      doesn't work either.

      Clues?

      TIA

      John

      John Logsdon "Try to make things as simple
      Quantex Research Ltd, Manchester UK as possible but not simpler"
      j.logsdon@... a.einstein@...
      +44(0)161 445 4951/G:+44(0)7717758675 www.quantex-research.com
    • Alexander Toresson
      ... You could try: sudo /etc/init.d/networking restart Regards, Alexander Toresson
      Message 2 of 6 , Jun 13, 2006
      • 0 Attachment
        On 6/14/06, John Logsdon <j.logsdon@...> wrote:
        > Following the recent thread on ubuntu, I have just installed 6.06 on my
        > Inspiron 6000. Everything works - wireless in WEP128 mode, screen has
        > nice small fonts so I can get >200 characters across it. The installation
        > was quite painless except the disk didn't allow me to reformat a partition
        > in another filesystem.
        >
        > It has KDE 3.5.2 and is running a 2.6.15.23 kernel. As I say it is quite
        > clean. I previously tried Kubuntu 5.10 which was OK but the sleep didn't
        > work and that is important so that I have been using native XP for some
        > time.
        >
        > I was looking for a RH-based system but none work properly IMHO at least
        > out of the box and I really haven't got time to fiddle around too much.
        >
        > For the record:
        >
        > Mnadriva 10.1 - well it wasn't that bad but the full screen resolution
        > wasn't available and I couldn't get the wireless to work.
        >
        > Scientific Linux 4.3 (a RHEL 4.3 derived distro) - again the full screen
        > resolution wasn't available and the wireless wouldn't handle 128WEP - it
        > would probably do 64WEP. It would connect (I could ping) then drop out.
        >
        > FC5 - a pretty recent toy but oh my! The screen was even worse at 800x600
        > and it didn't even find the wireless card... don't bother at all.
        >
        > So I have decided to stick to Kubuntu - no point in going Gentoo if
        > Kubuntu is almost working.
        >
        > The main problem I have - before I get add in the software I really want,
        > include CodeWeavers and put all my MS Office stuff on it - is that after
        > it goes to sleep/hibernates and I wake it up, the wireless does not
        > reconnect.:-((( Everything else looks OK - screen and sessions are
        > restored from disk etc.
        >
        > I have to go through setting it up including adding the key. I tried to
        > use ifconfig/iwconfig but it didn't like the 128 WEP key so I had to use
        > wlassistant which is graphical. It does connect then and stay up - until
        > it goes to sleep again then it disconnects of course and doesn't
        > reconnect!
        >
        > Not being familiar at all with Debian-based boxen - or KDE laptops come to
        > that, can anyone suggest how to automate the reconnection? I need to
        > specify the access point MAC as I have a bridge as well that broadcasts
        > the same ESSID etc. on the same channel (which is very annoying - why
        > doesn't wlassistant display the MAC address so you can differentiate?).
        > I have tried just disabling the interface and enabling it again but this
        > doesn't work either.
        >
        > Clues?
        >

        You could try:

        sudo /etc/init.d/networking restart

        Regards, Alexander Toresson
      • John Logsdon
        ... That s more RedHat spracht (at least there is no /etc/init.d/network in Kubuntu) but I solved this problem by resetting the WEP key from root: iwconfig
        Message 3 of 6 , Jun 14, 2006
        • 0 Attachment
          On Wed, 14 Jun 2006, Alexander Toresson wrote:

          > On 6/14/06, John Logsdon <j.logsdon@...> wrote:
          > >
          > > Not being familiar at all with Debian-based boxen - or KDE laptops come to
          > > that, can anyone suggest how to automate the reconnection? I need to
          > > specify the access point MAC as I have a bridge as well that broadcasts
          > > the same ESSID etc. on the same channel (which is very annoying - why
          > > doesn't wlassistant display the MAC address so you can differentiate?).
          > > I have tried just disabling the interface and enabling it again but this
          > > doesn't work either.
          > >
          > > Clues?
          > >
          >
          > You could try:
          >
          > sudo /etc/init.d/networking restart
          >
          > Regards, Alexander Toresson

          That's more RedHat spracht (at least there is no /etc/init.d/network in
          Kubuntu) but I solved this problem by resetting the WEP key from root:

          iwconfig eth1 key XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XX

          and it connected immediately. Everything else was there, including the
          default route that would be lost if the network were restarted.

          I noticed that in /etc/network/interfaces where the key etc is stored, it
          did not specify the channel so I added:

          wireless-channel 1

          before the key but that still didn't do anything.

          Where can I put this in a Debian-based system to restart the network
          automatically?

          Best wishes

          John

          John Logsdon "Try to make things as simple
          Quantex Research Ltd, Manchester UK as possible but not simpler"
          j.logsdon@... a.einstein@...
          +44(0)161 445 4951/G:+44(0)7717758675 www.quantex-research.com
        • Alexander Toresson
          ... No, this is how it s done in Debian, and I assumed it would be the same in Kubuntu, but that doesn t seem to be the case. Regards, Alexander Toresson
          Message 4 of 6 , Jun 14, 2006
          • 0 Attachment
            On 6/14/06, John Logsdon <j.logsdon@...> wrote:
            > On Wed, 14 Jun 2006, Alexander Toresson wrote:
            >
            > > On 6/14/06, John Logsdon <j.logsdon@...> wrote:
            > > >
            > > > Not being familiar at all with Debian-based boxen - or KDE laptops come to
            > > > that, can anyone suggest how to automate the reconnection? I need to
            > > > specify the access point MAC as I have a bridge as well that broadcasts
            > > > the same ESSID etc. on the same channel (which is very annoying - why
            > > > doesn't wlassistant display the MAC address so you can differentiate?).
            > > > I have tried just disabling the interface and enabling it again but this
            > > > doesn't work either.
            > > >
            > > > Clues?
            > > >
            > >
            > > You could try:
            > >
            > > sudo /etc/init.d/networking restart
            > >
            > > Regards, Alexander Toresson
            >
            > That's more RedHat spracht

            No, this is how it's done in Debian, and I assumed it would be the
            same in Kubuntu, but that doesn't seem to be the case.

            Regards, Alexander Toresson
          • Marvin R. Pierce
            /etc/network/interfaces _____ From: linux-dell-laptops@yahoogroups.com [mailto:linux-dell-laptops@yahoogroups.com] On Behalf Of John Logsdon Sent: Wednesday,
            Message 5 of 6 , Jun 14, 2006
            • 0 Attachment
              /etc/network/interfaces


              From: linux-dell-laptops@yahoogroups.com [mailto:linux-dell-laptops@yahoogroups.com] On Behalf Of John Logsdon
              Sent: Wednesday, 14 June 2006 6:44 PM
              To: linux-dell-laptops@yahoogroups.com
              Subject: Re: [linux-dell-laptops] Kubuntu 6.06 on i6000

              On Wed, 14 Jun 2006, Alexander Toresson wrote:

              > On 6/14/06, John Logsdon <j.logsdon@quantex- research. com> wrote:
              > >
              > > Not being familiar at all with Debian-based boxen - or KDE laptops come to
              > > that, can anyone suggest how to automate the reconnection? I need to
              > > specify the access point MAC as I have a bridge as well that broadcasts
              > > the same ESSID etc. on the same channel (which is very annoying - why
              > > doesn't wlassistant display the MAC address so you can differentiate? ).
              > > I have tried just disabling the interface and enabling it again but this
              > > doesn't work either.
              > >
              > > Clues?
              > >
              >
              > You could try:
              >
              > sudo /etc/init.d/ networking restart
              >
              > Regards, Alexander Toresson

              That's more RedHat spracht (at least there is no /etc/init.d/ network in
              Kubuntu) but I solved this problem by resetting the WEP key from root:

              iwconfig eth1 key XXXX-XXXX-XXXX- XXXX-XXXX- XXXX-XX

              and it connected immediately. Everything else was there, including the
              default route that would be lost if the network were restarted.

              I noticed that in /etc/network/ interfaces where the key etc is stored, it
              did not specify the channel so I added:

              wireless-channel 1

              before the key but that still didn't do anything.

              Where can I put this in a Debian-based system to restart the network
              automatically?

              Best wishes

              John

              John Logsdon "Try to make things as simple
              Quantex Research Ltd, Manchester UK as possible but not simpler"
              j.logsdon@quantex- research. com a.einstein@relativi ty.org
              +44(0)161 445 4951/G:+44(0) 7717758675 www.quantex- research. com

            • John Logsdon
              A solution: Add a line iwconfig eth1 key XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XX to the end of /etc/acpi/resume.sh I tried putting it in /etc/acpi/wireless.sh in the
              Message 6 of 6 , Jun 14, 2006
              • 0 Attachment
                A solution:

                Add a line

                iwconfig eth1 key XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XX

                to the end of /etc/acpi/resume.sh

                I tried putting it in /etc/acpi/wireless.sh in the bit where the wireless
                interface was restarted but the key wasn't parsed correctly and therefore
                no connection was made.

                This assumes that I am always connecting to the same network of course but
                if I am connecting to a wifi point elsewhere I can always go through a
                manual procedure. I expect it is possible to check the ESSID...

                Many thanks to those that emailed.

                Best wishes

                John

                John Logsdon "Try to make things as simple
                Quantex Research Ltd, Manchester UK as possible but not simpler"
                j.logsdon@... a.einstein@...
                +44(0)161 445 4951/G:+44(0)7717758675 www.quantex-research.com


                On Tue, 13 Jun 2006, John Logsdon wrote:

                > Following the recent thread on ubuntu, I have just installed 6.06 on my
                > Inspiron 6000. Everything works - wireless in WEP128 mode, screen has
                > nice small fonts so I can get >200 characters across it. The installation
                > was quite painless except the disk didn't allow me to reformat a partition
                > in another filesystem.
                >
                > It has KDE 3.5.2 and is running a 2.6.15.23 kernel. As I say it is quite
                > clean. I previously tried Kubuntu 5.10 which was OK but the sleep didn't
                > work and that is important so that I have been using native XP for some
                > time.
                >
                > I was looking for a RH-based system but none work properly IMHO at least
                > out of the box and I really haven't got time to fiddle around too much.
                >
                > For the record:
                >
                > Mnadriva 10.1 - well it wasn't that bad but the full screen resolution
                > wasn't available and I couldn't get the wireless to work.
                >
                > Scientific Linux 4.3 (a RHEL 4.3 derived distro) - again the full screen
                > resolution wasn't available and the wireless wouldn't handle 128WEP - it
                > would probably do 64WEP. It would connect (I could ping) then drop out.
                >
                > FC5 - a pretty recent toy but oh my! The screen was even worse at 800x600
                > and it didn't even find the wireless card... don't bother at all.
                >
                > So I have decided to stick to Kubuntu - no point in going Gentoo if
                > Kubuntu is almost working.
                >
                > The main problem I have - before I get add in the software I really want,
                > include CodeWeavers and put all my MS Office stuff on it - is that after
                > it goes to sleep/hibernates and I wake it up, the wireless does not
                > reconnect.:-((( Everything else looks OK - screen and sessions are
                > restored from disk etc.
                >
                > I have to go through setting it up including adding the key. I tried to
                > use ifconfig/iwconfig but it didn't like the 128 WEP key so I had to use
                > wlassistant which is graphical. It does connect then and stay up - until
                > it goes to sleep again then it disconnects of course and doesn't
                > reconnect!
                >
                > Not being familiar at all with Debian-based boxen - or KDE laptops come to
                > that, can anyone suggest how to automate the reconnection? I need to
                > specify the access point MAC as I have a bridge as well that broadcasts
                > the same ESSID etc. on the same channel (which is very annoying - why
                > doesn't wlassistant display the MAC address so you can differentiate?).
                > I have tried just disabling the interface and enabling it again but this
                > doesn't work either.
                >
                > Clues?
                >
                > TIA
                >
                > John
                >
                > John Logsdon "Try to make things as simple
                > Quantex Research Ltd, Manchester UK as possible but not simpler"
                > j.logsdon@... a.einstein@...
                > +44(0)161 445 4951/G:+44(0)7717758675 www.quantex-research.com
                >
                >
                >
                >
                >
                > --------------------------------------------------------------
                > Please post your X config files in the group links or database
                > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                > FAQ: http://www.whacked.net/ldl/faq
                > Yahoo! Groups Links
                >
                >
                >
                >
                >
                >
              Your message has been successfully submitted and would be delivered to recipients shortly.