Loading ...
Sorry, an error occurred while loading the content.

Re: [linux-dell-laptops] No X server support for Inspiron E1505/945GM WSXGA+ on Ubuntu 5.10 Breezy

Expand Messages
  • Sebastien
    Hi there, I also have an E1505 and I ve tried just about every major distro out there: Kubuntu 5.10, Mandriva 2006, Fedora Core 5, SUSE 9.3, SUSE 10.0 and SUSE
    Message 1 of 6 , Apr 8, 2006
    • 0 Attachment
      Hi there,

      I also have an E1505 and I've tried just about every major distro out
      there: Kubuntu 5.10, Mandriva 2006, Fedora Core 5, SUSE 9.3, SUSE 10.0
      and SUSE 10.1 Beta 9. The latter worked the best. FC 5 was also able to
      detect the graphics card correctly, but I prefer SUSE. I am actually
      writing this on the laptop.

      SUSE 10.1 RC1 should be coming out on Wednesday.


      twasserman wrote:
      > I've been unable to get the graphical display to work properly on the
      > new Inspiron E1505 with the high rez display supported by the 945GM
      > chipset. All of Ubuntu's text-based features work fine, and I have
      > done the standard apt-get updates/upgrades.
      >
      > Basically, the X Server won't start if I specify the device as "i810"
      > for the Intel chipset. If I change it to "vesa" and add an entry for
      > 12M of video RAM, everything starts OK and the apps work fine.
      > However, the max resolution for vesa is 1280x1024, which creates an
      > incorrect aspect ratio on the display, making it impossible to work
      > with images and skewing web pages.
      >
      > Has anyone had a similar problem and found a straightforward solution
      > (no kernel recompilation)? I've seen some discussions around this
      > problem for the Dapper release (6.04), but it doesn't appear to be
      > resolved yet. I've also seen the 915resolution hack, but that doesn't
      > appeal to me, since it requires applying it every time you boot.
      >
      > On a related topic, has anyone had success in getting full and correct
      > resolution with a different distro?
      >
      >
      >
      >
      >
      > --------------------------------------------------------------
      > Please post your X config files in the group links or database
      > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
      > FAQ: http://www.whacked.net/ldl/faq
      >
      >
      > ------------------------------------------------------------------------
      > YAHOO! GROUPS LINKS
      >
      > * Visit your group "linux-dell-laptops
      > <http://groups.yahoo.com/group/linux-dell-laptops>" on the web.
      > * To unsubscribe from this group, send an email to:
      > linux-dell-laptops-unsubscribe@yahoogroups.com
      > <mailto:linux-dell-laptops-unsubscribe@yahoogroups.com?subject=Unsubscribe>
      > * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
      > Service <http://docs.yahoo.com/info/terms/>.
      >
      >
      > ------------------------------------------------------------------------
      >
    • uteck
      You could try the latest Ubuntu flight cd if you want to stay with a Debian base. I am using that now a couple machines at it works and installs fine, but
      Message 2 of 6 , Apr 9, 2006
      • 0 Attachment
        You could try the latest Ubuntu 'flight' cd if you want to stay with a
        Debian base. I am using that now a couple machines at it works and
        installs fine, but they are not the model you are using.

        On 4/8/06, Sebastien <dodo_islander@...> wrote:
        > Hi there,
        >
        > I also have an E1505 and I've tried just about every major distro out
        > there: Kubuntu 5.10, Mandriva 2006, Fedora Core 5, SUSE 9.3, SUSE 10.0
        > and SUSE 10.1 Beta 9. The latter worked the best. FC 5 was also able to
        > detect the graphics card correctly, but I prefer SUSE. I am actually
        > writing this on the laptop.
        >
        > SUSE 10.1 RC1 should be coming out on Wednesday.
        >
        >
        > twasserman wrote:
        > > I've been unable to get the graphical display to work properly on the
        > > new Inspiron E1505 with the high rez display supported by the 945GM
        > > chipset. All of Ubuntu's text-based features work fine, and I have
        > > done the standard apt-get updates/upgrades.
        > >
        > > Basically, the X Server won't start if I specify the device as "i810"
        > > for the Intel chipset. If I change it to "vesa" and add an entry for
        > > 12M of video RAM, everything starts OK and the apps work fine.
        > > However, the max resolution for vesa is 1280x1024, which creates an
        > > incorrect aspect ratio on the display, making it impossible to work
        > > with images and skewing web pages.
        > >
        > > Has anyone had a similar problem and found a straightforward solution
        > > (no kernel recompilation)? I've seen some discussions around this
        > > problem for the Dapper release (6.04), but it doesn't appear to be
        > > resolved yet. I've also seen the 915resolution hack, but that doesn't
        > > appeal to me, since it requires applying it every time you boot.
        > >
        > > On a related topic, has anyone had success in getting full and correct
        > > resolution with a different distro?
        > >
        > >
        > >
        > >
        > >
        > > --------------------------------------------------------------
        > > Please post your X config files in the group links or database
        > > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
        > > FAQ: http://www.whacked.net/ldl/faq
        > >
        > >
        > > ------------------------------------------------------------------------
        > > YAHOO! GROUPS LINKS
        > >
        > > * Visit your group "linux-dell-laptops
        > > <http://groups.yahoo.com/group/linux-dell-laptops>" on the web.
        > > * To unsubscribe from this group, send an email to:
        > > linux-dell-laptops-unsubscribe@yahoogroups.com
        > >
        > <mailto:linux-dell-laptops-unsubscribe@yahoogroups.com?subject=Unsubscribe>
        > > * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
        > > Service <http://docs.yahoo.com/info/terms/>.
        > >
        > >
        > > ------------------------------------------------------------------------
        > >
        >
        >
        > --------------------------------------------------------------
        > Please post your X config files in the group links or database
        > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
        > FAQ: http://www.whacked.net/ldl/faq
        > Yahoo! Groups Links
        >
        >
        >
        >
        >
        >
        >
        >


        --
        no .sig found
        Please restart your browser.
      • Mark Hedges
        ... It sounds more like a question to ask (or search for) on the x.org wiki or mailing list. There is supposedly support for i945G, don t know about i945GM,
        Message 3 of 6 , Apr 10, 2006
        • 0 Attachment
          > > twasserman wrote:
          > > > I've been unable to get the graphical display to work properly on the
          > > > new Inspiron E1505 with the high rez display supported by the 945GM
          > > > chipset. All of Ubuntu's text-based features work fine, and I have
          > > > done the standard apt-get updates/upgrades.

          It sounds more like a question to ask (or search for) on the
          x.org wiki or mailing list. There is supposedly support for
          i945G, don't know about i945GM, maybe they need to know it
          doesn't work right, maybe your debug output would help them.

          Mark
        • gudavalli ramesh babu
          Hi , I have Inspiron - 630m . i too have the same problem . X interface is not working so i was working in the text based mode. when i tried to start the
          Message 4 of 6 , Apr 11, 2006
          • 0 Attachment
            Hi ,

            I have Inspiron - 630m . i too have the same problem
            . X interface is not working so i was working in the
            text based mode. when i tried to start the xserver
            using startx i could see some errors.

            Any help to resolve this is much appreciated.

            rgds,
            Ramesh
            --- Sebastien <dodo_islander@...> wrote:

            > Hi there,
            >
            > I also have an E1505 and I've tried just about every
            > major distro out
            > there: Kubuntu 5.10, Mandriva 2006, Fedora Core 5,
            > SUSE 9.3, SUSE 10.0
            > and SUSE 10.1 Beta 9. The latter worked the best. FC
            > 5 was also able to
            > detect the graphics card correctly, but I prefer
            > SUSE. I am actually
            > writing this on the laptop.
            >
            > SUSE 10.1 RC1 should be coming out on Wednesday.
            >
            >
            > twasserman wrote:
            > > I've been unable to get the graphical display to
            > work properly on the
            > > new Inspiron E1505 with the high rez display
            > supported by the 945GM
            > > chipset. All of Ubuntu's text-based features work
            > fine, and I have
            > > done the standard apt-get updates/upgrades.
            > >
            > > Basically, the X Server won't start if I specify
            > the device as "i810"
            > > for the Intel chipset. If I change it to "vesa"
            > and add an entry for
            > > 12M of video RAM, everything starts OK and the
            > apps work fine.
            > > However, the max resolution for vesa is 1280x1024,
            > which creates an
            > > incorrect aspect ratio on the display, making it
            > impossible to work
            > > with images and skewing web pages.
            > >
            > > Has anyone had a similar problem and found a
            > straightforward solution
            > > (no kernel recompilation)? I've seen some
            > discussions around this
            > > problem for the Dapper release (6.04), but it
            > doesn't appear to be
            > > resolved yet. I've also seen the 915resolution
            > hack, but that doesn't
            > > appeal to me, since it requires applying it every
            > time you boot.
            > >
            > > On a related topic, has anyone had success in
            > getting full and correct
            > > resolution with a different distro?
            > >
            > >
            > >
            > >
            > >
            > >
            >
            --------------------------------------------------------------
            > > Please post your X config files in the group links
            > or database
            > > To unsubscribe, email:
            > linux-dell-laptops-unsubscribe@yahoogroups.com
            > > FAQ: http://www.whacked.net/ldl/faq
            > >
            > >
            > >
            >
            ------------------------------------------------------------------------
            > > YAHOO! GROUPS LINKS
            > >
            > > * Visit your group "linux-dell-laptops
            > >
            > <http://groups.yahoo.com/group/linux-dell-laptops>"
            > on the web.
            > > * To unsubscribe from this group, send an
            > email to:
            > >
            > linux-dell-laptops-unsubscribe@yahoogroups.com
            > >
            >
            <mailto:linux-dell-laptops-unsubscribe@yahoogroups.com?subject=Unsubscribe>
            > > * Your use of Yahoo! Groups is subject to the
            > Yahoo! Terms of
            > > Service <http://docs.yahoo.com/info/terms/>.
            >
            > >
            > >
            > >
            >
            ------------------------------------------------------------------------
            > >
            >


            __________________________________________________
            Do You Yahoo!?
            Tired of spam? Yahoo! Mail has the best spam protection around
            http://mail.yahoo.com
          • gudavalli ramesh babu
            I fogot to mention that that this is on Suse 10.0 rgds, Ramesh ... ...
            Message 5 of 6 , Apr 11, 2006
            • 0 Attachment
              I fogot to mention that that this is on Suse 10.0

              rgds,
              Ramesh


              --- gudavalli ramesh babu <gudavalli_77@...>
              wrote:

              > Hi ,
              >
              > I have Inspiron - 630m . i too have the same
              > problem
              > . X interface is not working so i was working in the
              > text based mode. when i tried to start the xserver
              > using startx i could see some errors.
              >
              > Any help to resolve this is much appreciated.
              >
              > rgds,
              > Ramesh
              > --- Sebastien <dodo_islander@...> wrote:
              >
              > > Hi there,
              > >
              > > I also have an E1505 and I've tried just about
              > every
              > > major distro out
              > > there: Kubuntu 5.10, Mandriva 2006, Fedora Core 5,
              > > SUSE 9.3, SUSE 10.0
              > > and SUSE 10.1 Beta 9. The latter worked the best.
              > FC
              > > 5 was also able to
              > > detect the graphics card correctly, but I prefer
              > > SUSE. I am actually
              > > writing this on the laptop.
              > >
              > > SUSE 10.1 RC1 should be coming out on Wednesday.
              > >
              > >
              > > twasserman wrote:
              > > > I've been unable to get the graphical display to
              > > work properly on the
              > > > new Inspiron E1505 with the high rez display
              > > supported by the 945GM
              > > > chipset. All of Ubuntu's text-based features
              > work
              > > fine, and I have
              > > > done the standard apt-get updates/upgrades.
              > > >
              > > > Basically, the X Server won't start if I specify
              > > the device as "i810"
              > > > for the Intel chipset. If I change it to "vesa"
              > > and add an entry for
              > > > 12M of video RAM, everything starts OK and the
              > > apps work fine.
              > > > However, the max resolution for vesa is
              > 1280x1024,
              > > which creates an
              > > > incorrect aspect ratio on the display, making it
              > > impossible to work
              > > > with images and skewing web pages.
              > > >
              > > > Has anyone had a similar problem and found a
              > > straightforward solution
              > > > (no kernel recompilation)? I've seen some
              > > discussions around this
              > > > problem for the Dapper release (6.04), but it
              > > doesn't appear to be
              > > > resolved yet. I've also seen the 915resolution
              > > hack, but that doesn't
              > > > appeal to me, since it requires applying it
              > every
              > > time you boot.
              > > >
              > > > On a related topic, has anyone had success in
              > > getting full and correct
              > > > resolution with a different distro?
              > > >
              > > >
              > > >
              > > >
              > > >
              > > >
              > >
              >
              --------------------------------------------------------------
              > > > Please post your X config files in the group
              > links
              > > or database
              > > > To unsubscribe, email:
              > > linux-dell-laptops-unsubscribe@yahoogroups.com
              > > > FAQ: http://www.whacked.net/ldl/faq
              > > >
              > > >
              > > >
              > >
              >
              ------------------------------------------------------------------------
              > > > YAHOO! GROUPS LINKS
              > > >
              > > > * Visit your group "linux-dell-laptops
              > > >
              > >
              > <http://groups.yahoo.com/group/linux-dell-laptops>"
              > > on the web.
              > > > * To unsubscribe from this group, send an
              > > email to:
              > > >
              > > linux-dell-laptops-unsubscribe@yahoogroups.com
              > > >
              > >
              >
              <mailto:linux-dell-laptops-unsubscribe@yahoogroups.com?subject=Unsubscribe>
              > > > * Your use of Yahoo! Groups is subject to
              > the
              > > Yahoo! Terms of
              > > > Service
              > <http://docs.yahoo.com/info/terms/>.
              > >
              > > >
              > > >
              > > >
              > >
              >
              ------------------------------------------------------------------------
              > > >
              > >
              >
              >
              > __________________________________________________
              > Do You Yahoo!?
              > Tired of spam? Yahoo! Mail has the best spam
              > protection around
              > http://mail.yahoo.com
              >


              __________________________________________________
              Do You Yahoo!?
              Tired of spam? Yahoo! Mail has the best spam protection around
              http://mail.yahoo.com
            Your message has been successfully submitted and would be delivered to recipients shortly.